Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 26 Dec 2018, 15:02
aciurczak aciurczak is offline
 
Join Date: Jun 2005
Choosing highest PHP version for vB Blog 2.0.6

Hi all -

I have a 3.8.7 PL5 board that I'm looking to update (as much as feasible), without moving to 4.X. I'm currently on PHP 5.4.X. (which has been working fine for years). But I'm also using the standard vb blog module, 2.0.6. According to this, vb blog fails when PHP is updated to 5.6.

from vBulletin download site:
vBulletin 3.8.11 requires PHP 5.6.0+ and MySQL 5.5.8+.
vBulletin 3.8.10 requires PHP 5.5.0+ and MySQL 5.0.0+.
vBulletin 3.8.9 requires PHP 5.3.0+ and MySQL 4.1.0+.
vBulletin 3.8.7 and 3.8.8 require PHP 5.2.0+ and MySQL 4.0.16+.
I'm trying to find out the latest version of vBulletin and PHP that I can upgrade to without killing the blog feature. The options are looking like:

1 - don't change anything (vB 3.8.7 PL5 / PHP 5.4.X)
2 - update vB to 3.8.9, keep PHP at 5.4.X
3 - update vB to 3.8.10, update PHP to 5.5.X

Does anyone know whether PHP 5.5 will break the VB Blog product? Or have suggestions between the first two options?
Reply With Quote
  #2  
Old 26 Dec 2018, 15:24
In Omnibus's Avatar
In Omnibus In Omnibus is offline
 
Join Date: Apr 2010
Real name: Kris
PHP 5.5 and PHP 5.6 are both End Of Life so I'm not sure compatibility with the blog product is your biggest issue. But the information you have posted is correct. If I were in your position I think I would upgrade to 3.8.11 and PHP 7.1 for security reasons and use one of the many available tools to move all of the blogs to wordpress.
Reply With Quote
  #3  
Old 26 Dec 2018, 15:34
aciurczak aciurczak is offline
 
Join Date: Jun 2005
Fair enough, thanks. I see your point based on this. I hadn't realized even 5.6 was going EOL shortly. I do expect PHP 7.1 to break many/most of my forum addons, so upgrading to 3.8.11 and 7.1 probably isn't in the cards. If it gets to that point, I'd likely move the entire forum to another platform and rebuild it more comprehensively.
Reply With Quote
  #4  
Old 26 Dec 2018, 21:59
snakes1100 snakes1100 is offline
 
Join Date: Dec 2001
Real name: Anthony
MariaDB 10.2 is fine for 3.8.11
Reply With Quote
  #5  
Old 28 Feb 2019, 15:53
Kaelon's Avatar
Kaelon Kaelon is offline
 
Join Date: Jan 2002
I just want to confirm, for those of you following the vB3 add-on scene, that PHP 7.1 did, in fact, break virtually every add-on. It's the unfortunate, but inevitable, end of an era.
Reply With Quote
  #6  
Old 20 Jul 2019, 16:51
cmmguy cmmguy is offline
 
Join Date: Oct 2007
Originally Posted by Kaelon View Post
I just want to confirm, for those of you following the vB3 add-on scene, that PHP 7.1 did, in fact, break virtually every add-on. It's the unfortunate, but inevitable, end of an era.
Is there a list of addons that were not compatible? I am at the "need to upgrade PHP" point on my server. I dont have a lot of addon but some of the common one like "Thanks"
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 14:24.

Layout Options | Width: Wide Color: