Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #16  
Old 06 Jan 2020, 23:58
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
Unhappy

Originally Posted by ShikiSuen View Post
There may be an alternative approach if one doesn't want to mess up with PHP upgrades.

The latest dotnet core (available on macOS, Windows, and Linux) accepts PHP as one of its development language.
https://www.codingame.com/playground...s-on--net-core

I have faith that this badass won't complain about deprecated PHP 5 expressions.
Thank you for removing that. I wouldn't run the version you have, the files on nulled sites are usually corrupted with malware or in the least a back-door script "no good deed goes unpunished" and by that I mean, they're not releasing those versions just to be 100% nice, you'll be the one punished by running a compromised forum. 100% free is just not how those sites operate when it comes to giving free software "away" which is actually illegal and to be quite frank that was rather stupid no matter how you justified it - there is no nice way for me to sugar coat or word that differently please this one time in your life, head a warning and know better next time.
__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!
Reply With Quote
  #17  
Old 07 Jan 2020, 08:21
ShikiSuen's Avatar
ShikiSuen ShikiSuen is offline
 
Join Date: Nov 2019
Originally Posted by TheLastSuperman View Post
Thank you for removing that. I wouldn't run the version you have, the files on nulled sites are usually corrupted with malware or in the least a back-door script "no good deed goes unpunished" and by that I mean, they're not releasing those versions just to be 100% nice, you'll be the one punished by running a compromised forum. 100% free is just not how those sites operate when it comes to giving free software "away" which is actually illegal and to be quite frank that was rather stupid no matter how you justified it - there is no nice way for me to sugar coat or word that differently please this one time in your life, head a warning and know better next time.
My site is licensed. It is my risk using the distro I chose. (If not licensed, I may be unable to have access to resources offered by this site.) I will explain some further things through private message to you.

Removing that is due to financial reasons: If I publish the tutorials teaching genuine vBulletin 3.8.11 users how to modify their genuine forum files to PHP 7.4 compatible versions here, vBulletin 5 devs will feel sick. They are expecting old vBulletin users to buy new versions which can financially support their development.

Last edited by ShikiSuen; 07 Jan 2020 at 11:37.
Reply With Quote
  #18  
Old 11 Jan 2020, 17:57
PinkMilk PinkMilk is offline
 
Join Date: May 2010
Real name: Milk Pink
Originally Posted by lange View Post


All my 3.8.11 products /plugins (about ten mods) work fine with PHP 7.2+ except the following two mods:

https://www.vbulletin.org/forum/showthread.php?t=177552 (Cyb Chatbox)
7.2+ fix for
Error: Call to undefined function split() in ....\global.php(607) : eval()'d code on line 33

Open product xml and replace
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

with
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

3 instances:
Line 102, 116 and 529
Reply With Quote
  #19  
Old 11 Jan 2020, 19:39
lange lange is offline
 
Join Date: Apr 2003
Thank you very much, I will check it in the next days and give you a feedback.

--------------- Added 11 Jan 2020 at 20:43 ---------------

I tested it right now and it's fixed.


You fix is correct but I was getting the following error:


Thanks to snakes1100 for the following fix https://www.vbulletin.org/forum/show...58&postcount=6


I have several warnings but I can fix them by myself.


Thank you very much again
Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Forum Home Enhancements UF - Forum Updates on Homepage! (Updates come from posts in a specified thread) alexgeek vBulletin 3.6 Add-ons 21 03 Feb 2008 16:47



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 03:55.

Layout Options | Width: Wide Color: