Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Title Tag Grabber AND Video Embedding by BOP5 for VB5 Details »
Title Tag Grabber AND Video Embedding by BOP5 for VB5
Mod Version: 3.0.1, by BirdOPrey5 (IB Staff) BirdOPrey5 is offline
Developer Last Online: Jun 2019 I like it Show Printable Version Email this Page

vB Version: 5.1.x Rating: (2 votes - 5.00 average) Installs: 47
Released: 11 Oct 2012 Last Update: 30 Jun 2015 Downloads: 361
Not Supported Additional Files Re-usable Code  

.

IMPORTANT! - Updated version released here: https://www.vbulletin.org/forum/showthread.php?t=325277

All New Version 3.0

Use version 3.0.1 on VB 5.1.5 and newer (tested on 5.1.7)
It has not been tested on old versions of VB5. If you still have an old version of VB5 try the Version 2.0 download.

This mod can do two things:
  1. It can automatically grab the title of a page you are linking to
  2. It can embed video URLs automatically

For example it will turn:

http://www.vbulletin.org

to

vBulletin.org Forum - The Official vBulletin Resource!

This is working on both the simple and complex style URL BBcodes, and it will ignore existing links if you have specified a custom title.

It can also turn a link like: http://www.youtube.com/watch?v=gxEPV4kolz0 into an embedded video without use of the [video] BB Code.

In addition there is an option to auto embed old links that were previously embedded by the AME 2.x mod for vBulletin 3.x. If you still have [AME] BB Codes in your posts this mod can do its best to embed them like they used to be with AME.

Video Embedding is currently working with Youtube (both short and original URLs) and Vimeo.com videos.

The Mod should auto install, upload files as instructed in Readme (everything goes in the usual place.) Clear the system cache to see the mod work on existing posts.

If you wanted to undo the changes made by this mod simply delete the files/remove the mod/ and clear the cache. This mod does not alter the original posts, only the cached copies.

Please "Mark as Installed" if you use this.
Donations Always Appreciated.
Consider nominating for MOTM if you like it!

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	title-grab-settings.jpg
Views:	739
Size:	93.9 KB
ID:	144670  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Miscellaneous Hacks Kindle Daily Deal Grabber by BOP5 BirdOPrey5 vBulletin 4.x Add-ons 79 20 Oct 2014 04:20
Miscellaneous Hacks Add ALT and/or TITLE text to linked images in VB3 by BOP5 BirdOPrey5 vBulletin 3.8 Add-ons 20 16 Apr 2014 16:29
Miscellaneous Hacks Kindle Daily Deal Grabber by BOP5 (VB3) BirdOPrey5 vBulletin 3.8 Add-ons 14 14 Jan 2013 16:52

  #31  
Old 16 Apr 2015, 23:19
Vaskania's Avatar
Vaskania Vaskania is offline
 
Join Date: Aug 2014
Originally Posted by BirdOPrey5 View Post
Thanks for reporting this, I will look into it and post an update.
It's nothing wrong with your script. The bbcode files in VB5 itself had to be modified. Instead of having an option in the admincp, they forced url truncation to 55 chars in the php code.
__________________
Hivewire3D.com
Running vBulletin 5.1.6
Reply With Quote
  #32  
Old 27 Apr 2015, 20:20
indio007 indio007 is offline
 
Join Date: Apr 2015
Originally Posted by BirdOPrey5 View Post

In addition to embedding video URLs the mod can also work with databases that have been upgraded from VB 3.x where the "AME" mod was in use. The AME mod is not available for VB5 yet and I don't know if it ever will be. If you didn't clear the AME tags before upgrading to VB5 you probably have many video URLs still stuck inside the [AME] BBCode.. Such as [AME]http://www.youtube.com/watch?v=gxEPV4kolz0[/AME]. This mod can auto-embed video URLs inside AME BBCode. Again it will work with YouTube and Vimeo URLs. (Both original YouTube URLs and the shorter youtu.be URLs.)

Hi, I'm trying to get this package to work to convert the ame tags. Our tag syntax is like this.

[ame="https://www.youtube.com/watch?v=Adu-f9xERy8"]Mario[/ame]

Is this acceptable?
Reply With Quote
  #33  
Old 21 May 2015, 04:27
mdawg's Avatar
mdawg mdawg is offline
 
Join Date: Mar 2009
Originally Posted by kehindelawal View Post
still not working well. while some website display the title adequately, some just default to the LINK.

will like to get this working plss!
There seems to be no rime or reason to what URLs become titles and what become the default LINK.


Originally Posted by Vaskania View Post
Installed and working on 5.1.6.

Having an issue when editing posts though. Links show up truncated when editing, and as such, the link is no longer rewritten once the post is saved. Not sure if that's an issue with the mod or VB5's forced truncation though.

/edit
Got the above bit worked out. Was the forced truncation. Modified the bbcode_url functions and all's well.
Yes I have noticed this too, and yes it is a major pain if editing a post that has multiple links in it. If you wish to preserve to titles you must copy and paste the actual URLs back in before saving the post.

Vaskania can you please advise on what exactly to do to prevent this from happening.
Reply With Quote
  #34  
Old 01 Jun 2015, 23:55
mdawg's Avatar
mdawg mdawg is offline
 
Join Date: Mar 2009
Does this still work with 5.1.7 ? Because when I just posted a new URL in 5.1.7 with this hack running the URL appears odd, with the URL itself appearing between [url=" and
[/url] with the thread title sandwiched in between.
Reply With Quote
  #35  
Old 02 Jun 2015, 11:36
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
I have just updated this to version 3.0 to deal with the problems reported when editing posts.

It is now working fine for me on VB 5.1.7.

Please upgrade.

I have set the minimum version to VB 5.1.5. If you run VB 5.1.5 or higher I strongly recommend you to upgrade to the Version 3.0 product available in the download links.
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #36  
Old 02 Jun 2015, 15:48
mdawg's Avatar
mdawg mdawg is offline
 
Join Date: Mar 2009
Thanks! for the new version. Running on vb 5.1.7 now, and yes it maintains the thread title after editing and re-saving which was a real pain before when it lost the thread title.

Question: leaving this setting "Text For Pages With No Title" blank so that it just leaves the URL intact in full instead of the word Link when it cannot figure out the title - is there any downside to this? I mean, it seems like seeing the URL spelled out is better than the nondescriptive word link. If this is left blank it won't affect the mod's ability to pull titles or cause anything crazy to happen will it?
Reply With Quote
  #37  
Old 02 Jun 2015, 18:50
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
No downside. Just personal preference.
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #38  
Old 04 Jun 2015, 08:28
tomcoleman tomcoleman is offline
 
Join Date: Aug 2010
just installed this on 5.1.7

Now everytime I user posts you get an error saying "error loading Post"
Reply With Quote
  #39  
Old 04 Jun 2015, 12:21
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Originally Posted by tomcoleman View Post
just installed this on 5.1.7

Now everytime I user posts you get an error saying "error loading Post"
Are you sure you uploaded all the files?

Uninstall/remove the mod (if you haven't already) to stop the error.
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #40  
Old 09 Jun 2015, 08:33
tomcoleman tomcoleman is offline
 
Join Date: Aug 2010
Originally Posted by BirdOPrey5 View Post
Are you sure you uploaded all the files?

Uninstall/remove the mod (if you haven't already) to stop the error.
yes - had to remove/disable to make the board work again

Can you fix?
Reply With Quote
  #41  
Old 12 Jun 2015, 15:19
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
I've tested now on several VB5 sites without issue. Do you have any other mods installed?
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #42  
Old 20 Jun 2015, 18:49
scottct1 scottct1 is offline
 
Join Date: Mar 2002
I just installed this on 5.1.7 and get the following at the top of the screen.

Warning: file_put_contents(result.txt): failed to open stream: Permission denied in .../packages/bop5titletagsvb5/api/content/text.php on line 23 Warning: file_put_contents(nodeid.txt): failed to open stream: Permission denied in .../packages/bop5titletagsvb5/api/content/text.php on line 24 Warning: file_put_contents(keys.txt): failed to open stream: Permission denied in .../packages/bop5titletagsvb5/api/content/text.php on line 25

What does it mean?
Reply With Quote
  #43  
Old 20 Jun 2015, 19:09
scottct1 scottct1 is offline
 
Join Date: Mar 2002
Originally Posted by tomcoleman View Post
just installed this on 5.1.7

Now everytime I user posts you get an error saying "error loading Post"
Getting the same error. Fresh install of 5.1.7 only other add on installed is viglink.
Reply With Quote
  #44  
Old 30 Jun 2015, 19:21
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
It seems I inadvertently left several lines of debugging code enabled in the 3.0.0 release. This code would try to create text files with varias variable dumps.

Depending on your server setup this may have caused warning messages or errors when running this mod.

I have updated to version 3.0.1 and made sure all debug code is disabled.
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #45  
Old 22 Nov 2015, 15:09
mdawg's Avatar
mdawg mdawg is offline
 
Join Date: Mar 2009
This works but occasionally when I edit a post it still doesn't grab the title on the save, and I have to re-edit and re-paste the full URL.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 06:08.

Layout Options | Width: Wide Color: