Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 11 Jun 2010, 10:34
NBZ4live NBZ4live is offline
 
Join Date: Jun 2010
Wink Help with vBulletin Integration and Autologin

Hi,

I'm trying to integrate vBulletin into our product.
The automated account creation and validation of the session from our product works fine in the "init_startup" hook.
But now I have problems to perform an autologin to vBulletin if the Product session is valid and the vBulletin account exists. (without redirection page)

I have now tried this code:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

after filling
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

with information ("userid, usergroupid, membergroupids, infractiongroupids, username, password, salt") from the user table.

The Problem is: vBulletin generates a session and sets a cookie, but the userid in the session row and the cookie is 0.

Please help to solve this problem.

Thanks in advance.

Best Regards,
NBZ4live
Reply With Quote
  #2  
Old 15 Jun 2010, 10:40
NBZ4live NBZ4live is offline
 
Join Date: Jun 2010
Nobody an idea?
I already tried many ways to do that, but nothing helps.
I have successfully logged in user by editing the userid in his entry in the sessions table, but thew user will be loged in after a refresh. I can't use do_login_redirect(), because the redirect page makes another redirect and so on.
Reply With Quote
  #3  
Old 16 Jun 2010, 11:03
NBZ4live NBZ4live is offline
 
Join Date: Jun 2010
Ok. Have solved this by my own. You can close the topic.
Reply With Quote
  #4  
Old 01 Nov 2010, 12:32
aussiev8 aussiev8 is offline
 
Join Date: Aug 2004
what did you do to solve this? I've been trying to fake a session all day, and although my cookie's and db are set fine.. vb just creates a new session... its driving me crazy
Reply With Quote
  #5  
Old 30 Jul 2011, 18:16
tommythejoat's Avatar
tommythejoat tommythejoat is offline
 
Join Date: Apr 2008
Real name: Tom McIntyre
Unhappy Still a problem for me

I have exactly the same problem as was discussed above.

My single Signon using forms based authentication on a Windows server was working fine with vB3.8 for a year or so, but with vB4 the do_login_redirect triggers an infinite redirect.

My code transparently creates a vB account or logs the user in if their email address matches between vBulletin and my CRMS. I execute the login and my code with a button and it works fine, but if I have it fire from a hook, it gives the infinite redirect in v4.
Reply With Quote
  #6  
Old 20 Aug 2011, 16:20
otlayi otlayi is offline
 
Join Date: Jan 2011
Originally Posted by NBZ4live View Post
Ok. Have solved this by my own. You can close the topic.
I HATE people who take the time to post a problem on the forums, and even post a followup asking for more help, then "I solved it, not going to bother wasting anyone's time by telling them how, solve it on your own +++++++". If you're going to waste your time writing and saying you fixed it, at least say a couple words for people who also run into the same problem.

Originally Posted by tommythejoat View Post
I have exactly the same problem as was discussed above.

My single Signon using forms based authentication on a Windows server was working fine with vB3.8 for a year or so, but with vB4 the do_login_redirect triggers an infinite redirect.

My code transparently creates a vB account or logs the user in if their email address matches between vBulletin and my CRMS. I execute the login and my code with a button and it works fine, but if I have it fire from a hook, it gives the infinite redirect in v4.
Sounds exactly like what I've got, and was only a problem after vB4. It's do_login_redirect() that throws to a white page, logged in just fine, but redirect will never properly go through. Very, very frustrating to say the least..
Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Integration with vBulletin 3rd Party Login/Register/Autologin API oxylus Modification Graveyard 13 24 Jan 2008 11:35



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 14:06.

Layout Options | Width: Wide Color: