Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 16 May 2009, 22:57
Bellardia Bellardia is offline
 
Join Date: Jul 2007
Pcre

I really don't understand what is happening here; heres the situation.

I have a script that applies a pcre to a string using preg_match. Now I'm no whiz with regular expressions, and this one is pretty bloated because it is supposed to match only specific sentence forms. The issue comes in when I uploaded the script to my server (I was running it on local host). The script returns entirely different behaviour! When I run the same strings in my localhost and on my server I get two completely different results. Namely, I always get the expected matches on my localhost, but it hardly ever matches at all on my server.

Because of this, I tested it on a second server, and it behaved the same as on the first, and still entirely differently than my localhost! Are there any explanations for this? Is there settings or files that need to be changed/installed? On smaller pcre expressions the scripts seem to work identically, but are drastically different on for larger one.

Any help on this is appreciated.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 01:03.

Layout Options | Width: Wide Color: