Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
User Links in Navbar for vB 4 Details »
User Links in Navbar for vB 4
Mod Version: 1.0.1, by Boofo (R.I.P.) Boofo is offline
Developer Last Online: Jun 2012 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (13 votes - 5.00 average) Installs: 56
Released: 12 Mar 2011 Last Update: 12 Mar 2011 Downloads: 205
Not Supported Uses Plugins  

User Links in Navbar for vB 4
Version 1.0.1
(By Boofo)

What does this product do?
This product will add a drop-down menu with user links in the forum navbar. You can add up to 5 additional links, as well as link names and mouseover text, via the settings. It will check to see if you have Reputation enabled. If you do not, it will not show the reputation in the menu. It will also check to see if you have the "Threads Started by User in Postbit and Profile for vB 4" product installed on your site. If you do not, the thread count will not show in the menu.

Version Information:
Version 1.0.0 --Initial release for vB 4
Version 1.0.1 --Fixed issue with Friends link not working with vBSEO installed.

Installation Overview:
---------------------------
1 Product XML (2 Plugins, 58 Phrases, 1 Template, 17 Settings and 1 Style Variable)

Installation Instructions:
---------------------------
1. Add the following code to the additional.css template:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


2. Go to your Admin CP
Scroll down to 'Plugin System'
Click 'Manage Products'
Click 'Add/Import Product'
Click the 'Browse' button, and locate the product-boofo_user_links.xml file on your computer

3. Go to your Admin CP -> vBulletin Options -> 'User Links in Navbar' and set the following options:
User Links Forum Menu Display Order: Choose the location you want the User Links menu to show up in the Forum Tab. (Default is 3, Navbar after Private Messages)
User Links Blogs Menu Display Order: Choose the location you want the User Links menu to show up in the Blogs Tab. (Default is 2, Blogs after My Blog)
Additional Link (1-5) URL: Enter the URL of the link you want set as Additional Link (1-5).
Additional Link (1-5) Name: Enter the name of the Additional Link (1-5) that you want to show up in the menu.
Additional Link (1-5) Title Text: Enter the title text of Additional Link (1-5) you want to show on mouseover.

4. Go to your Admin CP -> Styles & Templates -> Style Manager -> StyleVars (In the All Style Options drop-down) -> Boofo -> boofo_userlinks_color
Enter the color code of the font color that you want the User Links menu title to show up in.

NOTE: You will need to do this for all styles.
------------------------------------------------------

Done!
Enjoy!

NOTE: There is also an Advanced Version (paid) available that allows each user to add up to 5 links of their choosing (instead of the Admin having to do it for everyone), as well as a Search menu that allows you to add settings for how many days you want to search for (2 days, 7, days, 12 days, 180 days, etc.) that is only available through my site. If anyone is interested, contact me via PM for details.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	user_links_in_navbar.png
Views:	1600
Size:	22.1 KB
ID:	127372  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #16  
Old 12 Mar 2011, 20:27
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Originally Posted by McAtze View Post
@Boofo: u have pm ..

i use vbseo with this rewrite ..

domain.de/members/username.html

--------------

€dit: Stop your searching Boofo .. the link from Gemma works ..


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
We know it works for those with vBSEO installed. That wasn't the problem. But it is fixed now so you can download the update.
Reply With Quote
  #17  
Old 12 Mar 2011, 20:32
McAtze McAtze is offline
 
Join Date: Oct 2009
thx for the fast help ...
__________________
IT-MaKu | Home of Döner
Reply With Quote
  #18  
Old 12 Mar 2011, 20:42
Hippy's Avatar
Hippy Hippy is offline
 
Join Date: Dec 2001
Originally Posted by Mr_Running View Post
Thanks Boofo

I notice a difference from the screen shot and what I have.
Some of the User Links go above the navbar
Just tested this and your correct.. but the defaul style is good .
it's a custom style i see this one..

downloaded here @ vb.org called blackend
using vb4.1.2 and the style is also for vb4.1.2

other wise Seems this will be a mch used mod
Attached Images
File Type: jpg default.jpg (90.9 KB, 20 views)
File Type: jpg blackend.jpg (52.4 KB, 27 views)
Reply With Quote
  #19  
Old 12 Mar 2011, 20:47
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Just edit the additonal.css code you added and change the color: {vb:stylevar blockhead_link_color}, if you want something other than white. As far as it being above the navbar, the custom skin must be causing that. Since I only use the default skin, that is what I coded it in. It looks like they use a lot of padding in that skin, which would account for it, I suppose.

Last edited by Boofo; 12 Mar 2011 at 20:53.
Reply With Quote
  #20  
Old 12 Mar 2011, 21:39
Mikevet1984's Avatar
Mikevet1984 Mikevet1984 is offline
 
Join Date: Nov 2010
Boofo's Miracle one more time....

hahahah

Thanks bro!

Last edited by Mikevet1984; 12 Mar 2011 at 22:45.
Reply With Quote
  #21  
Old 13 Mar 2011, 00:36
sulasno sulasno is offline
 
Join Date: Feb 2010
tagged and thanks

does this mod allow users to select their own links ?
Reply With Quote
  #22  
Old 13 Mar 2011, 03:09
gamerzhut gamerzhut is offline
 
Join Date: Jan 2010
Thanks, works like a charm.

Mark as installed & rated *****
Reply With Quote
  #23  
Old 13 Mar 2011, 12:56
Mr_Running Mr_Running is offline
 
Join Date: May 2010
Originally Posted by Hippy View Post
Just tested this and your correct.. but the defaul style is good .
it's a custom style i see this one..

downloaded here @ vb.org called blackend
using vb4.1.2 and the style is also for vb4.1.2

other wise Seems this will be a mch used mod
It looks like they use a lot of padding in that skin, which would account for it, I suppose.
Yes it may be the padding on mine as I did increase the size of the navbar and sub navbar slightly.

When I remove the additional links it does stay below.

Sulasno
does this mod allow users to select their own links ?
No not as of 1.0.1 but...Additional links can be set.
vB --> Settings --> Options --> User Links in Navbar

Thanks again Boofo rated 5 stars

Cheers,
Mr_Running
Reply With Quote
  #24  
Old 13 Mar 2011, 13:05
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Allowing users to add their own links would requite setting up profile fields. That could be done fairly easily, I suppose. If I get enough calls for it, then maybe I will look into it. It would have to be worth the time to mess with it.
Reply With Quote
  #25  
Old 13 Mar 2011, 13:41
Mr_Running Mr_Running is offline
 
Join Date: May 2010
Originally Posted by Boofo View Post
There should be some spacing on the left of the the menu subtitles if the code is installed in the additional.css..
Menu subtitles (Statistics, Post, etc) do seem a little close on mine as seen in post #9
The additional.css is added ???


Cheers,
Mr_Running
Reply With Quote
  #26  
Old 13 Mar 2011, 13:49
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Check and make SURE you added the code to the additional.css exactly as it is supposed to be. Are you using a custom skin of any kind? What browser were you in when you took that pic?
Reply With Quote
  #27  
Old 13 Mar 2011, 14:10
Mr_Running Mr_Running is offline
 
Join Date: May 2010
Checked additional.css --> seems good.
The only custom skin I am using is a change in some vB default colors.

The Browser was FireFox for the pic and I have now checked EI and Google. = Same
I have cleared the cache and cookies too.
Did not change.

Cheers,
Mr_Running
Reply With Quote
  #28  
Old 13 Mar 2011, 14:24
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Originally Posted by Mr_Running View Post
Yes it may be the padding on mine as I did increase the size of the navbar and sub navbar slightly.

Sulasno
You messed with the padding on the navbar. That is why it looks like it does now. If you check it with a default skin that has not been tampered with, it will show correctly. There is no way to account for all changes someone can make. I suggest either setting the padding and whatever else you did back to the default, or you will need to go into the additional.css and adjust the settings in the code you added there.
Reply With Quote
  #29  
Old 13 Mar 2011, 14:32
UncoderMom's Avatar
UncoderMom UncoderMom is offline
 
Join Date: May 2006
Real name: Lisa
Was waiting for you to release this! Its about time! LOL
__________________
And yeah, I say LOL a LOT! LOL
Reply With Quote
  #30  
Old 13 Mar 2011, 14:52
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
All you had to do was ask. You knew I was working on it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 10:24.

Layout Options | Width: Wide Color: