Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 03 Feb 2015, 16:35
mohammad6006's Avatar
mohammad6006 mohammad6006 is offline
 
Join Date: May 2008
Real name: Mohammad
get usergroupid value

I use this code in external vbulletin page :

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

work good for me and display usergroup 6

but for another users that usergroup is 20 : display 1 ( unregistered)

user is logged in forum

are there another way for get usergroupid?
__________________
http://forum.tractorfc.com
Reply With Quote
  #2  
Old 04 Feb 2015, 17:15
Medi0cr3 Medi0cr3 is offline
 
Join Date: Aug 2014

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Only gets the viewing user's "usergroupid" usergroup. What exactly are you requiring?
Reply With Quote
  #3  
Old 05 Feb 2015, 06:50
mohammad6006's Avatar
mohammad6006 mohammad6006 is offline
 
Join Date: May 2008
Real name: Mohammad
Originally Posted by Medi0cr3 View Post
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Only gets the viewing user's "usergroupid" usergroup. What exactly are you requiring?
I know

I create a file test.php
and insert that codes

so , my usergroup is 6 and when i run this page show 6
but for other users for example moderators and registered group display 1

1 is for unregistered group

this file can not detect other peoples
just work for me
__________________
http://forum.tractorfc.com
Reply With Quote
  #4  
Old 05 Feb 2015, 10:01
kh99 kh99 is offline
 
Join Date: Aug 2009
Real name: Kevin
If it's displaying 1 then it's probably seeing them as not logged in. I see that you're using chdir(), so I guess this is a script that's outside the forum directory? You might need to change your setting for "Path to Save Cookies" to '/'.
Reply With Quote
  #5  
Old 07 Feb 2015, 07:37
mohammad6006's Avatar
mohammad6006 mohammad6006 is offline
 
Join Date: May 2008
Real name: Mohammad
Originally Posted by kh99 View Post
If it's displaying 1 then it's probably seeing them as not logged in. I see that you're using chdir(), so I guess this is a script that's outside the forum directory? You might need to change your setting for "Path to Save Cookies" to '/'.
my forum is in : forum.site.com

other folder that i want to use forum cookie is : site.com/admin

cookie path setting is on : /
domain cookie setting is on : (space)

What value i need to set to work cookies on site.com/admin ?
__________________
http://forum.tractorfc.com
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 22:58.

Layout Options | Width: Wide Color: