Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Allow Usergroups to Post HTML Details »
Allow Usergroups to Post HTML
Mod Version: 1.00, by kall (Coder/Designer) kall is offline
Developer Last Online: Mar 2021 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.5.4 Rating: (34 votes - 4.32 average) Installs: 510
Released: 26 Sep 2005 Last Update: 28 Nov 2005 Downloads: 2010
Not Supported Uses Plugins Is in Beta Stage  

Just like the name says, this ultra-simple little Product will allow you to specify Usergroups that may post in HTML and have that HTML be parsed...SOME PEOPLE ARE HAVING TABLE PROBLEMS - THIS IS UNSUPPORTED USEAGE OF THE MODIFICATION AND I AM UNABLE TO ASSIST!

***BE AWARE THAT INDISCRIMINATE USE OF THIS HACK IS RISKY - RESTRICT IT TO ONLY THOSE USERGROUPS YOU TRUST ABSOLUTELY***

The scary message above is to make sure you are aware that enabling HTML for any group opens you up to security issues. This is why it is not a feature of Stock vB, probably.

I decided I needed to have the ability to post in HTML because I just installed ZT's RSS Feeds hack, and the ones I got from Google looked all horrible.

Now updated to be controlled by a Setting in Usergroup Manager, it's phrased and even works in editpost.php (preview) in WYSIWYG and normal modes, AND the Forum Rules shows HTML is ON.

This will not work retroactively. That is, if a User posted something in HTML before they were given the ability, that post has to be edited by that member (or someone else with HTML ability) in order to be parsed. I am assuming this is due to post caching.

Many thanks to Kirby for prodding me to figure it out by myself and not just telling me what to do.

A "demo" is here..html is OFF in that Forum, but the post is made by an Admin, so the HTML is parsed.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #226  
Old 07 Jun 2006, 19:53
mili mili is offline
 
Join Date: Jul 2003
I mentioned that it screws up tables like 3 months ago. No fix yet.

mili
Reply With Quote
  #227  
Old 09 Jun 2006, 17:29
rogersnm's Avatar
rogersnm rogersnm is offline
 
Join Date: Apr 2006
Location: Cyberspace, UK
Real name: Nick Rogers
ok, does it work on 3.6?
Reply With Quote
  #228  
Old 13 Jun 2006, 18:02
good2laugh good2laugh is offline
 
Join Date: Jul 2002
Originally Posted by rogersnm
ok, does it work on 3.6?
I just installed it on 3.6 and it seems to be working. It's not on a live board yet so no idea if everything is as should be. Seems to be fine though.

Thanks Kal < waddles off to find the install button >
__________________
Smile!
Reply With Quote
  #229  
Old 13 Jun 2006, 20:37
RFViet RFViet is offline
 
Join Date: Jan 2006
there is some posts , I want to turn off HTML, what should i do ??
Reply With Quote
  #230  
Old 14 Jun 2006, 19:36
creativepart creativepart is offline
 
Join Date: Jun 2006
I'm trying to get HTML to work for a few users. So this looked good.

I installed it, and turned on the parse html feature for that user group and did a test of a simple <li> next to a sentance.

Now Admins can see the bullet placed by the <li> but no one else can see it -- not even in the special usergroup with html parse set to yes.

Am I missing something? And why does the plugin manager show two installs of this plugin with one struck thru?
Reply With Quote
  #231  
Old 15 Jun 2006, 08:05
I-Web's Avatar
I-Web I-Web is offline
 
Join Date: Mar 2004
Yup works on 3.6 beta 2 have it running on a live board and as stated it is superb for rss feeds
Reply With Quote
  #232  
Old 22 Jun 2006, 17:27
bergonio's Avatar
bergonio bergonio is offline
 
Join Date: May 2006
Help!! I installed but people keep using the HTML... what I did wrong? I read all this thread and looks like I have to edit one XML.. if so... tell me what to read or what to do to make it !

thanks
Reply With Quote
  #233  
Old 23 Jun 2006, 18:47
Snake's Avatar
Snake Snake is offline
 
Join Date: Mar 2005
Location: Cleveland, OH
Real name: Josh
I've installed this hack but it doesn't allowe usergroups to parse HTML in signatures.
Reply With Quote
  #234  
Old 23 Jun 2006, 22:02
kall's Avatar
kall kall is offline
 
Join Date: Apr 2004
Real name: Ace
Originally Posted by Dark Cloud
I've installed this hack but it doesn't allowe usergroups to parse HTML in signatures.
Where exactly do I say that it does?
__________________
vBulletin Styles (All styles compatible with 3.8.4 - Steel Blue 4.0 Available) | vBulletin Hosting
Reply With Quote
  #235  
Old 24 Jun 2006, 14:45
Snake's Avatar
Snake Snake is offline
 
Join Date: Mar 2005
Location: Cleveland, OH
Real name: Josh
Nowhere but by looking at this thread, I thought it would parse the HTML anywhere on the forums. Oh well...
Reply With Quote
  #236  
Old 26 Jun 2006, 09:33
Freakpyromaniac Freakpyromaniac is offline
 
Join Date: Feb 2005
Wink

Is my understanding okay when i need to turn HTML on in the forum(Categories) that i wanted to use it. After that i need to give the right usergroups permissions ?

Or is it not needed to turn it on at the forums(categories)?
Reply With Quote
  #237  
Old 26 Jun 2006, 09:47
kall's Avatar
kall kall is offline
 
Join Date: Apr 2004
Real name: Ace
Originally Posted by Dark Cloud
Nowhere but by looking at this thread, I thought it would parse the HTML anywhere on the forums. Oh well...
I think someone did write a plugin that does signatures.. try a search.

@Freak: No no.. dont touch the Forum level, the settings at Usergroup level override it if set to Yes.
__________________
vBulletin Styles (All styles compatible with 3.8.4 - Steel Blue 4.0 Available) | vBulletin Hosting
Reply With Quote
  #238  
Old 29 Jun 2006, 20:04
Snake's Avatar
Snake Snake is offline
 
Join Date: Mar 2005
Location: Cleveland, OH
Real name: Josh
I've done a couple of searches but sadly with no result. Can you get that hack for me please?
Reply With Quote
  #239  
Old 04 Jul 2006, 10:04
kall's Avatar
kall kall is offline
 
Join Date: Apr 2004
Real name: Ace
Originally Posted by Dark Cloud
I've done a couple of searches but sadly with no result. Can you get that hack for me please?
http://www.vbulletin.org/forum/showthread.php?t=75590

__________________
vBulletin Styles (All styles compatible with 3.8.4 - Steel Blue 4.0 Available) | vBulletin Hosting
Reply With Quote
  #240  
Old 04 Jul 2006, 18:25
Snake's Avatar
Snake Snake is offline
 
Join Date: Mar 2005
Location: Cleveland, OH
Real name: Josh
Thanks but as you can see, I'm currently running on v3.5.4.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 18:30.

Layout Options | Width: Wide Color: