Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Allow Usergroups to Post HTML Details »
Allow Usergroups to Post HTML
Mod Version: 1.00, by kall (Coder/Designer) kall is offline
Developer Last Online: Mar 2021 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.5.4 Rating: (34 votes - 4.32 average) Installs: 510
Released: 26 Sep 2005 Last Update: 28 Nov 2005 Downloads: 2010
Not Supported Uses Plugins Is in Beta Stage  

Just like the name says, this ultra-simple little Product will allow you to specify Usergroups that may post in HTML and have that HTML be parsed...SOME PEOPLE ARE HAVING TABLE PROBLEMS - THIS IS UNSUPPORTED USEAGE OF THE MODIFICATION AND I AM UNABLE TO ASSIST!

***BE AWARE THAT INDISCRIMINATE USE OF THIS HACK IS RISKY - RESTRICT IT TO ONLY THOSE USERGROUPS YOU TRUST ABSOLUTELY***

The scary message above is to make sure you are aware that enabling HTML for any group opens you up to security issues. This is why it is not a feature of Stock vB, probably.

I decided I needed to have the ability to post in HTML because I just installed ZT's RSS Feeds hack, and the ones I got from Google looked all horrible.

Now updated to be controlled by a Setting in Usergroup Manager, it's phrased and even works in editpost.php (preview) in WYSIWYG and normal modes, AND the Forum Rules shows HTML is ON.

This will not work retroactively. That is, if a User posted something in HTML before they were given the ability, that post has to be edited by that member (or someone else with HTML ability) in order to be parsed. I am assuming this is due to post caching.

Many thanks to Kirby for prodding me to figure it out by myself and not just telling me what to do.

A "demo" is here..html is OFF in that Forum, but the post is made by an Admin, so the HTML is parsed.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #91  
Old 16 Oct 2005, 21:02
vBFreak's Avatar
vBFreak vBFreak is offline
 
Join Date: Nov 2001
Look at the screenshots, the second one shows my admin view of a signature of another admin, I can see it parsed... the first one shows a normal user view, there is no html-code parsed... what I want is, that every user can see every html-code of an admin parsed but no other users should be able to use html in their own posts, if an user posts html nobody should see that parsed...

If I would write something with my normal user, my admin account parses the html-code of the users and other users can see only the code from both admins and other users...

I've set "Should this usergroups HTML posts be parsed?" to Yes at the admin group, all other users have no there... What am I doing wrong?
Attached Images
File Type: gif admin.gif (52.4 KB, 72 views)
File Type: gif user.gif (57.0 KB, 83 views)
Reply With Quote
  #92  
Old 16 Oct 2005, 21:03
Andreas's Avatar
Andreas Andreas is offline
 
Join Date: Jan 2004
Real name: Andreas
@kall
The Plugin-Code in the ZIP definitly doesn't work correctly
Reply With Quote
  #93  
Old 16 Oct 2005, 21:16
vBFreak's Avatar
vBFreak vBFreak is offline
 
Join Date: Nov 2001
Here are 2 more screens, as you can see, my admin user parses the html-code of the user's post and signature and my own html code, but the user can't see my html and also not his own html...
Attached Images
File Type: gif admin2.gif (91.8 KB, 45 views)
File Type: gif user2.gif (84.2 KB, 40 views)
Reply With Quote
  #94  
Old 16 Oct 2005, 21:18
dastar dastar is offline
 
Join Date: Jun 2005
Funny, but other then having to enter advanced edit to make sure the HTML stays parsed, I don't have some of the problems others are having.
Reply With Quote
  #95  
Old 16 Oct 2005, 21:22
Andreas's Avatar
Andreas Andreas is offline
 
Join Date: Jan 2004
Real name: Andreas
@dastar
It doesn't stay; it will go away when parsed post cache expires, as the ZIP version of this Hack just checks your permission - instead of the permission of the post owner.

Last edited by KirbyDE; 17 Oct 2005 at 13:48.
Reply With Quote
  #96  
Old 16 Oct 2005, 22:42
dastar dastar is offline
 
Join Date: Jun 2005
Originally Posted by KirbyDE
@dastar
It doesn't stay; it will go away when parsed psot cach ZIP version of this Hack just checks your permission - instead of the permission of the post owner.
When does this happen? My guests and users can see the html as being parsed but still can't have their own html posts parsed (I have it set to only parse the admin's html).

I am not doubting you, just trying to understand it and recreate the problem on my forums so that I can see it myself.
Reply With Quote
  #97  
Old 17 Oct 2005, 07:31
kall's Avatar
kall kall is offline
 
Join Date: Apr 2004
Real name: Ace
Updated .zip .. before I announce this, can someone please test it? I took it straight from NZB, where it works perfectly.
__________________
vBulletin Styles (All styles compatible with 3.8.4 - Steel Blue 4.0 Available) | vBulletin Hosting
Reply With Quote
  #98  
Old 17 Oct 2005, 11:47
dastar dastar is offline
 
Join Date: Jun 2005
Hey Kall, I downloaded and installed the new one and it's working for me (granted, the other one worked for me too). Thanks Kall.

Last edited by dastar; 17 Oct 2005 at 13:46.
Reply With Quote
  #99  
Old 17 Oct 2005, 13:42
vBFreak's Avatar
vBFreak vBFreak is offline
 
Join Date: Nov 2001
Yeah, same for me, seems to work now...

Thanks for that great plugin
Reply With Quote
  #100  
Old 17 Oct 2005, 16:00
HUMMERh3 HUMMERh3 is offline
 
Join Date: Oct 2005
How does one install this... uploaded file"product-nzbgroupallowhtm3.5.0.xml" to plugin manager...but what do I do with "bitfield_allowhtml.xml" could someone please tell me as I am new at this.

Thanks!
Reply With Quote
  #101  
Old 17 Oct 2005, 16:08
Andreas's Avatar
Andreas Andreas is offline
 
Join Date: Jan 2004
Real name: Andreas
1) Uninstall
2) Upload the bitfield XML to includes/xml
3) Install

This is necessary, otherwise the bitfield cache will not get rebuilt resulting in errors in usergroup manager
Reply With Quote
  #102  
Old 17 Oct 2005, 17:44
-=Sniper=-'s Avatar
-=Sniper=- -=Sniper=- is offline
 
Join Date: May 2002
thanks man, this should be a default feature really.
Reply With Quote
  #103  
Old 18 Oct 2005, 08:56
Tulsa Tulsa is offline
 
Join Date: Jul 2005
Yep, working great!
Reply With Quote
  #104  
Old 20 Oct 2005, 03:35
Vtec44 Vtec44 is offline
 
Join Date: Jan 2005
Originally Posted by Andreas
Once again:
If you uninstall Hack the use custom Bitfields you must always delete the Bitfield XML before uninstalling it.
I deleted the bitfield_allowhtml.xml, then uninstalled the product, and got the error message below when creating a new user group:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #105  
Old 20 Oct 2005, 12:26
davidms davidms is offline
 
Join Date: Oct 2005
I'm new to this

Hey everone, I'm brand new to this, and I'm not sure how to install this plugin is there several 'hooks' that I install on this plugin or do I only install 2, - 1 for each file? (there are only two files in the plugin)

I read the general forum instructions for plugins, but I'm still not sure what to do. I'm not sure how to install this plugin.

Dave :nervous:

Last edited by davidms; 20 Oct 2005 at 12:29.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 07:41.

Layout Options | Width: Wide Color: