Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
[AJAX] Tabbed Forum Home Details »
[AJAX] Tabbed Forum Home
Mod Version: 1.5.0, by bobster65 (Member) bobster65 is offline
Developer Last Online: Nov 2013 I like it Show Printable Version Email this Page

vB Version: 3.8.x Rating: (75 votes - 4.92 average) Installs: 592
Released: 10 Apr 2008 Last Update: 03 Sep 2008 Downloads: 9237
Not Supported Template Edits Code Changes Additional Files Translations  

Tabbed Forum Home version 1.01

[AJAX] Tabbed Forum Home version 1.5.0 (BETA)

NOTE: Works with both 3.7x and 3.6x

Description: This MOD is for creating a "Tabbed" Forum Home Page to have Categories displayed within Tab containers (similar to what the new Profile System looks like on vb3.7). Please do not confuse this with the Tab Menu System here at vbulletin.org. They are totally different systems. These Tabs actually switch the content without leaving the main forums page.

I wrote the initial Non AJAX version based on reading many requests from members asking about how namepros created their custom tabbed forum home page. The first implementation I did was a request by bbwforums.net (which you can visit to see a working example). I have shared this version with many members already and decided to release it since it seems to be something that a lot of members are interested in.

UPDATE: I have released a BETA [AJAX] version for those that what something a little more robust and easier to install/configure. This Beta version will never go into production tho as version 2.0 will utilize the YUI AJAX Tabview Toolset. It IS stable tho and is currently running on a few live sites.

NOTE: Keep in mind, I wrote this with the assumption that you are fairly well versed and comfortable with editing files/templates and following the flow of things. If there is something you don't understand, PLEASE let me know so that I can help you understand it. This IS NOT a product that a novice can just plug and play and it takes a little bit of time to setup, but its well worth it in the end (if you want a custom unique look to your forum home page)... the next version (Don't ask when, cause its just on the drawing board) will be a product with ACP controls for easy setup

The attached Zip File(s) contain the Files and Instructions necessary to install each version.

DEMO: www.bbwforums.net or www.namepros.com
[Moderator Edit: The first URL has been un-linked as there has been reported malware on that domain. The mod author may edit this notice once the situation has been cleaned.]

Screen Shots: None, visit one or both of the above links as seeing them in action is better than some static image(s)..

Bobster

Change Log

version 1.01 -
tabcontent.js ver 2.2 to support remote links
updated install instructions (both in txt and rtf format)

version 1.5.0 -
BETA [AJAX] version

July 8, 2008 - Added xml file for WOL
Sep 2, 2008 - Updated xml file for WOL

Download Now

Only licensed members can download files, Click Here for more information.

Supporters / CoAuthors

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #406  
Old 22 Jun 2008, 00:52
bobster65's Avatar
bobster65 bobster65 is offline
 
Join Date: Mar 2006
Real name: Bob
Originally Posted by vidan View Post
hello bob, tryin to install,but fail. the tabs showed perfectly, but when click one or another tab it open nothing, only the loading.gif then no forum come out.

in step 3 :

STEP 3 - Create a NEW Template: FORUMHOMETAB


in step 4 :Insert this line at the very begining of the template.
------------------------------------------------------
<if condition="(THIS_SCRIPT == 'tabforumhome' AND in_array($forum['forumid'], $GLOBALS[tabcats])) OR THIS_SCRIPT == 'forumdisplay'">

is it tabforumhome or forumhometab? or both correctly?

thanks
THe THIS SCRIPT is for the php file which is named tabforumhome.php I purposely named the template just the opposite so that there would be no confusion lol
__________________
Please Do Not PM me for vBulletin assistance... I am currently only doing customization & addon's for Xenforo.
Reply With Quote
  #407  
Old 22 Jun 2008, 00:55
bobster65's Avatar
bobster65 bobster65 is offline
 
Join Date: Mar 2006
Real name: Bob
Originally Posted by vidan View Post
hello

i include my lv1 nopost and lv1post
you have not applied the template changes to those two templates.... read the install doc again, it shows you what template changes need to be made.. its the simplest template edit possible as you insert one line of code at the very beginning of the template and one tag at the very end..
__________________
Please Do Not PM me for vBulletin assistance... I am currently only doing customization & addon's for Xenforo.
Reply With Quote
  #408  
Old 22 Jun 2008, 11:49
Reminisce32 Reminisce32 is offline
 
Join Date: Jul 2007
Hi.. i think i did everything correctly but the tabs are not showing

you can see how it looks here http://www.maddengurus.com/forums/?styleid=1

or just go to the bottom and change the template to Default Style

what did i do wrong?

when i go to http://www.maddengurus.com/forums/tabforumhome.php

it shows Warning: in_array() [function.in-array]: Wrong datatype for second argument in /includes/functions_forumlist.php(350) : eval()'d code on line 1

is something wrong with tabforumhome.php in the beta version?

Last edited by Reminisce32; 22 Jun 2008 at 12:40.
Reply With Quote
  #409  
Old 22 Jun 2008, 12:54
Scamorz Scamorz is offline
 
Join Date: Oct 2006
Hi bob, thank you for this mod. It works but i found some problems...

I had to put /forum/ in the path to ajaxtabs.css and ajaxtabs.js
The script now is working but i don't see loading.gif

In Internet Explorer 6 i see this picture in the attachment:
Attached Images
File Type: jpg problem.jpg (12.4 KB, 43 views)
Reply With Quote
  #410  
Old 22 Jun 2008, 13:44
Reminisce32 Reminisce32 is offline
 
Join Date: Jul 2007
scamorz, any idea why mine looks the way it does? i checked the template edits over and over and i uploaded everything to the right place.
Reply With Quote
  #411  
Old 22 Jun 2008, 14:12
Scamorz Scamorz is offline
 
Join Date: Oct 2006
reminisce i dont' know. You can try to add /forum to the path before /clientscript/tabs/ajaxtabs.css and /clientscript/tabs/ajaxtabs.js in forumhome....so it works for me.
Reply With Quote
  #412  
Old 22 Jun 2008, 14:22
Reminisce32 Reminisce32 is offline
 
Join Date: Jul 2007
fixed it.. had to put the whole link from http://---------ajaxtabs.css and .js.

thanks
Reply With Quote
  #413  
Old 22 Jun 2008, 16:52
Reminisce32 Reminisce32 is offline
 
Join Date: Jul 2007
for some odd reason when i add another tab.. it adds it.. but when i click it it also pulls up another tab so two tabs come up and it wont open by itself.. anyone seen this before?
Reply With Quote
  #414  
Old 22 Jun 2008, 16:53
bobster65's Avatar
bobster65 bobster65 is offline
 
Join Date: Mar 2006
Real name: Bob
Originally Posted by Reminisce32 View Post
for some odd reason when i add another tab.. it adds it.. but when i click it it also pulls up another tab so two tabs come up and it wont open by itself.. anyone seen this before?
post your code.
__________________
Please Do Not PM me for vBulletin assistance... I am currently only doing customization & addon's for Xenforo.
Reply With Quote
  #415  
Old 22 Jun 2008, 17:09
Reminisce32 Reminisce32 is offline
 
Join Date: Jul 2007
edit... nevermind i saw the problem

..great mod. cant wait for the next version.

Last edited by Reminisce32; 22 Jun 2008 at 17:22.
Reply With Quote
  #416  
Old 22 Jun 2008, 18:02
Scamorz Scamorz is offline
 
Join Date: Oct 2006
Ok, i edited the path in .js file and now i see loading.gif
But in IE 6 i see this bad layout:
How i can resolve it?
Attached Images
File Type: jpg problem.jpg (12.4 KB, 24 views)
Reply With Quote
  #417  
Old 22 Jun 2008, 18:06
bobster65's Avatar
bobster65 bobster65 is offline
 
Join Date: Mar 2006
Real name: Bob
Originally Posted by Scamorz View Post
Ok, i edited the path in .js file and now i see loading.gif
But in IE 6 i see this bad layout:
How i can resolve it?
Play around with the CSS a little. Just make a copy of the original and start making adjustments to it (thats how I do it).. I am far from a CSS junkie lol .. Friggin IE messes everything up.. works fine for you in FF tho?
__________________
Please Do Not PM me for vBulletin assistance... I am currently only doing customization & addon's for Xenforo.
Reply With Quote
  #418  
Old 22 Jun 2008, 18:18
Scamorz Scamorz is offline
 
Join Date: Oct 2006
In FF works fine...
i am not expert in css...but i try to modify something

EDIT: i deleted <br style="clear: left" /> and now the layout in IE6 is ok!
Great mod!

Last edited by Scamorz; 22 Jun 2008 at 18:29.
Reply With Quote
  #419  
Old 22 Jun 2008, 18:28
bobster65's Avatar
bobster65 bobster65 is offline
 
Join Date: Mar 2006
Real name: Bob
Originally Posted by Scamorz View Post
In FF works fine...
i am not expert in css...but i try to modify something
do you have a link to your site so I can look at it in IE?
__________________
Please Do Not PM me for vBulletin assistance... I am currently only doing customization & addon's for Xenforo.
Reply With Quote
  #420  
Old 22 Jun 2008, 19:10
karnevil's Avatar
karnevil karnevil is offline
 
Join Date: Feb 2007
Hmmm well i'm not sure what I am doing wrong

www.legalbeagles.info/forums/tabforumhome.php

The 'tabs' end up being a bullet point list and there are no forums on forumhome at all, then if you click on each ''tab'' it takes you to www.legalbeagles.info/forums/tabforumhome.php with the relevant forum categories on - without any of the forum formatting (standard forumhome is www.legalbeagles.info/forums


I did all the template changes, and created the new template, and treble checked them, and the files are uploaded. I can't work out what I am missing at all.

Have removed template changes for now.

Am I missing something really obvious ?

Thanks in advance.
__________________
www.legalbeagles.info
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 20:27.

Layout Options | Width: Wide Color: