Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
AME 2.5 - Media Embedding for posts, sigs, vm's, groups and blogs Details »
AME 2.5 - Media Embedding for posts, sigs, vm's, groups and blogs
Mod Version: 2.5.6, by The Geek (Coder) The Geek is offline
Developer Last Online: Jan 2019 I like it Show Printable Version Email this Page

vB Version: 3.8.0 Rating: (192 votes - 4.75 average) Installs: 1968
Released: 20 Jan 2009 Last Update: 09 Dec 2009 Downloads: 12894
Not Supported DB Changes Uses Plugins Template Edits Additional Files  

From the makers of the letters O and Yea comes the hottest 'must have mod' of the season: AME 2.5 - The Return of The Hot Mama.

Thanks everyone for making AME 2.5 Mod of the Month

AME is the multi award winning modification that smartly scans new and edited posts for URLs from a customisable variety of web sites (i.e. YouTube or Amazon or about 200 others). If it finds a match, AME will 'transform' the URL into inline embedded media without your users ever having to even think about it.

It was important for me to create a system that did not need updating (and subsequent reinstalling) every time one of the sites it supported decided to change the way it displayed its media (which is all the fricken time). Therefore I built a system in which the 'definitions' for each site could be imported, exported, tweaked and shared on a whim. This way, you only have to import the definitions that you want. It also allows the vB community to get creative and share definitions that I wouldn't of thought of!

Which sites are supported?

Included in the default installation is YouTube and Amazon. At time of posting this, I believe that there are over 180 sites supported that have been created by the vBulletin community. These range from sites that stream videos to Amazon referral links to locally hosted music and video files.

Check out the 'add ons' section of this post below to see availible add-ons.

For a total list of features and an FAQ, see click here.
For a post on troubleshooting, click here.

Though not tested on any version of vBulletin lower than 3.7.4, in theory it should work on versions 3.5 and higher (just dont quote this bit!).

Big thanks goes out to all those in the community that have supported this mod. Especially Digital Jedi who gives great support on this mod and has created over 160 definitions for this system alone!


Installation/Upgrade
  • Upload the contents of the forums folder into your forums directory and import the product-ame.xml file into your product manager (if upgrading, choose 'yes' to overwrite previous installation).
  • After installation, make sure that the system is on (admincp->AME CP->Settings)
  • Then you may want to try to rebuild old URLs via the tools option.

Change Log
nJoy

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	newpost.jpg
Views:	6640
Size:	26.4 KB
ID:	93148   Click image for larger version

Name:	newpost_result.jpg
Views:	9506
Size:	61.9 KB
ID:	93149  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases DJ's AMEs :: Media Definitions for AME 2.5 :: More Video, Twitter, Pinterest... Digital Jedi vBulletin 3.8 Add-ons 2086 05 Sep 2018 16:05
Add-On Releases Digital Sith's AMEs - ADULT Media Definitions Digital Sith vBulletin 3.6 Add-ons 66 08 Sep 2015 23:44
Show Thread Enhancements AME 2.0 -Auto Media Embedding for posts, blogs, visitor and group messsages The Geek vBulletin 3.7 Add-ons 954 25 May 2014 10:58
Add-On Releases DJ's AME (Auto Media Embedding) XML Media Definitions (Third Time's the Charm) Digital Jedi Modification Graveyard 828 10 Mar 2010 06:45

  #391  
Old 01 Mar 2009, 22:59
Parafal Parafal is offline
 
Join Date: Feb 2009
Hi,

I installed it and my VB Forum became slow to post. Is this normal? Is there a way to avoid this?

I'm using the cache option.

thanks
Reply With Quote
  #392  
Old 01 Mar 2009, 23:12
Gladhatter Gladhatter is offline
 
Join Date: Oct 2008
Location: Clintwood VA
Real name: Charlie Swindall
Originally Posted by jdougher View Post
No, and a whole lot of the videos mentioned here do not work. What's with this stupid plugin?

You know the old addage about birds of a feather flocking together?

I think this is a perfect examply. You and the "Stupid" part of the stupid plugin seem to share some commanality and are flocking pretty tight.

I have a suggestion, Why not contact D.J. and offer him 50 dollars for each of the vids you wish added and then share them all freely with us once you get them unless he refuses the work for underpayment.
__________________
Visit the SBS to learn about traditional hat making skills and the finest pure sterling beaver custom handmade bespoke commissioned hats in the universe. www.gladhatter.com.
Reply With Quote
  #393  
Old 02 Mar 2009, 02:05
Gladhatter Gladhatter is offline
 
Join Date: Oct 2008
Location: Clintwood VA
Real name: Charlie Swindall
Originally Posted by Parafal View Post
Hi,

I installed it and my VB Forum became slow to post. Is this normal? Is there a way to avoid this?

I'm using the cache option.

thanks
Some one else ask and my forum as well became a turtle speed to post on but we installed about 50 mods hacks and custom codes and such and Geek says this should not slow it at all. I take his word for it but I also need to find what is really slowing mine some day soon.
__________________
Visit the SBS to learn about traditional hat making skills and the finest pure sterling beaver custom handmade bespoke commissioned hats in the universe. www.gladhatter.com.
Reply With Quote
  #394  
Old 02 Mar 2009, 08:27
Gamelobby's Avatar
Gamelobby Gamelobby is offline
 
Join Date: Jul 2007
Is there a way for this to work in the Competitions.php (Tournaments & Ladders system.?)

Also, when i do a Version check i get this..?
Version check failed. No version number was found at this location. The URL for the version check may be incorrect, or the server may be experiencing problems. Please try again later.
Reply With Quote
  #395  
Old 03 Mar 2009, 04:13
jayjenxi jayjenxi is offline
 
Join Date: Nov 2007
The embedded video appears twice. Did I do something wrong here?
__________________
Advent Destiny - a Gundam SEED role play
Reply With Quote
  #396  
Old 03 Mar 2009, 05:56
Gladhatter Gladhatter is offline
 
Join Date: Oct 2008
Location: Clintwood VA
Real name: Charlie Swindall
Originally Posted by jayjenxi View Post
The embedded video appears twice. Did I do something wrong here?

Yes you have duplicate definitions for this paticular site and maybe more sites or all of them. You will need to remove the duplicate.
__________________
Visit the SBS to learn about traditional hat making skills and the finest pure sterling beaver custom handmade bespoke commissioned hats in the universe. www.gladhatter.com.
Reply With Quote
  #397  
Old 03 Mar 2009, 10:13
RedDevil's Avatar
RedDevil RedDevil is offline
 
Join Date: Mar 2008
Real name: Steve
I have a problem with one of the internal link definitions.


I posted a link in the staff room referencing a members profile, the link was not displayed just the message, on investigating i disabled:

**Internal Linking (Member Profiles) then retested links appeared anyone else have this problem or is it being affected by another hack or maybe a bug.
Reply With Quote
  #398  
Old 03 Mar 2009, 18:16
The Geek's Avatar
The Geek The Geek is offline
 
Join Date: Sep 2003
Originally Posted by Parafal View Post
Hi,

I installed it and my VB Forum became slow to post. Is this normal? Is there a way to avoid this?

I'm using the cache option.

thanks
What is happening is that when you are submitting a post with one or more definitions in it, AME is fetching the contents of each destination page to extract data (i.e. titles and such). This will only happen when there is an ame match and the definition requests the info. You can however disable extraction per definition or on a global level without a problem (you just lose some of the whistles and bells). Note that some custom definitions may require extraction to be on though.

Originally Posted by Gamelobby View Post
Is there a way for this to work in the Competitions.php (Tournaments & Ladders system.?)

Also, when i do a Version check i get this..?
If it has hooks in the right areas, it shouldn't be a problem. Check out AMEs hooks for visitor messages, social messages, blogs, etc... to get an idea of how easy it is

Originally Posted by Red-Devil View Post
I have a problem with one of the internal link definitions.


I posted a link in the staff room referencing a members profile, the link was not displayed just the message, on investigating i disabled:

**Internal Linking (Member Profiles) then retested links appeared anyone else have this problem or is it being affected by another hack or maybe a bug.
If it was a custom definition, check with the author, they'll know for sure

HTHs!
Reply With Quote
  #399  
Old 03 Mar 2009, 21:19
davew davew is offline
 
Join Date: Oct 2005
Originally Posted by davew View Post
Hi,

Firstly, thanks for all your work on this Mod!

I'm sure I'm overlooking something dumb, but each time I post a link (internal or external) on my forum, AME converts the link to :

**Internal Linking (Threads)

and the link points back to the thread I've posted in.

If I disable AME and edit the post the original information shows, EG :
[ame="http://www.rx7club.com/showthread.php?t=806104"]Making The Case For The <Rotary> Powered FD: The Fix/ 2nd edit starts post 84, ^ info - RX7Club.com[/ame]

Running 3.8.1, AME 2.5.4, some other mods..

Any suggestions welcomed, and FYI I found somebody with a similar problem on vbulletin.com, not sure if he resolved it or not.

Cheers,
Dave
Hi Geek,

I'm guessing you missed my question, and I'd really appreciate some help - my forum just went "live" and I'd love to get this sorted

Pretty please!

Regards,
Dave
Reply With Quote
  #400  
Old 03 Mar 2009, 22:50
psychotica psychotica is offline
 
Join Date: Dec 2006
Hi Geek

When i put the File cache on the AME doesn't works, it display the URL of the Movie with the title but the video and the container didn't appear.

The path is correct and the folder has CHMOD 777.

Thanks.
Reply With Quote
  #401  
Old 04 Mar 2009, 09:52
The Geek's Avatar
The Geek The Geek is offline
 
Join Date: Sep 2003
Originally Posted by davew View Post
Hi Geek,

I'm guessing you missed my question, and I'd really appreciate some help - my forum just went "live" and I'd love to get this sorted

Pretty please!

Regards,
Dave
Hey Dave, based on what you have put, I would assume this is caused by a custom definition not working as expected. I can only provide support for the default ones so if indeed its a custom one, you'll need to ask the author. Otherwise let me know and ill be all over it
Reply With Quote
  #402  
Old 04 Mar 2009, 09:55
The Geek's Avatar
The Geek The Geek is offline
 
Join Date: Sep 2003
Originally Posted by psychotica View Post
Hi Geek

When i put the File cache on the AME doesn't works, it display the URL of the Movie with the title but the video and the container didn't appear.

The path is correct and the folder has CHMOD 777.

Thanks.
I doubt the problem is with the file cache (youll get warnings in the AME AdminCP if there is something suspect about your file cache).

I would lay money on the fact that you are trying to embed a video that has external embedding disabled. Check to make sure you can embed the video by looking at the destination page. Otherwise, paste the URL for me to check out.

HTHs
Reply With Quote
  #403  
Old 04 Mar 2009, 12:58
davew davew is offline
 
Join Date: Oct 2005
Originally Posted by The Geek View Post
Hey Dave, based on what you have put, I would assume this is caused by a custom definition not working as expected. I can only provide support for the default ones so if indeed its a custom one, you'll need to ask the author. Otherwise let me know and ill be all over it
Thanks very much for the response!

I have installed DJ's Definitions.. never thought to look there

Will update soon!

Cheers,
Dave
Reply With Quote
  #404  
Old 04 Mar 2009, 23:15
whaase whaase is offline
 
Join Date: May 2006
What code do I type into the vbadvanced BBcode module? I tried just the Youtube adress, it just displays the address.

I also tried [BBCODE=youtube]dqlbsiDL3A4[/BBCODE]

And it displays exactly that lol

Thanks
Reply With Quote
  #405  
Old 05 Mar 2009, 10:56
bjhuang bjhuang is offline
 
Join Date: Jul 2006
in newthread.php


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

an ending div tag is missing.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:25.

Layout Options | Width: Wide Color: