Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
VSa - Advanced Forum Statistics (AJAX) Details »
VSa - Advanced Forum Statistics (AJAX)
Mod Version: 7.1, by Valter (Coder) Valter is offline
Developer Last Online: May 2014 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (238 votes - 4.74 average) Installs: 2509
Released: 14 Feb 2010 Last Update: 02 Aug 2012 Downloads: 19846
Not Supported DB Changes Uses Plugins Auto-Template  

Info:
AJAX Forum Statistics:
-Latest Posts
-Latest Forum News
-Most Viewed Threads
-Hottest Threads
-Most Popular Forums
-Latest Classified Ads
-Latest Blog Entries
-Latest Group Posts
-Newest Members
-Top Posters
-Top Thread Starters
-Top Referrers
-Top Reputations
-Top Thanked
-Top Infractions
-Profile Visits
-Latest Social Groups
-Latest Donations

You can turn on/off individual stats, count data from last x days for some of them if you wish, trim titles/usernames to save page space, make several other functionality/make-up customizations... See screenshots.


You can have Main Stats box shown on several pages...
It's shown by default on forumhome (to disable it set "Main Top Stats box on ForumHome" to "None")
To activate another location:
a) add THIS_SCRIPT name to "Stats on pages" field in product options
b) add template name to "Stats in templates" field in product options
c) add "{vb:raw vsatopstats}" to the template you added Stats to


Notes:
-To set options go to: vBulletin Options > VSa - Advanced Forum Statistics
-"Top Thanked" requires Abe1's "Post Thanks" or Scandal's "Thumbs Up?" products to work
-"Latest Donations" requires "VSa - PayPal Donate" hack to work
-To move Top Stats box somewhere else on forumhome: 1.-Set placement setting to "None" 2.-Add "index" to "Stats on pages" setting 3.-Add "FORUMHOME" to "Stats in templates" setting 4.-Add "{vb:raw vsatopstats}" wherever you wish in FORUMHOME template.
-If Top Stats box is messed up because of long usernames or thread/forum titles be noted that you can trim them in ACP options.
-When forum/thread titles or usernames are trimmed, mouse-over will show you full version.


Installation:
-Import XML file (as product) through AdminCP: Plugin System > Manage Products > [Add/Import Product]


Versions:
v1.0 - Jun 12. 2006.
-First release
v6.6.1 - May 14. 2009.
-Latest vB 3.x version
v7.0 - Feb 14. 2010.
-First vB4 release
-Fixed some previous version bugs, optimized code
v7.0.1 - Feb 16. 2010.
-Fixed: Newpost/lastpost linking in 'Latest Posts'
-Fixed: Errors with PHP 5.3
-Fixed: AFS table messed up in footer
-Fixed: Several style errors, including XHTML incompatibilities
-New: Auto-insert on forumhome location - Below Forums
v7.0.2 - Feb 22. 2010.
-Fixed: Several style issues for unregistered users
-Fixed: 'Latest Donations' issues
-Fixed: Import error on some configs
-Fixed: Minor bugs
v7.0.3 - Apr 12. 2010.
-Fixed security bug (user able to set number of results manually)
v7.0.4 - Jan 14. 2012.
-Fixed: Status icons must be GIFs
-Fixed: Status icon overlay problems in Chrome and Safari
-Fixed: Drop-down menu items invisible until highlighted
-Fixed: Last unread post links not compatible with vBSEO
-Fixed: Search Member's posts shows results as threads
-Added: Rich thread prefix support
-Improved: CSS compatibility
-Minor bugs fixed
v7.0.5 - Jan 15. 2012.
-Links in Latest Posts are now fully SEO compatible
-New option: Automatically disable auto-refresh if server load is higher than X
v7.0.6 - Jan 17. 2012.
-Fixed: Prefixes linked in some thread stats
v7.0.7 - Jan 22. 2012.
-New: Show Stats in selected forum only
-Fixed: Some style issues
-Improved: Product menu style
-Improved: Menu disappears on click
-Changed background color variable: 'editor_background' used for better compatibility with custom styles
v7.0.8 - May 27. 2012.
-Fixed: QL Enable Stats link in vB 4.2
v7.0.9 - Jul 07. 2012.
-Fixed: Hide on misc.php requests not related to Stats
v7.1 - Avg 02. 2012.
-New: Top Thanked now works with "Thumbs Up?" system by Scandal
-Note: Above still works with "Post Thanks" system by Abe

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Screenshots

Click image for larger version

Name:	stats1.jpg
Views:	21147
Size:	178.7 KB
ID:	112315   Click image for larger version

Name:	stats2.jpg
Views:	14916
Size:	153.8 KB
ID:	112316   Click image for larger version

Name:	menu.jpg
Views:	9659
Size:	65.4 KB
ID:	112317   Click image for larger version

Name:	more.jpg
Views:	10644
Size:	73.7 KB
ID:	112318  

Click image for larger version

Name:	acp1.jpg
Views:	7317
Size:	109.4 KB
ID:	112319   Click image for larger version

Name:	acp2.jpg
Views:	6041
Size:	117.0 KB
ID:	112320  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Statistics Modifications Cyb - Advanced Forum Statistics Valter vBulletin 3.8 Add-ons 1232 19 Aug 2020 09:32
Statistics Modifications Cyb - Advanced Forum Statistics Valter vBulletin 3.7 Add-ons 651 02 Sep 2013 13:25
Statistics Modifications Cyb - Advanced Forum Statistics Valter vBulletin 3.6 Add-ons 1599 15 Feb 2013 03:33
Cyb - Advanced Forum Statistics Valter vBulletin 3.5 Add-ons 116 16 May 2010 03:57

  #1156  
Old 16 Sep 2013, 14:19
Edog Edog is offline
 
Join Date: Dec 2004
Originally Posted by Lena Gk View Post
i had this issue too. fixed it by playing around with the template. Find "vsa_topstats_newposts"

and search for "width:1%;white-space:nowrap;text-align:center;vertical-align:middle;" Remove any padding info right before it in the style, and set width to 2%. Save>reload and they should show up again
Thanks alot this worked great although now they are a little smushed so to speak but at least showing up
Reply With Quote
  #1157  
Old 07 Oct 2013, 06:47
frightie frightie is offline
 
Join Date: Aug 2003
I upgraded my VB to 4.2.1 recently and like many of you I had issues with the background being white. It took me a while, but I was able to fix the background by tweaking the appropriate templates. You can find everything you need to edit in Valter Templates.

For the LATEST POSTS row:

EDIT the template vsa_topstats_stats
SEARCH for vsastats_lpdiv (ignore the first result)
REPLACE background-color:{vb:stylevar editor_background.backgroundColor};
WITH background-color:#HEXCOLORHERE;

SEARCH again vsastats_lpdiv (should be just below previous one)
REPEAT steps above
SAVE

If you use another row that contains blocks you'll need to edit the template for that specific block. For example I have two blocks in a single row: Latest Blog Entries and Most Viewed Threads. So I had to edit the templates that correspond with each block, which were vsa_topstats_blogs and vsa_topstats_mostviewed. If you have something else like Most Popular Forums then you'd edit vsa_topstats_topfurms, etc..

Once you're in the correct template:

LOOK where it says <td style="padding:0px
ADD background-color:#HEXCOLORHERE; right before the padding:0px

EXAMPLE:

<td style="padding:0px

BECOMES

<td style="background-color:#000000;padding:0px

So you're just basically adding that small background line before each padding in the template, which should be 4 times.

See the attached image as an another example. Hope this helps.
Attached Images
File Type: jpg exmp.jpg (39.0 KB, 37 views)
Reply With Quote
  #1158  
Old 13 Oct 2013, 22:00
johnbmtl johnbmtl is offline
 
Join Date: Dec 2007
Forums Disappear

I just downloaded the latest version to my vBulletin (4.1.10).

The stats section doesn't appear anywhere and if I choose any option besides "below navbar" the forums disappear completely.

If I uninstall the mod, I have no forums at all.

Please help.
Reply With Quote
  #1159  
Old 14 Oct 2013, 05:23
huyhk huyhk is offline
 
Join Date: Apr 2012
I am wondering why it does not have Latest Threads?
Reply With Quote
  #1160  
Old 16 Oct 2013, 20:25
ZnaZ ZnaZ is offline
 
Join Date: Jan 2009
Real name: Göran Thörn
I updated to 4.2.2
and get the following error when I go into the community
Function split() is deprecated in ..../forum.php(791) : eval()'d code on line 49
and it disappears when I turn off VSa - VILXH - MN forumhome_complete
Reply With Quote
  #1161  
Old 16 Oct 2013, 21:26
ozzy47's Avatar
ozzy47 ozzy47 is offline
 
Join Date: Aug 2009
Real name: Chris
That is not from this mod, it's from this one, VSa - Visitors In Last X Hours

It has been updated to solve the errors.
__________________
You can get access to my 180 mods for vB 3.6 - 4.x at The Admin Zone as well as the professional support you are used to. New vBulletin Spider Definitions, vBulletin Spiders List Hits 1000 Spiders! ​ OzzModz down. Site has had a data breach, checking how the intrusion happened. Change your PW if you use the same one on my site and others.
Reply With Quote
  #1162  
Old 17 Oct 2013, 16:37
tsptom tsptom is offline
 
Join Date: Jan 2006
I have had this loaded for years and it works great. However, I have one members who says he can't get past the "loading" issue.

I made sure it wasn't the "not complete" URL issue that some have reported.

He says it works correctly for him on his home computer using Firefox, but at work he's using IE8 and it's not loading.

Are there any IE issues / settings that need to set / unset?

Thanks!
Reply With Quote
  #1163  
Old 17 Oct 2013, 18:55
tsptom tsptom is offline
 
Join Date: Jan 2006
Here's the error msg he's getting...

Internet Explorer's Cross-Site Scripting (XSS) Filter can help prevent one website from adding script code to another website. XSS Filter watches how websites interact, and when it recognizes a potential attack, it will automatically block script code from running. When this happens, you will see a message in the Information bar letting you know that the webpage was modified to help protect your privacy and security.
Originally Posted by tsptom View Post
I have had this loaded for years and it works great. However, I have one members who says he can't get past the "loading" issue.

I made sure it wasn't the "not complete" URL issue that some have reported.

He says it works correctly for him on his home computer using Firefox, but at work he's using IE8 and it's not loading.

Are there any IE issues / settings that need to set / unset?

Thanks!
Reply With Quote
  #1164  
Old 17 Oct 2013, 21:35
SPEEDKILLZ SPEEDKILLZ is offline
 
Join Date: Feb 2011
Real name: Chris
Love this mod, only 1 problem. Where and how do i fix this?
Attached Images
File Type: jpg stats.jpg (59.9 KB, 45 views)
__________________
Reply With Quote
  #1165  
Old 17 Oct 2013, 22:08
SPEEDKILLZ SPEEDKILLZ is offline
 
Join Date: Feb 2011
Real name: Chris
Only shows up like that when logged in.
__________________
Reply With Quote
  #1166  
Old 17 Oct 2013, 22:34
Ba'al's Avatar
Ba'al Ba'al is offline
 
Join Date: Oct 2010
Originally Posted by SPEEDKILLZ View Post
Love this mod, only 1 problem. Where and how do i fix this?
Did you try reducing the size of the text in the header "Top 10 Stats" it looks a little to large for that header imo.
__________________
Reply With Quote
  #1167  
Old 17 Oct 2013, 23:29
tsptom tsptom is offline
 
Join Date: Jan 2006
Originally Posted by SPEEDKILLZ View Post
Love this mod, only 1 problem. Where and how do i fix this?
Nice looking forum. As a test, I would try to put the stats at the top of the page instead of the bottom and see if the format issue persists. If not, you know it might be another hack/ mod, and not the Stats block.
Reply With Quote
  #1168  
Old 18 Oct 2013, 00:05
SPEEDKILLZ SPEEDKILLZ is offline
 
Join Date: Feb 2011
Real name: Chris
Originally Posted by Ba'al View Post
Did you try reducing the size of the text in the header "Top 10 Stats" it looks a little to large for that header imo.
Where would i edit such text?

Originally Posted by tsptom View Post
Nice looking forum. As a test, I would try to put the stats at the top of the page instead of the bottom and see if the format issue persists. If not, you know it might be another hack/ mod, and not the Stats block.
Thank you, yes i have moved it with the same results.

For some reason only when logged on?
__________________
Reply With Quote
  #1169  
Old 18 Oct 2013, 00:18
ozzy47's Avatar
ozzy47 ozzy47 is offline
 
Join Date: Aug 2009
Real name: Chris
Does the same thing happen on a unmodified default style?
__________________
You can get access to my 180 mods for vB 3.6 - 4.x at The Admin Zone as well as the professional support you are used to. New vBulletin Spider Definitions, vBulletin Spiders List Hits 1000 Spiders! ​ OzzModz down. Site has had a data breach, checking how the intrusion happened. Change your PW if you use the same one on my site and others.
Reply With Quote
  #1170  
Old 18 Oct 2013, 00:26
SPEEDKILLZ SPEEDKILLZ is offline
 
Join Date: Feb 2011
Real name: Chris
Originally Posted by ozzy47 View Post
Does the same thing happen on a unmodified default style?
No sir, it was fine on my last style.
__________________
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
Luvilla
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:20.

Layout Options | Width: Wide Color: