Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Send Mass Emails Using the Mailqueue System Details »
Send Mass Emails Using the Mailqueue System
Mod Version: 1.0, by Abe1 (Coder) Abe1 is offline
Developer Last Online: Jun 2010 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.8 Rating: (5 votes - 4.80 average) Installs: 65
Released: 18 Feb 2007 Last Update: Never Downloads: 325
Not Supported Code Changes  

Send Mass Emails Using the Mailqueue System 1.0


I recently changed where I send emails for my forum from. I had been using by server and now switched to an outside place. I found that sending a mass email would take FOREVER since it would take a few seconds per email it had to send out.

I had my vb setting of "Use Mailqueue System" set to 'Yes' but I realized it was NOT using the queue.

I found the way to enable the queue and sending mass emails takes me just a few seconds now! (This hack makes sending emails from your own server much faster also.)

This hack enables the vb queue only if you have 'Use Mailqueue System' turned on. Sending mass emails will take you a few seconds instead of minutes of hours!

Installation:

Open file 'admincp/email.php'.

Search for:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


CHANGE it to:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Please post your comments or suggestions for this hack. I read ALL posts.

MAKE SURE YOU CLICK INSTALL!
You will get an email when a new version is released.

Download Now

Only licensed members can download files, Click Here for more information.

Supporters / CoAuthors

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #46  
Old 09 Sep 2007, 22:34
Abe1's Avatar
Abe1 Abe1 is offline
 
Join Date: Feb 2004
Real name: Abe
Originally Posted by BillP View Post
I am trying this on a large board (90K users), and it's taking forever for each screen to finish sending to the mailqueue. I tried 500 users per time, and it took a minute or more for the 500, and then you have to hit "next" so I was looking at a couple of hours of this.

So I stopped, upped it to 10K users per pass, and now it's just taking several minutes for each 10K pass.

On the outbound side, server load is very high, so I have reduced it to process 3 on each mailqueue pass, that seems to help a little. But the site is at a crawl. We have 2 web servers and a mysql slave setup, if it matters.
Then it must take a long time to connect to your mail server.
__________________
MY HACKS -

Active Link Security 3.0.X | Add Title to Rank Images 3.5.X | Admin Log In As User 3.5.X 3.6.X | Advanced BBCode Permissions 3.5.X 3.6.X | Can't See Attachments Before Thanking a Post 3.5.X | Can't Thank and Groan the Same Post 3.5.X | Delete Post when Giving Infraction 3.6.X | Edit New Thread Button 3.5.X | External Data Provider Usergroup Permissions Setting 3.5.X | Forms Hack 3.5.X, 3.6.X | Log Logins Hack 3.5.X 3.6.X | Moderator Statistics 3.5.X | Post Award Hack 3.0.X 3.5.X | [AJAX] Post Thank You Hack 3.0.X 3.5.X 3.6.X | [AJAX] Post Groan Hack 3.5.X 3.6.X | Post Thank You Hack Stats for vBadvanced CMPS 2.x 3.5.X | Search Title only in search drop-down 3.5.X, 3.6.X | 'vBMenu' DHTML User Option 3.5.X 3.6.X | vBShout on all pages! 3.5.X
Reply With Quote
  #47  
Old 10 May 2008, 19:34
Division Division is offline
 
Join Date: Apr 2004
My Emails dont take 3 hours anymore stamped. Only 3 minutes to 30,000
Reply With Quote
  #48  
Old 26 Jul 2008, 05:21
PoetJA-1975's Avatar
PoetJA-1975 PoetJA-1975 is offline
 
Join Date: Sep 2006
Real name: Jacquii Cooke
Thanx again for the share! Brilliant mod ABE

Jacquii.
Reply With Quote
  #49  
Old 26 Jul 2008, 22:47
gobears20 gobears20 is offline
 
Join Date: Feb 2004
I just installed this and I have a few questions.

Does this have to do with going into your AdminCp and going to Users>Send Email to Users? If it does, one of my big problems that I have had is that I have 13,600 members and when I would try to send an email to them, it would time out after a while and I would have to re-boot my server. Does this hack work well with emailing all of your users? It would be really nice because I have not been able to send out a mass email to them ina while.
Reply With Quote
  #50  
Old 27 Jul 2008, 02:29
PoetJA-1975's Avatar
PoetJA-1975 PoetJA-1975 is offline
 
Join Date: Sep 2006
Real name: Jacquii Cooke
Originally Posted by gobears20 View Post
I just installed this and I have a few questions.

Does this have to do with going into your AdminCp and going to Users>Send Email to Users? If it does, one of my big problems that I have had is that I have 13,600 members and when I would try to send an email to them, it would time out after a while and I would have to re-boot my server. Does this hack work well with emailing all of your users? It would be really nice because I have not been able to send out a mass email to them ina while.
It's specifically for the email users.

Jacquii.
Reply With Quote
  #51  
Old 27 Jul 2008, 08:44
Abe1's Avatar
Abe1 Abe1 is offline
 
Join Date: Feb 2004
Real name: Abe
Originally Posted by gobears20 View Post
I just installed this and I have a few questions.

Does this have to do with going into your AdminCp and going to Users>Send Email to Users? If it does, one of my big problems that I have had is that I have 13,600 members and when I would try to send an email to them, it would time out after a while and I would have to re-boot my server. Does this hack work well with emailing all of your users? It would be really nice because I have not been able to send out a mass email to them ina while.
Yes, this hack should help.
__________________
MY HACKS -

Active Link Security 3.0.X | Add Title to Rank Images 3.5.X | Admin Log In As User 3.5.X 3.6.X | Advanced BBCode Permissions 3.5.X 3.6.X | Can't See Attachments Before Thanking a Post 3.5.X | Can't Thank and Groan the Same Post 3.5.X | Delete Post when Giving Infraction 3.6.X | Edit New Thread Button 3.5.X | External Data Provider Usergroup Permissions Setting 3.5.X | Forms Hack 3.5.X, 3.6.X | Log Logins Hack 3.5.X 3.6.X | Moderator Statistics 3.5.X | Post Award Hack 3.0.X 3.5.X | [AJAX] Post Thank You Hack 3.0.X 3.5.X 3.6.X | [AJAX] Post Groan Hack 3.5.X 3.6.X | Post Thank You Hack Stats for vBadvanced CMPS 2.x 3.5.X | Search Title only in search drop-down 3.5.X, 3.6.X | 'vBMenu' DHTML User Option 3.5.X 3.6.X | vBShout on all pages! 3.5.X
Reply With Quote
  #52  
Old 07 Aug 2008, 16:34
Welshy2008's Avatar
Welshy2008 Welshy2008 is offline
 
Join Date: Jul 2008
Mine says "OK" and emails sent successfully - But no-one receives them. I have set it to "send to members that have selected "No Emails".

Any Ideas Please?

I have also changed the admincp / email.php file as told.
Reply With Quote
  #53  
Old 08 Aug 2008, 03:04
Abe1's Avatar
Abe1 Abe1 is offline
 
Join Date: Feb 2004
Real name: Abe
Originally Posted by Welshy2008 View Post
Mine says "OK" and emails sent successfully - But no-one receives them. I have set it to "send to members that have selected "No Emails".

Any Ideas Please?

I have also changed the admincp / email.php file as told.
This show not effect the actual emails.
__________________
MY HACKS -

Active Link Security 3.0.X | Add Title to Rank Images 3.5.X | Admin Log In As User 3.5.X 3.6.X | Advanced BBCode Permissions 3.5.X 3.6.X | Can't See Attachments Before Thanking a Post 3.5.X | Can't Thank and Groan the Same Post 3.5.X | Delete Post when Giving Infraction 3.6.X | Edit New Thread Button 3.5.X | External Data Provider Usergroup Permissions Setting 3.5.X | Forms Hack 3.5.X, 3.6.X | Log Logins Hack 3.5.X 3.6.X | Moderator Statistics 3.5.X | Post Award Hack 3.0.X 3.5.X | [AJAX] Post Thank You Hack 3.0.X 3.5.X 3.6.X | [AJAX] Post Groan Hack 3.5.X 3.6.X | Post Thank You Hack Stats for vBadvanced CMPS 2.x 3.5.X | Search Title only in search drop-down 3.5.X, 3.6.X | 'vBMenu' DHTML User Option 3.5.X 3.6.X | vBShout on all pages! 3.5.X
Reply With Quote
  #54  
Old 10 Aug 2008, 04:39
gobears20 gobears20 is offline
 
Join Date: Feb 2004
I just want to let you know that this works really well! It is not only fast, it doesn't crash sql!

I have not had communication with my users in a whike, because the last time I sent an email to all users, it took a long time, but it ended up crashing sql. I have 13,640 members on my board. I only sent 50 at a time and it took less than seven minutes.

Thanks so mch for this!

Does anybody know of a fix for send a PM to all users? I have used this and it crashes sql also. Any idea on sending a PM to all users?
Reply With Quote
  #55  
Old 13 Aug 2008, 23:04
Welshy2008's Avatar
Welshy2008 Welshy2008 is offline
 
Join Date: Jul 2008
It did work, just took a little time to get there. Tested again (only on one user addy) and it went straight through.


What I would like to know is what bbcode? - would I need to add to it to add the "Individual" username of the person that I send them too, Please?


Many Thanks,

Welshy2008
Reply With Quote
  #56  
Old 27 Aug 2008, 21:22
Welshy2008's Avatar
Welshy2008 Welshy2008 is offline
 
Join Date: Jul 2008
Can anyone answer my post above please?
Reply With Quote
  #57  
Old 24 Jul 2011, 14:27
hdraye hdraye is offline
 
Join Date: Jul 2004
would that still work with 4.xx?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 22:19.

Layout Options | Width: Wide Color: