Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Admin Log In As User Details »
Admin Log In As User
Mod Version: 3.21, by Abe1 (Coder) Abe1 is offline
Developer Last Online: Jun 2010 I like it Show Printable Version Email this Page

vB Version: 4.0.0 Rating: (113 votes - 4.83 average) Installs: 1340
Released: 16 Nov 2009 Last Update: 17 Nov 2009 Downloads: 6583
Not Supported Uses Plugins Auto-Template Translations  

Admin Log In As User


About this hack:
This hack allows any admin that you set in admin permissions, to log in as any user. You have to go to the user's profile page and there will be a link to 'Log In As This User'. Also, there is a link the drop down menu in the ACP User Manager. If you are logged in as another user, you will get a message on top of the forum saying, 'You are currently logged in as another user. Click here to log back into your account.'

This hack is very easy to install. This hack has only the admin yes/no option. Just install and it's ready to be used!

Enjoy!

Installation information on hack:
  • Files edited: 0
  • Templates edited: 0
  • Files to upload: 1 (Product file via ACP only)
  • Time to install: 5 seconds

Updates:

Version 3.20 (11/16/09):
  • Released for vb 4.0 beta 3
Version 3.21 (11/17/09):
  • Removed the option to log in as yourself.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	1.JPG
Views:	6369
Size:	35.8 KB
ID:	106183   Click image for larger version

Name:	2.jpg
Views:	4010
Size:	51.5 KB
ID:	106184   Click image for larger version

Name:	3.JPG
Views:	4465
Size:	66.6 KB
ID:	106185   Click image for larger version

Name:	4.jpg
Views:	3263
Size:	85.2 KB
ID:	106186  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Administrative and Maintenance Tools Admin Log In As User Abe1 vBulletin 3.7 Add-ons 302 06 Mar 2014 18:01
Only Show IP:Logged if user is admin or supermod, and disable Post report by user Fallout2man vBulletin 2.x Full Releases 32 30 Jul 2002 02:20

  #226  
Old 30 Jun 2010, 01:33
Dissst Dissst is offline
 
Join Date: Jun 2010
Real name: David
installed works like a champ 4.0.3
Reply With Quote
  #227  
Old 30 Jun 2010, 17:53
fulviods fulviods is offline
 
Join Date: Jan 2005
Installed on 4.0.4 , i set the permissions but nothing appear
Reply With Quote
  #228  
Old 07 Jul 2010, 18:35
karel1985 karel1985 is offline
 
Join Date: Mar 2007
Real name: Karel B.
Originally Posted by fulviods View Post
Installed on 4.0.4 , i set the permissions but nothing appear
Same here, upgrades, installed but link is not visible...
__________________
Dutch Pc Helpforum - www.pc-helpforum.be
Reply With Quote
  #229  
Old 07 Jul 2010, 19:20
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Originally Posted by fulviods View Post
Installed on 4.0.4 , i set the permissions but nothing appear
Originally Posted by karel1985 View Post
Same here, upgrades, installed but link is not visible...
Somewhere in the thread here there is a plugin change that needs to be made which will work with 4.0.4. Read through the thread and you will find it.
Reply With Quote
  #230  
Old 08 Jul 2010, 06:14
ArchAngelz ArchAngelz is offline
 
Join Date: May 2010
4.04 only started recently right? Looking at the last few posts in this thread, I don't see any way to do this plugin change.

Besides, v4.04 is broken; I had all my image attachments deleted after upgrading.
Reply With Quote
  #231  
Old 08 Jul 2010, 07:33
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Originally Posted by ArchAngelz View Post
4.04 only started recently right? Looking at the last few posts in this thread, I don't see any way to do this plugin change.

Besides, v4.04 is broken; I had all my image attachments deleted after upgrading.
It isn't just with 4.0.4 that this started. Like I said, there is a plugin change in the thread that WILL fix it so it will work for you. I had to read through all of the posts to find it myself.
Reply With Quote
  #232  
Old 08 Jul 2010, 16:04
Footman Footman is offline
 
Join Date: Mar 2010
Originally Posted by ArchAngelz View Post
4.04 only started recently right? Looking at the last few posts in this thread, I don't see any way to do this plugin change.

Besides, v4.04 is broken; I had all my image attachments deleted after upgrading.
Here's the post with the required fix.

http://www.vbulletin.org/forum/showp...&postcount=202
Reply With Quote
  #233  
Old 10 Jul 2010, 02:50
Wilfred1 Wilfred1 is offline
 
Join Date: Jul 2009
It has stopped working for me now using 4.0.4 so I am thinking it is clashing with another mod...not sure which one though
Reply With Quote
  #234  
Old 10 Jul 2010, 17:13
ArchAngelz ArchAngelz is offline
 
Join Date: May 2010
It really is quite funny how someone who doesn't know how to read is trying to criticise/accuse others as not trying to read.

Best part is that the fix he thought was the fix, turned out that it may not be the fix he thought it was; as confirmed by the original fix author!

Shot himself in the foot once again.

As they say "Discussing Stratagems on Paper". Sometimes it takes a trying out rather than just reading and theorising.
Reply With Quote
  #235  
Old 10 Jul 2010, 21:05
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Nonsense deleted. If you cant post nicely, dont post at all.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #236  
Old 11 Jul 2010, 00:01
Wilfred1 Wilfred1 is offline
 
Join Date: Jul 2009
It DOES WORK in v4.0.4 after doing the plugin change here:
http://www.vbulletin.org/forum/showp...&postcount=202

However I have found that it clashes with vbSEO - if you are using vbSEO then this mod MAY not work.

I will see if I can find out why but please don't hold your breath as I am hard pressed for time given the disaster that v4 is because it CONSUMES ALL MY BLOODY TIME

Last edited by Wilfred1; 11 Jul 2010 at 03:27.
Reply With Quote
  #237  
Old 11 Jul 2010, 00:04
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by Wilfred1 View Post
It DOES WORK in v4.0.4 after doing the plugin change here:
http://www.vbulletin.org/forum/showp...&postcount=202

However I have found that it clashes with vbSEO - if you are using vbSEO then this mod unfortunately will not work.

I will see if I can find out why but please don't hold your breath as I am hard pressed for time given the disaster that v4 is because it CONSUMES ALL MY BLOODY TIME
I have it installed with that fix and working with vBSEO and 4.04.
Reply With Quote
  #238  
Old 11 Jul 2010, 03:26
Wilfred1 Wilfred1 is offline
 
Join Date: Jul 2009
Originally Posted by djbaxter View Post
I have it installed with that fix and working with vBSEO and 4.04.
Now that is interesting...I disabled vbseo and it worked...re-enabled vbseo and it didn't
Reply With Quote
  #239  
Old 11 Jul 2010, 03:36
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by Wilfred1 View Post
Now that is interesting...I disabled vbseo and it worked...re-enabled vbseo and it didn't
For other reasons, I have disabled the vBSEO "Rewrite Member Profile URLs?" - try that.

Also, I've disabled the vBSEO "remove blank space" option. It does nothing useful and it interferes with some other functions and add-ons (e.g., rotating banners). I don't think that one will affect this add-on, but give it a try too if the first doesn't work.
Reply With Quote
  #240  
Old 12 Jul 2010, 21:50
snnggledel's Avatar
snnggledel snnggledel is offline
 
Join Date: Dec 2009
Real name: Brandy
Great mod Abe thanks for all the work you have done
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:26.

Layout Options | Width: Wide Color: