Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 27 Feb 2018, 19:49
FatboyJay FatboyJay is offline
 
Join Date: Feb 2017
Question regarding upgrade from 4.2 to 5.x

Hello,
Im curious on a few issues when upgrading from version 4.2 to 5.x

1 is there a fee to upgrade from 4.2 to 5.x ?
2. Which version of 5.x is the best? 5.1,5.3..5.4?
3. I NEED add-ons and such ( marketplace, auction," like "buttons, reputation system, donate/PayPal, etc)
4. Is there a solid comparison guide or video that may help me with these questions?

Thank you to all who can help me out here. Ill be looking through the forums more but any tips, comments and opinions are always appreciated.
Reply With Quote
  #2  
Old 27 Feb 2018, 20:42
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
1. If you have a valid vBulletin license that includes vBulletin 5 then no. If you have an old license then you have to pay for the vBulletin 5 license. You can check this at vbulletin.com after logging in.
2. Use the latest version of vBulletin 5. Any older versions will have bugs/exploits present.
3. vBulletin 5 has a limited amount of plugins. If you absolutely need certain complex plugins then your best bet is to stay at vBulletin 4.
4. Not that I know of, but vbulletin.com displays all of the features of vBulletin 5. https://www.vbulletin.com/en/features/
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #3  
Old 27 Feb 2018, 20:59
FatboyJay FatboyJay is offline
 
Join Date: Feb 2017
Originally Posted by Dave View Post
1. If you have a valid vBulletin license that includes vBulletin 5 then no. If you have an old license then you have to pay for the vBulletin 5 license. You can check this at vbulletin.com after logging in.
2. Use the latest version of vBulletin 5. Any older versions will have bugs/exploits present.
3. vBulletin 5 has a limited amount of plugins. If you absolutely need certain complex plugins then your best bet is to stay at vBulletin 4.
4. Not that I know of, but vbulletin.com displays all of the features of vBulletin 5. https://www.vbulletin.com/en/features/
Thanks Dave! I'm still exploring to see what add-ons are currently supported in 5.4, I'm also checking add-ons for higher versions of vb4..
Hard to do as I'm not very savvy at locating these things. ..lol
I don't think I have the vb5 license so that will factor in my decision for sure. Your help is appreciated. Thanks.
Reply With Quote
  #4  
Old 27 Feb 2018, 23:52
noypiscripter's Avatar
noypiscripter noypiscripter is offline
 
Join Date: Aug 2013
You can request a vB5 demo to get a hands-on trial of vB5.

https://www.vbulletin.com/en/vb5-trial/

For vB5 mods, I actively develop mods for it.
__________________
Glenn Vergara, an ex-vB Developer, now a vB Mod Developer

GIPHY for vB5 | AutoLinker | Video Attachments Player | New Registered Users Module | Clear System Cache Cron | DragNDrop Upload | Topic AJAX AutoUpdate | Force Read Topic
Reply With Quote
  #5  
Old 28 Feb 2018, 00:06
FatboyJay FatboyJay is offline
 
Join Date: Feb 2017
Originally Posted by noypiscripter View Post
You can request a vB5 demo to get a hands-on trial of vB5.

https://www.vbulletin.com/en/vb5-trial/

For vB5 mods, I actively develop mods for it.
That would be cool, but can I add addons and such to it? Like a marketplace mod, auction thing if they have one..etc? Because that's what it boils down to, functionality for the user..I need those things and now I'm currently looking at all the options for add-ons I need, whatever one has all the ones I can use, ill pick that.one .
Thanks, ill see about trying a demo if I can!
Reply With Quote
  #6  
Old 28 Feb 2018, 00:54
noypiscripter's Avatar
noypiscripter noypiscripter is offline
 
Join Date: Aug 2013
I don't think you can install mods in the demo.
__________________
Glenn Vergara, an ex-vB Developer, now a vB Mod Developer

GIPHY for vB5 | AutoLinker | Video Attachments Player | New Registered Users Module | Clear System Cache Cron | DragNDrop Upload | Topic AJAX AutoUpdate | Force Read Topic
Reply With Quote
  #7  
Old 28 Feb 2018, 01:07
FatboyJay FatboyJay is offline
 
Join Date: Feb 2017
I didn't think you could either. Currently looking at mods and add-ons for vb4.x, as most people have been saying that the kids I want may not be available on vb5.x
Reply With Quote
  #8  
Old 28 Feb 2018, 22:56
Mark.B Mark.B is offline
 
Join Date: Feb 2004
There is certainly no marketplace or auction add-on for vB5.

You need to ask yourself this question: "Why do I want to upgrade?".
What is currently broken or not working on vB4 that is fixed in vB5?
What essential features (for you) are in vB5 that are not in vB4?

If you cannot give yourself valid answers to these question, then you should stay where you are.

NB the above advice applies to major upgrades for any software at all.
__________________
MARK.B (Member of the vB Support Team)
Reply With Quote
  #9  
Old 28 Feb 2018, 23:30
FatboyJay FatboyJay is offline
 
Join Date: Feb 2017
Originally Posted by Mark.B View Post
There is certainly no marketplace or auction add-on for vB5.

You need to ask yourself this question: "Why do I want to upgrade?".
What is currently broken or not working on vB4 that is fixed in vB5?
What essential features (for you) are in vB5 that are not in vB4?

If you cannot give yourself valid answers to these question, then you should stay where you are.

NB the above advice applies to major upgrades for any software at all.

Great advice for sure. The "upgrade" would be for improvements to the sites functionality and better overall user interface. But at that time, I was clueless on all that..since, I've come to learn that 5.x isn't really much of an upgrade if all the good stuff is in vb 4.x

I can't lose that type of stuff: auctions, classifieds..etc.
So as of right now, I'm looking at other vb 4.x options or better add-ons that fit my needs..some add-ons didn't work at all..or were too hard to troubleshoot. Thank you for your reply and advice, it does help.
Reply With Quote
  #10  
Old 01 Mar 2018, 03:12
Max Taxable's Avatar
Max Taxable Max Taxable is offline
 
Join Date: Feb 2011
Originally Posted by Mark.B View Post
You need to ask yourself this question: "Why do I want to upgrade?".
What is currently broken or not working on vB4 that is fixed in vB5?
What essential features (for you) are in vB5 that are not in vB4?.
Not to mention, "How will my long term members react to the suckage of the change?"
Reply With Quote
  #11  
Old 01 Mar 2018, 12:13
FatboyJay FatboyJay is offline
 
Join Date: Feb 2017
Max, they'll be forced to like it or leave it to SS..
If it's hard for me to manage the forum as it is, I gotta make a change to something that is more workable..
I figured if I upgraded version I may get the functionality I want but it looks like I won't get that in the vb 5.x versions
Reply With Quote
  #12  
Old 01 Mar 2018, 17:33
Mark.B Mark.B is offline
 
Join Date: Feb 2004
Originally Posted by Max Taxable View Post
Not to mention, "How will my long term members react to the suckage of the change?"
I know of many established sites that upgraded to vB5 and they and their users are happy with it.
__________________
MARK.B (Member of the vB Support Team)
Reply With Quote
  #13  
Old 28 Mar 2018, 04:04
final kaoss final kaoss is offline
 
Join Date: Apr 2006
I know of at least 5 sites that completely died after switching to vbulletin 5 and I know of at least 1 other site that's thinking of switching away from vbulletin 5 to something else.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 20:38.

Layout Options | Width: Wide Color: