Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 04 Apr 2014, 12:52
MaXimus's Avatar
MaXimus MaXimus is offline
 
Join Date: Nov 2011
WYSIWYG editor doesn't work in Chrome

I tried copy/pasting a post, which has links, formatting, and a picture

In Pale Moon/Firefox, everything gets copied with the hyper links, formatting, and the image

but in Chrome it just pastes plain text

I always thought it's a Chrome issue

now I tried in chrome, to copy a similar post but from a vBulletin 4 forum and that works perfectly!

so why doesn't it work with vB3?

is there anything I could do to make it work?

--------------- Added 04 Apr 2014 at 13:54 ---------------

I tried this

But after adding the following, when accessing my site I get a syntax error on line 5024 which is:

if (strpos($useragent, ‘chrome’) !== false)
{
preg_match(‘#(chrome)( browser)?/([0-9\.]+)#’, $useragent, $regs);
$is['firebird'] = $regs[3];

if ($regs[1] == ‘chrome’)
{
$is['chrome'] = $regs[3];
}
}

=======================

I think this is line 5024:

preg_match(‘#(chrome)( browser)?/([0-9\.]+)#’, $useragent, $regs);
$is['firebird'] = $regs[3];
Reply With Quote
  #2  
Old 05 Apr 2014, 20:48
MaXimus's Avatar
MaXimus MaXimus is offline
 
Join Date: Nov 2011
anyone?
__________________
MaxGeek Forum - #1 Site for PC supports and tweaking guides!
Reply With Quote
  #3  
Old 06 Apr 2014, 00:03
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
It's always been that way. I don't know that you can do anything about it.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #4  
Old 06 Apr 2014, 00:04
Max Taxable's Avatar
Max Taxable Max Taxable is offline
 
Join Date: Feb 2011
Originally Posted by Matrix Leader View Post
I tried copy/pasting a post, which has links, formatting, and a picture

In Pale Moon/Firefox, everything gets copied with the hyper links, formatting, and the image

but in Chrome it just pastes plain text
You'll see this with Safari too, since Chrome IS Safari. It's the nature of the beast.
Reply With Quote
  #5  
Old 11 Apr 2014, 14:22
MaXimus's Avatar
MaXimus MaXimus is offline
 
Join Date: Nov 2011
I wish Chrome's WYSIWG worked with vB3 then I can switch to it
Reply With Quote
  #6  
Old 11 Apr 2014, 15:52
Zachery's Avatar
Zachery Zachery is offline
 
Join Date: Jul 2002
Real name: Zachery Woods
Chrome/webkit wasn't a really good rendering engine back then. In fact, I remember having a conversation with the developers at the time. They had spent 8~ hours doing everything imaginable to get WYSIWYG support to work. But couldn't. Everyone else at the time came to the same conclusion. Thus, wysiwyg support was abandoned.
__________________
Looking for ImpEx?
Reply With Quote
  #7  
Old 11 Apr 2014, 16:37
MaXimus's Avatar
MaXimus MaXimus is offline
 
Join Date: Nov 2011
Originally Posted by Zachery View Post
Chrome/webkit wasn't a really good rendering engine back then. In fact, I remember having a conversation with the developers at the time. They had spent 8~ hours doing everything imaginable to get WYSIWYG support to work. But couldn't. Everyone else at the time came to the same conclusion. Thus, wysiwyg support was abandoned.
Actually, about 6 months ago, I installed this extension for Chrome and WYSIWYG worked like a charm on vBulletin3 but now Google has banned it! I don't know why the heck!

http://www.chromeextensions.org/othe...letin-wysiwyg/



Help me force install this bro

--------------- Added 11 Apr 2014 at 16:46 ---------------

oh darn! I forced install the extension, but it doesn't work like before. It did work perfectly before

--------------- Added 11 Apr 2014 at 16:47 ---------------

I wonder why no web developer thought of making such a useful extension or in this case, continuing to support it
__________________
MaxGeek Forum - #1 Site for PC supports and tweaking guides!
Reply With Quote
  #8  
Old 24 Jan 2017, 19:18
6piston's Avatar
6piston 6piston is offline
 
Join Date: Apr 2005
anyone ever found a solution?
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 16:49.

Layout Options | Width: Wide Color: