Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Members who have visited the forum (Today or last 24 hours). Details »
Members who have visited the forum (Today or last 24 hours).
Mod Version: 4.21, by Paul M (Member) Paul M is offline
Developer Last Online: Jan 2018 I like it Show Printable Version Email this Page

This thread is in the Modification Graveyard.
vB Version: 3.5.x Rating: (34 votes - 4.88 average) Installs: 1971
Released: 10 Jun 2005 Last Update: 15 May 2006 Downloads: 1069
Not Supported  

This modification is no longer available or supported.

This adds a simple display of all members who have visited the forum - either today (i.e. since midnight) or in the last 24 hours. Please note that it is not possible for this hack to count guests.

The main features of Version 4.xx are basically the same as previous versions ;

1. It displays the list on the Forum Home.
2. The list view is collapsable, so you just see the number.
3. Invisible users are only displayed to those allowed to see them (with a "*")
4. Users who should display as coloured or bold etc should be displayed correctly (based on the display usergroup).
5. If you 'hover' over a username it will show the time they were last active.
6. The list is in member name order.
7. The hack is now phrased.
8. The ability to turn it on/off is in the ACP Forum Home Options.
9. The ability to allow only certain usergroups to view the list is an ACP option (vBulletin Options > Who has visited today).
10. The switch between Visited Today and Rolling 24 Hours is an ACP option (many seem to miss this actually exists).
11. The listing of members can now be suppressed (a simple message is displayed instead).
12. The list of names can be set to be always collapsed on initial view.

Unzip the XML and import into vB using the ACP Product Manager.

To upgrade from version 4.10 onwards, you need to re-import the product with the overwrite option set to yes. To upgrade from version 4.01/4.02 to version 4.10 onwards, you need to uninstall the product and remove the template code in FORUMHOME - then upload the new product. To upgrade from version 3.xx to version 4.xx you need to delete the existing plugin and remove the template code in FORUMHOME - then upload the new product.

* Add-ons etc *

* An add-on to display a 'Most ever posters' count is available here.

* If you want the WVT display on a seperate page - see this post by EvilHawk - now updated to version 4.21.

* There is also a CMPS module that makes use of this plugin (by tgmorris).


History:

v4.10 : Removed the need to edit the FORUMHOME template.
v4.11 : Hyperlinked display icon to members list. Added vb number formatting to count.
v4.12 : Added ALT tag to above hyperlink.
v4.13 : Fixed problem affecting the most visitors add-on when more than 999 visit in a day.
v4.14 : Added name suppression & always collapsed options.
v4.15 : Updated the install code to only create the index if it doesn't already exist.
v4.16 : Fixed error in new install code (changed DROP to ADD !).
v4.17 : Updated ACP view permission option to take into account secondary groups.
v4.18 : Not publicly released.
v4.19 : Added 'nofollow' attribute to listed usernames.
v4.20 : Minor changes, no update necessary.
v4.21 : Minor changes to settings group, instructions updated.

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Show Your Support

  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Forum Home Enhancements Members who have visited Today (or in the last 24 hours). Paul M Modification Graveyard 1144 18 Mar 2011 18:15
Members who have visited today (with last 24 hours option). Paul M Modification Graveyard 602 17 Apr 2008 05:29

Comments
  #2  
Old 10 Jun 2005, 00:19
Chris M's Avatar
Chris M Chris M is offline
 
Join Date: Dec 2001
Real name: Chris Murphy, BSc
Installed and working fine

Satan
Reply With Quote
  #3  
Old 10 Jun 2005, 00:32
Link14716's Avatar
Link14716 Link14716 is offline
 
Join Date: Jun 2002
Real name: Matthew Gordon
This isn't working for me. It just shows " Total users that have visited today: 0" and an empty table.
__________________
Along with Zachery, I make releases as GeekyDesigns. Please do not PM or IM me for support.
Reply With Quote
  #4  
Old 10 Jun 2005, 00:44
StarBuG's Avatar
StarBuG StarBuG is offline
 
Join Date: Dec 2001
After uploading the xml file I get a white page in the acp.
The plugin can be found in the Plugin Manager and is set to active.

On index.php however there is no change at all.

StarBuG
Reply With Quote
  #5  
Old 10 Jun 2005, 00:45
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Originally Posted by StarBuG
After uploading the xml file I get a white page in the acp.
The plugin can be found in the Plugin Manager and is set to active.

On index.php however there is no change at all.

StarBuG
Did you do the template change ?
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #6  
Old 10 Jun 2005, 00:46
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Originally Posted by Link14716
This isn't working for me. It just shows " Total users that have visited today: 0" and an empty table.
Interesting - the code must be running for you to get a zero. Can you provide a link to your site, and a test login if possible.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #7  
Old 10 Jun 2005, 00:55
StarBuG's Avatar
StarBuG StarBuG is offline
 
Join Date: Dec 2001
DOH

I thought it was the xml alone
I will do the changes after the bug is fixed that I canīt access my templated

StarBuG
Reply With Quote
  #8  
Old 10 Jun 2005, 01:33
Link14716's Avatar
Link14716 Link14716 is offline
 
Join Date: Jun 2002
Real name: Matthew Gordon
Originally Posted by Paul M
Interesting - the code must be running for you to get a zero. Can you provide a link to your site, and a test login if possible.
I have disabled it. It works over 24 hours, just not since midnight.
__________________
Along with Zachery, I make releases as GeekyDesigns. Please do not PM or IM me for support.
Reply With Quote
  #9  
Old 10 Jun 2005, 01:53
Link14716's Avatar
Link14716 Link14716 is offline
 
Join Date: Jun 2002
Real name: Matthew Gordon
I fixed it by changing this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

to this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
Along with Zachery, I make releases as GeekyDesigns. Please do not PM or IM me for support.
Reply With Quote
  #10  
Old 10 Jun 2005, 01:59
Chris M's Avatar
Chris M Chris M is offline
 
Join Date: Dec 2001
Real name: Chris Murphy, BSc
I've altered it in my plugin code and it still works...

So so far so good

Satan
Reply With Quote
  #11  
Old 10 Jun 2005, 02:18
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Okay - I applied a slightly different fix (uploaded).

I'll take a proper look tomorrow at the timezone stuff and see which is the best method.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #12  
Old 10 Jun 2005, 02:19
volcan volcan is offline
 
Join Date: May 2005
Hi.
I install the hack but the only thing is showing is the "Total users that have visited today:"
but there is nothing in it.
Now I dint install the plugin I dont now where to install it.
Where do I upload it please?
I need a detail instractions please.
Thank you.
Regards.
Reply With Quote
  #13  
Old 10 Jun 2005, 02:23
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
You are running vB 3.5.0 beta ?
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #14  
Old 10 Jun 2005, 03:07
TTG's Avatar
TTG TTG is offline
 
Join Date: May 2004
Installed and works fine
Reply With Quote
  #15  
Old 10 Jun 2005, 03:12
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Originally Posted by TTG
Installed and works fine
Click install then please.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 03:25.

Layout Options | Width: Wide Color: