Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Mid Post AdsMid Post Advertisements (middle of the post) Details »
Mid Post AdsMid Post Advertisements (middle of the post)
Mod Version: 1.9, by YankForum (Coder) YankForum is offline
Developer Last Online: Sep 2014 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (22 votes - 4.73 average) Installs: 144
Released: 07 Oct 2010 Last Update: 09 Aug 2014 Downloads: 992
Not Supported Uses Plugins Auto-Template  

Hello
i decided to share this mod with everybody else , this is a paid hack , i received several PMs asking to share it with everybody else , so i did all credits goes to original author SecondV

What does this hack do ?

This mod simply lets you put your desired ads or any other codes just in the middle of first post , in each page of a thread .
you can see a live demo here





Known Issues :
  • you shouldn't edit your first post , that causes real problems , and you lose all the contents of first post. (this is solved in version 1.1)
  • sometimes it's not exactly in the middle of posts , that's because in logic sometimes there is no real half point , while some posts have even number of lines and some posts have odd number of lines . but it tries to put it to the nearest location to the mid point!

Try not to mention following things :
if you think it's against google TOS then don't install it but keep in mind you can also use it with other network ads , and keep in mind at no point google directly mentioned it's against their TOS to put adsense in between content , so do not insist

Installation :
Just Import the Prodcut and configure settings in admincp ( no template edits needed )
DONE

Updates
version 1.1 : first post editing bug FIXED
version 1.2 : option ADDED to hide copyright AND adsense input field integrated into mod's settings page
version 1.3 : option ADDED to limit ads to be visible to guests only as requested by jrwap
version 1.4 : The ads get applied to article comments as well on the CMS articles bug FIXED
version 1.5 : option ADDED to disable ads in certain forums ( as requested by wastemytime )
version 1.6 : unicode characters bug FIXED
version 1.7 : option for enabling ads in extra post ADDED
version 1.8 : changed the structure of while loop to maintain performance and speed
version 1.9 : first post image only (no text) bug FIXED

Enjoy and please please try not to forget to click as Installed if you liked it you can also Nominate it for MOTM , that's optional but clicking as installed is a must

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	1.jpg
Views:	7059
Size:	101.5 KB
ID:	122630   Click image for larger version

Name:	2.jpg
Views:	6111
Size:	182.0 KB
ID:	123090  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #31  
Old 09 Oct 2010, 06:37
Tryppnotic69 Tryppnotic69 is offline
 
Join Date: Nov 2007
Works great. Any chance of having an option for the ad to also appear in a vBulletin blog? I have more readers in my blogs than in my forums.
Reply With Quote
  #32  
Old 09 Oct 2010, 10:07
aseer_al7ob's Avatar
aseer_al7ob aseer_al7ob is offline
 
Join Date: May 2007
Real name: AHED
Originally Posted by YankForum View Post
i can't understand what exactly is the problem , can u provide me a link to what you say or explain a bit more ? mayb it's one of your mods conflicting with this one ?
See attachments

If in the beginning of the subject image and not text that can not be displayed all subject
Attached Images
File Type: jpg capture1.jpg (91.1 KB, 48 views)
File Type: jpg capture2.jpg (35.3 KB, 40 views)
__________________
Reply With Quote
  #33  
Old 09 Oct 2010, 10:32
YankForum's Avatar
YankForum YankForum is offline
 
Join Date: Mar 2010
Real name: alij
Originally Posted by aseer_al7ob View Post
See attachments

If in the beginning of the subject image and not text that can not be displayed all subject
tnx for feedback , but this is not how it works , it doesn't depend on the quality of content , it counts lines (br's) and divide the content in two parts , i tested by posting an image on top of the post and it did work great , this could have conflicting with the image resizer installed on your boards
__________________
No more signature for me , Tnx!
Reply With Quote
  #34  
Old 09 Oct 2010, 19:09
demonfatal demonfatal is offline
 
Join Date: Mar 2009
Thanks for this usefull mod...
On your site I see the ads in the first and last post of each pages...
Can you share the way with us please?
Reply With Quote
  #35  
Old 09 Oct 2010, 20:20
bongmatinhoc bongmatinhoc is offline
 
Join Date: Feb 2008
Thanks. very nice
Reply With Quote
  #36  
Old 09 Oct 2010, 21:24
Azonaco Azonaco is offline
 
Join Date: Aug 2008
Great mod but found a small problem. The ads get applied to article comments as well on the CMS articles.
Reply With Quote
  #37  
Old 10 Oct 2010, 05:00
YankForum's Avatar
YankForum YankForum is offline
 
Join Date: Mar 2010
Real name: alij
Originally Posted by demonfatal View Post
Thanks for this usefull mod...
On your site I see the ads in the first and last post of each pages...
Can you share the way with us please?
tnx for installig , the last post ads is a sepereate mod which can be found here and here

Originally Posted by bongmatinhoc View Post
Thanks. very nice
tnx urself , please click install if you install it
Originally Posted by Azonaco View Post
Great mod but found a small problem. The ads get applied to article comments as well on the CMS articles.
i never had article (comments) & CMS on my domain , can please provide me a link or more information , which parts are affected too ?
__________________
No more signature for me , Tnx!
Reply With Quote
  #38  
Old 10 Oct 2010, 08:04
YankForum's Avatar
YankForum YankForum is offline
 
Join Date: Mar 2010
Real name: alij
Originally Posted by Azonaco View Post
Great mod but found a small problem. The ads get applied to article comments as well on the CMS articles.
again tnx for feedback , this been FIXED in version 1.4 (only viewable in showthread) , please check it
__________________
No more signature for me , Tnx!
Reply With Quote
  #39  
Old 10 Oct 2010, 09:55
wastemytime wastemytime is offline
 
Join Date: Sep 2006
This is really great! The only thing i would need - and maybe others - is an option for Forum Permissions. I do not want it to show it in specific Forums in that way.

Would you consider to add the Option to exclude specific Forums?
Reply With Quote
  #40  
Old 10 Oct 2010, 12:05
andretan88888 andretan88888 is offline
 
Join Date: Jun 2010
mark as installed.
Do you accept custom request ?
Please send me private message if you accept it.thanks
__________________
forum jual beli
Reply With Quote
  #41  
Old 10 Oct 2010, 18:03
egyptsons's Avatar
egyptsons egyptsons is offline
 
Join Date: Jan 2004
Location: Egypt
Real name: Ahmed Salah
Sound great !! thanks for sharing
can we specify a forum to be appear in ?
__________________
EgyptSons.com
Photo Gallery
Upload Files
Html4Arab.com
Reply With Quote
  #42  
Old 10 Oct 2010, 18:52
YankForum's Avatar
YankForum YankForum is offline
 
Join Date: Mar 2010
Real name: alij
Originally Posted by wastemytime View Post
This is really great! The only thing i would need - and maybe others - is an option for Forum Permissions. I do not want it to show it in specific Forums in that way.

Would you consider to add the Option to exclude specific Forums?
Originally Posted by egyptsons View Post
Sound great !! thanks for sharing
can we specify a forum to be appear in ?
option added to disable ads in certain forums as requested , also please click INSTALL if you install it , tnx
__________________
No more signature for me , Tnx!
Reply With Quote
  #43  
Old 10 Oct 2010, 22:23
wastemytime wastemytime is offline
 
Join Date: Sep 2006
Wow, you are really fast with your support. Great, thank you very much!
Reply With Quote
  #44  
Old 10 Oct 2010, 23:14
wastemytime wastemytime is offline
 
Join Date: Sep 2006
I also had this Error:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

But i think it could be the Problem with parsed URLs or a Language Problem. I have a German Forum and i try to retrieve Titles from URLs with vbSEO. I removed my wrong Link and it worked again on that same Page.

So maybe if there is no English Language or ASCII Code, your Hack gets confused...

In my Case, this was the Problem.

Last edited by wastemytime; 10 Oct 2010 at 23:24.
Reply With Quote
  #45  
Old 10 Oct 2010, 23:39
egyptsons's Avatar
egyptsons egyptsons is offline
 
Join Date: Jan 2004
Location: Egypt
Real name: Ahmed Salah
Originally Posted by YankForum View Post
option added to disable ads in certain forums as requested , also please click INSTALL if you install it , tnx
Thank you so much
__________________
EgyptSons.com
Photo Gallery
Upload Files
Html4Arab.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 19:40.

Layout Options | Width: Wide Color: