Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 27 Sep 2012, 22:58
Toplink Toplink is offline
 
Join Date: Feb 2009
Stuck on Forum Home......Dummy Needs Help Please

Hi,

I am using ver 4.2 and am a fairly novice user. I made a recent change to my site that may have screwed things up..........

I didn't want the default page to be the what's new tab. So after reading somewhere how to change that setting (using settings/navigation manager) I changed the default page to the Forum Home.

All was fine, so I thought.

Now my site is 'stuck' on Forum Home. Whatever link you click, it stays on that same page.

I'm sure the solution is really simple, but I just can't find it, sorry.

Any ideas?

I've searched around, and others seem to have had the same issue, but there were never any solutions........

This is my site:

http://www.supplychainfocus.com/forum/forum.php
Reply With Quote
  #2  
Old 27 Sep 2012, 23:04
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
I'm not stuck on that tab.... if I click on What's New, it is the What's New tab that is highlighted. (You only have a Forum and What's New tab).
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #3  
Old 28 Sep 2012, 00:39
kh99 kh99 is offline
 
Join Date: Aug 2009
Real name: Kevin
I think I see the problem - you can't go to any forums or threads, it always redirects you back to forum.php. But I don't know why that happens.
Reply With Quote
  #4  
Old 28 Sep 2012, 04:53
CAG CheechDogg's Avatar
CAG CheechDogg CAG CheechDogg is offline
 
Join Date: Feb 2012
Go to your Admin CP, Settings>Content Management>Default Page

Make sure you have the following in the field: 1-Index

That should fix the problem
Reply With Quote
  #5  
Old 29 Sep 2012, 23:35
Toplink Toplink is offline
 
Join Date: Feb 2009
Originally Posted by kh99 View Post
I think I see the problem - you can't go to any forums or threads, it always redirects you back to forum.php. But I don't know why that happens.
Yep.............that's the problem.........

--------------- Added 29 Sep 2012 at 23:37 ---------------

Originally Posted by CAG CheechDogg View Post
Go to your Admin CP, Settings>Content Management>Default Page

Make sure you have the following in the field: 1-Index

That should fix the problem
Thanks.

But...........I don't have that menu option.
Admin CP, Settings>Content Management>Default Page

Maybe a different version? I'm on 4.2.

I did find a similar setting here:
Admin CP, Settings, Options, Forum Home:Options, Script Name for Forum Home Page
It had index in the field.
I tried 1-index
No change........
Reply With Quote
  #6  
Old 29 Sep 2012, 23:41
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Try disabling your modifications/plugins and see if you still have this problem.
Note: To temporarily disable the plugin system, edit includes/config.php and add this line right under <?php


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

If so, Create a new style with no parent:
  • Styles & Templates > Style Manager > Add New Style
  • Parent Style: No Parent Style
  • Title: Default vBulletin
  • Allow User Selection: Yes
  • Save
Then browse the site using that totally default vbulletin style - do you still have the same problem?
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #7  
Old 30 Sep 2012, 09:47
Toplink Toplink is offline
 
Join Date: Feb 2009
Thanks, but sounds a bit too technical for to undertake.........
Reply With Quote
  #8  
Old 30 Sep 2012, 16:42
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Reread what I wrote - it really is not hard and they are two basic troubleshooting steps every admin should know how to do. The alternative is to leave your site unable as it is.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #9  
Old 30 Sep 2012, 22:09
Toplink Toplink is offline
 
Join Date: Feb 2009
I take your point. and Thanks. I have a tech guy who does all this stuff and my other sites, just he is away on holiday at the moment. I'll have to leave it for his return then.

I'm just surprised that my changing a simple menu setting screwed things up, and was rather hoping a another simple menu setting would fix it :-(
Reply With Quote
  #10  
Old 30 Sep 2012, 22:17
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Well, why don't you just put it back to how it was?
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #11  
Old 30 Sep 2012, 22:46
Toplink Toplink is offline
 
Join Date: Feb 2009
Originally Posted by Lynne View Post
Well, why don't you just put it back to how it was?
Yep, tried that. First thing I tried. ......... No luck.

Just worried I will screw things up even more now.

I'll just havve to leave it 'as is' for now..........
Reply With Quote
  #12  
Old 01 Oct 2012, 00:49
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Are you sure you didn't touch any of your files also? It's like there is a redirect in place that no matter what you put as the URL (the page source has the correct URLs), you get redirected to the forum page.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #13  
Old 01 Oct 2012, 03:00
CAG CheechDogg's Avatar
CAG CheechDogg CAG CheechDogg is offline
 
Join Date: Feb 2012
That is what I think too , he has to have a redirect, look in your htaccess file and look for redirects.
Reply With Quote
  #14  
Old 01 Oct 2012, 08:06
Toplink Toplink is offline
 
Join Date: Feb 2009
Originally Posted by Lynne View Post
Are you sure you didn't touch any of your files also? It's like there is a redirect in place that no matter what you put as the URL (the page source has the correct URLs), you get redirected to the forum page.
Nope, didn't touch any files. I wouldn't know how to.

Only changed the settings in Settings/Navigation Manager. Making Forum the default, instead of What's New.

--------------- Added 01 Oct 2012 at 08:10 ---------------

This is the htaccess file........

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /forum/

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/forums/$1 [L,R=301]

#--------------------------
RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]
#--------------------------


Double Dutch to me. Does it look OK?

P.S. Seems to be two copies of this file. One in the root and one in the forums folder.

Last edited by Toplink; 01 Oct 2012 at 08:13.
Reply With Quote
  #15  
Old 01 Oct 2012, 16:31
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Since you are not running vbseo and you are not using Mod Rewrite Friendly URLs, you should not have any .htaccess files. I'd suggest renaming them (like to a.htaccess) and then seeing if you still have the same problem.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:54.

Layout Options | Width: Wide Color: