Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Last Poster Avatar Details »
Last Poster Avatar
Mod Version: 1.1.1, by phpdesk (Coder) phpdesk is offline
Developer Last Online: Mar 2017 I like it Show Printable Version Email this Page

vB Version: 4.1.8 Rating: (44 votes - 4.66 average) Installs: 342
Released: 13 Dec 2011 Last Update: 06 Jan 2012 Downloads: 2005
Not Supported Uses Plugins Template Edits Is in Beta Stage  

Info
This mod ads last posters' avatars next to their names on Forumdisplay pages. I've just finished a section of one of my bigger mods to come, and thought that some of you may just need this little enhancement on their forums. If so, feel free to download and test it.
Features
Not too many features for now, it's a pretty straight forward mod. I'm always open to your suggestions though.

- Display last poster avatars in threadbits on forumdisplay
- Display last poster avatars in forumbits on forumhome and forumdisplay
- Admin settings to enable display of last poster avatars in certain areas or disable globally
- Set an avatar size to best match the layout
- Choose an alternative avatar display on forumbits
- Zero database queries to keep things running smoothly





Installation
Import [phpdesk.com]-product-lpavatar.xml via AdminCP > Plugin System > Manage Products > [Add/Import Product]
Mod Support
- Do not forget to mark as installed to qualify for further assistance
- A small donation would always be welcome to support further development of this hack (Support Developer)
- I'll do my best to listen to your comments and suggestions as long as time permits
Ghangelog
1.0.0 | 2011-12-13
- First Release

1.0.1 | 2011-12-13
- Fixed file path issue affecting some forum setups

1.0.2 | 2011-12-14
- Added last poster avatars to forumbits on forumhome and forumdisplay

- Added admin options to control display of avatars


1.0.3 | 2011-12-15
- Added option to display a default avatar for users that have not uploaded a custom avatar of their own


1.0.4 | 2011-12-15
- Re-enabled last posters' avatars display on forumhome after fixing the reported issue


1.0.5 | 2011-12-16
- Added option to set the avatar size individually for the forumbits and threadbits display


1.1.0 | 2012-01-04
- Link the avatar to member profile page

- Offer additional way to position last poster avatars on forumbits

- Remove the unnecessary extra database queries

1.1.1 | 2012-01-04
- Fix display issue when avatars are set to be saved as files


1.X.X | PLANNED
- Add avatar to search results, new posts, today posts, etc

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	forumdisplay.png
Views:	6801
Size:	35.1 KB
ID:	135076   Click image for larger version

Name:	adminoptions.png
Views:	949
Size:	67.2 KB
ID:	135121   Click image for larger version

Name:	forumhome.png
Views:	6826
Size:	26.1 KB
ID:	135122  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases vBA CMPS Module: Display avatar top poster, newest member BlackThorn Modification Graveyard 5 17 Apr 2010 17:38

  #166  
Old 28 Jan 2012, 22:05
ALBCODERS ALBCODERS is offline
 
Join Date: Apr 2009
works perfect on vb 4.0.3 thanbkyou very nice idea
Reply With Quote
  #167  
Old 01 Feb 2012, 20:10
I.G.O.T.A.'s Avatar
I.G.O.T.A. I.G.O.T.A. is offline
 
Join Date: Mar 2011
Real name: JJ Smith
Any word on a update for 4.1.10?
Reply With Quote
  #168  
Old 03 Feb 2012, 11:52
avaare avaare is offline
 
Join Date: Jul 2009
on 4.1.10 not working "Last Poster Avatars on Threadbits"
Reply With Quote
  #169  
Old 03 Feb 2012, 18:00
thenashy thenashy is offline
 
Join Date: Jun 2011
4.1.10 Kind of working, kind of not.

Some are showing my avatar, even when I'm not the last poster. Some are right. The avatars are also showing in front of the last post title instead of the name. So it looks a bit messy.
Reply With Quote
  #170  
Old 05 Feb 2012, 12:44
mcyates mcyates is offline
 
Join Date: Jan 2003
Real name: Michael C Yates
It shows the avatar in 4.1.10 but its not displayed properly.
__________________
MY FOOTBALL FORUM
World Wide Football Discussion Forum
Reply With Quote
  #171  
Old 15 Feb 2012, 12:04
skokarl skokarl is offline
 
Join Date: Apr 2005
Can somebody fix this for 4.1.0 ?

Is it supported ?
Reply With Quote
  #172  
Old 15 Feb 2012, 15:18
Winter Sonata Winter Sonata is offline
 
Join Date: Apr 2010
Yes, it works!
Reply With Quote
  #173  
Old 15 Feb 2012, 17:03
sadiq6210 sadiq6210 is offline
 
Join Date: Sep 2005
Real name: Sadiq
Originally Posted by sadiq6210 View Post
Thanks dear .. Great work
Installed but the avatars is not appeared

for example:

the original link for an avatar is:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

but in this mod the link become wrong like this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Just the last (8) is missing
so nothing appeared

Thanks again
Originally Posted by phpdesk View Post
Hi all,

I have fixed the avatar display issue brought to you with the 1.1.0 release. As a matter of fact, I haven't tested on forums that were set to save avatars as files, and I've fixed the problem now. Do let me know if anything else comes up, I'll be more than happy to troubleshoot and get back to you with further fixes until this becomes a stable mod.

Thanks, Daryn, I have removed the outdated lines from the mod description, you're right
Originally Posted by sadiq6210 View Post
Now the avatar appears if the link is like this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


But if there is two digits after (_), for example:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The link will be like this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

There is no avatar because the last (9) is missing and will not include in the link!

Thanks dear
Any fix for this bug?
Reply With Quote
  #174  
Old 15 Feb 2012, 17:17
BlueCheri's Avatar
BlueCheri BlueCheri is offline
 
Join Date: Jul 2009
I think it's not working properly.

G!

Originally Posted by skokarl View Post
Can somebody fix this for 4.1.0 ?

Is it supported ?
Reply With Quote
  #175  
Old 18 Feb 2012, 21:10
MediaSVI MediaSVI is offline
 
Join Date: Feb 2012
Does not work in 4.1.10
Reply With Quote
  #176  
Old 24 Feb 2012, 18:37
cdnbacon cdnbacon is offline
 
Join Date: Nov 2006
I would also appreciate an update for 4.1.10, or a redirect to a working mod that does the same.
Reply With Quote
  #177  
Old 25 Feb 2012, 20:27
phpdesk phpdesk is offline
 
Join Date: Jan 2005
Hi guys, I got involved in a few large projects since the beginning of the year, I had to put development of this and my other vbulletin modifications on hold for now, please hold on or if any of you are willing to contribute to any of the fixes required in the meantime, feel free to drop me a message and I'll gladly add your codes to the package.
Reply With Quote
  #178  
Old 17 Mar 2012, 17:46
chimpmaster chimpmaster is offline
 
Join Date: Jan 2012
Upgrading to V4.1.11 it is working fine except for the default guest avatar. It displays userid # 127 for the avatar instead. Not a big deal, but something to look at when updating this mod. Great mod though and one that our members love.
Reply With Quote
  #179  
Old 07 Apr 2012, 20:36
Conehead555 Conehead555 is offline
 
Join Date: Oct 2010
Perfect in 4.1.7 but no "default avatar" option like in your screen shot.
Reply With Quote
  #180  
Old 26 May 2012, 09:20
lordtopcat lordtopcat is offline
 
Join Date: Oct 2004
Real name: Jamie Sutton
Installed on 4.2. I'd like to use the non legacy version with the avatar on the left and everything else on the right. When I select this option, the following happens. (see attached)

The legacy version works fine, as it should.

Any suggestions?
Attached Images
File Type: png avh.PNG (4.4 KB, 24 views)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 12:09.

Layout Options | Width: Wide Color: