Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Spiders Display on Forumhome and Who's Online for vb4 Details »
Spiders Display on Forumhome and Who's Online for vb4
Mod Version: 1.1.3, by Boofo (R.I.P.) Boofo is offline
Developer Last Online: Jun 2012 I like it Show Printable Version Email this Page

vB Version: 4.0.x Rating: (93 votes - 4.76 average) Installs: 666
Released: 28 May 2010 Last Update: 18 Jan 2012 Downloads: 4209
Not Supported Uses Plugins Additional Files  

Spider Display for vB 4
Version 1.1.3
(By Boofo)

What does this product do?
This product will display the number of spiders on Forumhome and Who's Online. It will also add the count behind the spider name on Forumhome if there is more than one of a certain spider [ i.e. Google (3) ].

Credits:
A big thank you goes out to Adrian for helping me come up with the fix for this for vB 4.1.2, and straightening me out on keys in an array. Also, thanks to Paul M and Mosh for the comma fix for 4.1.8. Another thanks goes out to Mosh for the image file as well as making the mod work with all versions of vB 4. And yet another thank you goes out to HMBeaty for helping me find the fix for vB 4.1.10 and testing it thoroughly.

Version Information:
Version 1.0.0 --Initial release for vB 4
Version 1.0.1 --The count variable was wrong for the spider plural convention. Thanks goes out to Mosh for catching it. Also, the spiders_vbulletin.xml file has been updated to a more recent version, and the link for it below has been changed to another site that is keeping it up to date better than the original spiders list.
Version 1.0.2 --Fixed double comma issue with vB 4.0.5 in IE8.
Version 1.0.3 --Fixed issue with spiders displaying in a vertical listing in some browsers. The phrase ",with 0 spiders" will no longer show when there are no spider names listed.
Version 1.0.4 --Fixed to work with vB 4.1.2. Also, the "spiders_vbulletin.xml" file has been updated to the latest version as of February 15, 2011. => vBulletin 4.1.2 only
Version 1.0.5 --Added a setting to change the color of the spider name in the listing. Added a setting for Allowed Usergroups who can view spiders in the listing. Added a "View Map" link that will show up behind the spider count (or guest count if no spiders are currently on the site) on both the Forumhome and Who's Online. This link will only be visible if you have the "Digital Point User Map" mod installed. The spiders_vbulletin.xml file has also been updated to the latest version as of February 25, 2011. => vBulletin 4.1.2 only
Version 1.0.6 --Removed font color setting and added Style Variable setting for the Spider Display Font Color, so it can be set for each style separately. Set the dependency minversion to 4.1.2 in the xml file so there would be no improper version installs anymore. The spiders_vbulletin.xml file has also been updated to the latest version as of March 15, 2011. => vBulletin 4.1.2 only
Version 1.0.7 --Now fully phrased, as requested. => vBulletin 4.1.2 only
Version 1.0.8 --Should now work with all versions of vB 4, from 4.0.0 and up, including 4.1.8. Added a spider image to show before each spider, if the setting is enabled. It is off by default. The "spiders_vbulletin.xml" file has been updated to the latest version as of November 29, 2011.
Version 1.0.9 --Added a white spider icon image to go with styles that are dark. A setting has been added to choose what color image (black or white) you want to display before each spider name in the listing. The "spiders_vbulletin.xml" file has been updated to the latest version as of January 1, 2012.
Version 1.1.0 --Removed setting to choose the color of the spider icon and replaced it with a new style variable for the path to what spider image you wish to display for each style.
Version 1.1.1 --Added a setting to set the vertical alignment of the Spider Image. Added some more spider images.
Version 1.1.2 --Fixed to work on vB 4.1.10.
version 1.1.3 --Fixed to work with DragonByte Tech InfoPanels version 2.04 and above only.

NOTE: The word "Spider" or "Spiders" will no longer show up after each spider name listed in the activeusers listing on the Forumhome.

Installation overview:
----------------------------
1 Product XML (6 Plugins, 15 Phrases, 3 Settings, 2 Style Variables)
1 spiders_vbulletin.xml (located in the upload/includes/xml directory of this product ZIP file)
6 Spider Image files (located in the upload/images/misc directory of this product ZIP file)

Installation Instructions:
----------------------------
1. Upload the spider image files to the forums/images/misc directory on your site.

2. Upload spiders_vbulletin.xml to the forums/includes/xml directory on your site.

NOTE: Go to the following link for spiders_vbulletin.xml updates: http://www.wolfshead-solutions.com/spiders-list

3. Go to 'Admin CP -> Settings -> Options -> Who's Online Options -> Enable Spider Display' and make sure it is set to 'Yes'

4. Go to your Admin CP
Scroll down to 'Plugin System'
Click 'Manage Products'
Click 'Add/Import Product'
Click the 'Browse' button, and locate the 'product-boofo_spiderdisplay.xml' file on your computer

5. Go to your Admin CP -> vBulletin Options -> 'Spiders Display on Forumhome and Who's Online' and set the following options:
Spiders Display : Allowed Usergroups: These usergroups can view the Spiders Display on Forumhome. (Default is: '0' - All Usergroups)
Spiders Display : Show Spider Icon: Show Spider Icon to the left of each spider? (Default is: '1' - Yes)
Spiders Display : Spider Icon Vertical Position: Set the vertical-align property of the Spider Image. (Default is: 'bottom')

6. Style Variables:
Go to your Admin CP -> Styles & Templates -> Style Manager -> Style Variable Editor -> Click Go Button -> Boofo -> boofo_spiders_color
Enter the color code of the font color that you want the spiders to show up in.
Go to your Admin CP -> Styles & Templates -> Style Manager -> Style Variable Editor -> Click Go Button -> Boofo -> boofo_spiders_icon_image
This is your spiders display icon image. Set to the path of the spiders display icon image you want to use.

NOTE: You will need to do this for all styles.
-----------------------------------------------------

Done!
Enjoy!



Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	whos_online_spider.png
Views:	3244
Size:	9.4 KB
ID:	121311   Click image for larger version

Name:	wgo_spider.png
Views:	4573
Size:	25.0 KB
ID:	121309   Click image for larger version

Name:	Spider_Image.png
Views:	1919
Size:	11.9 KB
ID:	135400  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Forum Home Enhancements Spiders on ForumHome [NO FILE EDIT] Atakan KOC vBulletin 3.8 Add-ons 62 31 Jul 2012 19:18
Forum Home Enhancements Spiders on ForumHome Atakan KOC vBulletin 3.7 Add-ons 63 17 Dec 2010 11:43
Forum Home Enhancements Show Spiders on ForumHome amykhar vBulletin 3.6 Add-ons 206 17 Oct 2009 10:44
Show Spiders Online on ForumHome amykhar vBulletin 3.5 Add-ons 197 28 May 2007 00:36
Show Spiders Online on ForumHome amykhar vBulletin 3.0 Full Releases 330 08 Feb 2006 18:13

  #391  
Old 07 Apr 2012, 02:37
ywwz ywwz is offline
 
Join Date: Jul 2009
working on 4.1.11 well. took bit long to find how to set the spider image..
Reply With Quote
  #392  
Old 11 Apr 2012, 23:43
kingMOB kingMOB is offline
 
Join Date: Nov 2007
Just implemented this modification: Generate Currently Active Users More Efficiently.

After that, any usergroup allowed to see the spiders do not get the list of active users (neither the spiders). Disabling "Spiders Display on Forumhome and Who's Online" and the list appears. Is there a way to make both work together?
Reply With Quote
  #393  
Old 11 Apr 2012, 23:53
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Originally Posted by kingMOB View Post
Just implemented this modification: Generate Currently Active Users More Efficiently.

After that, any usergroup allowed to see the spiders do not get the list of active users (neither the spiders). Disabling "Spiders Display on Forumhome and Who's Online" and the list appears. Is there a way to make both work together?
The "Generate Currently Active Users More Efficiently" is only good for anything below 4.1.2. vBulletin 4.1.3 and up doesn't need that fix. What version of vb are you using?

And you need to click install if you want any more help.
Reply With Quote
  #394  
Old 12 Apr 2012, 00:20
kingMOB kingMOB is offline
 
Join Date: Nov 2007
Originally Posted by Boofo View Post
The "Generate Currently Active Users More Efficiently" is only good for anything below 4.1.2. vBulletin 4.1.3 and up doesn't need that fix. What version of vb are you using?

And you need to click install if you want any more help.
4.0.8
Reply With Quote
  #395  
Old 12 Apr 2012, 01:13
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
What is happening is the Spiders mod is using the old 4.0.8 code and you have updated that code to the new way it does it. You would have to edit the spiders mod xml to allow your 4.0.8 version to use the new code. It can be done fairly easily if you know what to look for. That would have to be a custom job.
Reply With Quote
  #396  
Old 12 Apr 2012, 06:01
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Originally Posted by kingMOB View Post
4.0.8
Since you uninstalled the mod, I won't bother with a fix for you then. It'll still be here when you upgrade.
Reply With Quote
  #397  
Old 12 Apr 2012, 11:10
kingMOB kingMOB is offline
 
Join Date: Nov 2007
This is really hard to understand =)

I came here for help because of this incompatibility, you asked what vb version I'm using and just said basically things that I already know without point the solution. Looking at the "Not Supported" alert up there and the "That would have to be a custom job" which I understood would be a paid job I uninstalled the mod. If I knew how to fix it my request for help here would be unnecessary.

6 messages and nothing =)

This is a good mod, could you please help me fix this incompatibility issue? I'll click the "Installed" up there again as you demand, even with it uninstalled since it is not working... the reason why I came here for help =)
Reply With Quote
  #398  
Old 17 Apr 2012, 23:18
HellRZR HellRZR is offline
 
Join Date: Feb 2011
Hi Boofo,

I installed the mod, recheck the install multiple times and the spider display does not show up? I am running VB 4.1.11 with security patch. I am however running a purchased skin which modified the forum home template. Can you give me a heads up on where I can check to see why it isn't working?

I have this running on another site without a problem.

Many thanks...
__________________
www.sidexside.ca
Pour les vrais mordus du sidexside....
Reply With Quote
  #399  
Old 17 Apr 2012, 23:27
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Make sure to do this (as in the first post instructions):

2. Upload spiders_vbulletin.xml to the forums/includes/xml directory on your site.
3. Go to 'Admin CP -> Settings -> Options -> Who's Online Options -> Enable Spider Display' and make sure it is set to 'Yes'

If that does not fix it, the forumhome template is where you need to look then.
Reply With Quote
  #400  
Old 17 Apr 2012, 23:38
HellRZR HellRZR is offline
 
Join Date: Feb 2011
Originally Posted by Boofo View Post
Make sure to do this (as in the first post instructions):




If that does not fix it, the forumhome template is where you need to look then.
Double checked again, Step 2 and 3 are done correctly. What would I look for in the forumhome template. I know its theme related and not mod related, but any pointer would be much appreciated. Thank-you.
__________________
www.sidexside.ca
Pour les vrais mordus du sidexside....
Reply With Quote
  #401  
Old 17 Apr 2012, 23:47
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Compare the original template with the changed one. If you check it in the default style, it will work.
Reply With Quote
  #402  
Old 18 Apr 2012, 03:32
kingMOB kingMOB is offline
 
Join Date: Nov 2007
Uninstalled. Do not work with the Generate Currently Active Users More Efficiently (wich is a good modification for the ones like me that do not use version 4.1.2+).
Reply With Quote
  #403  
Old 18 Apr 2012, 17:45
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Originally Posted by kingMOB View Post
Uninstalled. Do not work with the Generate Currently Active Users More Efficiently (wich is a good modification for the ones like me that do not use version 4.1.2+).
Yes it does work with that mod. Others have used it. But, as I said before, it would have to be edited to work properly since that is not a vb default action until a later version.
Reply With Quote
  #404  
Old 26 Apr 2012, 23:48
rockerzteam rockerzteam is offline
 
Join Date: Sep 2009
Would love to see this for 3.8.7 Alot of old school guys dont want to go to 4.x.x
Reply With Quote
  #405  
Old 27 Apr 2012, 00:01
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Since I only use vb 4 it really wouldn't be worth the time to convert it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 18:39.

Layout Options | Width: Wide Color: