Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 20 Apr 2010, 19:10
Mutt's Avatar
Mutt Mutt is offline
 
Join Date: Nov 2001
Questions about building a product to share.

I've made several mods that I'd share here but when I export the product, it's always missing stuff.

one is the control panel settings. they've been set as part of this product when I made them & all of the phases for the control panel settings make it into the xml file but the options section is always blank. See the attachments. the setting group & each setting is set as part of my product. in the xml file, the setting phases are there but the option section is blank so when you import it, there are no cp settings. is there a way to get these to export or do I need to manually add them to the XML file?

also, how to i tag my templates as part of the product so they get exported as well?

i know it's not a good sign that I don't know how to make a product file but I'm gonna share code but I have to learn at some point. last time a shared a mod it was find line xx & add this after, etc, etc.

as I upgrade from 3.8 to v4 & upgrade my mods, making the product only makes sense. might as well share them.

thanks in advance
Reply With Quote
  #2  
Old 21 Apr 2010, 16:52
Vaupell's Avatar
Vaupell Vaupell is offline
 
Join Date: Apr 2008
Real name: Martin
develop on a closed envirement suchs as on your computer with a
local installation of vbulletin and run it in Debug mode.

That enables product selection when creating
phrases, templates, etc etc..
But also allows you to change product on each item
incase you select wrong product on creation..

Exporting from debug mode, works flawlessly for me,
but if i export from a online site, i get all sort of problems and missing pieces.
__________________
My website Evisystems
- - - Stuff - - -
follow the white rabbit, feed! your head
Reply With Quote
  #3  
Old 21 Apr 2010, 19:05
Mutt's Avatar
Mutt Mutt is offline
 
Join Date: Nov 2001
Originally Posted by Vaupell View Post
develop on a closed envirement suchs as on your computer with a
local installation of vbulletin and run it in Debug mode.

That enables product selection when creating
phrases, templates, etc etc..
But also allows you to change product on each item
incase you select wrong product on creation..

Exporting from debug mode, works flawlessly for me,
but if i export from a online site, i get all sort of problems and missing pieces.
good to know. I try flipping debug on. thanks
Reply With Quote
  #4  
Old 29 Apr 2010, 00:20
Mutt's Avatar
Mutt Mutt is offline
 
Join Date: Nov 2001
i discovered the problem w/ my templates not saving to he product. I was adding templates to my custom style & when I set them to my product, it would get ignored. when I instead added the template to the master style, it worked fine.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:37.

Layout Options | Width: Wide Color: