Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 20 Jan 2019, 02:40
annatar annatar is offline
 
Join Date: Jan 2010
v3.8.11 on Debian9 with mariadb 10.1 cannot login?

Hello,

I am trying to do some research for a friend to upgrade their forum instance. They are currently running a fully patched debian 8 system with vB 3.8.11 and everything works properly.

In order to try to help them with the upgrade process I have made a VM clone of that system. If I uninstall php 5.6 from debian 8 and install php 7.0 there are no issues and their forum works properly inside the virtual machine.

However, if I do a full apt-get upgrade; apt-get dist-upgrade to debian 9 then when I try to access the forum index page I get the message

'You have been banned for the following reason: No reason was specified. Date the ban will be lifted: Never'

If I try to access the admin page after I enter the login credentials it simply loops back to the login page.

My suspicion is that something in MariaDB 10.1 for Debian 9 has changed, maybe some system setting, and it is causing some query to behave badly.

I have tried removing ever plugin that was installed to vB and also ensured all of the php files are untouched.

I have turned on vB debug information but I don't see anything obvious.

I can tell that on debian8 with php 5.6 or php 7.0 when it works more queries are being executed when hitting the login page.

Has anyone else seen a similar issue or have any suggestions on what I could try to track down the source of the problem?

Thanks in advance for reading and any suggestions.
Reply With Quote
  #2  
Old 20 Jan 2019, 03:19
motd2 motd2 is offline
 
Join Date: Jan 2010
You have a problem with the encoding in the database.
Reply With Quote
  #3  
Old 20 Jan 2019, 04:57
annatar annatar is offline
 
Join Date: Jan 2010
Originally Posted by motd2 View Post
You have a problem with the encoding in the database.
Thanks for the suggestion. I manged to get the forum displaying properly by adding the following into the config.php file

$config['Mysqli']['charset'] = 'latin1';

What confuses me though is if I check the character_set in mariadb with the query: SHOW VARIABLES LIKE 'char%';

I can see the character set is not latin1 but utf8.

However, if I go into the admin panel for vB and check the diagnostics for MySQL variables I see character_set_results, character_set_connection and character_set_client reporting latin1

I'm not sure if this is due to the config.php value or if something else has a misconfigured value.
Reply With Quote
  #4  
Old 20 Jan 2019, 16:05
snakes1100 snakes1100 is offline
 
Join Date: Dec 2001
Real name: Anthony
When doing the apt-get upgrade, is apache being updated?

If so, depending on apache 2.2 or 2.4 verify apache has mod_rpaf or remoteip module installed.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 06:40.

Layout Options | Width: Wide Color: