Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
AutoLinker Lite, keyword linker for vBulletin 3.7 and 4.x, and vbcms Details »
AutoLinker Lite, keyword linker for vBulletin 3.7 and 4.x, and vbcms
Mod Version: 1.0.7, by kermit2 (Member) kermit2 is offline
Developer Last Online: Feb 2016 I like it Show Printable Version Email this Page

vB Version: 4.0.2 Rating: (8 votes - 4.75 average) Installs: 79
Released: 26 Mar 2010 Last Update: 17 Oct 2014 Downloads: 703
Not Supported DB Changes Uses Plugins Template Edits Additional Files  

AutoLinker Lite is a keyword linker for vBulletin 3.7 upwards, 4.x, and vBulletin CMS. It allows the webmaster to configure particular words or phrases as keywords, which will then be automatically linked when they appear in user posts. As well as being hyperlinked, keywords can have pop-over info boxes, as in the image below:



These info boxes are highly configurable (colours, borders, fade in/fade out effect etc), and can contain html - meaning you can embed images, videos etc. Balloon-style boxes are also supported.

AutoLinker Lite has a flexible permissions system, allowing you to control which forums a given link appears in, and which usergroups it is visible too.

This is a free version of a commercial product, and contains a limit on the number of AutoLinks that you may create. Other than that, it is fully functional.

Please note that AutoLinks in the CMS do not work in vBulletin 4.0.0 and 4.0.1. 4.0.2 and upwards are fine.

A couple more images to hopefully whet your appetite:

Some of the things you can do with HTML:



Admin control panel:



Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Geek Auto-Linker 4.5 LITE The Geek vBulletin 3.5 Add-ons 206 06 Jul 2011 17:21
Major Additions AutoLinker Lite, keyword linker for vBulletin 3.7 and 4.x, and vbcms kermit2 Modification Graveyard 2 25 Mar 2010 15:57

  #61  
Old 30 Apr 2010, 07:49
kermit2 kermit2 is offline
 
Join Date: Jun 2008
Would you like me to take a quick look at your admin cp? If so, just PM me the details and I'll take a look today. Off the top of my head I can't think what the problem is, but I might get a bit of inspiration from looking around
Reply With Quote
  #62  
Old 30 Apr 2010, 09:18
TimberFloorAu's Avatar
TimberFloorAu TimberFloorAu is offline
 
Join Date: May 2008
Real name: Blue
Did you sort the "alt" attributes for "paid version" mate ?
__________________

My Hacks [ click ] | Steve ~ Administrator for British Expats AustraliaBound.org/forum | Test our forum - user; don pass; pass123
Sports Tipping Mod - coming February 2010 ~ Show your Interest !
Reply With Quote
  #63  
Old 30 Apr 2010, 19:04
kermit2 kermit2 is offline
 
Join Date: Jun 2008
Sorry yes, that was fixed last week if you want to re-download
Reply With Quote
  #64  
Old 30 Apr 2010, 22:46
TimberFloorAu's Avatar
TimberFloorAu TimberFloorAu is offline
 
Join Date: May 2008
Real name: Blue
Cheers.

Have you also fixed the image path in autolink.js for tip_balloon

This is returning multiple 404/410 bad requests.
Seems the path is faulting out to:

forum/tip_balloon/image

This folder doesnt exist, also doesnt exist in d/l package.

Line: config.BalloonImgPath="tip_balloon/"
__________________

My Hacks [ click ] | Steve ~ Administrator for British Expats AustraliaBound.org/forum | Test our forum - user; don pass; pass123
Sports Tipping Mod - coming February 2010 ~ Show your Interest !

Last edited by TimberFloorAu; 30 Apr 2010 at 23:07.
Reply With Quote
  #65  
Old 01 May 2010, 22:48
kermit2 kermit2 is offline
 
Join Date: Jun 2008
You're right. That was fixed a few weeks ago, but hadn't made it into the released version yet (it has now). A quick fix is just to edit the line to read:

config. BalloonImgPath = "autolinker/images/balloons/yellow/"
Reply With Quote
  #66  
Old 02 May 2010, 07:45
LoveStream LoveStream is offline
 
Join Date: Jan 2009
unicode problems

Thanks man of your good module.

I had a uni_code problem in my MySQL while import from old GAL tables.

Of course I could NOT add a new with Korean Character to a link entry.

I will attach here two capture shot for your update release.

Could you fix that for the non-english users.

Yours.
Attached Images
File Type: png autolinker_unicode_issue02.PNG (50.4 KB, 19 views)
File Type: png autolinker_unicode_issue01.png (96.2 KB, 12 views)

Last edited by LoveStream; 02 May 2010 at 07:51.
Reply With Quote
  #67  
Old 03 May 2010, 09:33
kawe kawe is offline
 
Join Date: Aug 2008
Parse error: syntax error, unexpected $end in C:\xampp\htdocs\test\admincp\autolinker_admin.php on line 1815
Reply With Quote
  #68  
Old 03 May 2010, 15:39
RedPoint RedPoint is offline
 
Join Date: Oct 2007
Originally Posted by kermit2 View Post
You're right. That was fixed a few weeks ago, but hadn't made it into the released version yet (it has now). A quick fix is just to edit the line to read:

config. BalloonImgPath = "autolinker/images/balloons/yellow/"
I make your changes but dont help me.

The files dont exist in your download here.
Reply With Quote
  #69  
Old 03 May 2010, 22:32
kermit2 kermit2 is offline
 
Join Date: Jun 2008
Originally Posted by RedPoint View Post

The files dont exist in your download here.
Sorry yes, think my brain was on strike. I've just updated the original post with an updated version (1.0.4) which should correct this. In your case you just need to replace autolinker.js with the new version (no need to reinstall everything)
Reply With Quote
  #70  
Old 03 May 2010, 22:38
kermit2 kermit2 is offline
 
Join Date: Jun 2008
Originally Posted by LoveStream View Post

I had a uni_code problem in my MySQL while import from old GAL tables.

Yours.
In v1.0.4, I've changed the charset on the tables to utf8 (rather than latin1) ... hopefully this will solve the problem.

If you don't want to re-install, you could manually change the charset (through the mysql command line client, or phpmyadmin or similar):


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

, where xxx is the table name (which in turn will depend on any table name prefix you're using).

There are 9 tables to modify, each beginning {PREFIX}_autolinker_

Hope that helps
Reply With Quote
  #71  
Old 03 May 2010, 22:41
kermit2 kermit2 is offline
 
Join Date: Jun 2008
Originally Posted by kawe View Post
Parse error: syntax error, unexpected $end in C:\xampp\htdocs\test\admincp\autolinker_admin.php on line 1815
Don't suppose you've modified the file have you? Sounds like a missing } somewhere, but it's certainly not giving an error here. Maybe it's been mangled during upload?
Reply With Quote
  #72  
Old 16 May 2010, 18:25
iamacyborg iamacyborg is offline
 
Join Date: Sep 2009
I'm very interested in this mod, but I've got a question.
I want the links to take a specific table from various mediawiki pages, is there any way I could get it to do that automatically, or would I have to create everything manually (meaning updating whenever wiki pages update, etc)?
__________________
GamingLove
Love Wiki
Reply With Quote
  #73  
Old 17 May 2010, 10:09
kermit2 kermit2 is offline
 
Join Date: Jun 2008
There's not a way to do that automatically at the moment I'm afraid, although we could custom code it for you probably
Reply With Quote
  #74  
Old 17 May 2010, 10:19
iamacyborg iamacyborg is offline
 
Join Date: Sep 2009
That would be good. Is there any chance you could email me at jacques [at] iamacyborg.com with details about pricing if you were to custom code it?
I'll definitely be purchasing the product anyway, it's too useful to pass up on.
__________________
GamingLove
Love Wiki
Reply With Quote
  #75  
Old 20 May 2010, 02:51
Haywire0311 Haywire0311 is offline
 
Join Date: May 2010
I really want to install this and if all is good go for the pro version but I can't get past the darn install.

I uploaded everything to the appropriate folders (used the v 1.0.4 file) and when I go to upload the XML file, I get this error in the admincp:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I gave it a shot by using the 1.0.3 file and was able to get around that error. However, once I go to create a new display template or even a new link, I get this error:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

HELP!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:32.

Layout Options | Width: Wide Color: