Register Members List Search Today's Posts Mark Forums Read

Reply
 
Article Options
How 2 Guide - Impex a Failed 4.0 Upgrade (w/o Backup) into a Fresh 4.0 install
TheLastSuperman
Join Date: Sep 2008
Posts: 5,391

Hey vb.org members and coders! Not much to say except I have a beautiful wife, three fantastic kids, and I develop Websites and Forums for a living 40+ hours a week.

North Carolina
by TheLastSuperman TheLastSuperman is offline 18 Nov 2009

vBulletin 4.0 Failed Upgrade without backup into a Fresh 4.0 Install!


By:


What do you mean Mike?

Well it's simple, a member recently approached me to do some work for him, it seems he was under the impression there was a forum backup by his host on the server or in cpanel. After attempting the vBulletin 4.0 Beta 3 upgrade the forums were not acting correctly, only forums.php was accessable and content and blog.php were white pages full of code text plus admincp access to CMS or Blog was throwing out errors like it was 1999!

We both brainstormed and decided to try Impex and it worked! The only problems were the attachments and so far a problem with the Blog which we have currently disabled until we can figure it out or simply wait until the next version release. The most important thing is his forums are back and members can navigate without white pages of code text! It lives! It is another community not lost .

Demo: http://www.overclockingwiki.org/forums/forum.php (Please note there are still bugs and NO attachments could be saved and this should be considered a "Last Resort" for any owner much like the owner of OverclockingWiki!)

Now you should have backed up before attempting an upgrade on a LIVE site and in fact is it ADVISED AGAINST UPGRADING A LIVE SITE TO 4.0 BETA 3! Backup info is HERE for others browsing this thread not seeing the sticky threads up top before you came here .

Even now, you should backup this database in the case that a future version release could fix your dilemma, you can find more info on that here: http://www.vbulletin.com/forum/showt...grading-to-4-0 and REMEMBER to backup both your files and the database.

Originally Posted by Lynne View Post
Thanks, Mike. I just don't want people thinking this is a total fix for their problem instead of going back to an older database. (And actually, another Mod got around to approving this before I did. )
Originally Posted by SirAdrian View Post
Here's my advice:

1) Don't install beta software on a live site
2) If you choose to, back up everything first

It's a last resort... don't assume this will work for you. Not that I have doubts, but it's just flat out careless.

Thanks for sharing Mike. Hopefully this helps a few people.
I totally agree with both of you and the reason this is being quoted per the posts below (on vb.com):

This is ONLY for those who upgraded without a backup in place and have SEVERE issues, please do not attempt this without first backing up what you now have! I cannot stress the importance of backups enough neither can anyone here who has been running a forum for quite some time if you do argue that would be futile.

I know from experience some simply do not read so if you are doing so now please read this entire article carefully and ONLY attempt this if you had no backup whatsoever AND you fear not having your forums active and open will hinder you in a personal or business perspective etc AS a possible new version could solve your dilemma you might just need time on your side.

Step 1) Download IMPEX from the members area on vBulletin.com

Step 2) Open up a new tab or window and navigate here: http://www.vbulletin.com/docs/html/impex

Step 3) Install a FRESH vBulletin Suite OR Forums Only depending on your purchase into a Sub folder within your forums root folder i.e.

http://www.yoursite.com/forum/vB4fix

DO NOT LOGIN TO THE OLD SITE log out before proceeding and you cannot be logged into both once you start it will not let you due to cookies!

Step 4) Turn off BOTH forums.

Step 5) Follow all the IMPEX instructions in the manual including filling in the correct Database names and Users and Passwords required.

Main Overview = http://www.vbulletin.com/docs/html/main/impex then navigate the links provided they take you through the setup process step by step.

Step 6) With my situation and I suspect all others the cpnav bitfiled will not display properly I'm sure it's a simple fix but I had not time for that it was forum alive time eh? To solve that simply go up top to your address bar and backspace to forum or forums i.e.

http://www.yoursite.com/forum/impex/index.html

And then enter in your customer # and proceed with the script changing the version importing FROM to vBulletin 3.6 and importing INTO to vBulletin 3.7/3.8 as there is no 4.0 option . Take your time and READ EVERYTHING - Anything with cycles of 1000+ I changed to 100 which is more time consuming but I found it to time out the first time I ran it when leaving those at higher cycle numbers.

Once the Impex is done, login to the new impexed forum and DOUBLE-CHECK all forum and usergroup permissions!!!! This is a MUST! Makes sure to fix and correct any and all of these before the board is opened up later on!!!!

Step 7) Now it's time to test and move! Can you do more than before? If so and your happy then we move this to your old forums directory on the server and run a script to fix the cookie login problems

7a) Move the vB4fix folder up a level into the same directory as your forum which might be public_html as an example but it depends on your host and setup just make sure it is in the same folder as the forum folder!

7b) Rename forum to OEMforum and then rename vB4fix to forum. Now in your vBulletin 4.0 download form the members area look in the do_not_upload folder and upload tools.php to then new forum directory inside admincp and in your browser type in:

http://www.yoursite.com/forum/admincp/tools.php

Then scroll down to:

Cookies
Cookie Prefix bb (set in includes/config.php)
[Reset Cookie Domain] Reset the cookie domain to be blankCurrently: ( blank )
[Reset Cookie Path] Reset the cookie path to be /Currently: /
And reset both then remove tools.php and login!

Step 8) Attachments might be an issue and so might the Blog, if you receive ANY DB error emails turn the Blog off immediately and enjoy your newly saved forum complete with CMS and Forums then wait for a new release and cross your fingers! You can review the IMPEX manual for more information and additional cleanup procedures.

Originally Posted by Lynne View Post
I posted this in the article Mike submitted over on vb.org and I'll say it here too:

Just a warning!!!! Impex has not been upgraded to run with vB4.0, therefore it cannot make the huge change to the attachment area that needs to be done. Most likely you will LOSE ALL YOUR OLD ATTACHMENTS if you use this method. I suppose, if you didn't make a backup of your database in the first place and you are happy just to have your forums back that this is no big deal. But, if it is a big deal and you do have a backup somewhere, that may be the better option for you. You will need to weigh whether an old backup with lots of lost threads/posts but with attachments is better than a bunch of recent threads/posts but no attachments.
IF you have questions please post them below HOWEVER please be sure you have checked the IMPEX MANUAL before doing so!

I hope this helps some of you who's communities don't seem to be salvageable at the moment

Please be aware this is still the Beta 3 so there are bugs regardless if you had a perfect upgrade or not.

Mike

Last edited by TheLastSuperman; 20 Nov 2009 at 16:25.. Reason: Auto-Merged DoublePost
Views: 5912
Reply With Quote
Comments
  #2  
Old 18 Nov 2009, 03:04
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Just a warning!!!! Impex has not been upgraded to run with vB4.0, therefore it cannot make the huge change to the attachment area that needs to be done. Most likely you will LOSE ALL YOUR OLD ATTACHMENTS if you use this method. I suppose, if you didn't make a backup of your database in the first place and you are happy just to have your forums back that this is no big deal. But, if it is a big deal and you do have a backup somewhere, that may be the better option for you. You will need to weigh whether an old backup with lots of lost threads/posts but with attachments is better than a bunch of recent threads/posts but no attachments.
__________________
Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #3  
Old 18 Nov 2009, 03:18
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
Thanks Lynne for pushing this through and also I edited my post @ vb.com to reflect your statement as well

http://www.vbulletin.com/forum/showt...56#post1845656

Mike
__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman - Custom vBulletin Modifications, Styles, and Services.
Need a Host? I recommend URLJet.

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!
Reply With Quote
  #4  
Old 18 Nov 2009, 03:53
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Thanks, Mike. I just don't want people thinking this is a total fix for their problem instead of going back to an older database. (And actually, another Mod got around to approving this before I did. )
__________________
Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #5  
Old 18 Nov 2009, 04:33
Adrian Schneider's Avatar
Adrian Schneider Adrian Schneider is offline
 
Join Date: Jul 2004
Here's my advice:

1) Don't install beta software on a live site
2) If you choose to, back up everything first

It's a last resort... don't assume this will work for you. Not that I have doubts, but it's just flat out careless.

Thanks for sharing Mike. Hopefully this helps a few people.
Reply With Quote
  #6  
Old 18 Nov 2009, 04:50
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
Cool

Originally Posted by Lynne View Post
Thanks, Mike. I just don't want people thinking this is a total fix for their problem instead of going back to an older database. (And actually, another Mod got around to approving this before I did. )
Originally Posted by SirAdrian View Post
Here's my advice:

1) Don't install beta software on a live site
2) If you choose to, back up everything first

It's a last resort... don't assume this will work for you. Not that I have doubts, but it's just flat out careless.

Thanks for sharing Mike. Hopefully this helps a few people.
I totally agree with both of you and the reason I bolded this in the guide above:

This is ONLY for those who upgraded without a backup in place and have SEVERE issues, please do not attempt this at home if that is not the case, MTV will not accept video submissions... ohh wait wrong thought however you get the idea, seriously.

I know from experience some simply do not read so if you are doing so now please re-read the article above and ONLY attempt this if you had no backup whatsoever AND you fear not having your forums active and open will hinder you in a personal or business perspective etc AS a possible new version could solve your dilemma you might just need time on your side.

Edit: Actually I'm going to take the joking out and reword it with our quotes so everyone is very clear on this

Mike
__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman - Custom vBulletin Modifications, Styles, and Services.
Need a Host? I recommend URLJet.

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!

Last edited by TheLastSuperman; 18 Nov 2009 at 17:45.
Reply With Quote
  #7  
Old 10 Jan 2010, 18:18
MEdwards MEdwards is offline
 
Join Date: Mar 2005
Question Sometimes not even a backup prevents all issues

Figuring that we could handle any issues -- We installed 4.0.0 Beta4 on a live site 3.8.4_Pl-1 (never ever will make that mistake again) and ran into some problems. So, restored the 3.8.4_PL-1 backup and went back to work. A few days later installed the latest security fix PL-2, everything seems fine. Except looking at 3.8.4_PL-2 db noticed that there were 240 tables, the default 3.8.4 vB is about 150 tables.

So, put a copy of the then live db into a development db and attempted to upgrade to the 4.0.0_PL-1 -- Not able to -- since there were some 4.0.0 tables already in the 3.8.4_PL-2 db (don't ask me how this happened -- nothing in our operations log can explain this)

Now facing the task of writing/using a database comparison script to somehow clean the existing live db 3.8.4_PL-2 (cleaning version will be offline) back to a version of 3.8.4 that we can use to successfully upgrade to 4.0.

I wish there was way to import the current live data into a clean version of the 3.8.4 db (we have one from November -- before we started messing with the 4.0.0 beta4) I've looked at Impex and appreciate the info in this thread -- but it looks like we'd lose our deep links and search results and since this forum is over 10 years old -- we're loathe to do that.

Any other ideas?

M
Reply With Quote
  #8  
Old 12 Jan 2010, 01:17
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
Originally Posted by MEdwards View Post
Figuring that we could handle any issues -- We installed 4.0.0 Beta4 on a live site 3.8.4_Pl-1 (never ever will make that mistake again) and ran into some problems. So, restored the 3.8.4_PL-1 backup and went back to work. A few days later installed the latest security fix PL-2, everything seems fine. Except looking at 3.8.4_PL-2 db noticed that there were 240 tables, the default 3.8.4 vB is about 150 tables.

So, put a copy of the then live db into a development db and attempted to upgrade to the 4.0.0_PL-1 -- Not able to -- since there were some 4.0.0 tables already in the 3.8.4_PL-2 db (don't ask me how this happened -- nothing in our operations log can explain this)

Now facing the task of writing/using a database comparison script to somehow clean the existing live db 3.8.4_PL-2 (cleaning version will be offline) back to a version of 3.8.4 that we can use to successfully upgrade to 4.0.

I wish there was way to import the current live data into a clean version of the 3.8.4 db (we have one from November -- before we started messing with the 4.0.0 beta4) I've looked at Impex and appreciate the info in this thread -- but it looks like we'd lose our deep links and search results and since this forum is over 10 years old -- we're loathe to do that.

Any other ideas?

M
I would open a support ticket and await an official response. If they are unable to help then I will suggest some ideas but due to the reasons you mentioned above and a few more Impex is a last resort and was never intended to be used as any form of upgrade tool. I only posted this because the few sites I used this method on had a fubared database due to a failed upgrade, there were never any guarantees and honestly we are lucky this even worked and that they have Live sites now. They knew the risks before we began and yet they have sites but this was Beta without support your Gold with it, submit a ticket, bare with them it's busy now for them and come back and see me only if all hope seems lost.

Good Luck & Sincerely,

Mike
__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman - Custom vBulletin Modifications, Styles, and Services.
Need a Host? I recommend URLJet.

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Article Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 00:26.

Layout Options | Width: Wide Color: