Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
[AJAX] Helpful Answers - Allow users to rate individual posts Details »
[AJAX] Helpful Answers - Allow users to rate individual posts
Mod Version: 2.4.2, by Ted S (Coder) Ted S is offline
Developer Last Online: Dec 2016 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (63 votes - 4.78 average) Installs: 589
Released: 16 Jan 2010 Last Update: 12 Aug 2012 Downloads: 3829
Not Supported DB Changes Uses Plugins Template Edits Additional Files  

Helpful Answers has been used to record over 6 MILLION times on more than 2,000 forums. If you're not using HA your users are looking for it!

Every day your users contribute hundreds if not thousands of posts making it hard for new members and guests to separate out the best answers from those that are less helpful. The Helpful Answers System offers your members a quick way
to rate individual posts as either helpful or not allowing future visitors to understand the value of each post.

Designed to be flexible, HA has over 30 configurable settings:
  • Use image or text ratings AJAX or traditional links.
  • Offer yes/no or scaled 1-10 point ranking.
  • Turn off negative ratings for a positive only system.
  • Decide which forums are open for helpful answer ratings.
  • Audit the system and identify top users and potential abusers.
  • Ban specific members from using the system.
  • Customize the message shown after a post is rated.
  • Show a page with the top helpful posts.
  • Show rating stats on a user's profile.
  • Hide posts that rate "too low"
  • Template driven so you can customize it all for your forum.
For advanced users template conditionals and variables let you further extend the functionality to color highlight good or bad posts, include ratings in userís profiles and much more.

Modification Installation [Must Read]:


Step 1: Upload the addon files found in the upload/ folder to your forum directory
Step 2: Install the plugin through your vB Administration area
Step 3: Configure settings & enable the mod in individual forums


You must configure settings & enable forums before voting will show up.

Anonymous Stats Tracking (optional):

By default this addon will pass basic rating data (positive or negative) to a 3rd party site for statistical purposes. Only the most basic data is captured (the vote and your site name) and no user information or specific forum details are logged, not even an IP address. You can disable this through the admin.


Mod Philosophy -- Drive Your Own Success:

All of my mods are inspired by my work in digital marketing and are designed to drive registrations, interaction or other engagement activities the core platform does not address.

Each is designed to fit a general need by providing a starting point but it's on you to decide how to make things work to their best possible outcome. Feel free to suggest what you'd like to see next but don't wait to have what everyone else has; figure out what your forum needs and customize away.

Download Now

Only licensed members can download files, Click Here for more information.

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	1-16-2010 1-11-43 PM.jpg
Views:	12429
Size:	41.6 KB
ID:	110159   Click image for larger version

Name:	admin-stats1.gif
Views:	8435
Size:	15.5 KB
ID:	110160   Click image for larger version

Name:	admin-stats2.gif
Views:	6904
Size:	11.3 KB
ID:	110161  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases [AJAX] Helpful Answers - Post Rating System (plus many sub-features) Ted S vBulletin 3.8 Add-ons 1801 02 May 2016 10:34
Add-On Releases [AJAX] Helpful Answers - Allow users to rate individual posts Ted S vBulletin 3.7 Add-ons 196 19 Oct 2010 06:17

  #286  
Old 21 Mar 2010, 19:58
DarknessDivine's Avatar
DarknessDivine DarknessDivine is offline
 
Join Date: May 2004
Originally Posted by Ted S View Post
You have negative turned to 'no' but which voting display option are you using?
Rollover thumbs which was the only one I could get to actually show up with Negative No checked.

I set it to allow negatives and it works so I guess I can leave it for now.
Reply With Quote
  #287  
Old 22 Mar 2010, 05:10
Ted S Ted S is offline
 
Join Date: Dec 2003
Thanks. I'll take another look as this is the same settings one of my sites uses, but without any % issue.
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #288  
Old 22 Mar 2010, 05:33
GONUMBER6's Avatar
GONUMBER6 GONUMBER6 is offline
 
Join Date: Jan 2010
Real name: Lisa
I am having the same problem with the rollover thumbs and only positive feedback setting as well. Works fine with positive & negative. Using version 4.02
Reply With Quote
  #289  
Old 22 Mar 2010, 23:34
Wild Bronco Wild Bronco is offline
 
Join Date: Jan 2005
Installed and working nicely Thanks

I don't know if this has been sugested but, this would be nice for the CMS as well...
10 out of 10 members found this article helpful.
Reply With Quote
  #290  
Old 23 Mar 2010, 00:02
Wild Bronco Wild Bronco is offline
 
Join Date: Jan 2005
And in the blog similar to facebooks LIKE thing
Reply With Quote
  #291  
Old 23 Mar 2010, 03:45
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by Geiri View Post
And in the blog similar to facebooks LIKE thing
This is something I'm looking at. Each feature is entirely seperate but I'll likely clone the mod for each of them.
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #292  
Old 24 Mar 2010, 03:19
Wild Bronco Wild Bronco is offline
 
Join Date: Jan 2005
Originally Posted by Ted S View Post
This is something I'm looking at. Each feature is entirely seperate but I'll likely clone the mod for each of them.
Nice
Reply With Quote
  #293  
Old 29 Mar 2010, 17:21
Mostjolly's Avatar
Mostjolly Mostjolly is offline
 
Join Date: Apr 2008
Real name: Nhat
Hey Ted,

Why do we get the same results, for example:

Did you find this post helpful? Positive | Negative

1) When I click on Positive I get "1 people found this post to be useful." THIS IS ACCEPTABLE.

2) When I click on Negative I STILL get "1 people found this post to be useful." THIS IS UNACCEPTABLE... (because it's not useful for negative response..)

Technically, we're getting the SAME PHRASE weither be Negative or Positive.. which is confusing.

Solution: I would prefer whenever someone clicks on Negative sign it should give us "1 people found this post to be lame/shameful".

How could I add an extra phrase associated for Negative ratings?

P.S. BTW, 1 people found this post..... is my costume phrase
Reply With Quote
  #294  
Old 31 Mar 2010, 01:44
Hikikomori Hikikomori is offline
 
Join Date: Mar 2010
I think the profile.php?do=helpfulans page breaks the layout (left sidebars), just a tiny bit.

I was also wondering would it be possible to have a setting to only allow marking a helpful post for the threadstarter? In a specific forum I want the threadstarter to be eligible to be marked as helpful/not helpful, but not any additional posts in that thread.
Reply With Quote
  #295  
Old 04 Apr 2010, 00:50
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by traffiking View Post
Hey Ted,

Why do we get the same results, for example:

Did you find this post helpful? Positive | Negative

1) When I click on Positive I get "1 people found this post to be useful." THIS IS ACCEPTABLE.

2) When I click on Negative I STILL get "1 people found this post to be useful." THIS IS UNACCEPTABLE... (because it's not useful for negative response..)

Technically, we're getting the SAME PHRASE weither be Negative or Positive.. which is confusing.

Solution: I would prefer whenever someone clicks on Negative sign it should give us "1 people found this post to be lame/shameful".

How could I add an extra phrase associated for Negative ratings?

P.S. BTW, 1 people found this post..... is my costume phrase
When someone clicks negative and the negative option is enabled it should state that 1 out of 2 people found the post helpful. Be sure you are using the original phrase and template to get this functionality. If you have changed it you need to be sure your phrase works properly.
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #296  
Old 04 Apr 2010, 00:51
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by Hikikomori View Post
I was also wondering would it be possible to have a setting to only allow marking a helpful post for the threadstarter? In a specific forum I want the threadstarter to be eligible to be marked as helpful/not helpful, but not any additional posts in that thread.
You would have to modify the addon to do this.
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #297  
Old 04 Apr 2010, 15:42
Greight's Avatar
Greight Greight is offline
 
Join Date: Oct 2009
First thanks again for this nice mod, then can you please add a function so that the user can cancel his vote?
Reply With Quote
  #298  
Old 05 Apr 2010, 01:00
Forum Lover Forum Lover is offline
 
Join Date: Jun 2007
Real name: aupurbo
Ted S, can we have similar for blogs too please?
Reply With Quote
  #299  
Old 05 Apr 2010, 04:02
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by Forum Lover View Post
Ted S, can we have similar for blogs too please?
Yes. Soon.
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #300  
Old 05 Apr 2010, 07:36
Verionia Verionia is offline
 
Join Date: Jul 2009
I am using 4.02, followed the instructions manual yet nothing shows... cant get this mod to work.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 06:32.

Layout Options | Width: Wide Color: