Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 17 Aug 2016, 21:12
dknelson dknelson is offline
 
Join Date: Oct 2004
How to link Username to Profile in Welcome Thread

I have a hack that automatically creates a welcome thread for new members. It works as it should. The following code will post something like:

Welcome newmember from Dallas, TX.

Of course "new members" is the actually new members username.

I would like the username to link to their profile though. I know it must be pretty easy for anybody who does coding but I haven't gotten it to work. Here is the code that results in the text above. Could somebody PLEASE re-write it so that the username is a link to their profile?


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

If it matters, I'm running 4.2.3 PL2
Reply With Quote
  #2  
Old 18 Aug 2016, 15:08
Dragonsys's Avatar
Dragonsys Dragonsys is offline
 
Join Date: Jan 2008
Real name: Eric
You can't use a link in a thread title. You could use it in the post body though.
You would need to change:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

to something like this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #3  
Old 18 Aug 2016, 16:44
dknelson dknelson is offline
 
Join Date: Oct 2004
Thanks. I'll give it a try. Much appreciated.

--------------- Added 18 Aug 2016 at 20:57 ---------------

OK...thank you so much. Here's the thing though, you are correct that it works in the body of the welcome thread but it also works in the title of the thread. That is fine but just though I would let you know.
Reply With Quote
  #4  
Old 20 Aug 2016, 10:44
dknelson dknelson is offline
 
Join Date: Oct 2004
Well, I have to recant. You seem to be correct about the link in the title. After I did that, it seemed to affect the sending of the confirmation emails. Sometimes they were delivered and sometimes not. It is the only thing I had changed so I assume that is what was causing it. Is it possible that some email provides block emails with links in the title and some don't? Like I said, it seemed to work about 60% of the time. I've changed it back now so will see if that was the problem but I suspect it was. I'm not sure why that welcome script would affect the confirmation email though.

Last edited by dknelson; 20 Aug 2016 at 11:14.
Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Profile Enhancements Profile Welcome Message - Users can add a message at the top of their profile sockwater vBulletin 3.7 Add-ons 54 27 Sep 2011 07:54



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 08:49.

Layout Options | Width: Wide Color: