Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Commbull (Community Bulletin) 5.1a for vBulletin 4.01 Details »
Commbull (Community Bulletin) 5.1a for vBulletin 4.01
Mod Version: 4.5F for 4, by djbaxter (Coder/Designer) djbaxter is offline
Developer Last Online: Feb 2021 I like it Show Printable Version Email this Page

vB Version: 4.0.4 Rating: (1 vote - 5.00 average) Installs: 58
Released: 21 Jan 2010 Last Update: 14 Jul 2010 Downloads: 319
Not Supported DB Changes Uses Plugins Template Edits Auto-Template Additional Files  

This not the CommBull product itself. This is simply instructions for adapting it to work with vBulletin 4.x.

Download CommBull from: Commbull (Community Bulletin) 5.1a for vBulletin 3.8x

grandeur_69 has released his latest version of CommBull as a free add-on, indicating that he no longer has time to continue developing it. I am posting this here for the benefit of other vBulletin 4.x who don't want to lose the newsletter feature (grandeur_69 has approved this).

At http://www.vbulletin.org/forum/showp...6&postcount=71 a member asks:

Hi, the version 5.1a work fine with vbulletin 4.0.1 ?
My response is posted at http://www.vbulletin.org/forum/showp...5&postcount=72 and reproduced here...

I have the previous (commercial) version, 4.5f, which does run successfully via a cron job, running on 4.01. It required some modification of the installation instructions but it does work. I expect you should be able to get this version running as well, although as the coder noted the cron capability won't work.

1. Edit product-Commbull.xml and find the following line:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Change to:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


2. Upload the files and import the product.

3. Now you need to do the template edits so that members can opt-in or opt-out of your newsletter. The current instructions are as follows:

4. Template modifications
--------------------------------------

Template: "Modify User Option" -> "modifyoptions"

After:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Add:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Now, obviously this won't work in 4.x. These need to be modified as follows:

1. Edit Template: "Modify User Option" -> "modifyoptions"

FIND:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


ADD AFTER:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

That first part (above) is the option to receive or not receive the newsletters.

Next would be the option for HTML or plain text emails, which should be:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Update:

This now works. I had a ( instead of a { on the previous code. Thanks to grandeur_69 for pointing this out!

Notes:
  1. The product is not mine so I can't offer any support for CommBull itself. However, I have been using the paid versions of this mod for some time and I'm happy to offer what support I can for making the changes necessary to get it running on 4.x.

  2. I have been in communication with grandeur_69. He has indicated that he has no objections to this thread and that as he gets time he will be trying to develop this add-on further as a free product.

Update July 12, 2010: Product XML file provided by grandeur_69 for vBulletin 4.x.

NOTE:
  1. If you have already done the manual edits, do NOT use the XML file. And if you import the XML file, you should not need to do the manual edits.
  2. Some people are encountering problems using the XML file. If you are one of them, uninstall the product and use the manual edits. Those seem to work just fine.


Update July 14, 2010: Error in XML file corrected.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	top-custom-text.jpg
Views:	3324
Size:	61.4 KB
ID:	110697   Click image for larger version

Name:	top-new-threads.jpg
Views:	2674
Size:	51.1 KB
ID:	110698   Click image for larger version

Name:	articles.jpg
Views:	1831
Size:	48.6 KB
ID:	110699  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Administrative and Maintenance Tools Commbull (Community Bulletin) 5.1b grandeur_69 vBulletin 3.8 Add-ons 288 11 Jul 2014 04:19
Commbull (Community Bulletin) grandeur_69 vBulletin 3.5 Add-ons 116 19 Aug 2012 14:59
CommBull (Community Bulletin) grandeur_69 vBulletin 3.0 Full Releases 449 24 Feb 2009 04:16

  #31  
Old 06 Jun 2010, 05:02
ArchAngelz ArchAngelz is offline
 
Join Date: May 2010
Originally Posted by djbaxter
I have the previous (commercial) version, 4.5f, which does run successfully via a cron job, running on 4.01. It required some modification of the installation instructions but it does work. I expect you should be able to get this version running as well, although as the coder noted the cron capability won't work.
Can you share how the installation instructions should be modified in order to get v4.5 working? It seems that v4.5 may be better than v5.1 and hence, installation instructions for that may be useful.
Reply With Quote
  #32  
Old 06 Jun 2010, 21:25
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by ArchAngelz View Post
Can you share how the installation instructions should be modified in order to get v4.5 working? It seems that v4.5 may be better than v5.1 and hence, installation instructions for that may be useful.
The modifications above are for 4.5f but shouild work with 5.1.

If you are asking how to install 4.5f, if you have a copy, those versions require either the Zend Optimizer or Ioncube installed on youjr server.

The installations instructions for 4.5f are as follows (from the ReadMe):

ENCODED FILES
=============
The files in these packages are encrypted to protect the code. You will need to install Zend Optimizer (zend.com) or IonCube (ioncube.com) to make the files work.

INSTALL:
======

1. Add Commbull XML Product Plugin
----------------------------------------------

- Go to your ACP and select "Plugin System -> Manage Products".
- Click "[Add/Import Product]".
- Navagate to the "commbull-product.xml" file included with this installation file and click "Open".
- Then click "Import".


2. File Upload
-------------------------------------
- upload all the files in either the upload-IonCube or upload-Zend folders in Binary Mode, depending one which optimizer you have installed. Do not upload the folder itself, but only it's contents to the forum root. I did not make any changes to any of the vB files, so you don't have to worry about any of them being overwritten.

IN BINARY MODE:
---- if you do not upload the files in Binary mode, you will get something that looks like:
Fatal error: Unable to read 42220 bytes in /site/root/forums/admincp/commbull.php on line 0


3. Cronjob
-------------

- A default cron (Sunday at 4am) was added when you imported the Plugin, however it is disabled by default.
- Go into "Scheduled Tasks" -> "Scheduled Task Manager" and edit "commbull_newsletter_send_task" to the desired schedule.

**NOTE: before the cron can run properly, you must "save" the settings necessary to run it on it's own. To do that, you will need to partially start the first run. Go to ./admincp/commbull.php and change all the necessary settings that you wish to run and be sure to select "Save Preferances" near the bottom, otherwise it won't have anything
to run and the cron will fail. If you view the cronlog, and it failed, you will see "Commbull [No Settings Defined! - quitting]".
Reply With Quote
  #33  
Old 13 Jun 2010, 01:04
docvader's Avatar
docvader docvader is offline
 
Join Date: Dec 2002
Getting back to this unsubscribe issue, the mailer points to an unsubscribe link of:

http://forum.russbo.com/admincp/$commbull_unsubscribe

$commbull_unsubscribe doesn't work. Any idea as to what to change that PHP line to, to make it work appropriately?

This seems to get you to the edit options page, but I wasn't sure if there was a commbull specific link


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
russbo.com

Last edited by docvader; 13 Jun 2010 at 01:10.
Reply With Quote
  #34  
Old 13 Jun 2010, 02:22
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
No, that's it. If you've followed directions, that should take the member to options where s/he can uncheck the "receive commbull newsletters" option.
Reply With Quote
  #35  
Old 12 Jul 2010, 16:22
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Update July 12, 2010: Product XML file provided by grandeur_69 for vBulletin 4.x.
Reply With Quote
  #36  
Old 13 Jul 2010, 20:49
Dragonsys's Avatar
Dragonsys Dragonsys is offline
 
Join Date: Jan 2008
Real name: Eric
When someone checks (or unchecks) the boxes in their Options, the settings are not saved in the DB. Everything else is working perfectly.
Reply With Quote
  #37  
Old 14 Jul 2010, 01:16
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by Dragonsys View Post
When someone checks (or unchecks) the boxes in their Options, the settings are not saved in the DB. Everything else is working perfectly.
It's working for me.

Make sure the member knows to scroll down to the bottom of the page and click on "Save".

One other possibility is that if it's an admin who is configured as "unalterable" in config.php, I'm not sure whether that will be saved.

Added: Are you talking about the manual edits or the XML file?
Reply With Quote
  #38  
Old 14 Jul 2010, 02:38
Dragonsys's Avatar
Dragonsys Dragonsys is offline
 
Join Date: Jan 2008
Real name: Eric
Originally Posted by djbaxter View Post
It's working for me.

Make sure the member knows to scroll down to the bottom of the page and click on "Save".

One other possibility is that if it's an admin who is configured as "unalterable" in config.php, I'm not sure whether that will be saved.

Added: Are you talking about the manual edits or the XML file?
The manual edits, to modifyoptions. I used the latest xml file you uploaded yesterday.
I was trying it in my settings. I have checked and I am an admin, but I am not unalterable, in config.php.

I changed my settings via a SQL cmd. then I went into my settings and unchecked the HTML Type. When I hit save, it blanked both boxes. The only way I can get it to set back to enabled, is by using a SQL cmd.
Reply With Quote
  #39  
Old 14 Jul 2010, 02:53
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
What vBulletin version are you using?
Reply With Quote
  #40  
Old 14 Jul 2010, 03:41
Dragonsys's Avatar
Dragonsys Dragonsys is offline
 
Join Date: Jan 2008
Real name: Eric
Originally Posted by djbaxter View Post
What vBulletin version are you using?
4.0.4 PL1


Looking at the xml file, I do see this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I wonder if my manual edits are conflicting with the edits inside the xml file.
Reply With Quote
  #41  
Old 14 Jul 2010, 03:56
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Oh. Did you do the manual edits AND import the XML file? It should be either/or, not both.

I'll edit the instructions to clarify that.

What I would suggest is that you undo the manual edits and see if that works for you. If you still have a problem, uninstall and start again, this time trying just the XML file.
Reply With Quote
  #42  
Old 14 Jul 2010, 04:22
Dragonsys's Avatar
Dragonsys Dragonsys is offline
 
Join Date: Jan 2008
Real name: Eric
Originally Posted by djbaxter View Post
Oh. Did you do the manual edits AND import the XML file? It should be either/or, not both.

I'll edit the instructions to clarify that.

What I would suggest is that you undo the manual edits and see if that works for you. If you still have a problem, uninstall and start again, this time trying just the XML file.
lol yeah that is what I figured after I looked at the xml file, so I am trying that. I will let you know how it goes.

EDIT:
Ok, when I uninstalled and reinstalled, without the manual edits (I reverted the template prior to install). They check boxes do not show up at all.

Last edited by Dragonsys; 14 Jul 2010 at 04:31.
Reply With Quote
  #43  
Old 14 Jul 2010, 04:31
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Sorry about that. I have posted a warning now so others don't make that mistake.
Reply With Quote
  #44  
Old 14 Jul 2010, 04:44
Dragonsys's Avatar
Dragonsys Dragonsys is offline
 
Join Date: Jan 2008
Real name: Eric
Originally Posted by djbaxter View Post
Sorry about that. I have posted a warning now so others don't make that mistake.
not a problem
The template edits from the xml file do not show up though
Reply With Quote
  #45  
Old 14 Jul 2010, 04:58
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
OK. Then uninstall it and use the manual edits. I'll let grandeur_69 know.

Are you using a custom template? or the default?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:12.

Layout Options | Width: Wide Color: