Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Watermark Generator Details »
Watermark Generator
Mod Version: 1.1, by Disasterpiece (Coder) Disasterpiece is offline
Developer Last Online: Oct 2019 I like it Show Printable Version Email this Page

vB Version: 4.0.x Rating: (22 votes - 4.77 average) Installs: 153
Released: 18 May 2011 Last Update: 09 Jun 2011 Downloads: 1061
Not Supported DB Changes Uses Plugins Additional Files Is in Beta Stage  

Quick Info

This mod adds a watermark to album and attachment images.
The watermark is customizable via image files or specified text.
Processed images are cached and the original files remain untouched, so you can modify or remove the watermark anytime you want.


Features

- Intelligent Caching
- Uses standard vBulletin methods, therefore no file modifications necessary
- Settings-Preview with a sample image in Adminpanel
- Generative plugin behaviour, works with most other mods which use the same hooks or use attachment images elsewhere

Installation


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Changelog

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Additional Info

The Mod is currently in BETA. This means, that we tested it on a test environment (vb 4.0.x to 4.1.3) but has not yet undergo excessive stress test.
Keep an eye out for updated versions until the final release!
If you encounter any bugs, missing or misplaced features, let us know!

F.A.Q

- I don't see changes in my live images!
> To see changes on the image files you have to clear your browser's cache!
In firefox it's enough to force a fresh reload via STRG+F5 and on other browsers STRG+F5 or SHIFT+F5 should work.
If you don't perform this step, your browser will show the old cached version and maybe the watermark won't show or changes won't apply.

- My png/gif watermark isn't transparent, instead I get a black background!
> PNG-8 is known for having transparency problems, GIF in some cases as well.
Fall back to PNG-24 with Alpha channel (all modern image tools should be able to save as PNG-24)
If you have trouble creating a working png-24 with alpha channel, you can send me a PM with a link to your watermark and I'll convert it to png-24 for you.

- I have trouble with special characters or non-latin charactersets!
> The addon is using standard php functionalities for the text. If for any reason you have trouble with special chars, I suggest using a transparent png-24 with the text from an external image tool instead.

Support / Branding

We provide quality vbulletin software modifications for zero costs. To help our mod to be well-known, a backlink is added to your forum footer by the plugin, where the plugin is used in any way.
You must not remove the copyright/backlink code!
However, if you like to support us, you are allowed to remove the footer note with a small donation (10$ minimum).
If you choose to do so, we'll contact you via the email provided by paypal with instructions on how to remove the footer note.
A link to paypal donation service can be found on the top right area of this post.

Feel free to contact an author of the mod if you have any questions or suggestions.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	plwatermark_2.jpg
Views:	2797
Size:	105.4 KB
ID:	129186   Click image for larger version

Name:	plwatermark_3.jpg
Views:	3204
Size:	120.2 KB
ID:	129187   Click image for larger version

Name:	plwatermark_admin12.jpg
Views:	1685
Size:	108.0 KB
ID:	129188   Click image for larger version

Name:	plwatermark_admin11.jpg
Views:	3106
Size:	68.3 KB
ID:	129189  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #181  
Old 08 Mar 2013, 11:50
autoescala autoescala is offline
 
Join Date: Oct 2011
I tried this mod on my vb.4.2 pl3 and don't work, dont load the images
Uninstalled.....
Reply With Quote
  #182  
Old 12 Mar 2013, 15:27
grafixonline grafixonline is offline
 
Join Date: Oct 2012
I also installed it on my vb 4.2 and the images would not load. Is there a fix?
Reply With Quote
  #183  
Old 13 Mar 2013, 05:47
Disasterpiece's Avatar
Disasterpiece Disasterpiece is offline
 
Join Date: Apr 2007
Try changing the image plugin. GD or imagemagick, one should work, the other won't.
Reply With Quote
  #184  
Old 30 Apr 2013, 06:43
MZF-Onkel MZF-Onkel is offline
 
Join Date: Feb 2011
Works mostly fine under vBulletin 4.2.0 Patch Level 3.

In some old images, the watermark will not be shown, but in all newly uploaded it works

We use GD, here are some more informations:

GD Support enabled
GD Version bundled (2.0.34 compatible)
FreeType Support enabled
FreeType Linkage with freetype
FreeType Version 2.2.1
GIF Read Support enabled
GIF Create Support enabled
JPEG Support enabled
libJPEG Version 6b
PNG Support enabled
libPNG Version 1.2.10
WBMP Support enabled
XPM Support enabled
libXpm Version 30411
XBM Support enabled

It's in my opinion the BEST MOD for using Watermark in Images.

Best regards
Onkel
Reply With Quote
  #185  
Old 30 Apr 2013, 08:00
autoescala autoescala is offline
 
Join Date: Oct 2011
Dear Onkel,

When u install it, the watermark works for u in admin panel preview section ???

I my case I see the watermark, and I can test with the text option of watermark, but If I try use watermark image dont do nothing.

Best Regards
Reply With Quote
  #186  
Old 14 May 2013, 08:00
MZF-Onkel MZF-Onkel is offline
 
Join Date: Feb 2011
we tested it with the TEST Image, this works fine.

In the beginning we have some problems with the Images, they don't loaded.

I've installed an actually GD Version on the Server an now it works fine.

The problem that some old pictures have no watermark persists, unfortunately.
I don't know why.

Have you check your cache directory?
Have you installed some other Mods?

Best regards from Berlin
Reply With Quote
  #187  
Old 14 May 2013, 10:21
Disasterpiece's Avatar
Disasterpiece Disasterpiece is offline
 
Join Date: Apr 2007
I have no solution for the missing watermarks on older images, but can you use a different browser and checks if its still the same? Maybe your browser just cached old images.

Or try to move your attachments between database and filesystem once so they get reprocessed. Maybe it starts working then.
Reply With Quote
  #188  
Old 23 Jun 2013, 05:23
furnival furnival is offline
 
Join Date: Mar 2008
I am yet another user of this mod who would appreciate the option to stop it from watermarking images attached to posts in certain forums. Please consider this feature for the next release!

Also please consider moving the admin cp options to the standard position along with all the other VB plugin options, under the normal settings link. It seems unnecessary for this to have its own seperate menu.
Reply With Quote
  #189  
Old 24 Jun 2013, 16:48
Disasterpiece's Avatar
Disasterpiece Disasterpiece is offline
 
Join Date: Apr 2007
Originally Posted by furnival View Post
I am yet another user of this mod who would appreciate the option to stop it from watermarking images attached to posts in certain forums. Please consider this feature for the next release!
This is already on the to-do list for the next update.

Originally Posted by furnival View Post
Also please consider moving the admin cp options to the standard position along with all the other VB plugin options, under the normal settings link. It seems unnecessary for this to have its own seperate menu.
The usual settings page is not as flexible as a custom admin menu, but I'll see what I can do to put it all in one place.
Reply With Quote
  #190  
Old 23 Aug 2013, 21:10
Stefan118 Stefan118 is offline
 
Join Date: Dec 2010
The only issue i have with this SUPER mod is that it doesn't clear the cache after X seconds?
or is it minutes or days?

I hope it is seconds, just as about everything in vB.
If not, please do not laugh

I have set it to 86400 seconds, that should be 24 hours...
The cache is now 5 days old since i manualy cleared it.
Reply With Quote
  #191  
Old 13 Oct 2013, 12:40
Wajow-community Wajow-community is offline
 
Join Date: Dec 2009
Doesn't work for me
Reply With Quote
  #192  
Old 09 Nov 2013, 16:31
Wajow-community Wajow-community is offline
 
Join Date: Dec 2009
update for vb 4.2.x?
Reply With Quote
  #193  
Old 06 Dec 2013, 15:55
MZF-Onkel MZF-Onkel is offline
 
Join Date: Feb 2011
works fine with 4.2.2
Reply With Quote
  #194  
Old 14 Jan 2014, 18:11
Alibass's Avatar
Alibass Alibass is offline
 
Join Date: Mar 2007
Thumbs up

**Installed**

Running 4.2.2 here with attachments in file storage system. I had to input cache directory manually in my database. Other than that 'it works as advertised.

Thanks
__________________
Alibass
Reply With Quote
  #195  
Old 21 Mar 2014, 20:57
mkkak mkkak is offline
 
Join Date: Mar 2012
Originally Posted by Stefan118 View Post
The only issue i have with this SUPER mod is that it doesn't clear the cache after X seconds?
or is it minutes or days?

I hope it is seconds, just as about everything in vB.
If not, please do not laugh

I have set it to 86400 seconds, that should be 24 hours...
The cache is now 5 days old since i manualy cleared it.
The Same Problem
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 01:40.

Layout Options | Width: Wide Color: