Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #646  
Old 16 Jan 2009, 03:42
amcd amcd is offline
 
Join Date: Oct 2004
You have to run SQL queries to drop indices. If you do not know about this, ask for help from server support. Wrong commands can delete/damage data and it may not be reversible.
__________________
eXBii.com - Indian community
no XB no fun know XB know fun !
Reply With Quote
  #647  
Old 16 Jan 2009, 07:28
JamesN JamesN is offline
 
Join Date: Apr 2004
Thanks, this has been done.

Is there anything else that should be done?

--------------- Added 16 Jan 2009 at 10:28 ---------------

I'm now getting these errors upon creating new threads. Any idea why?

Database error in vBulletin 3.8.0:

Invalid SQL:

SELECT thread.threadid, MATCH(thread.title) AGAINST ('test') AS score
FROM thread AS thread

WHERE MATCH(thread.title) AGAINST ('test')
AND thread.open <> 10


LIMIT 5;

MySQL Error : Can't find FULLTEXT index matching the column list

Last edited by JamesN; 16 Jan 2009 at 10:28. Reason: Auto-Merged DoublePost
Reply With Quote
  #648  
Old 16 Jan 2009, 11:17
amcd amcd is offline
 
Join Date: Oct 2004
Do you have similar threads turned on? If not, then this does not look like a default vbulletin query. Must be some addon or mod.
__________________
eXBii.com - Indian community
no XB no fun know XB know fun !
Reply With Quote
  #649  
Old 16 Jan 2009, 11:31
JamesN JamesN is offline
 
Join Date: Apr 2004
Yep, similar threads is turned on. Shouldn't it be for it to work with Sphinx?
Reply With Quote
  #650  
Old 16 Jan 2009, 12:09
amcd amcd is offline
 
Join Date: Oct 2004
Unfortunately, no. The sphinx implementation posted in this thread does not work with similar threads.
__________________
eXBii.com - Indian community
no XB no fun know XB know fun !
Reply With Quote
  #651  
Old 16 Jan 2009, 12:27
JamesN JamesN is offline
 
Join Date: Apr 2004
Oh ok - thanks, is there anything else that needs to be switched off for it to work correctly?
Reply With Quote
  #652  
Old 16 Jan 2009, 14:17
mta mta is offline
 
Join Date: Oct 2005
I've installed and integrated sphinx search 0.98.1 w/ VB 3.7.4p1 using the included plugin and instructions on the first post of this thread.

I'm limiting sphinx and vb to 500 results.

Everything appears to be working fine, except clicking on "Find all posts/threads by user..." from within the member's profile when the user has hundreds ( vs tens ) of posts. This results in the following error:

The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.
MySQL error logging is on, but no errors are showing up in the logs.

I'm using everything stock as provided in examples ( sphinx.conf ) and search_sphinx.php, save I uncommented prefixchoice for vb 3.7 and re-replaced INSERT INTO w/ REPLACE INTO.

I'll post configs if necessary.

Any suggestions/help?

Thanks!

--------------- Added 16 Jan 2009 at 15:06 ---------------

It may be worthy to note that going to Search/Advanced Search and searching for posts/threads by user works without issue.

Last edited by mta; 16 Jan 2009 at 15:06. Reason: Auto-Merged DoublePost
Reply With Quote
  #653  
Old 16 Jan 2009, 17:39
amcd amcd is offline
 
Join Date: Oct 2004
That search does not use sphinx AFAIK. And the error you are reporting looks like a Firefox caching problem.
__________________
eXBii.com - Indian community
no XB no fun know XB know fun !
Reply With Quote
  #654  
Old 20 Jan 2009, 09:27
tmc tmc is offline
 
Join Date: May 2008
Originally Posted by LauraS View Post
Running into a problem with sphinx in terms of getting statistics for users. Whenever I try to click on Find all posts by username or Find all threads started by username in the statistics section for a user I always get the following message back:

1. Sorry - no matches. Please try some different terms. %1$s

Any of you guys have any ideas? I know for a face there are threads/posts for the user I'm analyzing. Almost looks like something isn't being escaped out in the sphinx code. I installed sphinx using the plugin method with search_sphinx.php file. Normal search on site seems to work. It's just seems messed up when trying to analyze user stats.
Anyone have a solution for this yet?? I basically can't turn Sphinx back on until I know how to fix it.. :/

I'm using 3.8.0
Reply With Quote
  #655  
Old 30 Jan 2009, 09:10
djxcee djxcee is offline
 
Join Date: Mar 2008
Real name: Chris N.
I'm sorry if it's already answered (can't go though 44 pages...)

How much CPU load would sphinx take off compare to the default search engine?
Reply With Quote
  #656  
Old 30 Jan 2009, 09:34
amcd amcd is offline
 
Join Date: Oct 2004
That depends on a large number of factors and cannot be quantified by a rule of thumb. But believe us when we say that it will be worth the effort.
__________________
eXBii.com - Indian community
no XB no fun know XB know fun !
Reply With Quote
  #657  
Old 01 Feb 2009, 19:19
Kevlar's Avatar
Kevlar Kevlar is offline
 
Join Date: Nov 2001
Originally Posted by djxcee View Post
I'm sorry if it's already answered (can't go though 44 pages...)

How much CPU load would sphinx take off compare to the default search engine?
It makes a huge difference ... but then again, I have 15 million posts to index.
__________________
KEVLAR
www.bimmerforums.com
Reply With Quote
  #658  
Old 28 Feb 2009, 21:39
JamesN JamesN is offline
 
Join Date: Apr 2004
If I want to revert back to the default vBulletin search engine for a while, what do I need to do?
Reply With Quote
  #659  
Old 09 Mar 2009, 15:29
ibautocommunity's Avatar
ibautocommunity ibautocommunity is offline
 
Join Date: Jan 2009
Real name: Anders
Originally Posted by JamesN View Post
If I want to revert back to the default vBulletin search engine for a while, what do I need to do?
You would have to remove the sphinx plugin / hacks and rebuild the search index.
Reply With Quote
  #660  
Old 10 Mar 2009, 15:00
Simetrical Simetrical is offline
 
Join Date: Nov 2006
I have a weird problem on my site. Compare these two searches:

http://www.twcenter.net/forums/searc...ss&query=Darth
http://www.twcenter.net/forums/searc...th&showposts=1

They search for exactly the same thing, the word "Darth". The first one (results as threads) shows all the recent occurrences of the word, as expected. But the second one (results as posts) cuts off at August 2, 2007. The effect doesn't occur for other words, like "Vader":

http://www.twcenter.net/forums/searc...ss&query=Vader
http://www.twcenter.net/forums/searc...er&showposts=1

Does anyone have any ideas?
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:31.

Layout Options | Width: Wide Color: