Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Link Anonymizer Details »
Link Anonymizer
Mod Version: 1.10, by Marco van Herwaarden (Member) Marco van Herwaarden is offline
Developer Last Online: Dec 2010 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.5.1 Rating: (4 votes - 5.00 average) Installs: 154
Released: 06 Sep 2005 Last Update: 25 Nov 2005 Downloads: 676
Not Supported Uses Plugins  

Link Anonymizer v1.02a & 1.03, 1.04, 1.05.3 & 1.10

Author: MarcoH64

vBulletin Version: 3.5.1

Warning: Version 1.02 might create double anonym links if you edit a post multiple times. Version 1.03 has been reported not to be working for some people. Please read posts in this thread if you plan on using this hack, until i had time to look into this.
v1.05 and higher should be the best versions
1.10 Is an updated version of 1.05.3 and is considered a stable release. Only version 1.10 will be supported now.

Description:
This Product will add a self configurable anonymising link to all external urls in posts.

Installation:
Install the XML-file as Product.

Configuration:
vBulletin Options->Link Anonymizer :
  • Local Addresses
Local addresses are not anonymized. If you leave this option blank, the value for vBulletin Options Cookie Domain will be used. Do not use a http:// prefix.

If you start the name with a dot (.mydomain.com) all server addresses ending with this will be considered local. If you want to add mulitple domain/servernames, seperate them by a single space.


Link to a anonymizer function. Use preceding / if needed. Other Usable Anonymizers:
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


  • Allways anonymize Unparseble URLs (* New in version 1.10)
Please click install if you are using this hack.

Donations are always welcomed at Paypal: marcoh64 AT gmail.com

Change log:
6-9-2005 v1.01
- 1 setting was missing from product file due to wrong Product. Fixed
7-9-2005 v1.02
- Under some conditions a newly posted post with only a link would not get anonymized. Fixed.
7-9-2005 v1.02a
- Fixed bug when handling generic local domain (starting with a dot '.'') Sorry for the many updates.
8-10-2005 v1.03
- Totally new way of doing this, on view instead of on write.
- Solved doubling the anonym link on edit
10-10-2005 v1.04
- Link not didn't get anonym prefix if URL= didn't contain http://. Solved.
- Added truncate table post_parsed to install routine.
1-11-2005 v1.05
- Standard Editor fixed
- Simple URL's in standard editor fixed.
- Default anonymizer changed
2-11-2005 v1.05.1
- Fixed bug where only the last url to the same domain in a single post was anonymised.
9-11-2005 v1.05.2
- Added option to ignore certain protocols in the vBulletin Options (ie. ignore https, ftp, ....).
- Attempt to fix reported bug where an inline fragment (#fragment) would also be anonymized.
10.11.2005 v1.05.3
- Another attempt to ignore fragments
25.11.2005 v1.10
- Fixed a bug where some urls could lead to a parse error. Example of an url leading to this error:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

- Added new parameter to vB Options: Always anonimyze unparseble URLs
- This is considered a very stable release. No bug reports pending
- All previous versions are from now on unsupported

Upgrades:
If you are running an older version and want to upgrade, simply do an overwrite install.

It is possible that there are still double links in the database from old versions. If you wish to remove these, run the following queries (make backup first!!):

SQL Query: (how to run queries)
update post set pagetext = replace(pagetext, "http://YOURANONIMIZERLINK/","");

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases Link Anonymizer and Censor Marco van Herwaarden vBulletin 3.6 Add-ons 103 12 Sep 2014 10:39

  #46  
Old 08 Oct 2005, 08:56
Chad F. Chad F. is offline
 
Join Date: Nov 2004
It works fine when I make a new post. I ran those queries and it did not do anything, all the old links still have http://anonym.to/? in front of them 5 times.
Reply With Quote
  #47  
Old 08 Oct 2005, 11:48
Marco van Herwaarden Marco van Herwaarden is offline
 
Join Date: Jul 2004
Sorry no time now, but will later today post the exact query you will need to run.
__________________
Marco van Herwaarden
Ex vBulletin.org Coordinator
Reply With Quote
  #48  
Old 08 Oct 2005, 12:51
RMS-Chef RMS-Chef is offline
 
Join Date: Aug 2003
When I installed 1.03 the system simply stopped working.
Tried overwrite, then uninstalled and reinstalled.
Currently on RC3.

EDIT:
Just updated to v3.5 Gold and still, the plugin just does not work for me.
__________________
Hi.

Last edited by RMS-Chef; 08 Oct 2005 at 18:19.
Reply With Quote
  #49  
Old 08 Oct 2005, 19:03
C_P's Avatar
C_P C_P is offline
 
Join Date: Sep 2004
Originally Posted by RMS-Chef
When I installed 1.03 the system simply stopped working.
Tried overwrite, then uninstalled and reinstalled.
Currently on RC3.

EDIT:
Just updated to v3.5 Gold and still, the plugin just does not work for me.
Seems I have same issue after upgrade. I then added the following and seems to work
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

in the Local addresses are not anonymized section.

Last edited by C_P; 08 Oct 2005 at 21:48.
Reply With Quote
  #50  
Old 08 Oct 2005, 21:38
Loki12 Loki12 is offline
 
Join Date: Jul 2004
Originally Posted by RMS-Chef
When I installed 1.03 the system simply stopped working.
Tried overwrite, then uninstalled and reinstalled.
Currently on RC3.

EDIT:
Just updated to v3.5 Gold and still, the plugin just does not work for me.
I am on 3.5.0, just installed this product, and it is not working at all...
Reply With Quote
  #51  
Old 08 Oct 2005, 21:49
JohnBee JohnBee is offline
 
Join Date: Oct 2004
Same here, uninstalled the old version, ran the queeries and installed 1.03 now nothing...

I don't think running the links through a public anonymizer will beat your other system, if there is any .htaccess of any kind the anonymizer will not process the link. Your last hack approach was good it simply needed some refinement where post editing took place in order to deal with duplicating the redirector code.

Hope you sort it out soon, as for myself I have put back the old system until its sorted out

Additionaly there was a =3.0.x privacy link MOD, it used the same principle as this one here and had no inherent problems with duplicate tags. Perhaps you could take a peek at the other KACK to see if you can't use the same approach for this hack

Last edited by JohnBee; 08 Oct 2005 at 21:55.
Reply With Quote
  #52  
Old 09 Oct 2005, 08:44
Marco van Herwaarden Marco van Herwaarden is offline
 
Join Date: Jul 2004
Sorry guys i will try to have a look one of these days, but not much time now.

Looking at a 3.0 hack will not help, since the internals are really different.

I don't really understand why 1.03 shouldn't work for some people, it is working fine on my testboard.
__________________
Marco van Herwaarden
Ex vBulletin.org Coordinator
Reply With Quote
  #53  
Old 09 Oct 2005, 14:59
dasdingansich dasdingansich is offline
 
Join Date: Jan 2005
I noticed some strange behavior:

it works flawless when using the "insert hyperlink" feature, but when posting only the text "www.google.com" or "http://www.google.com" it wouldnīt render the anonymizer URL into until I edited the posting and saved again.

the problem ist, only few people actually use that button and just prefer to type away ... do you know any workaround?
Reply With Quote
  #54  
Old 09 Oct 2005, 21:34
Marco van Herwaarden Marco van Herwaarden is offline
 
Join Date: Jul 2004
I actually never even tested the 'insert hyperlink'. I have just tested it with typing w ww.google.com on my testboard. Strange that it doesn't work.

I don't really have time to dig deep inot this right now, but i will try to find some time tomorrow or the day after.

Until then i will post a warning in the first post.

PS Since version 1.03 is adding the link when displaying a post, it shouldn't make a difference how you entered it in the first place, very strange. Try just doing a refresh, maybe the AJAX screen update when posting is not showing it.
__________________
Marco van Herwaarden
Ex vBulletin.org Coordinator

Last edited by Marco van Herwaarden; 09 Oct 2005 at 21:38.
Reply With Quote
  #55  
Old 09 Oct 2005, 21:52
Catlover Catlover is offline
 
Join Date: Jul 2005
MarcoH64, strange, but fact: some links anonymized, some - not Links posted by some users - just direct links, but all links i posted - anonymized...i don't understand why it happens.
Reply With Quote
  #56  
Old 09 Oct 2005, 22:14
Marco van Herwaarden Marco van Herwaarden is offline
 
Join Date: Jul 2004
Any chance you could PM me some links of posts that are working and some that are not working?

PS If your board is closed, send also a test account.
__________________
Marco van Herwaarden
Ex vBulletin.org Coordinator
Reply With Quote
  #57  
Old 10 Oct 2005, 03:28
Chad F. Chad F. is offline
 
Join Date: Nov 2004
I just re-installed the plugin again and like before it works on new posts etc. but now its not anonymizing links in old posts..
Reply With Quote
  #58  
Old 10 Oct 2005, 09:01
dasdingansich dasdingansich is offline
 
Join Date: Jan 2005
btw, I had two ideas for new features:

- a setting for what kind of URLīs are anonymized.
like anonymize all kinds of pages like plain domains, folders, .htm, .php and so on, but donīt anonymze file links

- ability to turn it on / off on a per forum basis.
In my case I really only need it in one forum, and I definately canīt use it in another.

(one forum is called "politics", sometimes people are hotlinking sites we really donīt want visitors from. A totally different forum on the same messageboard is movie-related, and we need to be able to link .movīs and to save them with right-click.)
Reply With Quote
  #59  
Old 10 Oct 2005, 09:03
dasdingansich dasdingansich is offline
 
Join Date: Jan 2005
another suggestion:

I found out anonymizer.com sucks, itīs only free for a few clicks, after that Iīm getting popups and ad pages, telling me I should subscribe. Right now Iīm using www.anonym.to - seems to be free and easy!
also killing the referrer, but no proxy.
Reply With Quote
  #60  
Old 10 Oct 2005, 09:11
Marco van Herwaarden Marco van Herwaarden is offline
 
Join Date: Jul 2004
New version v1.04, should fix the reported bugs.

Will wait to see if this is working good for everyone (did some more extensive testing this time). If all is ok, i will have a look at the feature suggestions.

@dasdingansich
You can configure what anonymizer you want to use, but maybe i should change the default if that one is too much limited.
__________________
Marco van Herwaarden
Ex vBulletin.org Coordinator
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 18:32.

Layout Options | Width: Wide Color: