Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
VB Pro Garage Timeslips Details »
VB Pro Garage Timeslips
Mod Version: 3.0.9, by Dylanblitz (Contributor) Dylanblitz is offline
Developer Last Online: Feb 2017 I like it Show Printable Version Email this Page

vB Version: 4.0.x Rating: (43 votes - 4.70 average) Installs: 259
Released: 25 Feb 2010 Last Update: 29 Sep 2012 Downloads: 1665
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Translations  

Description
VB Pro Garage Timeslips (formerly CND Garage/Timeslips) is a free vehicle and timeslips add on for vBulletin 4. This is a great way to allow members to show off their rides, whether they are cars, motorcycles, atv's, etc. Site administrators have dozens of options to tailor the way the garage is displayed and the number of vehicles, images and timeslips the user can enter. User vehicle creation is done through a simple screen with dropdowns and simple text fields. Users can enter either miles or km and system will automatically calculate differences for front page statistics.

** New Features **

* SEO Friendly URLs (htaccess only)
* Page Caching - physical html files which make a HUGE reduction in sql queries
* Front Categories - a category system as an alternate front page to the block layout. I believe it will increase the garage ranking in search engines greatly when used with SEO URL's and the included dynamic meta tags.
* Thread Creation - Automatically create new threads in the forum of your choosing with the text of your choosing when a new vehicle is created in the garage.

Main Features

* No vb template modification needed
* Ajax driven menu's to keep load time down if you have a very large lists of makes/models
* Usergroup level permissions to set the amount of vehicles, images, timeslips allowed
* 99.9% of the text is phrased so that it can be translated for multinational sites
* On the fly image/text watermarking ability to make sure images are tied to your site
* Lytebox image presentation

Installation
Instructions, tips and more are now in the included chm file. If you have problems with the chm I have the document published at:
http://www.vbprogarage.com/forums/docs/html_vb4_ts_300/

The quick and dirty install:
1) Upload all files in the upload folder
2) Import vb_pro_garage.xml into Product Manager
3) Import vb_pro_garage_language_english.xml into Languages & Phrases
4) If you want all makes and models I've collected, import vb_pro_garage_vehicles^^new_install_only.xml into Product Manager

Post Installation
So you don't have to find it in the instructions. After install, there is a button up top in the navbar. This button by default is admin only. This is so you can configure and test without having to close the garage. When you are ready to deploy to the community:
ACP->Settings->Options->Garage General Settings - Set Garage Menu Button to Enabled.

The garage is developed on vb 4.0.7 and tested back to 4.0.0. The garage will run on PHP 5.x+ compiled with GD/GD2 and MySQL 5.x+

Additional options for the garage like adding featured businesses that support your site, fuel tracking, dyno charts, modifications and lots more are included in the commercial version.

Many thanks to Coroner for his stylebridge which led me on a path that saved me hours and hours of template editing

There are a few bugs that you might run into on this version. Instead of working on correcting them in the files and working on getting a new package up here, I'm working on the next version and including the posts that fix the errors here.

Change Log:
v3.0.9 - 09/29/2012
-----------------------------
Fixed sql injection problem
Replaced depreciated split function usage
Fixed sql error on image comments
Fixed Make/Model count on front page resetting to 1
Fixed extra unlabeled field on vehicle create/edit (Timeslips only)
Fixed postbit dropdown showing character code
Fixed tables incorrectly set with TYPE instead of ENGINE
Added navigation manager links to product xml

v3.0.8 - 12/9/2010
-----------------------------
Fixed missing vehicle comment code

v3.0.7 - 12/1/2010
-----------------------------
Fixed error with non existant garage_special_track table

v3.0.6 - 11/21/2010
-----------------------------
Fixed who's online error
Fixed map infowindow colors

v3.0.5 - 11/15/2010
-----------------------------
Fixed error with member profile vehicle block
Fixed member tab url path
Fixed error on vehicle map with apostrophes in title

v3.0.4a - 11/12/2010
-----------------------------
Corrected package error

v3.0.4 - 11/11/2010
-----------------------------
Fixed error with front blocks
Fixed style error with vB4.0.8 changes

v3.0.3 - 11/2/2010
-----------------------------
Fixed duplicate countries
Fixed vehicle view slideshow image size
Fixed username browse error
Fixed geocode error on missing zip
Fixed postbit error with vehicles that have a apostrophe in the name

v3.0.2 - 10/25/2010
-----------------------------
Fixed missing add vehicle button on member profile
Added bbcode capabilities to welcome box on garage front page
Moved vehicle count to db table to ease db queries
Added notification scheduled task to send message to new users about adding a garage entry
Added default clear image for watermark
Fixed code to disregard watermark option if image is missing
Fixed search username error
Updated obsolete data queries
Added SEO Friendly URLS
Added page caching capabilities
Fixed sql error with moving vehicle class and color to new selection on deletion in ACP
Added function to replace non english characters with english characters in ajax selection lists
Added image comments
Added notification for image and vehicle comments
Added option to add page title
Added zip code to vehicle and googlemap
Added ability to disable and ability to hide info for googlemap

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	01_front_cat.png
Views:	4119
Size:	133.0 KB
ID:	123185   Click image for larger version

Name:	01_front.jpg
Views:	2308
Size:	63.1 KB
ID:	123186   Click image for larger version

Name:	02_ajax_image_data.png
Views:	1793
Size:	62.1 KB
ID:	123187   Click image for larger version

Name:	02a_browse.jpg
Views:	1931
Size:	86.8 KB
ID:	123188  

Click image for larger version

Name:	03_add_vehicle.jpg
Views:	1122
Size:	94.5 KB
ID:	123189   Click image for larger version

Name:	04_view_vehicle.jpg
Views:	1425
Size:	89.1 KB
ID:	123190   Click image for larger version

Name:	05_add_timeslip.png
Views:	901
Size:	24.6 KB
ID:	123191   Click image for larger version

Name:	06_view_timeslip.png
Views:	784
Size:	18.3 KB
ID:	123192  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases CND Garage - Timeslips Dylanblitz vBulletin 3.8 Add-ons 227 24 May 2015 21:29

  #496  
Old 17 Jan 2011, 18:11
Kolbi's Avatar
Kolbi Kolbi is offline
 
Join Date: Mar 2009
Real name: Matthias
I gives me errors with vB 4.1.1:
Deprecated: Assigning the return value of new by reference is deprecated in htdocs\includes\garage_func_var.php on line 6412

Deprecated: Assigning the return value of new by reference is deprecated in htdocs\includes\garage_func_var.php on line 6692

Deprecated: Assigning the return value of new by reference is deprecated in htdocs\includes\garage_func_var.php on line 8110
Reply With Quote
  #497  
Old 17 Jan 2011, 20:17
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by KeystoneAirsoft View Post
Hi all.

Has anyone got this to work 100% with all features running vBulletin 4.1.0 Patch Level 2? I have tried to install it 3 times and am unable to get the Comments section to show anywhere and all comment areas are enabled in admin.

Just curious if it works.

Thanks.
Are you not able to comment or are the comments not showing up?
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #498  
Old 17 Jan 2011, 20:19
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by Kolbi View Post
I gives me errors with vB 4.1.1:
If you open includes/garage_func_vars.php and replace all instances of


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

with


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

it should fix it. There are 3 of them to replace.
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #499  
Old 17 Jan 2011, 21:04
Sixes Sixes is offline
 
Join Date: Apr 2010
No worries on my end and I am now at 4.1.1
Reply With Quote
  #500  
Old 09 Feb 2011, 15:01
bjarne2 bjarne2 is offline
 
Join Date: Dec 2009
Thumbs down

It is simply too poor software. It will not work in Internet Explorer 8 without it is in the Compatible mode and the rest of the vbulletin works in a different way. I have spent several days to put myself in the function of the software. It is so poorly written and sloppy that it will not buy the full virsion. This is really bad publicity for the official version.
We are in vBulletin 4.1.1 now........
Reply With Quote
  #501  
Old 16 Feb 2011, 21:27
Trumpetrhapsody Trumpetrhapsody is offline
 
Join Date: Oct 2009
On my forum when you put that gallery block on the main forum homepage set to "under who's online" it wedges it between Today's Events and Forum Statistics. Would be nice to be all the way under in it's own block.

Also would be good to touch up the looks of when you have it showing "All vehicles" in the postbit, I think they're a bit far apart, maybe need some sort of <HR> above them to separate from the rest of the info, maybe a header title or something?

EDIT: Somehow updating to this latest version has messed up something in my vb user profiles, some code is showing haha. Oh and I'm still getting 500 server errors trying to upload images, and it's very buggy in IE8.
__________________
VB4.1.8 Forum: http://www.OzarkAutoSport.com

Last edited by Trumpetrhapsody; 16 Feb 2011 at 22:04.
Reply With Quote
  #502  
Old 17 Feb 2011, 17:09
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by Trumpetrhapsody View Post
On my forum when you put that gallery block on the main forum homepage set to "under who's online" it wedges it between Today's Events and Forum Statistics. Would be nice to be all the way under in it's own block.

Also would be good to touch up the looks of when you have it showing "All vehicles" in the postbit, I think they're a bit far apart, maybe need some sort of <HR> above them to separate from the rest of the info, maybe a header title or something?

EDIT: Somehow updating to this latest version has messed up something in my vb user profiles, some code is showing haha. Oh and I'm still getting 500 server errors trying to upload images, and it's very buggy in IE8.
The WGO box doesn't have a template hook underneath it unfortunately. I'll see if I can get it into the ad location down there in the next version.

If you have an option to display all vehicles in the postbit then it's not OOB code. That was developed by a user. I incorporated it into the core product but it works differently now.

What kind of code is showing in the user profile? It's probably the new postbit data. It's stored in a custom profile field, but it's only visible to the admin.

With the image error, does it show you any code errors or just a 500 page?
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #503  
Old 17 Feb 2011, 17:15
Trumpetrhapsody Trumpetrhapsody is offline
 
Join Date: Oct 2009
My mistake, that was a mod for the garage, I've disabled it for now but the code in the profile, and breaking of the PM system remains.

This shows in some user profiles:

About FlatBlack

<div class="imlinks">
<div class="popupmenu vehicleaction">
<a class="popupctrl" href="#"><strong>Vehicles</strong></a>
<ul class="popupbody popuphover vehicleaction_body">
<li class="left"><a href="http://www.nwamotorsports.net/garage_vehicle.

And I get a 500 Internal Server error when viewing PM's and trying to upload an image. No code errors, just the page:

0
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, cgiadmin@yourhostingaccount.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
With "500 Internal Server Error" in the tab.

EDIT: Fixed the PM issue by fully uninstalling that modification (was Bzopi's). Now just the image upload issue is the last crippling problem.

And yeah it seems like the:

{vb:raw template_hook.forumhome_wgo_pos5} or {vb:raw ad_location.board_below_whats_going_on}

Hooks would've worked better. Guess i'll just move it manually for now if I can, just looks wonky.
__________________
VB4.1.8 Forum: http://www.OzarkAutoSport.com

Last edited by Trumpetrhapsody; 17 Feb 2011 at 17:41.
Reply With Quote
  #504  
Old 17 Feb 2011, 18:06
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by Trumpetrhapsody View Post
My mistake, that was a mod for the garage, I've disabled it for now but the code in the profile, and breaking of the PM system remains.

This shows in some user profiles:




And I get a 500 Internal Server error when viewing PM's and trying to upload an image. No code errors, just the page:


With "500 Internal Server Error" in the tab.

EDIT: Fixed the PM issue by fully uninstalling that modification (was Bzopi's). Now just the image upload issue is the last crippling problem.

And yeah it seems like the:

{vb:raw template_hook.forumhome_wgo_pos5} or {vb:raw ad_location.board_below_whats_going_on}

Hooks would've worked better. Guess i'll just move it manually for now if I can, just looks wonky.
Could you pm me a temp account that has access to create vehicles? I'll see if I can find out the problem.

The pos5 hook is still part of the block. I'll try and attach to the below_whats_going_on later, it would be the best bet since it's outside of the WGO box but it's not a hook so you can't just attach to it unfortunately.

bszopi's addon hasn't been updated in a while since I incorporated it, there was probably some conflict between the addon and changed code in the garage. Glad that's worked out though
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #505  
Old 17 Feb 2011, 18:11
Trumpetrhapsody Trumpetrhapsody is offline
 
Join Date: Oct 2009
Actually it's still giving issues, that one user has that code back again, and now his postbit even shows this:

<div class="imlinks"> <div class="popupmenu vehicleaction"> <a class="popupctrl" href="#"><strong>Vehicles</strong></a> <ul class="popupbody popuphover vehicleaction_body"> <li class="left"><a href="http://www.nwamotorsports.net/garage_vehicle.


I'll PM you an account. Thanks!


EDIT: Fixed that user's postbit and profile issue by using the garage's "rebuild postbit" feature. Must have been a conflict between your new system and bzopi's old one. Now just the image uploading issue remains!

DoubleEdit:

I fixed the position of the forumhome gallery bar, thusly:

Edit your ForumHome template, find and move {vb:raw template_hook.forumhome_wgo_pos5} Two </div>'s down.
Then open up the product xml (vb_pro_garage), find template_hook.forumhome_wgo_pos3 and change the 3 to a 5.
Now re-import the product xml you just edited.

As far as I know nothing is using the 5 position, so it should be fine. Works and looks great on my board (could use a little padding underneath though). This should work till Dylan gets it fixed properly in the next release.
__________________
VB4.1.8 Forum: http://www.OzarkAutoSport.com

Last edited by Trumpetrhapsody; 17 Feb 2011 at 19:22.
Reply With Quote
  #506  
Old 18 Feb 2011, 17:31
Trumpetrhapsody Trumpetrhapsody is offline
 
Join Date: Oct 2009
Image issue resolved! My PHP memory limit was set to 8MB, increased it to 64MB and now everything is working like it should.

One style problem i'm still having though, in the forumHome gallery bar if you have a really wide pic it'll shove everything off the screen to the right. Looks like it needs a width constraint along with the height limit.
__________________
VB4.1.8 Forum: http://www.OzarkAutoSport.com
Reply With Quote
  #507  
Old 24 Feb 2011, 22:55
venom2124's Avatar
venom2124 venom2124 is offline
 
Join Date: Feb 2009
Okay keep getting the following message


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I'm also getting an error that my picture ,which is JPG format, Not a supported image type (jpg, gif, png).

Would like to see if we can resolve the issue.
Reply With Quote
  #508  
Old 25 Feb 2011, 01:06
cTak cTak is offline
 
Join Date: Sep 2006
Dylan,

How can you edit colors?

I have been trying to edit the colors when viewing garage.php. My forum has a black background and white text. I read one of your posts and you said to edit .alt1 and .alt2 in garage_css, I did that and saved the CSS, but it did not change anything when viewing the website.

What am I missing??

Thanks!!

Also need to edit the background of the "slideshow" area on garage.php
__________________
Version 4.1.2 User
Reply With Quote
  #509  
Old 26 Feb 2011, 11:30
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by cTak View Post
Dylan,

How can you edit colors?

I have been trying to edit the colors when viewing garage.php. My forum has a black background and white text. I read one of your posts and you said to edit .alt1 and .alt2 in garage_css, I did that and saved the CSS, but it did not change anything when viewing the website.

What am I missing??

Thanks!!

Also need to edit the background of the "slideshow" area on garage.php
Are you sure you edited the template in the right style? It should match the style of the forum. PM me a link and I'll take a look. If the garage requires an account to view it send me one with access as well
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #510  
Old 26 Feb 2011, 11:33
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by venom2124 View Post
Okay keep getting the following message


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I'm also getting an error that my picture ,which is JPG format, Not a supported image type (jpg, gif, png).

Would like to see if we can resolve the issue.
Is this on one specific jpg or any jpg you try and upload? It looks like I see a bunch of vehicles with images on your site so I'm not sure.
__________________
VB Pro Garage with Timeslips
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 05:41.

Layout Options | Width: Wide Color: