Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
VB Pro Garage Timeslips Details »
VB Pro Garage Timeslips
Mod Version: 3.0.9, by Dylanblitz (Contributor) Dylanblitz is offline
Developer Last Online: Feb 2017 I like it Show Printable Version Email this Page

vB Version: 4.0.x Rating: (43 votes - 4.70 average) Installs: 259
Released: 25 Feb 2010 Last Update: 29 Sep 2012 Downloads: 1665
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Translations  

Description
VB Pro Garage Timeslips (formerly CND Garage/Timeslips) is a free vehicle and timeslips add on for vBulletin 4. This is a great way to allow members to show off their rides, whether they are cars, motorcycles, atv's, etc. Site administrators have dozens of options to tailor the way the garage is displayed and the number of vehicles, images and timeslips the user can enter. User vehicle creation is done through a simple screen with dropdowns and simple text fields. Users can enter either miles or km and system will automatically calculate differences for front page statistics.

** New Features **

* SEO Friendly URLs (htaccess only)
* Page Caching - physical html files which make a HUGE reduction in sql queries
* Front Categories - a category system as an alternate front page to the block layout. I believe it will increase the garage ranking in search engines greatly when used with SEO URL's and the included dynamic meta tags.
* Thread Creation - Automatically create new threads in the forum of your choosing with the text of your choosing when a new vehicle is created in the garage.

Main Features

* No vb template modification needed
* Ajax driven menu's to keep load time down if you have a very large lists of makes/models
* Usergroup level permissions to set the amount of vehicles, images, timeslips allowed
* 99.9% of the text is phrased so that it can be translated for multinational sites
* On the fly image/text watermarking ability to make sure images are tied to your site
* Lytebox image presentation

Installation
Instructions, tips and more are now in the included chm file. If you have problems with the chm I have the document published at:
http://www.vbprogarage.com/forums/docs/html_vb4_ts_300/

The quick and dirty install:
1) Upload all files in the upload folder
2) Import vb_pro_garage.xml into Product Manager
3) Import vb_pro_garage_language_english.xml into Languages & Phrases
4) If you want all makes and models I've collected, import vb_pro_garage_vehicles^^new_install_only.xml into Product Manager

Post Installation
So you don't have to find it in the instructions. After install, there is a button up top in the navbar. This button by default is admin only. This is so you can configure and test without having to close the garage. When you are ready to deploy to the community:
ACP->Settings->Options->Garage General Settings - Set Garage Menu Button to Enabled.

The garage is developed on vb 4.0.7 and tested back to 4.0.0. The garage will run on PHP 5.x+ compiled with GD/GD2 and MySQL 5.x+

Additional options for the garage like adding featured businesses that support your site, fuel tracking, dyno charts, modifications and lots more are included in the commercial version.

Many thanks to Coroner for his stylebridge which led me on a path that saved me hours and hours of template editing

There are a few bugs that you might run into on this version. Instead of working on correcting them in the files and working on getting a new package up here, I'm working on the next version and including the posts that fix the errors here.

Change Log:
v3.0.9 - 09/29/2012
-----------------------------
Fixed sql injection problem
Replaced depreciated split function usage
Fixed sql error on image comments
Fixed Make/Model count on front page resetting to 1
Fixed extra unlabeled field on vehicle create/edit (Timeslips only)
Fixed postbit dropdown showing character code
Fixed tables incorrectly set with TYPE instead of ENGINE
Added navigation manager links to product xml

v3.0.8 - 12/9/2010
-----------------------------
Fixed missing vehicle comment code

v3.0.7 - 12/1/2010
-----------------------------
Fixed error with non existant garage_special_track table

v3.0.6 - 11/21/2010
-----------------------------
Fixed who's online error
Fixed map infowindow colors

v3.0.5 - 11/15/2010
-----------------------------
Fixed error with member profile vehicle block
Fixed member tab url path
Fixed error on vehicle map with apostrophes in title

v3.0.4a - 11/12/2010
-----------------------------
Corrected package error

v3.0.4 - 11/11/2010
-----------------------------
Fixed error with front blocks
Fixed style error with vB4.0.8 changes

v3.0.3 - 11/2/2010
-----------------------------
Fixed duplicate countries
Fixed vehicle view slideshow image size
Fixed username browse error
Fixed geocode error on missing zip
Fixed postbit error with vehicles that have a apostrophe in the name

v3.0.2 - 10/25/2010
-----------------------------
Fixed missing add vehicle button on member profile
Added bbcode capabilities to welcome box on garage front page
Moved vehicle count to db table to ease db queries
Added notification scheduled task to send message to new users about adding a garage entry
Added default clear image for watermark
Fixed code to disregard watermark option if image is missing
Fixed search username error
Updated obsolete data queries
Added SEO Friendly URLS
Added page caching capabilities
Fixed sql error with moving vehicle class and color to new selection on deletion in ACP
Added function to replace non english characters with english characters in ajax selection lists
Added image comments
Added notification for image and vehicle comments
Added option to add page title
Added zip code to vehicle and googlemap
Added ability to disable and ability to hide info for googlemap

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	01_front_cat.png
Views:	4119
Size:	133.0 KB
ID:	123185   Click image for larger version

Name:	01_front.jpg
Views:	2308
Size:	63.1 KB
ID:	123186   Click image for larger version

Name:	02_ajax_image_data.png
Views:	1793
Size:	62.1 KB
ID:	123187   Click image for larger version

Name:	02a_browse.jpg
Views:	1931
Size:	86.8 KB
ID:	123188  

Click image for larger version

Name:	03_add_vehicle.jpg
Views:	1122
Size:	94.5 KB
ID:	123189   Click image for larger version

Name:	04_view_vehicle.jpg
Views:	1425
Size:	89.1 KB
ID:	123190   Click image for larger version

Name:	05_add_timeslip.png
Views:	901
Size:	24.6 KB
ID:	123191   Click image for larger version

Name:	06_view_timeslip.png
Views:	784
Size:	18.3 KB
ID:	123192  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases CND Garage - Timeslips Dylanblitz vBulletin 3.8 Add-ons 227 24 May 2015 21:29

  #661  
Old 27 Aug 2011, 02:44
maupz maupz is offline
 
Join Date: Aug 2011
Dylan, We really appreciate this app it works wonderfull

Just one quick question

How do I do to center the app, my forum has a center frame just like this forum but when i access the garage everything appears on left side!!!

THANKS IN ADVANCE!!!!!!
Reply With Quote
  #662  
Old 27 Aug 2011, 02:44
maupz maupz is offline
 
Join Date: Aug 2011
And how do I remove or move to another part of the forum the Random garage in the main screen
Reply With Quote
  #663  
Old 27 Aug 2011, 20:29
maupz maupz is offline
 
Join Date: Aug 2011
We are working in the Spanish Language, when We Finish, I will send the mod to the Developer!

And please if someone could help us with my questions I will really appreciate this!

Regards
Reply With Quote
  #664  
Old 28 Aug 2011, 06:36
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by markis13446 View Post
Hi tried to leave a comment on a photo, but getting this error:

Invalid SQL:
SELECT COUNT(image_id) AS ImageCommCount FROM garage_image_comments WHERE image_id = '82' WHERE active = '1';

MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE active = '1'' at line 1
Error Number : 1064
Open includes/garage_func_var.php
Find

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

replace with


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
VB Pro Garage with Timeslips
Reply With Quote
  #665  
Old 28 Aug 2011, 06:42
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by maupz View Post
Dylan, We really appreciate this app it works wonderfull

Just one quick question

How do I do to center the app, my forum has a center frame just like this forum but when i access the garage everything appears on left side!!!

THANKS IN ADVANCE!!!!!!
I would play with the garage_css template. You should be able to center it in there.
Maybe at the bottom where it has body change it to.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Originally Posted by maupz View Post
And how do I remove or move to another part of the forum the Random garage in the main screen
It isn't designed to go anywhere else. It's a forumhome block.
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #666  
Old 28 Aug 2011, 06:56
thebucky84 thebucky84 is offline
 
Join Date: Nov 2010
Real name: Shawn
Originally Posted by Dylanblitz View Post
I'll have to update a good chunk of code to add that.

I'll check the vehicle count calculation.
Just wondering if you have taken a look yet. Also the models don't count either. There are 2 WRX's and the count has (1)

also "admin" account gets all the notifications about trim requests and all. How do i change the "admin" value to another username?

thanks

Last edited by thebucky84; 28 Aug 2011 at 07:15.
Reply With Quote
  #667  
Old 28 Aug 2011, 07:29
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by thebucky84 View Post
Just wondering if you have taken a look yet. Also the models don't count either. There are 2 WRX's and the count has (1)

also "admin" account gets all the notifications about trim requests and all. How do i change the "admin" value to another username?

thanks
Try running the rebuild counts in the ACP maintenance section and let me know if it fixes it.
The notification user(s) are set in the Garage Notifications Settings area. The field is called Users to Notify
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #668  
Old 28 Aug 2011, 08:36
thebucky84 thebucky84 is offline
 
Join Date: Nov 2010
Real name: Shawn
Got it thanks! As for the vehicle count i wont know if it works until a new vehicle joins. I updated my sql so thats why i wont know if it worked. I will let you know though.


edit: the recount works, guess i have to do it every time a vehicle is added though. appreciate the help!

Last edited by thebucky84; 28 Aug 2011 at 19:59.
Reply With Quote
  #669  
Old 30 Aug 2011, 04:57
maupz maupz is offline
 
Join Date: Aug 2011
Originally Posted by Dylanblitz View Post
I would play with the garage_css template. You should be able to center it in there.
Maybe at the bottom where it has body change it to.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


It isn't designed to go anywhere else. It's a forumhome block.
Thanks but the issue persist!

The whole forum body is center like this vbuletin.org forum but when I open the garage everythign appears to the left.

On the other hand, I'm almost finishing the spanish translation if you are interested in include in your downloads.

Regards
Reply With Quote
  #670  
Old 31 Aug 2011, 05:42
thebucky84 thebucky84 is offline
 
Join Date: Nov 2010
Real name: Shawn
Is there a fix so every time someone adds a vehicle I don't have to go into the Admincp and reset vehicle and trim count?
Reply With Quote
  #671  
Old 31 Aug 2011, 18:04
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by thebucky84 View Post
Is there a fix so every time someone adds a vehicle I don't have to go into the Admincp and reset vehicle and trim count?
Not yet, I can't figure out where the problem is on it, the code looks right. You could turn that block off if you want for now until I get it worked out.
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #672  
Old 31 Aug 2011, 18:06
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by maupz View Post
Thanks but the issue persist!

The whole forum body is center like this vbuletin.org forum but when I open the garage everythign appears to the left.

On the other hand, I'm almost finishing the spanish translation if you are interested in include in your downloads.

Regards
Did you download the style from here? It sounds like it's a style issue. The default style will have it centered without having to add anything. I'd like to get ahold of the style to try and figure it out, hard to troubleshoot the problem if I can play with it heh.
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #673  
Old 03 Sep 2011, 15:29
markis13446 markis13446 is offline
 
Join Date: Aug 2011
Thanks for all the support Dylanblitz,

Two other issues:

- The timeslips on the Garage mainpage is not showing ascending. It looks like its grabbing the middlge of the pack. I tried adjusting settings with no luck.
- Some vehicles cant be rated, why is this? Some have ratings, but now can longer be rated.
Reply With Quote
  #674  
Old 03 Sep 2011, 23:09
zeus_r6 zeus_r6 is offline
 
Join Date: Jun 2007
Did a fix ever come up with skewing the display of subforums when enabling the random garage images in IE?
Reply With Quote
  #675  
Old 04 Sep 2011, 16:55
g00gl3r g00gl3r is offline
 
Join Date: Sep 2005
Dylanblitz,

Firstly what a brilliant mod. Rated Excellent and nominated for MOTM for you.

I've installed it all, but I have VBSEO running and it appears when I add the htaccess code, and turn on the SE friendly URL's, I get "page not found".

Does it conflict with VBSEO? I can't seem to find anything after a quick search in this thread.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 04:57.

Layout Options | Width: Wide Color: