Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
vbBux / vbPlaza v1.5.8 (Points + Store System) Details »
vbBux / vbPlaza v1.5.8 (Points + Store System)
Mod Version: 1.5.8, by CMX_CMGSCCC (Member) CMX_CMGSCCC is offline
Developer Last Online: Sep 2014 I like it Show Printable Version Email this Page

This thread is in the Modification Graveyard.
vB Version: 3.5.4 Rating: (43 votes - 4.88 average) Installs: 771
Released: 02 Feb 2006 Last Update: 13 Jul 2006 Downloads: 343
Not Supported DB Changes Uses Plugins Template Edits Additional Files  

vbBux / vbPlaza v1.5.8 by CMX (http://www.cmgsccc.com)
Official Homepage - http://www.vbplaza.com

v1.5.7 AND HIGHER are now compatible with vBulletin v3.5.x and v3.6.x

Welcome to the largest points/store system for vBulletin! READ THE ENTIRE POST AGAIN AS THERE HAVE BEEN CHANGES SINCE THE CONVERSION TO vbBux / vbPlaza!!

Credits: MrZeropage for ibProArcade Support, John for v3 Arcade Support, Caimakale for various additions including ribbons and his other addons for vbPlaza, defi for the addon for Paypal Subscriptions.

New Premium Modification Forum: http://www.vbulletin.org/forum/forumdisplay.php?f=171
If you post a new thread in there, it will be easier to track the answer to your thread folks!

Now with 135 Options for purchasing at your forums and this is still rising folks!

NOTE: As of this version, there is a Template Patcher helper inside the Admin CP. Admin CP -> vbPlaza Maintenance -> Auto Patch Templates, when you run this the first time, it will just list the changes that it has found/not found. If you press Attempt Auto Patches, it will modify the template changes it has found only. It will also modify all styles for your forums. I have tested this on all 3 of my licensed vBulletin production websites and the patches all worked great.

UPDATED MUST READ NOTES:
1) RE-READ THE UPGRADING OR NEW INSTALLATION INSTRUCTIONS AS THEY HAVE CHANGED FROM THE PREVIOUS VERSIONS!!
2) IF UPGRADING FROM A PREVIOUS VERSION OF eBux / eStore. YOU MUST INSTALL THIS ONE FIRST TO SAVE YOUR SETTINGS. (BUT YOU WOULD KNOW THIS IF YOU READ THE UPGRADING INSTRUCTIONS!! DONT SAY I DIDNT WARN YOU!!)

Branding Free Option
If you have donated in the past, you can get the Branding Free Option for Free by sending CMX a PM on the http://www.vbplaza.com/forums Message Board.
Otherwise, you will need to purchase it by signing up for an account at http://www.vbplaza.com/forums/register.php and then going to http://www.vbplaza.com/forums/payments.php

Features List:
This section has been moved due to its length. Look in the file included insize the zip named features.txt.

Release Notes:
This section will only show the most recent changes. For the rest of the changes, look in the file included inside the zip named changes.txt.

NOTE: If you want ibProArcade, v3 Arcade or vBookie integration now, you'll have to install the appropriate Addon included in the download. The reason for these parts being packaged as Addons, is to make the install a little smaller for users who do not have an Arcade, and because both Arcades cant be installed simultaneously as well. So it saves space only installing the one that you currently have.

v1.5.8 Updates:
1) Bugfix: Quick editing a post with BB Codes, modified the post directly instead of modifying a copy.
2) Bugfix: Some phrases fixed.
3) Bugfix: TABLEPREFIX bug has been fixed.
4) Bugfix: Addon Product XML sheets do not have executionorder in them anymore for vB 3.5 compatibility.

Database Backups Recommended!
Although I have upgraded 3 forums with this script already, it IS recommended that you backup your database before installing this product!!

Upgrading Instructions:
NOTE: THESE INSTRUCTIONS ARE FOR UPGRADING IF YOU HAD A PREVIOUS VERSION OF eBux / eStore INSTALLED!!
1) DO NOT UNINSTALL eBux / eStore (UNLESS YOU WANT TO LOSE ANY AND ALL SETTINGS.)
2) Reupload all of the files in the upload folder to your forum's root folder. Make sure that all files are being overwritten. Do not move on to the next step until all files are transferred successfully!
NOTE: It could take a long time to install if you have a lot of registered users, be PATIENT! It should display the messages as it goes along to let you know that it IS working.
3) After finished with step 2!! Reimport the product-vbbuxplaza.xml file via Admin CP -> Plugin System -> Manage Products -> Add/Import Product. Make sure that Allow Overwrite is set to YES.
4) Refresh the Admin CP and you will see all of the vbBux / vbPlaza Admin CP features at the top.
5) UNINSTALL THE OLD eBux / eStore NOW!! Go to Admin CP -> Plugin System -> Manage Products -> eBux / eStore -> Uninstall.
6) You can delete all files/folders that have the word estore or elottery in them from the FTP as well.
7) You will need to redo the template edits listed below as almost all of them have changed since the previous eBux / eStore.

If upgrading from a previous version of vbBux / vbPlaza follow these instructions:
1) Reupload all of the files in the upload folder to your forum's root folder. Make sure that all files are being overwritten. Do not move on to the next step until all files are transferred successfully!
2) After finished with step 2!! Reimport the product-vbbuxplaza.xml file via Admin CP -> Manage Products -> Add/Import Product. Make sure that Allow Overwrite is set to YES.
3) Refresh the Admin CP and get to checking your settings!
NOTE: You will be happy know that NO templates have been updated from v1.5.0 to v1.5.2!

New Installation Instructions:
1) Upload all of the files/folders in the UPLOAD folder to your forum's root folder.
2) Import the product-vbbuxplaza.xml via Admin CP -> Manage Products -> Add/Import Product.
NOTE: It could take a long time to install if you have a lot of registered users, be PATIENT! It should display the messages as it goes along to let you know that it IS working.
3) Refresh the Admin CP and start setting up your settings!
4) You will need to do all of the template edits listed below as well.

Template Edits:
A) Inside templates 'postbit' AND 'postbit_legacy':

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace With:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Next Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace With:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Then Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace With:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Then Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add Below:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

B) Inside template 'navbar':

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add Below:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Then Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add Above:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

C) Inside template 'MEMBERINFO':

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace With:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Next Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace With:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Then Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add Above:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

D) Inside template 'forumrules':

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add Below:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

E): Inside template 'USERCP_SHELL':

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add Above:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

F): Inside template 'threadbit':

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace With:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

vBulletin 3.5.x Only Edit:

Next Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace With:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


vBulletin 3.6.x Only Edit:

Next Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace With:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

G): Inside template 'memberlist_resultsbit':

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace With:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

-CMX

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Show Your Support

  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #2581  
Old 28 Feb 2006, 19:58
Kajouka's Avatar
Kajouka Kajouka is offline
 
Join Date: Feb 2006
Originally Posted by caimakale
I have to agree with CMX...if you don't give them an opportunity to change it back, then you might start losing people. I changed somebody's avatar on my site and they got pissed and instantly went and changed it back. If that option wasn't available, they may have not come back for quite awhile.

Of course nobody want's my "signature" owned avatar. Of course it's my dolphins avatar at 50% opacity and on top of it it reads "I got owned by caimakale and all I got for it was this lousy avatar!"

* caimakale has an idea for lordofguns site
I guess it just depends on the membership of the board. I'm on a board for twin parents that requires you to keep the avatars for a week. People give other people all kinds of crazy, insane, (sometimes humilitating) avatars and everyone just laughs and has fun giving them back. The attitude there is that it's all fun and games and everyone does it. I don't think I've seen anyone who's been upset or offended over it.

If you're on a board where people would be 'upset' then don't use the feature. If you're not, then it's a good feature to have. For my board, offensive avatars aren't allow anyway, so I'll probably just say you can't change it for a week if the store won't do it for me.
Reply With Quote
  #2582  
Old 28 Feb 2006, 20:57
exilera exilera is offline
 
Join Date: Sep 2005
CMX, please read

This is a fantastic hack, and it's a fantastic addition to my forums. Support has been fantastic as well; definitely the best of any other hack I've installed. I have just a couple requests for the next version.

1. Let us know which template edits have changed from version to version.
2. Possibly eliminate the need for template edits all-together? (don't know if this is possible, as I'm not a programmer)
3. Fix the undefined 'points' phrase, where the word 'point' is labeled as "%1$". As with the above, I don't know how to fix this because I do not know which template edits have changed from the previous version, aside from Forumrules (I think?).

And a questions:
For the 'History' view, how would I switch 'thead' with 'tcat', so the title bar (with the title 'History' in it) is 'tcat' and the bar below it is 'thead'?
Reply With Quote
  #2583  
Old 28 Feb 2006, 21:02
Red Blaze's Avatar
Red Blaze Red Blaze is offline
 
Join Date: Jan 2003
Real name: Frank E.
Exilera, just find the ebux/estore bit from the postbit and/or postbit legacy and over right it with the new one. *points to first post*
Reply With Quote
  #2584  
Old 28 Feb 2006, 21:02
Gizmo5h1t3's Avatar
Gizmo5h1t3 Gizmo5h1t3 is offline
 
Join Date: Aug 2005
Real name: STEVE
Originally Posted by exilera
CMX, please read

This is a fantastic hack, and it's a fantastic addition to my forums. Support has been fantastic as well; definitely the best of any other hack I've installed. I have just a couple requests for the next version.

1. Let us know which template edits have changed from version to version.
2. Possibly eliminate the need for template edits all-together? (don't know if this is possible, as I'm not a programmer)
3. Fix the undefined 'points' phrase, where the word 'point' is labeled as "%1$". As with the above, I don't know how to fix this because I do not know which template edits have changed from the previous version, aside from Forumrules (I think?).

And a questions:
For the 'History' view, how would I switch 'thead' with 'tcat', so the title bar (with the title 'History' in it) is 'tcat' and the bar below it is 'thead'?

forumrules, memberinfo, and postbit legacy changed mate.
do those edits, and itll sort itself out.
Reply With Quote
  #2585  
Old 28 Feb 2006, 21:22
Zowners Zowners is offline
 
Join Date: Dec 2005
REQUEST

Option that : Users receive a PM when they receive a paycheck, saying the amount they received, as well as why (what usergroup)
Reply With Quote
  #2586  
Old 28 Feb 2006, 21:26
exilera exilera is offline
 
Join Date: Sep 2005
Originally Posted by Gizmo5h1t3
forumrules, memberinfo, and postbit legacy changed mate.
do those edits, and itll sort itself out.
I made the changes in the Postbit, not the Postbit legacy... is that ok, or does it have to be in both?

I still have the definition problem in the eStore main page. All other references to 'points' are ok, and I've double checked all of the template edits...
Reply With Quote
  #2587  
Old 28 Feb 2006, 21:48
LBSources LBSources is offline
 
Join Date: Nov 2005
Real name: Lenny
oddly after the last upgrade seems i cant get the ebux info to show in the memberinfo .. anyone else having this problem?

ive made the current necessary edits..
__________________
.....
LBSources

Learn About The Bronx, New York!
Reply With Quote
  #2588  
Old 28 Feb 2006, 21:51
VBUsers's Avatar
VBUsers VBUsers is offline
 
Join Date: Sep 2004
Originally Posted by LBSources
oddly after the last upgrade seems i cant get the ebux info to show in the memberinfo .. anyone else having this problem?

ive made the current necessary edits..

you dg i havent touched my edits since the last one and theyre showing up fine.
__________________
- Steve M.
Medical Marijuana Forums
High 5 Media LLC
Reply With Quote
  #2589  
Old 28 Feb 2006, 21:52
Rickie3's Avatar
Rickie3 Rickie3 is offline
 
Join Date: Nov 2004
Real name: Rick
ok i have a problem i have Rules Hack v1.5 installed http://www.vbulletin.org/forum/showthread.php?t=104044

now the problem is when someone clicks the "rules" button it just goes to a blank page
http://www.sats-general.com/forum/rules.php.

so i disabled ebux/estore plugin and the "rules" link worked, any suggestions why this could be happening????
Reply With Quote
  #2590  
Old 28 Feb 2006, 21:55
LBSources LBSources is offline
 
Join Date: Nov 2005
Real name: Lenny
Originally Posted by lowandloudinc
you dg i havent touched my edits since the last one and theyre showing up fine.
lol .. good to know.. doesnt help me i upgraded as directed by the upgrade docs.. and for some oddity, it doesnt show up ..

let me see your memberinfo ebux code
__________________
.....
LBSources

Learn About The Bronx, New York!
Reply With Quote
  #2591  
Old 28 Feb 2006, 21:59
VBUsers's Avatar
VBUsers VBUsers is offline
 
Join Date: Sep 2004
Originally Posted by LBSources
lol .. good to know.. doesnt help me i upgraded as directed by the upgrade docs.. and for some oddity, it doesnt show up ..

let me see your memberinfo ebux code

you know where im at. ill give it to you so you can check it out
__________________
- Steve M.
Medical Marijuana Forums
High 5 Media LLC
Reply With Quote
  #2592  
Old 28 Feb 2006, 23:14
RDX1 RDX1 is offline
 
Join Date: Apr 2002
Originally Posted by RDX1
Even after clearing user history and rebuilding datastore, in the users profile it shows something different.

Item ID Item Name Item Cost
12 Sticky Thread 10.00
48 Can Modify Profile 8.32

After clearing user history, none of these options are buyable.


What version are you using and did u upload all files before importing the product?

1.2.3 and and yes, problem still persists since 1.1.8
Reply With Quote
  #2593  
Old 28 Feb 2006, 23:34
Twigz Twigz is offline
 
Join Date: Dec 2004
Real name: TJ
Originally Posted by Rickie3
ok i have a problem i have Rules Hack v1.5 installed http://www.vbulletin.org/forum/showthread.php?t=104044

now the problem is when someone clicks the "rules" button it just goes to a blank page
http://www.sats-general.com/forum/rules.php.

so i disabled ebux/estore plugin and the "rules" link worked, any suggestions why this could be happening????
I am also having this problem since the install of the last update. It is causing this issue with the Rules hack mentioned above and also the vB Affiliates hack. They both worked on all previous versions, untill this latest update. Like Rickie said above, when you disable the eBux/eStore they both work correctly. Just thought I would also chime in and let ya know that not just one person is having this issue.

Other then that Great Hack and Great Author, Keep up the good work!

-Twigz
Reply With Quote
  #2594  
Old 28 Feb 2006, 23:36
VBUsers's Avatar
VBUsers VBUsers is offline
 
Join Date: Sep 2004
Originally Posted by Twigz
I am also having this problem since the install of the last update. It is causing this issue with the Rules hack mentioned above and also the vB Affiliates hack. They both worked on all previous versions, untill this latest update. Like Rickie said above, when you disable the eBux/eStore they both work correctly. Just thought I would also chime in and let ya know that not just one person is having this issue.

Other then that Great Hack and Great Author, Keep up the good work!

-Twigz

yea twiggy im having an issue with the affiliates as well. i dont think im using the same rules hack so thats ok. only issue i have so far.
__________________
- Steve M.
Medical Marijuana Forums
High 5 Media LLC
Reply With Quote
  #2595  
Old 01 Mar 2006, 00:37
CMX_CMGSCCC CMX_CMGSCCC is offline
 
Join Date: Sep 2003
Originally Posted by kylek
CMX,

Just sent a small contribution to a great cause, thanks always for the fast and great support that you give all of us!!
Thanx for supporting eBS!

Originally Posted by lordofgun
This is really weird. I just turned on the ability to use/edit signatures in my store. Then I purchased the ability to use/edit signature. As soon as I purchased it, my rep power was displayed as 0 in postbit even though it should have been 107. It still gave 107 rep points when i repped someone, but it displayed as 0 in my postbit.

I turned off the use/edit sig feature in my store...still displayed as 0 in postbit.

Finally, I turned the use/edit sig back on, went into the store, and removed my purchase. Only then did my rep power return to being displayed as 107 in my postbit. Needless to say, I have disabled that option for now.

Does that make any sense?
That's odd, I'll look into that, maybe it has a double check on another flag somewhere else.

Originally Posted by Zowners
I get errors on my site with 2.3

Like clicking the store and getting this message

Welcome to our %1$s %2$s, enjoy your stay!
Did u upload all files again and reimport the product with allow overwrite set to yes?

Originally Posted by Murty
Hey,

thought of an idea. How about the option to display the users points in the navbar somewhere?
I think u can do that now by using $bbuserinfo[points] ?

Originally Posted by Mr. Bone88
Hi everyone,

I installed this hack and I'm really liking it a lot! I have one question though.....how do I remove "Bank:" and "Total Points:" from the postbit?

Thanks in advance,
~Mr. Bone88
Just remove the part that says $vbphrase[ebux_points]: from the postbit edit that you had to make.

Originally Posted by Zelda-King
It would appear PMs are sent from userid 1 regardless of what userid you set it for. (Just got a PM from myself [userid=1] saying I won the lottery in spite of setting it to my 'Bot' [userid=9].)
Ooops, the cron jobs I dont think used estore_send_pm, I'll fix that.

Originally Posted by trackpads
CMX, any luck on my gifts?

Thanks again,

-Jason
Have to refresh my memory, been busy the past couple days and I havent time to go back and find the post. Send me a PM about it as well.

Originally Posted by ericgtr
Hey all, great mod here. Most of my users are really enjoying this but I have one who insists that he does not want it, is there a way to turn it off for one user?

Also, people have been buying into the daily lottery for a few days now but it's not showing any winners, the cron appears to be running as it should.

Thanks for any help you can provide.
Each user has 2 settings right now when u edit them via Admin CP. 1 is to access the eStore and the other is receives points, what did u have in mind about it though? Like having them not see any points/gifts/etc?

Originally Posted by Cyricx
Okay, heres the glow and shadow stuff. This is what I use on my forums. I've gotten them to both work within the same div.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
Thanx, I'll look into it.

Originally Posted by kpr
Upgraded.

Thanks for the most exellent hack and the support you are given top notch
Thanx for supporting eBS!

Originally Posted by ericgtr
At the moment I got too many users whining about it, without the ability to turn it off for specific users or groups (that I can find anyway) I have disabled it.
Whining it about it for what reason? You can disable usergroups from using the eStore entirely. And there are 2 settings for users to "receive points on/off" and "access estore on/off".

Originally Posted by flypaper
{1} is undefined, that's the problem. I'm not sure where its supposed to be defined tho...
The template edits have changed in postbit/postbit_legacy/MEMBERINFO and forumrules, they need to be redone.

They are done in this new way so if u changed the phrase ebux_points, it will use that in place of where it used points before.

Originally Posted by exilera
Yea, I corrected the postbit error by removing all of the previous postbit edits for ebux and reapplying them, but it's still showing up undefined in the estore page. I'm not sure which edit would apply there, and I've readded all the edits.
It shows on the main eStore? Try to import the product again with overwrite set to Yes.

Originally Posted by Christie189
I've got a quick question. I've managed to get this on my board, up and running. But I see no place to edit the estore category list, etc. I do have the estore settings and ebux settings option under admincp > vbulletin options. But there seems to be some things missing. No place to set thief options, nothing. Help!
After u have installed this, refresh your Admin CP, u should see 4 new menu options near the top.

Originally Posted by Ilovechase
CMX- hate to bother you as I know you are very busy. I have a couple of more things going on.

I have one member that none of her gifts show in the post. I have tried the gift fix. also
2)the points arent calculating correctly as far as you get a certain amount for posting it adds different amounts each time you post.

last one:
I have a stupid question LOL where can I rebuild bitfield? I looked under maintence in the cp.

thank you
Monie
1) I thought we fixed that issue?

2) How many points per character do u have the setting enabled for? If you have a number entered instead of 0, of course posts will give more/less points based on how long the posts are.

To rebuild bitfields, I forget the exact URL something like /admincp/index.php?do=rebuildbitfields

Originally Posted by X-Files
We need to block All Item History from regular users. How would I go about allowing it for admins only?
I'll have to add a setting for that in the future release.

Originally Posted by X-Files
I have noticed some weird point things going on but CMX said this can not be happening. I get 2 points every now and then just for veiwing posts and it is not even set for 2 and I am the only one on my dev site.
If someone views the same thread as u, it will add to the thread creator's points twice. If u have a busy forums that could be whats happening.

Originally Posted by flypaper
I'm having lottery problems. I have a user who every time he purchases a lottery ticket, it shows in Item History as 'free' and he never actually gets to buy the ticket.

Additionally, it doesn't look like the lottery ending time takes AM/PM into account.
It only says free on the main page, soon as the click on Buy Lottery Ticket, it lists the types of tickets, soon as they hit Purchase it will list the prices.

Originally Posted by flypaper
I'm having lottery problems. I have a user who every time he purchases a lottery ticket, it shows in Item History as 'free' and he never actually gets to buy the ticket.

Additionally, it doesn't look like the lottery ending time takes AM/PM into account.
Hmm, I'll look into that, its probably just recording it in the history as wrong because I purchased tickets and it removed my points I know.

The lottery time uses ur servers time, whatever ur servers clock is set to thats what gets used.

Originally Posted by neutek
it will not let me change the values in "Mass Forums Settings"
every time i change them. and then go back to it its 1 - 15 - 5

and. btw this sets the points for all forums correct?
and the "Points Per Thread Multiplier" just multiplys the above set amount
In Mass Forums it will always say 1, 15, 5.... But if u go an edit the Actual Forums under Forums & Moderators, u will see that it set them to whatever u wanted to set them to.

Originally Posted by Replicators
The buy attachment feature is not working for me >8(
Do u have it enabled? And are u using the global all attachments cost X points?

Originally Posted by X-Files
Every time I start a reply I get 0.02 points and then get 1 point for submitting the reply.
I'm unable to replicate this problem.

Originally Posted by MissKalunji
i noticed something else....if there is no comment added to the gift they wont show....
It should show, PM me the actual item's entry line from the database, perhaps its getting stored incorrectly there or something.

Originally Posted by exilera
Are all these problems a result of the newest 1.2.3 patch?
Because everyone didnt redo the template edits... lol

Originally Posted by X-Files
Could this be causing false page views?

Google AdSense Spider
/forum/showthread.php?p=198946 Viewing Thread
Test

Can guests be ignored? I am not sure we want them ignored I am just asking.
Hmm, thats very possible, later today I will log out and try to view a thread as a Guest and see what happens.

Originally Posted by grains
I have it set to ADMINISTRATOR - YES, for each category, but i still have the same result.
Usergroups -> Usergroup Manager -> usergroup u want to have access -> Can Access eStore at the bottom.

Originally Posted by grains
Figured it out.....as an administrator...i could only belong to one group in order to access the estore page.

Isnt that a bug?
Explain this better in a PM to me and I'll look into it.

Originally Posted by exilera
CMX, please read

This is a fantastic hack, and it's a fantastic addition to my forums. Support has been fantastic as well; definitely the best of any other hack I've installed. I have just a couple requests for the next version.

1. Let us know which template edits have changed from version to version.
2. Possibly eliminate the need for template edits all-together? (don't know if this is possible, as I'm not a programmer)
3. Fix the undefined 'points' phrase, where the word 'point' is labeled as "%1$". As with the above, I don't know how to fix this because I do not know which template edits have changed from the previous version, aside from Forumrules (I think?).

And a questions:
For the 'History' view, how would I switch 'thead' with 'tcat', so the title bar (with the title 'History' in it) is 'tcat' and the bar below it is 'thead'?
I'll look into this to see if its possible to do away with template edits, or at least some of them, there are no variables that could be modified for the forumrules for example that I know of... lol

#3 u need to redo the template edits and it will use whatever u have for the phrase ebux_points, u should fix postbit/postbit_legacy/MEMBERINFO & forumrules.

Originally Posted by Zowners
REQUEST

Option that : Users receive a PM when they receive a paycheck, saying the amount they received, as well as why (what usergroup)
The reason there is no option for a paycheck is because it would add too many queries to send a PM to each and every user it gave a paycheck to. Especially if u gave a paycheck to ur Registered usergroups so they get some points weekly too..

Originally Posted by exilera
I made the changes in the Postbit, not the Postbit legacy... is that ok, or does it have to be in both?

I still have the definition problem in the eStore main page. All other references to 'points' are ok, and I've double checked all of the template edits...
Depends on which postbit u use, I would do them in both to be on the safe side... Plus I'm adding a new Store Option real soon so the user can Purchase which postbit they want

Originally Posted by Rickie3
ok i have a problem i have Rules Hack v1.5 installed http://www.vbulletin.org/forum/showthread.php?t=104044

now the problem is when someone clicks the "rules" button it just goes to a blank page
http://www.sats-general.com/forum/rules.php.

so i disabled ebux/estore plugin and the "rules" link worked, any suggestions why this could be happening????
I know the problem and this issue will be resolved in v1.2.4

Originally Posted by RDX1
Originally Posted by RDX1
Even after clearing user history and rebuilding datastore, in the users profile it shows something different.

Item ID Item Name Item Cost
12 Sticky Thread 10.00
48 Can Modify Profile 8.32

After clearing user history, none of these options are buyable.


What version are you using and did u upload all files before importing the product?

1.2.3 and and yes, problem still persists since 1.1.8
I fixed this in somewhere along the line, make sure u have uploaded all files via FTP and overwrote the old files as well as Import the product with Allow Overwrite set to Yes.

-CMX
__________________
http://www.cmgsccc.com/
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 17:07.

Layout Options | Width: Wide Color: