Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 30 Dec 2015, 14:32
r5mjh r5mjh is offline
 
Join Date: Dec 2015
why are my php custom files not working

hi there, im playing around with a upgrade of vb to maybe 4.2.3 and have found that it requires php 5.4, problem is if i change from 5.2.17 to 5.4 my custom php files wont work

is there a easy fix for this??
or do i need to go 4.2.2 as this is 5.2.17 friendly

any help appreciated thanx
Reply With Quote
  #2  
Old 30 Dec 2015, 17:06
Dragonsys's Avatar
Dragonsys Dragonsys is offline
 
Join Date: Jan 2008
Real name: Eric
we would have to be able to see your custom files code to figure out what is wrong with them, but it sounds like you are using deprecated functions.

Without at least errors, we can only guess.
Reply With Quote
  #3  
Old 30 Dec 2015, 17:43
r5mjh r5mjh is offline
 
Join Date: Dec 2015
basically the code controls many different php pages, also the custom software has to require 2 other modified files header.php,global.php

but if i change the php to 5.4 nothing works

4.2.3 requires 5.4 and 3.8.9 requires 5.3 or above we are currrently on 3.7.1

i can provide some code which is from the home.php file which works on 5.2.17 but not 5.4


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Last edited by TheLastSuperman; 30 Dec 2015 at 19:51.
Reply With Quote
  #4  
Old 30 Dec 2015, 18:11
Dragonsys's Avatar
Dragonsys Dragonsys is offline
 
Join Date: Jan 2008
Real name: Eric
Please enclose that PHP in the PHP bbcode, to make it more readable.
Also, whe you change to PHP v5.4 does it give any errors, or just nothing at all?

Also, try changing all the <? to <?php
Reply With Quote
  #5  
Old 30 Dec 2015, 19:48
r5mjh r5mjh is offline
 
Join Date: Dec 2015
ok im not a total noob lol but im not up on the bbcode part, ive just duplicated on another part of the server using a different forum database all works correctly on 5.2.17 but as soon as i put it on 5.4 the custom php pages stop working not the vb itself

we have loads of custom tabs that all work with vb and none work with 5.4 php
Reply With Quote
  #6  
Old 30 Dec 2015, 22:05
Dragonsys's Avatar
Dragonsys Dragonsys is offline
 
Join Date: Jan 2008
Real name: Eric
Originally Posted by r5mjh View Post
ok im not a total noob lol but im not up on the bbcode part, ive just duplicated on another part of the server using a different forum database all works correctly on 5.2.17 but as soon as i put it on 5.4 the custom php pages stop working not the vb itself

we have loads of custom tabs that all work with vb and none work with 5.4 php
No worries
Right, I understand that vBulletin works, but your custom pages do not. However, do they generate any errors, or just blank pages?

Also, in your PHP pages change <? to <?php some installs are strict requiring the full tag
Reply With Quote
  #7  
Old 31 Dec 2015, 10:26
r5mjh r5mjh is offline
 
Join Date: Dec 2015
Originally Posted by Dragonsys View Post
No worries
Right, I understand that vBulletin works, but your custom pages do not. However, do they generate any errors, or just blank pages?

Also, in your PHP pages change <? to <?php some installs are strict requiring the full tag
got ya matey yep it gives a server 500 error on 5.4 saying it not on the server or somrthing else

but is fine with 5.2.17 ill give that a try matey and report back

--------------- Added 31 Dec 2015 at 12:56 ---------------

well done dragon that worked for php 5.4 but some pages dont work 5.2.17 now lol but if we are upgrading thats not a problem thanx for your help sir apprec

can these php custom pages be used in 4.2.3 still??
Reply With Quote
  #8  
Old 31 Dec 2015, 15:51
Dragonsys's Avatar
Dragonsys Dragonsys is offline
 
Join Date: Jan 2008
Real name: Eric
Originally Posted by r5mjh View Post
well done dragon that worked for php 5.4 but some pages dont work 5.2.17 now lol but if we are upgrading thats not a problem thanx for your help sir apprec

can these php custom pages be used in 4.2.3 still??
Strange, that change shouldn't affect it in PHP 5.2
I'm not sure if they will still work on vb v4 since they were written for v3. I would copy your forums to a test site and try the upgrade see what errors you get, if any
Reply With Quote
  #9  
Old 01 Jan 2016, 16:17
r5mjh r5mjh is offline
 
Join Date: Dec 2015
thanx matey ill do that next

1 more question, does vb only use 1 database even if you choose to put albumpictures to the database? ive got 2 they look linked
Reply With Quote
  #10  
Old 01 Jan 2016, 16:21
Dragonsys's Avatar
Dragonsys Dragonsys is offline
 
Join Date: Jan 2008
Real name: Eric
Originally Posted by r5mjh View Post
thanx matey ill do that next

1 more question, does vb only use 1 database even if you choose to put albumpictures to the database? ive got 2 they look linked
Yes, vb only uses 1 DB, unless you have a custom mod which changes this
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:12.

Layout Options | Width: Wide Color: