Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Module CMPS: PhotoPost vBGallery Details »
Module CMPS: PhotoPost vBGallery
Mod Version: 2.6, by Zachariah (Coder/Designer) Zachariah is offline
Developer Last Online: Jan 2020 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.8 Rating: (10 votes - 4.90 average) Installs: 132
Released: 15 Sep 2006 Last Update: 28 Aug 2007 Downloads: 1249
Supported Template Edits  

/* ----------------- 8/28/2007 6:41pm -----------------

Add Gallery Images to your vBAdvanced CMPS 3.x
Do you have PhotoPost vBGallery v2.0 + installed ?

Looking @ changes in the gallery. This hack will work with vbgallery 2.2, 2.3 out of the box.
- you can get a patch if you have 2.0, 2.1 - here.

Tested on:
- vBulletin 3.6.8
- PhotoPost vBGallery v2.3
- vBadvanced CMPS v3.0 RC1

1 query added to CMPS

Zachariah @ http://www.szone.us/

EX: 3 CMPS blocks 3 different settings
http://www.szone.us/index.php?id=gallery

--------------------------------------------------*/


Change Log
===========
2.6
- Added option for module title.
- Added option for module link.
- Added option to choose from thumbnail, normal, origianal


2.5
- Added Template: adv_portal_vbgallery_imagebit
- Edited Template: adv_portal_vbgallery_nav - added search dropdown
- Edited Template: adv_portal_vbgallery - changed to work with standard CMPS wrapper
- Multi-Modules can be used on the same page using the same php file with different settings
EX: 3 CMPS blocks 3 different settings http://www.szone.us/index.php?id=gallery


2.2
- reworked to work on CMPS 3.0

2.1
- Package added to: imagegallery.module
- Block settings per CMPS page
- Permissions fixed


2.0
- adv_gallery_images -> ppgal_images

1.9
- Added vb3.6

1.8
- Added functions_gallery_store.php
- Added column span support

1.7
- Install w/ product in 1 file.
- Killed the need for FORUMHOME template edit.
- AdminCP options to change the hack settings
- Added: Parts of the gallery's Nav bar w/ dropdowns
(My Stuff*, What's New, What's Popular,Search) to the hack with on/off option.

* My Stuff will not be seen if you are a guest.

1.6
- Added: If the gallery is off or disabled the hack not show up.
- Added: templates to support the hack vs. gallery templates
(allows you to customize the templates for the look and feel you want vs. mess up the way your gallery templates look.)


1.5
- <If> usergroup can not see thunbnails FORUMHOME edit will not show up.

1.4
- Removed Phrase to name gallery <table> now use $vba_options[gallery_title]
- Added 3 prases in "global" - filesize,category,dimensions

1.3
- Display images from specific categories.

1.2
- added Phrase support

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	admin.jpg
Views:	1119
Size:	61.4 KB
ID:	59673   Click image for larger version

Name:	all_options.jpg
Views:	1665
Size:	47.1 KB
ID:	59674   Click image for larger version

Name:	no_data.jpg
Views:	1165
Size:	24.5 KB
ID:	59675  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Module CMPS: PhotoPost vBGallery Zachariah vBulletin 3.5 Add-ons 379 01 Aug 2010 09:36
Add-On Releases Module CMPS: Add vBGallery Image comments Zachariah vBulletin 3.6 Add-ons 13 21 Jul 2008 03:31
Module CMPS: Add vBGallery Image comments Zachariah vBulletin 3.5 Add-ons 23 24 Nov 2007 06:28

  #76  
Old 26 Nov 2006, 06:26
jcfuller jcfuller is offline
 
Join Date: Aug 2005
Originally Posted by jlaine View Post
I'm only getting it when I'm not logged in and viewing the main page now (and with regular users apparently, just got an e-mail on it), I just got it installed myself so I haven't started digging

The one other error was fixed by changing adv_gallery_images to ppgal_images in the php file, this one now that I'm getting would be after the aforementioned fix.
Same for me. :cross-eyed:
Reply With Quote
  #77  
Old 27 Nov 2006, 15:45
bolobala bolobala is offline
 
Join Date: Nov 2005
Installed!
But this images show in Forum Home not good, how can i arrange it into 1 row.
In my 4rum it just show into 3 rows
http://ngoichatnghenhac.biz/4rum/
Help me plz

Last edited by bolobala; 27 Nov 2006 at 16:24.
Reply With Quote
  #78  
Old 27 Nov 2006, 20:44
Trana Trana is offline
 
Join Date: Apr 2005
Originally Posted by jlaine View Post
The one other error was fixed by changing adv_gallery_images to ppgal_images in the php file, this one now that I'm getting would be after the aforementioned fix.
Can someone please post a complete version of the module so we can fix this in the meantime?

I'm still not sure why changing the names of all the tables for the gallery only constitutes a x.1 increment in revision numbers.

Thanks for keeping vbg going though.
Reply With Quote
  #79  
Old 05 Dec 2006, 04:01
gator777's Avatar
gator777 gator777 is offline
 
Join Date: Feb 2005
Zach,

Any word on the fix?
Reply With Quote
  #80  
Old 15 Dec 2006, 15:03
TRR TRR is offline
 
Join Date: Jan 2005
Been a while, so I am bumping. Any word on a fix? Thanks!
Reply With Quote
  #81  
Old 28 Dec 2006, 15:35
carpzone carpzone is offline
 
Join Date: Feb 2006
Yes the block works fine with the datbase call change.

But i get databse error when i'm not logged in.
The block only shows up ( and my website) when a users is registered.

Is there a fix to work this out ? ...
Reply With Quote
  #82  
Old 31 Dec 2006, 16:43
zetetic's Avatar
zetetic zetetic is offline
 
Join Date: Apr 2004
Real name: Tom
In case this wasn't clear to anyone, most of the db errors are the result of an incorrect table name in the vbgallery_block.php file.

Make sure to edit vbgallery_block.php

find:

adv_gallery_images

and change to:

ppgal_images

Save changes and upload the file to your server.
Reply With Quote
  #83  
Old 31 Dec 2006, 20:12
carpzone carpzone is offline
 
Join Date: Feb 2006
Hm Yes, I did change that database call fom ADV_..... to PPGAL_..... in the vbgalleryblock.

The block works only if logged in.
If i turn the block on for Unlogged visitors. My webpage dont open.

I get follow error by email


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #84  
Old 01 Jan 2007, 06:20
zetetic's Avatar
zetetic zetetic is offline
 
Join Date: Apr 2004
Real name: Tom
Hmm, I spoke to soon. It works fine for me in Firefox, but using IE I get that same db error.
Reply With Quote
  #85  
Old 01 Jan 2007, 23:57
gunitman247 gunitman247 is offline
 
Join Date: Aug 2005
Real name: Josh
any thing like this for photoplog?
Reply With Quote
  #86  
Old 06 Jan 2007, 22:03
johnstires johnstires is offline
 
Join Date: Mar 2006
Originally Posted by zetetic View Post
Hmm, I spoke to soon. It works fine for me in Firefox, but using IE I get that same db error.
That fix worked for me in FF and IE7! Thanks!
Reply With Quote
  #87  
Old 07 Jan 2007, 11:41
gator777's Avatar
gator777 gator777 is offline
 
Join Date: Feb 2005
I'm unable to get this mod working no matter what I do. I've used this block for a long time, and I miss not having it on my site. I hope Zach has the time to fix it. For now, I am using the "Recent Comments Block" to fill the void.

I hope you read this Zach
Reply With Quote
  #88  
Old 07 Jan 2007, 14:34
johnstires johnstires is offline
 
Join Date: Mar 2006
Originally Posted by gator777 View Post
I'm unable to get this mod working no matter what I do. I've used this block for a long time, and I miss not having it on my site. I hope Zach has the time to fix it. For now, I am using the "Recent Comments Block" to fill the void.

I hope you read this Zach
Make sure the table prefixes match up. That was my problem.

First, make sure to edit vbgallery_block.php

http://www.vbulletin.org/forum/showp...9&postcount=82

AND

Make this change.

http://www.vbulletin.org/forum/showp...2&postcount=52
Reply With Quote
  #89  
Old 08 Jan 2007, 01:47
gator777's Avatar
gator777 gator777 is offline
 
Join Date: Feb 2005
Originally Posted by johnstires View Post
Make sure the table prefixes match up. That was my problem.

First, make sure to edit vbgallery_block.php

http://www.vbulletin.org/forum/showp...9&postcount=82

AND

Make this change.

http://www.vbulletin.org/forum/showp...2&postcount=52
Thanks for your help, but I'm still getting the error messages. I am using....

CMPS x2.2.1
VB v3.6.4
Photopost VB Gallery 2.1

All was goon until I installed Photopost VB Gallery 2.1. If I had know it was going to diable my block, I would not have upgraded to Photopost VB Gallery 2.1.
Reply With Quote
  #90  
Old 21 Jan 2007, 12:29
carpzone carpzone is offline
 
Join Date: Feb 2006
Originally Posted by carpzone View Post
Hm Yes, I did change that database call fom ADV_..... to PPGAL_..... in the vbgalleryblock.

The block works only if logged in.
If i turn the block on for Unlogged visitors. My webpage dont open.

I get follow error by email


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
Nobody has a clue what the problem is ?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 09:02.

Layout Options | Width: Wide Color: