Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Advanced Application Forms Details »
Advanced Application Forms
Mod Version: 1.4.7, by nhawk (Member) nhawk is offline
Developer Last Online: Feb 2020 I like it Show Printable Version Email this Page

This thread is in the Modification Graveyard.
vB Version: 4.1.1 Rating: (53 votes - 4.89 average) Installs: 408
Released: 20 May 2011 Last Update: 07 Sep 2015 Downloads: 2882
Not Supported Translations  

THIS ADD-ON IS NO LONGER AVAILABLE AND IS NOT SUPPORTED

* General Information *
------------------------------
This is an add-on that is designed for vBulletin 4.1.1 or later. It may not work on earlier versions of vBulletin.


Nominated twice for MOTM (October 2011, January 2012)


Features
  • Unlimited Application Types*
  • Unlimited Application Positions*
  • Unlimited Questions*
  • Different Application Positions for each Application Type
  • Different Questions for each Application Position.
  • Allow others to add/edit Application Types by permissions.
  • Allow others to edit Positions/Questions by permissions.
  • Edit Application Types, Positions and Questions in either ACP or from board.
  • Show Multiple Application Types in Community Menu or direct link to them.
  • Control Application Type access by Usergroup, Postcount
  • Control Application Position access by Usergroup, Postcount
  • Notification of an application via Forum Thread and/or Email and/or Private Message
  • Specify Different Forums for Reports by Application Position.
  • Define a default question set that can be included on all applications.
  • Much, much more!

* Limited only if you are limited in database size and/or free disk space.


* INSTALLATION *
-------------------
1) Upload the contents of the 'upload' folder to your forum's root.
(If your forum's location is http://www.example.com/forums/, the root is /forums/)

2) Depending on your server configuration, you will need to change the permissions of the advappfiles folder to either 775 or 777

3) Import the product XML file (product-advapp.xml) into the Product Manager in AdminCP.

4) Take some time to set the options, application types and application postions in the new Application Forms area of AdminCP.
(It's really not that hard!)

5) Make sure this modification is marked as 'Installed' on vBulletin.org!
(If you want to get notices from me about updates for this modification.)

* UPGRADE INSTRUCTIONS *
-----------------------------
1) Upload the contents of the 'upload' folder to your forum's root.
(If your forum's location is http://www.example.com/forums/, the root is /forums/)

2) Import the product XML file (product-advapp.xml) into the Product Manager in AdminCP and be sure "Allow Overwrite" is set to 'Yes'.

3) vB 4.2.x ONLY - Go to ACP->Settings->Options->Application Form Settings and set 'vB 4.2 Community Menu Update' to 'Yes'.

UPGRADING TO VERSION 1.3.8 or HiGHER
Depending on your server configuration, you will need to change the permissions of the advappfiles folder to either 775 or 777

If you have edited the advapp_application template, you need to revert the template before upgrading to 1.3.8 or higher.
Once the upgrade is complete, you can re-apply your changes to that template.


* History (Changelog) *
-------------------------
1.4.7 (September 7, 2015)
- Fix Certain characters not being stored/displayed properly.

1.4.6 (January 2, 2014)
- Fix Certain non-english characters not being stored/displayed properly.

1.4.5 (October 11, 2013) (not released vB.org)
- Fix No thread status showing in new threads when Thread Status Pro version 1.0.3 is installed.

1.4.4 (August 5, 2013)
- Fix Change single MySQL call to vB database call for systems that don't play well with direct MySQL calls.

1.4.3 (July 15, 2013)
- Fix Extra tabs in first response line in email notificactions.

1.4.2 (June 18, 2013)
- Fix Applications still able to be submitted after member logs out when unusual usergroup settings are used.

1.4.1 (June 8, 2013)
- Fix regex error missing from query.

1.4.0 (June 4, 2013) (not released on vB.org)
- Fix community menu not updating properly with vB 4.2.1

1.3.9 (May 2, 2013)
- Fix thread starter not showing when new thread is created and using actual userid to post new thread.

1.3.8 (May 2, 2013) (not released on vB.org)
- Add file upload option to application questions.(Available from ACP ONLY)

1.3.7 (May 1, 2013)
- Add error field in question editor for validation failure.

1.3.6 (May 1, 2013) (not released on vB.org)
- Fix moderated threads not showing as moderated in ACP.
- Change regex validated fields are now optional if no error message is defined for the field.
- Change streamline code for displaying applications forms.

1.3.5 (April 29, 2013)
- Change question save routine to prevent misnumbering of question order.
- Add single line text answers now allow regular expression matching.(Editing regex available from ACP ONLY)
- Add flood check for new threads
- Add flood check for new posts.

1.3.4 (April 22, 2013) (not released on vB.org)
- Fix header/title phrase input on application type screen not showing properly on forum application screens.
- Fix several typographical errors in phrases.

1.3.3 (March 2, 2013)
- Fix database error if Thread Status Pro is not installed.
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.3.2 JUST UPLOAD FILES TO YOUR SERVER)

1.3.2 (February 28, 2013) (not released on vB.org)
- Add support for default forum thread status from Thread Status PRO
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.3.1 JUST UPLOAD FILES TO YOUR SERVER)

1.3.1 (November 20, 2012)
- Fix database error when saving application type with some punctuated admin usernames.
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.3.0 JUST UPLOAD FILES TO YOUR SERVER)

1.3.0 (November 19, 2012) (never released on vB.org)
- Fix item selection problems with Firefox browser
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.2.9 JUST UPLOAD FILES TO YOUR SERVER)

1.2.9 (July 30, 2012)
- Fix error when editing application types in board (was not happening in ACP edit)
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.2.8 JUST UPLOAD application-types.php to your server)

1.2.8 (May 23, 2012)
- Improved work around for vB 4.2 bug pertaining to navigation menu items (JIRA VBIV-14959).

1.2.7 (May 21, 2012)
- Work around for vB 4.2 bug pertaining to navigation menu items (JIRA VBIV-14959).

1.2.6 (May 20, 2012) (never released on vB.org)
- Made system compatible with vB 4.2.0

1.2.5 (February 27, 2012)
- Fix IP address not being displayed when answer color option is used.
- Fix overlap of nav tab with nav menu.

1.2.4 (January 17, 2012)
- Fix URL not being parsed when answer color is defined and URL is the only thing in the answer.

1.2.3 (January 11, 2012)
- Add replacement variables to PM after submitting application.
- Add answer color option to main settings.
- Add multiple choice answers in column format option to main settings.
- Add 'All of the above' Multiple Choice question type.

1.2.2 (December 16, 2011) (NO NEED TO IMPORT XML WHEN UPGRADING FROM 1.2.1, JUST UPLOAD FILES TO SERVER)
- Fix UTF-8 character display for expected answers.
- Fix sorting problem with first application questions.

1.2.1 (December 15, 2011) (not uploaded on vBulletin.org)
- Add option to PM a member after submitting an application.
- Add numeric ordering to edit position questions in ACP ONLY. (NOTE: Numbering MUST stay as 1,2,3.. NEVER use 10, 20, 30...)

1.2.0 (December 7, 2011)
- Fix database error when single quote is used in expected responses. (NO NEED TO IMPORT XML WHEN UPGRADING FROM 1.1.9, JUST UPLOAD FILES TO SERVER)

1.1.9 (December 5, 2011) (Not uploaded on vBulletin.org)
- Fix quote character not being displayed properly in posts. (NO NEED TO IMPORT XML WHEN UPGRADING FROM 1.1.8, JUST UPLOAD FILES TO SERVER)

1.1.8 (December 2, 2011)
- Fix 'not enough posts' now displays when it should. (NO NEED TO IMPORT XML WHEN UPGRADING FROM 1.1.7, JUST UPLOAD FILES TO SERVER)

1.1.7 (November 5, 2011)
- Added single selection dropdown box for questions.

1.1.6 (October 13, 2011) (Not uploaded on vBulletin.org)
- Code enhancements for future expansion.

1.1.5 (September 4, 2011)
- Repair forum based application group type editor. (NO NEED TO IMPORT XML WHEN UPDATING FROM 1.1.4 to 1.1.5, JUST UPLOAD FILES TO SERVER - NO NEED TO UPDATE IF YOU DON'T USE THE FORUM BASED EDITOR)

1.1.4 (August 27, 2011)
- Change hard coded Yes/No answers to standard vBulletin Yes/No phrases (thanks to Ellendway for testing).

1.1.3 (August 15, 2011)
- Corrected post format problems.
- Changed human verify portion of template.
- Changed hard coded Yes/No questions to standard vBulletin Yes/No Phrases.

1.1.2 (July 30, 2011)
- Code enhancements to allow for future expansion.

1.1.1 (July 6, 2011)
- Fix human verification. (problem found while converting mod to vB 3.8.7)

1.1.0 (June 29, 2011)
- Installation script change to correct installation problem where plugin was not importing completely for some people.

1.0.9 (June 21, 2011)
- Removed odd credit line for skin.

1.0.8 (June 14, 2011)
- Changed URL parse option so URLs are now parsed in all text fields.
- Changed 'Use First Text Answer As Subject' to subject replacement variable.
- Added option to remove member name from first line of reports.
- Added option to post application reports in an existing thread.
- Moved 'Start Application' button label to advapp vBulletin Phrase.
- Moved 'I am applying for the postion of' text from template to advapp vBulletin Phrase.
- Changed template so 'Member Name' now uses advapp vBulletin Phrase.
- Changed CSS so 'Start Application' button is centered on page.
- Removed remnant heading phrase from application form template.

1.0.7 (June 8, 2011)
- Fix minor bug where multi-line text was being cut into smaller sections.
- Added option to parse URLs. (it is in the position editor)

1.0.6 (June 6, 2011)
- Added option to use first single line text answer as report subject.
- Added option to require approval of the thread created when a member submits an application.
- Added options to redirect member to different locations after submitting an application.

1.0.5 (June 4, 2011)
- Fix default questions were carrying over their display positions causing answers to record improperly.
- Added option to show applications in navbar tabs.

1.0.4 (June 1, 2011)
- Database table creation change to make it compatible with MySQL 5.5.8
(NO NEED TO UPDATE IF YOU ARE ALREADY RUNNING VERSION 1.0.3)

1.0.3 (May 23, 2011)
- Added note about default email/pm user ids to position editors.
- Added Delete All Questions to ACP question editor.
- Added the ability to use a Thread Prefix for report threads.

1.0.2 (May 20, 2011)
- Fix rewind error.

1.0.1 (May 20, 2011)
- Changed database creation method for those that might be having problems.

1.0.0 (May 20, 2011)
- Initial Release

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
New Posting Features Easy Forms v4.x - Create a form or multiple forms without php or html knowledge bananalive vBulletin 4.x Add-ons 2069 23 Sep 2019 03:17
New Posting Features Easy Forms - Create a form or multiple forms without php or html knowledge bananalive vBulletin 3.8 Add-ons 1671 20 Dec 2018 01:02
Add-On Releases Forms Pack *** Forms Hack add-on Deepdog009 vBulletin 3.6 Template Modifications 2 27 Jul 2007 01:52
Forms Pack + (4) *** Forms Hack add-on Deepdog009 vBulletin 3.5 Template Modifications 1 09 May 2007 00:12

  #271  
Old 27 Jan 2012, 00:41
TombstoneWarrior's Avatar
TombstoneWarrior TombstoneWarrior is offline
 
Join Date: Jan 2012
[QUOTE=nhawk;2292871]
Originally Posted by TombstoneWarrior View Post

You are on the wrong screen.

Go to ACP->Application Forms->Application Types



Once there edit the application type and set 'This Application Type is Active' to 'Yes'.



And be sure you have permissions to view the application type.
thank you for the pic's here are mine proving i am set right and i still am not getting this to work!!what could be wrong????
Attached Images
File Type: jpg Capture1.jpg (21.8 KB, 10 views)
File Type: jpg Capture2.jpg (32.1 KB, 11 views)
File Type: jpg Capture.jpg (92.2 KB, 114 views)
File Type: png Capture3.PNG (12.9 KB, 14 views)
__________________
[B][I] IM A NEWBIE AT THIS PLEASE HELP ME WHERE YOU CAN. ALL THIS IS SO NEW TO ME!!
Reply With Quote
  #272  
Old 27 Jan 2012, 03:18
snowlion snowlion is offline
 
Join Date: Mar 2005


This is global setting to Add/Edit Permission.It has nothing to do with what we're talking about here. You have to...

Go to ACP > Application Forms > Application Types > Edit your application type > scrool down and search > Allowed Usergroups > Select the usergroups will be allowed to see this application group. > Tick the check boxes > Save.


Attached Images
File Type: png edit.png (31.7 KB, 114 views)
Reply With Quote
  #273  
Old 27 Jan 2012, 16:42
nhawk nhawk is offline
 
Join Date: Jan 2011
[QUOTE=TombstoneWarrior;2292884]
Originally Posted by nhawk View Post
thank you for the pic's here are mine proving i am set right and i still am not getting this to work!!what could be wrong????
Wait.. I spotted something wrong.

You MUST define at least one usergroup that can NOT use the application system in ACP->Settings->Options->Application Form Settings, Usergroup Settings.

The most common usergroup to forbid is 8, banned users.

Last edited by nhawk; 27 Jan 2012 at 16:49.
Reply With Quote
  #274  
Old 27 Jan 2012, 20:28
TombstoneWarrior's Avatar
TombstoneWarrior TombstoneWarrior is offline
 
Join Date: Jan 2012
[QUOTE=nhawk;2293091][QUOTE=TombstoneWarrior;2292884]

Wait.. I spotted something wrong.

You MUST define at least one usergroup that can NOT use the application system in ACP->Settings->Options->Application Form Settings, Usergroup Settings.

The most common usergroup to forbid is 8, banned users.[/QUOTE]i had to addthe 8 to the form now it is working fine!!!! as to the other settings i did have the admin checked so it had to be adding the 8 to the settings in the options part. thanks forpointing that out and lettinfg me know because that was def the problem. THANK YOU ALL FOR YOUR HELP GUY'S!!!! can someone tell me what this mean's on the app and what i should put there if i want the app sent to me ( admin )>>> CAN SOMEONE POST A PIC TO SET THIS APP SETTINGS FOR A NEW APP POSTION AND FOR THE APP TO BE SENT TO ME (ADMIN). sorry about the cap's
__________________
[B][I] IM A NEWBIE AT THIS PLEASE HELP ME WHERE YOU CAN. ALL THIS IS SO NEW TO ME!!

Last edited by TombstoneWarrior; 27 Jan 2012 at 23:59.
Reply With Quote
  #275  
Old 12 Feb 2012, 14:29
TombstoneWarrior's Avatar
TombstoneWarrior TombstoneWarrior is offline
 
Join Date: Jan 2012
THANK EVERYONE WO HELPED ME FIGURE OUT MY PROBLEM WITH THIS MOD. :sry about the caps" though you all do deserve a shout!!!!
__________________
[B][I] IM A NEWBIE AT THIS PLEASE HELP ME WHERE YOU CAN. ALL THIS IS SO NEW TO ME!!
Reply With Quote
  #276  
Old 17 Feb 2012, 17:04
killerford's Avatar
killerford killerford is offline
 
Join Date: Jan 2012
Real name: Josh
I run a gaming clan and would be awesome to have this for new recruits to fill out to apply for the clan. Is this possible? Where does the applications go when people have filled them out?
Reply With Quote
  #277  
Old 17 Feb 2012, 21:30
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by killerford View Post
I run a gaming clan and would be awesome to have this for new recruits to fill out to apply for the clan. Is this possible? Where does the applications go when people have filled them out?
It is used by many for just this purpose.

The applications are either sent via PM or Email, or they are posted in a thread.
Reply With Quote
  #278  
Old 18 Feb 2012, 00:01
CharlieDelta CharlieDelta is offline
 
Join Date: Apr 2010
I use it for this purpose exactly and it works perfect!
I highly recommend it and I also recommend using it along with his Poll and Promote pro add on. It is dirt cheap and works great!
Reply With Quote
  #279  
Old 19 Feb 2012, 18:44
mIQe mIQe is offline
 
Join Date: Dec 2011
Hi,

What have I done wrong when those using the application form get these:
"I would like to apply for" "Please select the position you are applying for."
But nothing to choose or write?

I have 7 application forms out of which 6 are active.
And this problem is only with 2 of the active ones.

Last edited by mIQe; 20 Feb 2012 at 07:09.
Reply With Quote
  #280  
Old 20 Feb 2012, 11:50
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by mIQe View Post
Hi,

What have I done wrong when those using the application form get these:
"I would like to apply for" "Please select the position you are applying for."
But nothing to choose or write?

I have 7 application forms out of which 6 are active.
And this problem is only with 2 of the active ones.
Could be a few things...

1)You haven't given permisson for the 'Application Positions' to the usergroup that has this problem

2) You haven't set 'This Position is Active' to 'Yes' in the application positions

3) You haven't assigned a 'Application Type' to the application positions.

4) You've set the User Post Count too high for the application positions.
Reply With Quote
  #281  
Old 20 Feb 2012, 16:12
killerford's Avatar
killerford killerford is offline
 
Join Date: Jan 2012
Real name: Josh
Uploading the files and it's saying failed to retrieve directly listings
Reply With Quote
  #282  
Old 20 Feb 2012, 16:50
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by killerford View Post
Uploading the files and it's saying failed to retrieve directly listings
What's saying that? Your FTP software?

If that's the case, I can't help with that.
Reply With Quote
  #283  
Old 23 Feb 2012, 23:51
deverill2010 deverill2010 is offline
 
Join Date: Jan 2011
Nhawk I have a couple of questions before I install this.

I'm currently using easy forms and have the results posted to a thread in a private forum. What I've been trying to do is display the form within a CMS article.

I tried using an inline frame but it showed the whole website inside the article aswell as the form instead of just the form.

With your mod can I display the form within a cms article and still have the results posted to a thread in my private forum?
Reply With Quote
  #284  
Old 24 Feb 2012, 13:18
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by deverill2010 View Post
Nhawk I have a couple of questions before I install this.

I'm currently using easy forms and have the results posted to a thread in a private forum. What I've been trying to do is display the form within a CMS article.

I tried using an inline frame but it showed the whole website inside the article aswell as the form instead of just the form.

With your mod can I display the form within a cms article and still have the results posted to a thread in my private forum?
The mod itself doesn't post to the CMS and I've never tried doing that.

But I would think that 'Promote to Article' should work. Try it and let us all know.
Reply With Quote
  #285  
Old 24 Feb 2012, 14:41
deverill2010 deverill2010 is offline
 
Join Date: Jan 2011
I don't see the 'promote to article' on the application form, i dont want the results IN the CMS.

I want to display the actual form within a article/static page ON the CMS.

See image - I really need this
Attached Images
File Type: jpg form.jpg (49.5 KB, 9 views)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 07:25.

Layout Options | Width: Wide Color: