Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Commbull (Community Bulletin) 5.1a for vBulletin 4.01 Details »
Commbull (Community Bulletin) 5.1a for vBulletin 4.01
Mod Version: 4.5F for 4, by djbaxter (Coder/Designer) djbaxter is offline
Developer Last Online: Feb 2020 I like it Show Printable Version Email this Page

vB Version: 4.0.4 Rating: (1 vote - 5.00 average) Installs: 59
Released: 22 Jan 2010 Last Update: 14 Jul 2010 Downloads: 317
Not Supported DB Changes Uses Plugins Template Edits Auto-Template Additional Files  

This not the CommBull product itself. This is simply instructions for adapting it to work with vBulletin 4.x.

Download CommBull from: Commbull (Community Bulletin) 5.1a for vBulletin 3.8x

grandeur_69 has released his latest version of CommBull as a free add-on, indicating that he no longer has time to continue developing it. I am posting this here for the benefit of other vBulletin 4.x who don't want to lose the newsletter feature (grandeur_69 has approved this).

At http://www.vbulletin.org/forum/showp...6&postcount=71 a member asks:

Hi, the version 5.1a work fine with vbulletin 4.0.1 ?
My response is posted at http://www.vbulletin.org/forum/showp...5&postcount=72 and reproduced here...

I have the previous (commercial) version, 4.5f, which does run successfully via a cron job, running on 4.01. It required some modification of the installation instructions but it does work. I expect you should be able to get this version running as well, although as the coder noted the cron capability won't work.

1. Edit product-Commbull.xml and find the following line:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Change to:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


2. Upload the files and import the product.

3. Now you need to do the template edits so that members can opt-in or opt-out of your newsletter. The current instructions are as follows:

4. Template modifications
--------------------------------------

Template: "Modify User Option" -> "modifyoptions"

After:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Add:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Now, obviously this won't work in 4.x. These need to be modified as follows:

1. Edit Template: "Modify User Option" -> "modifyoptions"

FIND:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


ADD AFTER:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

That first part (above) is the option to receive or not receive the newsletters.

Next would be the option for HTML or plain text emails, which should be:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Update:

This now works. I had a ( instead of a { on the previous code. Thanks to grandeur_69 for pointing this out!

Notes:
  1. The product is not mine so I can't offer any support for CommBull itself. However, I have been using the paid versions of this mod for some time and I'm happy to offer what support I can for making the changes necessary to get it running on 4.x.

  2. I have been in communication with grandeur_69. He has indicated that he has no objections to this thread and that as he gets time he will be trying to develop this add-on further as a free product.

Update July 12, 2010: Product XML file provided by grandeur_69 for vBulletin 4.x.

NOTE:
  1. If you have already done the manual edits, do NOT use the XML file. And if you import the XML file, you should not need to do the manual edits.
  2. Some people are encountering problems using the XML file. If you are one of them, uninstall the product and use the manual edits. Those seem to work just fine.


Update July 14, 2010: Error in XML file corrected.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	top-custom-text.jpg
Views:	3320
Size:	61.4 KB
ID:	110697   Click image for larger version

Name:	top-new-threads.jpg
Views:	2671
Size:	51.1 KB
ID:	110698   Click image for larger version

Name:	articles.jpg
Views:	1827
Size:	48.6 KB
ID:	110699  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Administrative and Maintenance Tools Commbull (Community Bulletin) 5.1b grandeur_69 vBulletin 3.8 Add-ons 288 11 Jul 2014 05:19
Commbull (Community Bulletin) grandeur_69 vBulletin 3.5 Add-ons 116 19 Aug 2012 15:59
CommBull (Community Bulletin) grandeur_69 vBulletin 3.0 Full Releases 449 24 Feb 2009 05:16

  #106  
Old 14 Jul 2012, 21:32
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Yes I'm still using version 4.5f. Still working on vBulletin 4.20.
Reply With Quote
  #107  
Old 15 Jul 2012, 08:47
docvader's Avatar
docvader docvader is offline
 
Join Date: Dec 2002
Thanks DJ, I'll try it. I'll dig through my laptop and find it.
__________________
russbo.com
Reply With Quote
  #108  
Old 24 Aug 2012, 00:33
420 420 is offline
 
Join Date: Nov 2004
Just upgraded VB 4.1.12 to VB 4.20 PL 2 and now Commbull doesn't work.

Any ideas?
Reply With Quote
  #109  
Old 08 Sep 2012, 02:40
Nelson58 Nelson58 is offline
 
Join Date: Oct 2011
So this does NOT work with 4.2?

Please advise if this can be upgraded.

Thanks!


Nelson
Reply With Quote
  #110  
Old 14 Sep 2012, 13:54
Nelson58 Nelson58 is offline
 
Join Date: Oct 2011
No response? I will assume the newsletter does not work with 4.2 and will not work with 5.0 .


Nelson
Reply With Quote
  #111  
Old 20 Sep 2012, 20:24
Nelson58 Nelson58 is offline
 
Join Date: Oct 2011
I wanted to see for myself if it worked. So I installed 5.1a on my 4.2 pl2 Vbulletin site. Made the changes indicated above. It shows that it is emailing the newsletters, but it doesn't email anything. I changed the crom setting in the email options in admincp and got the same result. Does not work with 4.2 pl2.


Nelson

Last edited by Nelson58; 20 Sep 2012 at 21:15.
Reply With Quote
  #112  
Old 24 Sep 2012, 00:34
Calystos's Avatar
Calystos Calystos is offline
 
Join Date: Apr 2009
Real name: Lucas Black
I've not had any luck with commbull working on 4.2 either. Which is a major shame as it was awesome. And a lot better to look at and configure/etc, than some of the others I've tried.

Anyone managed to figure out why its stopped working? I've not had the time to look into it myself yet.
Reply With Quote
  #113  
Old 24 Sep 2012, 01:30
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
If you still have one of the older versions (paid versions) try that. Version 5.1 never really worked properly for me but 4.5f is still going strong, week after week, now on 4.2.0 PL2.

Otherwise, please give me details about your settings and I'll try to figure it out.

One recommendation to try is this:
AdminCP >> Settings >> Email Options

Use Mailqueue System = No

Use Cron Based Sending = No

Number of Emails to Send Per Batch = 1000 (tweak this if it creates problems on your server)

E-Mail Send Delay = None (tweak this if it creates problems on your server)

Encode as UTF-8 = No

SMTP Email = No

Last edited by djbaxter; 24 Sep 2012 at 01:38.
Reply With Quote
  #114  
Old 25 Sep 2012, 21:55
Calystos's Avatar
Calystos Calystos is offline
 
Join Date: Apr 2009
Real name: Lucas Black
Originally Posted by djbaxter View Post
If you still have one of the older versions (paid versions) try that. Version 5.1 never really worked properly for me but 4.5f is still going strong, week after week, now on 4.2.0 PL2.

Otherwise, please give me details about your settings and I'll try to figure it out.

One recommendation to try is this:
AdminCP >> Settings >> Email Options

Use Mailqueue System = No

Use Cron Based Sending = No

Number of Emails to Send Per Batch = 1000 (tweak this if it creates problems on your server)

E-Mail Send Delay = None (tweak this if it creates problems on your server)

Encode as UTF-8 = No

SMTP Email = No
Thanks, will check those above suggestions and see if that helps. If not will drop down to that 4.5f version.

Our commbull settings are pretty much default, but I have noticed one bug in the 5.1 version that if you try to enable it to post a copy of the newsletter to a forum it comes up with a mysql error of invalid sql but no actual info as if the sql query is blank or something.

Here are the above listed settings that we (currently) have set and have been set for as long as I can recall and used to work with pre-4.2 vbulletin.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #115  
Old 25 Sep 2012, 22:43
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by Calystos View Post
Thanks, will check those above suggestions and see if that helps. If not will drop down to that 4.5f version.

Our commbull settings are pretty much default, but I have noticed one bug in the 5.1 version that if you try to enable it to post a copy of the newsletter to a forum it comes up with a mysql error of invalid sql but no actual info as if the sql query is blank or something.
I've never tried to use that feature.

Originally Posted by Calystos View Post
Here are the above listed settings that we (currently) have set and have been set for as long as I can recall and used to work with pre-4.2 vbulletin.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
I had problems getting cron-based sending to work correctly and eventually juist disabled it. On my server, everything functions well with it turned off and erratically with it turned on.
Reply With Quote
  #116  
Old 26 Sep 2012, 00:29
Calystos's Avatar
Calystos Calystos is offline
 
Join Date: Apr 2009
Real name: Lucas Black
Originally Posted by djbaxter View Post
I've never tried to use that feature.
I had problems getting cron-based sending to work correctly and eventually juist disabled it. On my server, everything functions well with it turned off and erratically with it turned on.
Yeah, that feature appears to be buggy. Shame, thought would be handy for an archive of the sent messages.

Hmm, seems it was cron-based sending to blame. Turned it off and it posted fine. Though the post it actually posted is like info from July and not the most current info, eg it doesn't display the most recent thread/posts but the ones from way back in July when it stopped working, lol. Though it also appears to have sent a load of other messages too. Again, all from July. So perhaps the vbulletin cron post sending was messed up. Am going to check the vb bugs list an forums to see if theres any info on a fix for that. As the cron based sending system woulda been handy.
Reply With Quote
  #117  
Old 26 Sep 2012, 00:41
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by Calystos View Post
Yeah, that feature appears to be buggy. Shame, thought would be handy for an archive of the sent messages.

Hmm, seems it was cron-based sending to blame. Turned it off and it posted fine. Though the post it actually posted is like info from July and not the most current info, eg it doesn't display the most recent thread/posts but the ones from way back in July when it stopped working, lol. Though it also appears to have sent a load of other messages too. Again, all from July. So perhaps the vbulletin cron post sending was messed up. Am going to check the vb bugs list an forums to see if theres any info on a fix for that. As the cron based sending system woulda been handy.
You may have a rather large mail queue by now if you've had cron-based emailing on for a while. If you have a VPS or dedicated server, you can flush this through WHM. Otherwise, ask your host to have a look at the queue and remove old emails.
Reply With Quote
  #118  
Old 26 Sep 2012, 01:04
Calystos's Avatar
Calystos Calystos is offline
 
Join Date: Apr 2009
Real name: Lucas Black
Yeah, its on a dedicated server. And appears to have caught up now. I wonder if its actually that to have been the cause. EG a messed up mailqueue from back then, maybe a host server issue or a crashed/bugged daemon. *shrugs*

Will re-enable the cron and run a test later to see if it works again. And will monitor the mail queues closely from now on and see.
Reply With Quote
  #119  
Old 26 Sep 2012, 02:31
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Honestly, I wouldn't bother. I'm on a dedicated server too and all cron mail sending did was slow everything down. Everything works just fine without it.

Those with super-large mailing lists and or shared hosting with limits on emails per hour may need it. But since you can adjust those settings yourself, seriously just bypass it.
Reply With Quote
  #120  
Old 26 Sep 2012, 03:43
SilverBoy SilverBoy is offline
 
Join Date: Feb 2002
Real name: Malik
It is working with me, but the most read threads or most replied threads blocks always grab data from the day one of the forum, and the date that we entered to select only threads starting from it don't work any more !!
for example if I select the date as 1 September, it displays threads written in 2003 and the last reply was in 2006 !!
How I can solve this???
__________________
One of highly customized vBCMS used for news site.
www.manshor.net
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 15:18.

Layout Options | Width: Wide Color: