Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Commbull (Community Bulletin) 5.1a for vBulletin 4.01 Details »
Commbull (Community Bulletin) 5.1a for vBulletin 4.01
Mod Version: 4.5F for 4, by djbaxter (Coder/Designer) djbaxter is offline
Developer Last Online: Feb 2020 I like it Show Printable Version Email this Page

vB Version: 4.0.4 Rating: (1 vote - 5.00 average) Installs: 59
Released: 22 Jan 2010 Last Update: 14 Jul 2010 Downloads: 316
Not Supported DB Changes Uses Plugins Template Edits Auto-Template Additional Files  

This not the CommBull product itself. This is simply instructions for adapting it to work with vBulletin 4.x.

Download CommBull from: Commbull (Community Bulletin) 5.1a for vBulletin 3.8x

grandeur_69 has released his latest version of CommBull as a free add-on, indicating that he no longer has time to continue developing it. I am posting this here for the benefit of other vBulletin 4.x who don't want to lose the newsletter feature (grandeur_69 has approved this).

At http://www.vbulletin.org/forum/showp...6&postcount=71 a member asks:

Hi, the version 5.1a work fine with vbulletin 4.0.1 ?
My response is posted at http://www.vbulletin.org/forum/showp...5&postcount=72 and reproduced here...

I have the previous (commercial) version, 4.5f, which does run successfully via a cron job, running on 4.01. It required some modification of the installation instructions but it does work. I expect you should be able to get this version running as well, although as the coder noted the cron capability won't work.

1. Edit product-Commbull.xml and find the following line:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Change to:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


2. Upload the files and import the product.

3. Now you need to do the template edits so that members can opt-in or opt-out of your newsletter. The current instructions are as follows:

4. Template modifications
--------------------------------------

Template: "Modify User Option" -> "modifyoptions"

After:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Add:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Now, obviously this won't work in 4.x. These need to be modified as follows:

1. Edit Template: "Modify User Option" -> "modifyoptions"

FIND:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


ADD AFTER:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

That first part (above) is the option to receive or not receive the newsletters.

Next would be the option for HTML or plain text emails, which should be:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Update:

This now works. I had a ( instead of a { on the previous code. Thanks to grandeur_69 for pointing this out!

Notes:
  1. The product is not mine so I can't offer any support for CommBull itself. However, I have been using the paid versions of this mod for some time and I'm happy to offer what support I can for making the changes necessary to get it running on 4.x.

  2. I have been in communication with grandeur_69. He has indicated that he has no objections to this thread and that as he gets time he will be trying to develop this add-on further as a free product.

Update July 12, 2010: Product XML file provided by grandeur_69 for vBulletin 4.x.

NOTE:
  1. If you have already done the manual edits, do NOT use the XML file. And if you import the XML file, you should not need to do the manual edits.
  2. Some people are encountering problems using the XML file. If you are one of them, uninstall the product and use the manual edits. Those seem to work just fine.


Update July 14, 2010: Error in XML file corrected.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	top-custom-text.jpg
Views:	3320
Size:	61.4 KB
ID:	110697   Click image for larger version

Name:	top-new-threads.jpg
Views:	2671
Size:	51.1 KB
ID:	110698   Click image for larger version

Name:	articles.jpg
Views:	1827
Size:	48.6 KB
ID:	110699  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Administrative and Maintenance Tools Commbull (Community Bulletin) 5.1b grandeur_69 vBulletin 3.8 Add-ons 288 11 Jul 2014 05:19
Commbull (Community Bulletin) grandeur_69 vBulletin 3.5 Add-ons 116 19 Aug 2012 15:59
CommBull (Community Bulletin) grandeur_69 vBulletin 3.0 Full Releases 449 24 Feb 2009 05:16

  #121  
Old 26 Sep 2012, 04:11
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by SilverBoy View Post
It is working with me, but the most read threads or most replied threads blocks always grab data from the day one of the forum, and the date that we entered to select only threads starting from it don't work any more !!
for example if I select the date as 1 September, it displays threads written in 2003 and the last reply was in 2006 !!
How I can solve this???
Yes, the date not updating has been a longstanding problem and I never found a fix for that.

What I do is periodically between mail-outs I go into the AdminCP and adjust the date and then click on preview mailing. After that it will use the new date until I go in and manually change it again.
Reply With Quote
  #122  
Old 26 Sep 2012, 06:39
Calystos's Avatar
Calystos Calystos is offline
 
Join Date: Apr 2009
Real name: Lucas Black
Yup, totally confirm that it was indeed that cron mail sending system. Works without it enabled, but enable it and it just stops so yeah gonna leave that disabled from now on I think, lol. I reckon its because the commbull system had its cron file removed so its trying to run the cron but can't because of the missing file.

Am gonna look into the issue in regards to why the post to forum option doesn't work sometime soon though. It comes up with an invalid sql query, "query was empty" error. It posts to the forum fine, but then it seems it resets or blanks the query in regards to continuing on to actually email the post. Go fig. Its not an essential feature, but thought it might be handy for a backup log or something. Or maybe for other things.

Last edited by Calystos; 26 Sep 2012 at 06:47.
Reply With Quote
  #123  
Old 29 Sep 2012, 15:46
Nelson58 Nelson58 is offline
 
Join Date: Oct 2011
Originally Posted by djbaxter View Post
If you still have one of the older versions (paid versions) try that. Version 5.1 never really worked properly for me but 4.5f is still going strong, week after week, now on 4.2.0 PL2.

Otherwise, please give me details about your settings and I'll try to figure it out.

One recommendation to try is this:
AdminCP >> Settings >> Email Options

Use Mailqueue System = No

Use Cron Based Sending = No

Number of Emails to Send Per Batch = 1000 (tweak this if it creates problems on your server)

E-Mail Send Delay = None (tweak this if it creates problems on your server)

Encode as UTF-8 = No

SMTP Email = No
How would I get one of the older versions, like 4.5f to try it on my 4.20 PL system?

Thanks!

Nelson
Reply With Quote
  #124  
Old 29 Sep 2012, 16:44
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by Allthumbz View Post
How would I get one of the older versions, like 4.5f to try it on my 4.20 PL system?

Thanks!

Nelson
You would have to contact grandeur_69 who created the product. The earlier versions were commercial products.
Reply With Quote
  #125  
Old 30 Sep 2012, 05:46
SilverBoy SilverBoy is offline
 
Join Date: Feb 2002
Real name: Malik
Originally Posted by djbaxter View Post
Yes, the date not updating has been a longstanding problem and I never found a fix for that.

What I do is periodically between mail-outs I go into the AdminCP and adjust the date and then click on preview mailing. After that it will use the new date until I go in and manually change it again.
Thanks djbaxter for your reply, but really I didn't get the point

I want the date criteria to be applied to most reply and most read threads, is there away to do this?

Thanks .
__________________
One of highly customized vBCMS used for news site.
www.manshor.net
Reply With Quote
  #126  
Old 30 Sep 2012, 16:00
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by SilverBoy View Post
Thanks djbaxter for your reply, but really I didn't get the point

I want the date criteria to be applied to most reply and most read threads, is there away to do this?

Thanks .
Not to my knowledge. Then again, I don't know why you'd want to do that.
Reply With Quote
  #127  
Old 01 Oct 2012, 00:04
SilverBoy SilverBoy is offline
 
Join Date: Feb 2002
Real name: Malik
Thanks again
I want it to display the most active threads in my forum in this week for example, not to show my members 8 years old threads and in the most cases it is dead thread now .
__________________
One of highly customized vBCMS used for news site.
www.manshor.net
Reply With Quote
  #128  
Old 01 Oct 2012, 00:58
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
From the AdminCP for my version of CommBull:

Show info starting from this date: Day Month Year

Only include threads that have been started or replied to since this date? Yes/No

Note: Only applies to sections sorted by Most Replies or Most Views (others automatically adhere to above date)
Do you see this in your version?
Reply With Quote
  #129  
Old 01 Oct 2012, 05:44
SilverBoy SilverBoy is offline
 
Join Date: Feb 2002
Real name: Malik
yes but it didn't change any thing !! always getting the same threads !!
__________________
One of highly customized vBCMS used for news site.
www.manshor.net
Reply With Quote
  #130  
Old 02 Oct 2012, 20:05
Nelson58 Nelson58 is offline
 
Join Date: Oct 2011
Originally Posted by djbaxter View Post
You would have to contact grandeur_69 who created the product. The earlier versions were commercial products.
djbaxter,

I don't mean to be a pest, but is there any way you can help me to get this working on 4.2 PL2? I installed the 5.1 on here but no go.

I would be willing to pay for a newsletter app that works with 4.2 since I wont be able to afford to upgrade to 5.0 for a while.

Thanks man!


Nelson
www.Hobby-Machinist.com
Reply With Quote
  #131  
Old 02 Oct 2012, 20:17
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
I could give it a try but I'm using 4.5f. I was never as happy with the later versions. Do you have an earlier version?
Reply With Quote
  #132  
Old 04 Oct 2012, 17:16
Nelson58 Nelson58 is offline
 
Join Date: Oct 2011
Originally Posted by djbaxter View Post
I could give it a try but I'm using 4.5f. I was never as happy with the later versions. Do you have an earlier version?
I contacted Grandeur and got no response.

So many people want a newsletter, myself included, it really does energize the less active members of the forum.

If you or someone could get 5.1 working, I would be very appreciative and send you some money via Paypal.

Nelson
www.Hobby-Machinist.com
Reply With Quote
  #133  
Old 04 Oct 2012, 18:03
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
If you PM or email me the following, I'll see what I can do:
  • FTP access
  • Admin CP access with admin privileges
Reply With Quote
  #134  
Old 05 Oct 2012, 16:26
Nelson58 Nelson58 is offline
 
Join Date: Oct 2011
Originally Posted by djbaxter View Post
If you PM or email me the following, I'll see what I can do:
  • FTP access
  • Admin CP access with admin privileges
Do you want me to reinstall 5.1a first?

Thanks,

Nelson
Reply With Quote
  #135  
Old 05 Oct 2012, 17:01
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Up to you. I can do that if you wish.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 05:07.

Layout Options | Width: Wide Color: