Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Title Tag Grabber AND Video Embedding by BOP5 for VB5 Details »
Title Tag Grabber AND Video Embedding by BOP5 for VB5
Mod Version: 3.0.1, by BirdOPrey5 (IB Staff) BirdOPrey5 is offline
Developer Last Online: Nov 2019 I like it Show Printable Version Email this Page

vB Version: 5.1.x Rating: (2 votes - 5.00 average) Installs: 47
Released: 11 Oct 2012 Last Update: 30 Jun 2015 Downloads: 361
Not Supported Additional Files Re-usable Code  

.

IMPORTANT! - Updated version released here: https://www.vbulletin.org/forum/showthread.php?t=325277

All New Version 3.0

Use version 3.0.1 on VB 5.1.5 and newer (tested on 5.1.7)
It has not been tested on old versions of VB5. If you still have an old version of VB5 try the Version 2.0 download.

This mod can do two things:
  1. It can automatically grab the title of a page you are linking to
  2. It can embed video URLs automatically

For example it will turn:

http://www.vbulletin.org

to

vBulletin.org Forum - The Official vBulletin Resource!

This is working on both the simple and complex style URL BBcodes, and it will ignore existing links if you have specified a custom title.

It can also turn a link like: http://www.youtube.com/watch?v=gxEPV4kolz0 into an embedded video without use of the [video] BB Code.

In addition there is an option to auto embed old links that were previously embedded by the AME 2.x mod for vBulletin 3.x. If you still have [AME] BB Codes in your posts this mod can do its best to embed them like they used to be with AME.

Video Embedding is currently working with Youtube (both short and original URLs) and Vimeo.com videos.

The Mod should auto install, upload files as instructed in Readme (everything goes in the usual place.) Clear the system cache to see the mod work on existing posts.

If you wanted to undo the changes made by this mod simply delete the files/remove the mod/ and clear the cache. This mod does not alter the original posts, only the cached copies.

Please "Mark as Installed" if you use this.
Donations Always Appreciated.
Consider nominating for MOTM if you like it!

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	title-grab-settings.jpg
Views:	745
Size:	93.9 KB
ID:	144670  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Miscellaneous Hacks Kindle Daily Deal Grabber by BOP5 BirdOPrey5 vBulletin 4.x Add-ons 79 20 Oct 2014 05:20
Miscellaneous Hacks Add ALT and/or TITLE text to linked images in VB3 by BOP5 BirdOPrey5 vBulletin 3.8 Add-ons 20 16 Apr 2014 17:29
Miscellaneous Hacks Kindle Daily Deal Grabber by BOP5 (VB3) BirdOPrey5 vBulletin 3.8 Add-ons 14 14 Jan 2013 17:52

  #46  
Old 31 Jan 2016, 19:38
DemOnstar's Avatar
DemOnstar DemOnstar is offline
 
Join Date: Dec 2012
Does this mod remove the control functions, pause, full screen etc from the window within the thread?

If so, how can it be changed?

Cheers. . . ...
Reply With Quote
  #47  
Old 20 Apr 2016, 22:31
mdawg's Avatar
mdawg mdawg is offline
 
Join Date: Mar 2009
With vb 5.2.1 have you noticed any issue with this mod converting email addresses and other stuff into http: format? This does appear to be an issue with this mod and not with 5.2.1 because I toggled your mod on and off, and only with the mod ON did I notice the below issue:

For example on a post on my vb 5.2.1 forum I had an email address
webmaster@mysite.com
entered into a post, and the forum first converted it upon saving to look like this
< a href="http://webmaster@mysute.com</a>
(no hyperlink)

and then when I did nothing more than edit/save without touching it, it converted it to a hyperlink looking like this
http://webmaster@mysite.com

so finally I had to turn HTML ON, and add noparse /noparse tags to beginning and end and then it looked like this finally
webmaster@mysite.com
but not a hyperlink.

This seems to have something to do with the word WEB in webmaster that alerts your mod to convert to an http hyperlink.

I experienced this same issue when I tried to enter the text
test-site.php

into a post and your mod converted it in the same way as above, except directly to a bizarre hyperlink
http://test-site.php
without the interim strange conversion, again necessitating the noparse /noparse tags.

Again - I went into a test forum of mine and toggled your mod on and off, and turning it off rectified this issue, so there is an issue with your mod and vb 5.2.1

Or maybe this was there all along as a bug in your mod, and the word "web" in webmaster or the hyphen in the .php makes your mod think this is a URL to be converted.


To clarify:

Of these for example

wp-atomic.php
wp-installit.php

word-installit.php
word-atomic.php

forbear-atomic.php

The first four end up http: conversions. The last one, not.


webmaster@mysite.com
hello@mysite.com

the first with the word webmaster in it, ends up converted to http:// hyperlink. The second, remains as a webmail hyperlink.

Last edited by mdawg; 21 Apr 2016 at 21:58.
Reply With Quote
  #48  
Old 09 Jun 2016, 06:33
shimei shimei is offline
 
Join Date: Feb 2015
Any plans for vb 5.2.2? Anyone know whether this mod works?
Reply With Quote
  #49  
Old 10 Jun 2016, 04:34
mdawg's Avatar
mdawg mdawg is offline
 
Join Date: Mar 2009
It does work with 5.2.2 with the noted above issues from my 4/20/16 post.
Reply With Quote
  #50  
Old 10 Jun 2016, 15:07
shimei shimei is offline
 
Join Date: Feb 2015
Works for me using 5.2.2.

Last edited by shimei; 10 Jun 2016 at 15:21.
Reply With Quote
  #51  
Old 13 Jun 2016, 17:41
mdawg's Avatar
mdawg mdawg is offline
 
Join Date: Mar 2009
It does work yes and I have it installed on 5.2.2 However it has the above noted issue from my post # 47

Last edited by mdawg; 14 Jun 2016 at 04:38.
Reply With Quote
  #52  
Old 10 Aug 2016, 04:37
shimei shimei is offline
 
Join Date: Feb 2015
Is there a way to exclude the urls in < iframes >

Edit: looks it will exclude if using \</iframe>| in the ignore regex feature.

Thanks,
Shim

Last edited by shimei; 10 Aug 2016 at 18:24.
Reply With Quote
  #53  
Old 10 Aug 2016, 18:10
mdawg's Avatar
mdawg mdawg is offline
 
Join Date: Mar 2009
The solution I found was to bookcase the problematic terms with noparse /noparse tags. But, it would be preferable if the software were updated to prevent the issue entirely because you can't really know what terms will be problematic before you post them....

Last edited by mdawg; 19 Aug 2016 at 23:53.
Reply With Quote
  #54  
Old 24 Mar 2017, 15:18
Manuela Manuela is offline
 
Join Date: Mar 2017
Just tested it in vb 5.2.6

Worked great for videos... but I had to deactivate it.

Because for URL it also rewrote all links within attached images from URL and they were not shown anymore.

Setting "Auto Parse ALL URLs" to "No" also disabled the video function... so its unfortunately useless for me.

Do you think you can find a solution for this problem?
Reply With Quote
  #55  
Old 24 Mar 2017, 20:30
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Can you post a plaint text example of the attached image issue that is causing you problem? So I can enter the text on my VB5 forum and see if I can replicate the issue?
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #56  
Old 25 Mar 2017, 11:43
Manuela Manuela is offline
 
Join Date: Mar 2017
Sure.. here is what it does to an attachement when implemented with extern URL:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

This only happens to extern URLs, not to image attachements that had been uploaded to server.
Reply With Quote
  #57  
Old 28 Mar 2017, 11:32
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Hello,

I need the text you type into the post before it happens, not after it happens.

You can get the text by viewing the raw source in the Advanced editor before submitting the post.
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #58  
Old 29 Mar 2017, 00:05
Manuela Manuela is offline
 
Join Date: Mar 2017
That was an attached image used on vb 5.2.6.
No written Text, URL or written BBCode.

Clicked on the Image Icon, filled in the Image-URL and then saved the post. Nothing else.

And after installing and activating the mod all attached images in posts turned to the code I added above.
Reply With Quote
  #59  
Old 09 Apr 2017, 13:14
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Sorry I don't foresee anytime to work on this, I have marked it re-usable code, if anyone wants to take a look at improving it themselves and releasing an updated version, feel free.
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #60  
Old 24 Apr 2017, 18:57
mdawg's Avatar
mdawg mdawg is offline
 
Join Date: Mar 2009
What it seems to do is truncate the URL for external links IF it is a really long URL such as say one for an image, example:
https://lh3.googleusercontent.com/zm...ghO5dS0dg=w300

it turns it into this upon saving:
https://lh3.googleusercontent.com

I don't believe this has anything to do with "images" per se, it just means that this hack is altering any really long external URLs when posted as external links. (When you use the ADD LINK function.) When you click to edit the external link URL, it is all there, but after you post it, it is truncated such that it no longer goes to the correct URL.

Within the same post if you post the URL as a line in the post text (NOT as an external link), the URL appears fine.

To summarize again:
If you try to use the Add Link function to the right of the Image button, upon posting the URL is truncated and invalid. However if you click to edit, the URL is all there. Just upon saving the URL is altered.

But if you simply post a URL within the message, it appears okay.

I am assuming that this is something this hack is doing, and not a bug in VB 5.3.0


---

As far as what Manuela is saying up there, yes it does post the image when you try to find and post it via URL, but it also makes a crazy URL at the top of the post, which for this URL
https://lh3.googleusercontent.com/zm...ghO5dS0dg=w300

looks like this:
[ATTACH=JSON]{"data-align":"none","data-size":"full","title":"zmJTC0HBAeAk9ZcCjNANsQMLv78-oc04-b9olW60XYFBj78jf3-Iuj36EghO5dS0dg=http://w300.jpg","data-attachmentid":74051}[/ATTACH]


---

So these are two separate, perhaps related, bugs with the hack. I wish Bird O'Prey could find the time to revise this very useful hack. We could pass a donation hat and I would contribute if that would make a difference. Thanks!

Last edited by mdawg; 24 Apr 2017 at 19:15.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 13:23.

Layout Options | Width: Wide Color: