Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
8WayRun.Com - Media Library Details »
8WayRun.Com - Media Library
Mod Version: 4.1.7, by Jaxel (Coder) Jaxel is offline
Developer Last Online: Sep 2013 I like it Show Printable Version Email this Page

This modification is currently quarantined.
vB Version: 4.0.x Rating: (131 votes - 4.73 average) Installs: 916
Released: 17 Apr 2010 Last Update: 27 Oct 2010 Downloads: 7899
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Translations External Content  

Don't forget to click INSTALL!
I'm an unemployed computer programmer... if you appreciate the work I have done on this mod, please don't hesitate in offering me a donation by clicking the "Support Developer" link to the right of this text. A donation of $50 or more automatically gives you the right to remove the copyright footer for this modification from a single forum.

This is a new modification, spawning from the old VB 3.x Video Directory modifications.
For all intents and purposes, both my old Video Directory Remixed mod, and Survivor's original Video Directory mod have been discontinued. Neither of us are maintaining these older versions, they will not receive any future updates and we will not be providing any support. This version has a new name because it has been completely rewritten from scratch and is not being built on Survivor's old code. Because of this, if you are upgrading to this new version, from the old version, be sure to read this entire post in order to understand the upgrade process.

What is this mod?
Simply put, this mod is a directory for media. It supports URL inputs, in order to extract meta data and directorize media into a simple and easy to understand library. Users can add their favorite media from a select few online distribution centers (such as Youtube or Vimeo) and categorize and tag them as they see fit. This mod offers rudimentary support for the hosting of local media. An administrator can upload a media to the /customVID/ (default) directory; then add the media to the library using the URL code of "local:filename". Media hosted locally will be displayed using JWPlayer, but will not provide meta data, so that kind of information will need to be entered manually.

Demo:
http://www.8wayrun.com/media.php

Features:
  • Integrated directly into the vBulletin user database and product manager.
  • Fully phrased and built on tempaltes for easy re-skinning and styling.
  • Simple to use administration features and usergroup permission settings.
  • Landing page with the most recent, most popular and highest rated media.
  • Ability to add media into a single category, while adding multiple tags.
  • Ability to browse media through categories, tags, and user contributions.
  • Summary tag cloud with a link to the entire list of tags in the system.
  • Comment and rating system based on AJAX including graceful degredation.
  • Individual RSS Feeds for newest videos, categories, tags and user media.
  • Search function for titles and descriptions.
Installation:
If you are upgrading from before version 1.1, please install that version first.
  1. Upload all the files in the "upload" directory of the attached zip file to your forum root.
  2. CHMOD the /customVID/thumbs/ directory to full read/write/execute 777 permissions.
  3. CHMOD the /customVID/sitemap/ directory to full read/write/execute 777 permissions.
  4. Import the product file called "product-medialibrary.xml" in the Product Manager of vBulletin.
  5. Set your usergroup permissions and media library settings in your administration control panel.
  6. OPTIONAL: Enable the "Generate XML Media Sitemap" scheduled task in your administration control panel.

    NOTES: Make sure you decide what you wish to use for your thumbnail quality setting. By default, thumbnails are saved at 50% quality. At 50%, thumbnails will only be 2kb in size, but at the expense of quality. At 100%, thumbnails will be about 15kb in size, but will have the highest quality. I recommend setting it to 80%, which would leave thumbnails at 5kb in size with still excellent quality.

    Every time you change your thumbnail quality setting, you will need to run the "Rebuild Media Thumbnails" to see any changes.
Upgrading from VDR:
  1. The "video*" tables from your previous installation of VDR need to exist in your database.
  2. Enable the "media ADMIN import" plugin in the plugin manager of your control panel.
  3. Run the "Import Media from VDR" process in your update counters menu in maintenance.
  4. Disable the "media ADMIN import" plugin in the plugin manager of your control panel.
  5. Run the "Rebuild Media Thumbnails" process in your update counters menu in maintenance.
  6. You may now uninstall VDR once you confirm everything has been imported as intended.

    NOTES: You will mostly likely get at least one error while rebuilding media thumbnails...

    When you get an error, click the details link for that media. If the media displays some sort of error such as "This video has been removed" or "This video no longer exist", then that means that media is gone and you'll be unable to generate a thumbnail for that particular media. Use the available options on that media's detail page to DELETE it from your library. Then go back to your browser window which is rebuilding thumbnails and click the "retry from this position" link.

    If you got an error for a media, but after clicking the details link you can find no obvious error with the video; then the error could have just been a simple syn/ack failure. Just click the "retry from this position" link and the system will try to rebuild that thumbnail again.
Known Bugs:
There is a conflict with this modification and some of Valter's VSA modifications that will prevent navbar permissions from being handled correctly. I don't know exactly who's fault it is; but I'm pretty sure there are no errors in my code that would be causing this problem. There is a work around for this however.

Admin Control Panel > Plugins & Products > Plugin Manager > "media NAVTAB"

Find the code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	product-screenshot1.jpg
Views:	10617
Size:	89.6 KB
ID:	116041   Click image for larger version

Name:	product-screenshot2.jpg
Views:	5286
Size:	91.5 KB
ID:	116042   Click image for larger version

Name:	product-screenshot3.jpg
Views:	4544
Size:	81.3 KB
ID:	116043   Click image for larger version

Name:	product-screenshot4.jpg
Views:	7473
Size:	82.6 KB
ID:	116044  

Click image for larger version

Name:	product-screenshot5.jpg
Views:	5369
Size:	87.1 KB
ID:	116045   Click image for larger version

Name:	product-screenshot6.jpg
Views:	3938
Size:	113.6 KB
ID:	116046   Click image for larger version

Name:	product-screenshot7.jpg
Views:	4054
Size:	103.7 KB
ID:	116047   Click image for larger version

Name:	product-screenshot8.jpg
Views:	3415
Size:	107.9 KB
ID:	116048  

Show Your Support

  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases Digital Sith's AMEs - ADULT Media Definitions Digital Sith vBulletin 3.6 Add-ons 66 08 Sep 2015 23:44
Mini Mods 8WayRun.Com - Random Header Jaxel vBulletin 4.x Add-ons 47 11 Jan 2013 23:26
Add-On Releases Media Block for DnP Instant! Musicbox - Display the fun media list anywhere ! silveryhat vBulletin 3.8 Add-ons 2 19 Jan 2011 14:12
Add-On Releases DJ's AME (Auto Media Embedding) XML Media Definitions (Third Time's the Charm) Digital Jedi Modification Graveyard 828 10 Mar 2010 06:45

  #2191  
Old 30 Jul 2011, 11:28
lild100 lild100 is offline
 
Join Date: Oct 2010
Hi guys does anyone know why the thumbnails are not showing on the latest media? http://www.tabletennisdaily.co.uk/forum/forum.php
Reply With Quote
  #2192  
Old 30 Jul 2011, 19:31
michal72 michal72 is offline
 
Join Date: Nov 2010
Originally Posted by lild100 View Post
Hi guys does anyone know why the thumbnails are not showing on the latest media? http://www.tabletennisdaily.co.uk/forum/forum.php
Check /customVID/thumbs/ permissions

CHMOD the /customVID/thumbs/ directory to full read/write/execute 777 permissions.
Reply With Quote
  #2193  
Old 30 Jul 2011, 20:47
TrIp0d TrIp0d is offline
 
Join Date: Jan 2011
Please can you upload the new template files?
Thank you
Reply With Quote
  #2194  
Old 30 Jul 2011, 23:03
orangefive orangefive is offline
 
Join Date: Nov 2009
Awesome - had some initial problems but the 4.1.4 fix in post 140ish has it working sweet as!!!! www.thewoollybacks.co.uk
Reply With Quote
  #2195  
Old 31 Jul 2011, 09:23
tele955848 tele955848 is offline
 
Join Date: Nov 2008
Fehler:
The requested URL /forum/media/m1-1sta-clanvideo was not found on this server.
Was habe ich falsch gemacht?
Reply With Quote
  #2196  
Old 05 Aug 2011, 06:47
rockerzteam rockerzteam is offline
 
Join Date: Sep 2009
Wheres this mod for 3.8.x
Reply With Quote
  #2197  
Old 06 Aug 2011, 23:04
MotMann MotMann is offline
 
Join Date: Jan 2006
Originally Posted by orangefive View Post
Awesome - had some initial problems but the 4.1.4 fix in post 140ish has it working sweet as!!!! www.thewoollybacks.co.uk

Where is the fix?

And did you try SEO URL? Then you have some problems.. maybe.
Reply With Quote
  #2198  
Old 10 Aug 2011, 21:01
tele955848 tele955848 is offline
 
Join Date: Nov 2008
Originally Posted by tele955848 View Post
Fehler:
The requested URL /forum/media/m1-1sta-clanvideo was not found on this server.
Was habe ich falsch gemacht?

Kein Support
Reply With Quote
  #2199  
Old 11 Aug 2011, 03:29
burntire burntire is offline
 
Join Date: Jun 2006
Not working on 4.1.5. Getting the description must be 4 characters error message when trying to submit media.
Reply With Quote
  #2200  
Old 12 Aug 2011, 15:52
nando99 nando99 is offline
 
Join Date: Dec 2005
Real name: Fernando
Ok... so I know this mod is half past dead with it's lack of support but i was wondering if anyone's encountered this problem:

I'm on 4.1.3 and it installed fine. the thing is, its not popping up on the nav bar, i thought it was because i'm using the Tabs Add System for vBulletin 4 (sstab advanced) but i disabled it and the Media link still doesnt show up.

I dont really mind that, bc i can add it manually BUT when i go to the media page, i dont get the media menu links to administrate etc...

Anyone run into this?
__________________
Part Time Gamerz - It's not that serious...
Reply With Quote
  #2201  
Old 13 Aug 2011, 09:32
Doc2911 Doc2911 is offline
 
Join Date: Dec 2009
it work´s with 4.1.5.
only the name of the thread dosn't work, but y can change it manual!
__________________
vb4.2.0PL2
there where i living
Reply With Quote
  #2202  
Old 13 Aug 2011, 15:23
Jeromedia603 Jeromedia603 is offline
 
Join Date: May 2008
None of my links on the actual media page work. They all direct you to a page that does not exist... has anyone else encountered this problem?
Reply With Quote
  #2203  
Old 13 Aug 2011, 17:12
ARSamo ARSamo is offline
 
Join Date: Aug 2009
Originally Posted by rammieone View Post
did you remember the fix ?

There is a conflict with this modification and some of Valter's VSA modifications that will prevent navbar permissions from being handled correctly. I don't know exactly who's fault it is; but I'm pretty sure there are no errors in my code that would be causing this problem. There is a work around for this however.

Admin Control Panel > Plugins & Products > Plugin Manager > "media NAVTAB"

Find the code:
Code:
$perms = media_permissions();
Replace with:
Code:
$perms['rate'] = true;
$perms['comment'] = true;
$perms['submit'] = true;
$perms['playlist'] = true;

if (is_member_of($vbulletin->userinfo, explode(',','5,6')))
{
$perms['modtags'] = true;
$perms['modcategory'] = true;
$perms['modservice'] = true;
}
Thank you Sir, i've fixed it
__________________
Reply With Quote
  #2204  
Old 14 Aug 2011, 01:28
NoSGR NoSGR is offline
 
Join Date: Mar 2010
I have a problem.

When i click on "Retrieve Info" it retrieves all info of the video (YouTube) but not the Description.

Even if i write the description myself, it doesn't save it and gives error message that there is not Description given.

Can anybody help with this?
Reply With Quote
  #2205  
Old 14 Aug 2011, 11:00
ARSamo ARSamo is offline
 
Join Date: Aug 2009
Originally Posted by weetabx View Post
you using vsachat ? if so

There is a conflict with this modification and some of Valter's VSA modifications that will prevent navbar permissions from being handled correctly. I don't know exactly who's fault it is; but I'm pretty sure there are no errors in my code that would be causing this problem. There is a work around for this however.

Admin Control Panel > Plugins & Products > Plugin Manager > "media NAVTAB"

Find the code:
Code:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

REPLACE with:
Code:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
some mod group having still problem to administrate section (for tag, cat and services)..... how can i fix it plz
__________________
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:38.

Layout Options | Width: Wide Color: