Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Import External Images Details »
Import External Images
Mod Version: 1.0.5, by y2ksw (Coder) y2ksw is offline
Developer Last Online: Oct 2019 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (38 votes - 4.68 average) Installs: 303
Released: 07 Nov 2010 Last Update: 14 Feb 2011 Downloads: 1874
Supported DB Changes Uses Plugins Additional Files Translations  

This vBulletin 4 product imports external images in your posts from external servers or paths into a specific path, normally your forum's image folder.

Differently than the previous product Image Cache for vBulletin 3.x., it parses the posts at regular intervals for new images and replaces the external references in the background. Also, instead of using only a single folder, it creates folders for years and months, making it much easier to handle large quantities of images. The source and destination image URL's are stored into database, too, avoiding unnecessary duplicates.

It moves and optionally converts images from one place to another. It is a handy tool in order to keep your images local to your forums.

Version 1.0.4 is temporarily in BETA stage until the users have confirmed the newly requested features.
Version 1.0.5 is still in BETA stage. It adds a new bunch of additional features, one of which allows you to test your mathematical understanding ... and a few other to fine-tune CURL and socket timeouts, and resizing on the fly of too large images. If you don't know what these options do, please leave them at their default values.

Download Now

Only licensed members can download files, Click Here for more information.

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	08-11-2010-11.32.53.jpg
Views:	3960
Size:	112.4 KB
ID:	123480   Click image for larger version

Name:	02-02-2011-22.06.39.jpg
Views:	2746
Size:	126.0 KB
ID:	126356  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #706  
Old 11 Feb 2017, 16:51
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
Originally Posted by y2ksw View Post
No, but they have changed the server settings in order to reduce the server load. Eventually you can get it back working by reducing the number of imported images for every run.
I only had it set to 1...

Anyway we can get this to import Tapatalk images?
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.

Reply With Quote
  #707  
Old 12 Feb 2017, 04:45
KevinL KevinL is offline
 
Join Date: Apr 2005
Figured it out. Great mod.

Thanks!

Last edited by KevinL; 12 Feb 2017 at 05:33.
Reply With Quote
  #708  
Old 13 Feb 2017, 21:40
KevinL KevinL is offline
 
Join Date: Apr 2005
Question, I am having an issue where a few images are being replaced with different images from the source image. Source images and replacement images are all different in different posts/threads.

Any insight on this issue? Let me know what you need from me.

Thanks
Reply With Quote
  #709  
Old 13 Feb 2017, 22:33
y2ksw's Avatar
y2ksw y2ksw is offline
 
Join Date: Aug 2003
Real name: Giovanni
Originally Posted by RichieBoy67 View Post
I only had it set to 1...

Anyway we can get this to import Tapatalk images?
In theory yes, however I'm unsure about the technical problems.
__________________
Giovanni
Italian support: http://www.vbulletin.it/
Reply With Quote
  #710  
Old 13 Feb 2017, 22:35
y2ksw's Avatar
y2ksw y2ksw is offline
 
Join Date: Aug 2003
Real name: Giovanni
Originally Posted by KevinL View Post
Question, I am having an issue where a few images are being replaced with different images from the source image. Source images and replacement images are all different in different posts/threads.

Any insight on this issue? Let me know what you need from me.

Thanks
No idea. Unless the server is feeding random images ...
__________________
Giovanni
Italian support: http://www.vbulletin.it/
Reply With Quote
  #711  
Old 13 Feb 2017, 22:53
Kane@airrifle's Avatar
Kane@airrifle Kane@airrifle is offline
 
Join Date: Jun 2011
Real name: Kane
Originally Posted by RichieBoy67 View Post
I only had it set to 1...

Anyway we can get this to import Tapatalk images?
Originally Posted by y2ksw View Post
In theory yes, however I'm unsure about the technical problems.
Works just fine on my site.
Reply With Quote
  #712  
Old 15 Feb 2017, 17:05
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
Originally Posted by Kane@airrifle View Post
Works just fine on my site.
How did you accomplish it?
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.

Reply With Quote
  #713  
Old 15 Feb 2017, 20:40
Kane@airrifle's Avatar
Kane@airrifle Kane@airrifle is offline
 
Join Date: Jun 2011
Real name: Kane
Originally Posted by RichieBoy67 View Post
How did you accomplish it?
Not sure what you mean? Any external image url that sits between [img] tags in the post table is imported as is intended by this mod. Certainly is the case on my board unless I missing some other Tapatalk function..
Reply With Quote
  #714  
Old 17 Feb 2017, 04:09
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Version 1.0.4 is temporarily in BETA stage until the users have confirmed the newly requested features.

Version 1.0.5 is still in BETA stage. It adds a new bunch of additional features, one of which allows you to test your mathematical understanding ... and a few other to fine-tune CURL and socket timeouts, and resizing on the fly of too large images. If you don't know what these options do, please leave them at their default values.
Are these two versions still in beta?
Reply With Quote
  #715  
Old 20 Feb 2017, 00:44
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
I decided to install version 1.05 which seems to be working generally quite well except for the following error:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

What's interesting is that so far at least it is always the same image (see above) but different threads and your add-on is in fact correctly inserting clear.gif in those threads.

I'm on a tweaked dedicated server so I don't think the "MySQL server has gone away" is the usual problem of too many connections (persistent connections is off)... not sure what to make of this.

Any suggestions?

Is it a bad idea to be running version 1.05? (I didn't get a response to my previous question above.)
Reply With Quote
  #716  
Old 20 Feb 2017, 16:52
BadgerDog BadgerDog is offline
 
Join Date: Oct 2006
Real name: Doug
I'll add my 2 cents....

I've been using y2ksw's mod for years and it's been working flawlessly on our v4.1.3 pl8 ...

I check every morning by manually running his "vB4 Import External Images" cron job, just to see if it's hanging on any image imports, which way back in early versions used to be the result of it trying to import some HUGE freakin image a member had linked to in a post.

I haven't had it hang up for years, but I still check it as an old habit....

I'm running v1.06, but it's been so long, I can't remember why. That's what happens when you get to be almost 70.

I know I had PayPal donated to y2ksw for his excellent work and I also think I did more PayPal's a few times more as he privately helped me with some issues. I may have ended up with v1.06 as a result. For some reason, I think along the way working with him, he did something to ensure that it didn't crash when some clown member tries to link to a picture off-site that's too large for the code to handle. I think he also had me change some PHP values, but again, it's been so long since I've had to touch anything.

v1.06 is what my AdminCP currently shows me running and it's been reliable and probably one of the best vBulletin add-ons we use.

It's amazing to see images from members that go back years and years, which have long since been deleted from their original off-site linked to storage, still be showing in their posts. Being a research site, it has been extremely helpful in keeping old threads with pictures still relevant after several years, instead of getting that dreaded "Photo Missing" error.

Thanks again for your excellent add-on y2ksw ...

Hope that helps someone else here ...

Regards,
Doug
Reply With Quote
  #717  
Old 20 Feb 2017, 17:03
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
I would be glad to donate towards an updated version that addresses the issues I mentioned in my above post.
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.

Reply With Quote
  #718  
Old 21 Feb 2017, 17:30
Sonik_elf's Avatar
Sonik_elf Sonik_elf is offline
 
Join Date: Aug 2015
Hello.
Sorry.. I installed it .. And? How to start the scanning process and import images?
__________________
iddqd, idkfa
Reply With Quote
  #719  
Old 21 Feb 2017, 18:23
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
1. Go to AdminCP >> Options >> Settings >>vB4 Import External Images and input your settings and enable the addon

2. Go to AdminCP >> Scheduled Tasks >> Scheduled Task Manager >> vB4 Import External Images

3. Edit your settings there and then enable the cron job /scheduled task.
Reply With Quote
  #720  
Old 21 Feb 2017, 23:19
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
It's now occurring with other images:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Missing images seem to create a problem?
Reply With Quote
Reply

Tags
lisansdevir


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 08:29.

Layout Options | Width: Wide Color: