Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Advanced Application Forms Details »
Advanced Application Forms
Mod Version: 1.4.7, by nhawk (Member) nhawk is offline
Developer Last Online: Dec 2019 I like it Show Printable Version Email this Page

This thread is in the Modification Graveyard.
vB Version: 4.1.1 Rating: (53 votes - 4.89 average) Installs: 408
Released: 20 May 2011 Last Update: 07 Sep 2015 Downloads: 2882
Not Supported Translations  

THIS ADD-ON IS NO LONGER AVAILABLE AND IS NOT SUPPORTED

* General Information *
------------------------------
This is an add-on that is designed for vBulletin 4.1.1 or later. It may not work on earlier versions of vBulletin.


Nominated twice for MOTM (October 2011, January 2012)


Features
  • Unlimited Application Types*
  • Unlimited Application Positions*
  • Unlimited Questions*
  • Different Application Positions for each Application Type
  • Different Questions for each Application Position.
  • Allow others to add/edit Application Types by permissions.
  • Allow others to edit Positions/Questions by permissions.
  • Edit Application Types, Positions and Questions in either ACP or from board.
  • Show Multiple Application Types in Community Menu or direct link to them.
  • Control Application Type access by Usergroup, Postcount
  • Control Application Position access by Usergroup, Postcount
  • Notification of an application via Forum Thread and/or Email and/or Private Message
  • Specify Different Forums for Reports by Application Position.
  • Define a default question set that can be included on all applications.
  • Much, much more!

* Limited only if you are limited in database size and/or free disk space.


* INSTALLATION *
-------------------
1) Upload the contents of the 'upload' folder to your forum's root.
(If your forum's location is http://www.example.com/forums/, the root is /forums/)

2) Depending on your server configuration, you will need to change the permissions of the advappfiles folder to either 775 or 777

3) Import the product XML file (product-advapp.xml) into the Product Manager in AdminCP.

4) Take some time to set the options, application types and application postions in the new Application Forms area of AdminCP.
(It's really not that hard!)

5) Make sure this modification is marked as 'Installed' on vBulletin.org!
(If you want to get notices from me about updates for this modification.)

* UPGRADE INSTRUCTIONS *
-----------------------------
1) Upload the contents of the 'upload' folder to your forum's root.
(If your forum's location is http://www.example.com/forums/, the root is /forums/)

2) Import the product XML file (product-advapp.xml) into the Product Manager in AdminCP and be sure "Allow Overwrite" is set to 'Yes'.

3) vB 4.2.x ONLY - Go to ACP->Settings->Options->Application Form Settings and set 'vB 4.2 Community Menu Update' to 'Yes'.

UPGRADING TO VERSION 1.3.8 or HiGHER
Depending on your server configuration, you will need to change the permissions of the advappfiles folder to either 775 or 777

If you have edited the advapp_application template, you need to revert the template before upgrading to 1.3.8 or higher.
Once the upgrade is complete, you can re-apply your changes to that template.


* History (Changelog) *
-------------------------
1.4.7 (September 7, 2015)
- Fix Certain characters not being stored/displayed properly.

1.4.6 (January 2, 2014)
- Fix Certain non-english characters not being stored/displayed properly.

1.4.5 (October 11, 2013) (not released vB.org)
- Fix No thread status showing in new threads when Thread Status Pro version 1.0.3 is installed.

1.4.4 (August 5, 2013)
- Fix Change single MySQL call to vB database call for systems that don't play well with direct MySQL calls.

1.4.3 (July 15, 2013)
- Fix Extra tabs in first response line in email notificactions.

1.4.2 (June 18, 2013)
- Fix Applications still able to be submitted after member logs out when unusual usergroup settings are used.

1.4.1 (June 8, 2013)
- Fix regex error missing from query.

1.4.0 (June 4, 2013) (not released on vB.org)
- Fix community menu not updating properly with vB 4.2.1

1.3.9 (May 2, 2013)
- Fix thread starter not showing when new thread is created and using actual userid to post new thread.

1.3.8 (May 2, 2013) (not released on vB.org)
- Add file upload option to application questions.(Available from ACP ONLY)

1.3.7 (May 1, 2013)
- Add error field in question editor for validation failure.

1.3.6 (May 1, 2013) (not released on vB.org)
- Fix moderated threads not showing as moderated in ACP.
- Change regex validated fields are now optional if no error message is defined for the field.
- Change streamline code for displaying applications forms.

1.3.5 (April 29, 2013)
- Change question save routine to prevent misnumbering of question order.
- Add single line text answers now allow regular expression matching.(Editing regex available from ACP ONLY)
- Add flood check for new threads
- Add flood check for new posts.

1.3.4 (April 22, 2013) (not released on vB.org)
- Fix header/title phrase input on application type screen not showing properly on forum application screens.
- Fix several typographical errors in phrases.

1.3.3 (March 2, 2013)
- Fix database error if Thread Status Pro is not installed.
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.3.2 JUST UPLOAD FILES TO YOUR SERVER)

1.3.2 (February 28, 2013) (not released on vB.org)
- Add support for default forum thread status from Thread Status PRO
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.3.1 JUST UPLOAD FILES TO YOUR SERVER)

1.3.1 (November 20, 2012)
- Fix database error when saving application type with some punctuated admin usernames.
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.3.0 JUST UPLOAD FILES TO YOUR SERVER)

1.3.0 (November 19, 2012) (never released on vB.org)
- Fix item selection problems with Firefox browser
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.2.9 JUST UPLOAD FILES TO YOUR SERVER)

1.2.9 (July 30, 2012)
- Fix error when editing application types in board (was not happening in ACP edit)
(NO NEED TO IMPORT XML IF YOU WERE RUNNING v1.2.8 JUST UPLOAD application-types.php to your server)

1.2.8 (May 23, 2012)
- Improved work around for vB 4.2 bug pertaining to navigation menu items (JIRA VBIV-14959).

1.2.7 (May 21, 2012)
- Work around for vB 4.2 bug pertaining to navigation menu items (JIRA VBIV-14959).

1.2.6 (May 20, 2012) (never released on vB.org)
- Made system compatible with vB 4.2.0

1.2.5 (February 27, 2012)
- Fix IP address not being displayed when answer color option is used.
- Fix overlap of nav tab with nav menu.

1.2.4 (January 17, 2012)
- Fix URL not being parsed when answer color is defined and URL is the only thing in the answer.

1.2.3 (January 11, 2012)
- Add replacement variables to PM after submitting application.
- Add answer color option to main settings.
- Add multiple choice answers in column format option to main settings.
- Add 'All of the above' Multiple Choice question type.

1.2.2 (December 16, 2011) (NO NEED TO IMPORT XML WHEN UPGRADING FROM 1.2.1, JUST UPLOAD FILES TO SERVER)
- Fix UTF-8 character display for expected answers.
- Fix sorting problem with first application questions.

1.2.1 (December 15, 2011) (not uploaded on vBulletin.org)
- Add option to PM a member after submitting an application.
- Add numeric ordering to edit position questions in ACP ONLY. (NOTE: Numbering MUST stay as 1,2,3.. NEVER use 10, 20, 30...)

1.2.0 (December 7, 2011)
- Fix database error when single quote is used in expected responses. (NO NEED TO IMPORT XML WHEN UPGRADING FROM 1.1.9, JUST UPLOAD FILES TO SERVER)

1.1.9 (December 5, 2011) (Not uploaded on vBulletin.org)
- Fix quote character not being displayed properly in posts. (NO NEED TO IMPORT XML WHEN UPGRADING FROM 1.1.8, JUST UPLOAD FILES TO SERVER)

1.1.8 (December 2, 2011)
- Fix 'not enough posts' now displays when it should. (NO NEED TO IMPORT XML WHEN UPGRADING FROM 1.1.7, JUST UPLOAD FILES TO SERVER)

1.1.7 (November 5, 2011)
- Added single selection dropdown box for questions.

1.1.6 (October 13, 2011) (Not uploaded on vBulletin.org)
- Code enhancements for future expansion.

1.1.5 (September 4, 2011)
- Repair forum based application group type editor. (NO NEED TO IMPORT XML WHEN UPDATING FROM 1.1.4 to 1.1.5, JUST UPLOAD FILES TO SERVER - NO NEED TO UPDATE IF YOU DON'T USE THE FORUM BASED EDITOR)

1.1.4 (August 27, 2011)
- Change hard coded Yes/No answers to standard vBulletin Yes/No phrases (thanks to Ellendway for testing).

1.1.3 (August 15, 2011)
- Corrected post format problems.
- Changed human verify portion of template.
- Changed hard coded Yes/No questions to standard vBulletin Yes/No Phrases.

1.1.2 (July 30, 2011)
- Code enhancements to allow for future expansion.

1.1.1 (July 6, 2011)
- Fix human verification. (problem found while converting mod to vB 3.8.7)

1.1.0 (June 29, 2011)
- Installation script change to correct installation problem where plugin was not importing completely for some people.

1.0.9 (June 21, 2011)
- Removed odd credit line for skin.

1.0.8 (June 14, 2011)
- Changed URL parse option so URLs are now parsed in all text fields.
- Changed 'Use First Text Answer As Subject' to subject replacement variable.
- Added option to remove member name from first line of reports.
- Added option to post application reports in an existing thread.
- Moved 'Start Application' button label to advapp vBulletin Phrase.
- Moved 'I am applying for the postion of' text from template to advapp vBulletin Phrase.
- Changed template so 'Member Name' now uses advapp vBulletin Phrase.
- Changed CSS so 'Start Application' button is centered on page.
- Removed remnant heading phrase from application form template.

1.0.7 (June 8, 2011)
- Fix minor bug where multi-line text was being cut into smaller sections.
- Added option to parse URLs. (it is in the position editor)

1.0.6 (June 6, 2011)
- Added option to use first single line text answer as report subject.
- Added option to require approval of the thread created when a member submits an application.
- Added options to redirect member to different locations after submitting an application.

1.0.5 (June 4, 2011)
- Fix default questions were carrying over their display positions causing answers to record improperly.
- Added option to show applications in navbar tabs.

1.0.4 (June 1, 2011)
- Database table creation change to make it compatible with MySQL 5.5.8
(NO NEED TO UPDATE IF YOU ARE ALREADY RUNNING VERSION 1.0.3)

1.0.3 (May 23, 2011)
- Added note about default email/pm user ids to position editors.
- Added Delete All Questions to ACP question editor.
- Added the ability to use a Thread Prefix for report threads.

1.0.2 (May 20, 2011)
- Fix rewind error.

1.0.1 (May 20, 2011)
- Changed database creation method for those that might be having problems.

1.0.0 (May 20, 2011)
- Initial Release

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
New Posting Features Easy Forms v4.x - Create a form or multiple forms without php or html knowledge bananalive vBulletin 4.x Add-ons 2069 23 Sep 2019 03:17
New Posting Features Easy Forms - Create a form or multiple forms without php or html knowledge bananalive vBulletin 3.8 Add-ons 1671 20 Dec 2018 01:02
Add-On Releases Forms Pack *** Forms Hack add-on Deepdog009 vBulletin 3.6 Template Modifications 2 27 Jul 2007 01:52
Forms Pack + (4) *** Forms Hack add-on Deepdog009 vBulletin 3.5 Template Modifications 1 09 May 2007 00:12

  #286  
Old 24 Feb 2012, 14:53
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by deverill2010 View Post
I don't see the 'promote to article' on the application form, i dont want the results IN the CMS.

I want to display the actual form within a article/static page ON the CMS.

See image - I really need this
Promote to article would be in the post when a new thread is created by AAF. It's not an option in the mod itself.
Reply With Quote
  #287  
Old 24 Feb 2012, 14:59
deverill2010 deverill2010 is offline
 
Join Date: Jan 2011
Yeah but that's not going to promote the actual form into a article for users to fill out is it, but instead promote the results of a submitted form.

I want the actual form which users fill out and submit their applications in the cms, I've tried using a inline frame with the direct form URL but like the other mod it shows the whole website with the form and not just the pplication form it's self.
Reply With Quote
  #288  
Old 24 Feb 2012, 15:03
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by deverill2010 View Post
Yeah but that's not going to promote the actual form into a article for users to fill out is it, but instead promote the results of a submitted form.

I want the actual form which users fill out and submit their applications in the cms, I've tried using a inline frame with the direct form URL but like the other mod it shows the whole website with the form and not just the pplication form it's self.
I see, I thought you wanted the results in the CMS.

In that case, no.. there's no way that I know of to do this.
Reply With Quote
  #289  
Old 24 Feb 2012, 15:04
deverill2010 deverill2010 is offline
 
Join Date: Jan 2011
Meh thanks anyway.
Reply With Quote
  #290  
Old 25 Feb 2012, 21:58
Alan_SP's Avatar
Alan_SP Alan_SP is offline
 
Join Date: Nov 2009
Originally Posted by deverill2010 View Post
I want the actual form which users fill out and submit their applications in the cms, I've tried using a inline frame with the direct form URL but like the other mod it shows the whole website with the form and not just the pplication form it's self.
To do this, you need to edit template: advapp_application

You need to remove from it:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

After that you'll have much better looking iframe page of your applications inside CMS.

But mind you that you'll loose all navigation elements. Use this only if you want people to fill applications only inside CMS iframe.
Reply With Quote
  #291  
Old 26 Feb 2012, 13:43
killerford's Avatar
killerford killerford is offline
 
Join Date: Jan 2012
Real name: Josh
This is a really good mod but when applications are posted there is no title what so ever, how can i change that? can i change it so who ever posted the application is on the title?
Reply With Quote
  #292  
Old 26 Feb 2012, 13:59
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by killerford View Post
This is a really good mod but when applications are posted there is no title what so ever, how can i change that? can i change it so who ever posted the application is on the title?
Edit the application position and fill out the "Report Subject" field.

Use {1} to include the member name in the subject.
Reply With Quote
  #293  
Old 26 Feb 2012, 14:54
deverill2010 deverill2010 is offline
 
Join Date: Jan 2011
Originally Posted by Alan_SP View Post
To do this, you need to edit template: advapp_application

You need to remove from it:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

After that you'll have much better looking iframe page of your applications inside CMS.

But mind you that you'll loose all navigation elements. Use this only if you want people to fill applications only inside CMS iframe.
Hi Alan I have removed them from the template but it still shows my site.

http://www.midwiferyonline.co.uk/app...ms.php?appid=1 Thats the direct URL to the example form with this mod, but it still shows the whole website within the iframe.

Thanks, Jade
Reply With Quote
  #294  
Old 27 Feb 2012, 17:18
Terminal-Access Terminal-Access is offline
 
Join Date: Sep 2006
Real name: Lee Wickham
I have just installed this wonderfull mod on to my board and have been testing it out and its working lovely apart from one little thing.

when an applicant submits one of our applications and we have set the option to display that applicants ip addres its not showing up at all on the filled in application

VB version 4.1.10 (CMS + forums + blog)
we have set the application to be placed in to a hidden forum that only staff can see.

any ideas guys ?

Update:

ok one other thing and im sure this will be a very simple fix, but their appears to be a css bug with IE, were the contence of the application form drop down menu overlaps the quick links bar. (see attatched screen shot)




This dose not happen on Firefox or Chrome
Attached Images
File Type: png Advanced Application form - bug IE.png (12.0 KB, 84 views)

Last edited by Terminal-Access; 27 Feb 2012 at 17:48.
Reply With Quote
  #295  
Old 27 Feb 2012, 20:16
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by Terminal-Access View Post
I have just installed this wonderfull mod on to my board and have been testing it out and its working lovely apart from one little thing.

when an applicant submits one of our applications and we have set the option to display that applicants ip addres its not showing up at all on the filled in application

VB version 4.1.10 (CMS + forums + blog)
we have set the application to be placed in to a hidden forum that only staff can see.

any ideas guys ?

Update:

ok one other thing and im sure this will be a very simple fix, but their appears to be a css bug with IE, were the contence of the application form drop down menu overlaps the quick links bar. (see attatched screen shot)




This dose not happen on Firefox or Chrome
Thank you!

Fix is uploaded.

Download and install version 1.2.5.

Last edited by nhawk; 27 Feb 2012 at 20:30.
Reply With Quote
  #296  
Old 29 Feb 2012, 15:57
Alan_SP's Avatar
Alan_SP Alan_SP is offline
 
Join Date: Nov 2009
Originally Posted by deverill2010 View Post
Hi Alan I have removed them from the template but it still shows my site.

http://www.midwiferyonline.co.uk/app...ms.php?appid=1 Thats the direct URL to the example form with this mod, but it still shows the whole website within the iframe.
Ok, there are more templates that contain header, navbar and footer.

They are:

advapp_edit
advapp_select

You could add test code in every template to find out which template is which, so you could know where you need to remove navigation elements.

Test code could be simple:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Put it just below <body> HTML code. This will tell you which template you're looking at, hence where you need to remove navigation elements which interfere with iframe.

And just to inform you, right now on your site I see Internal server error.
Reply With Quote
  #297  
Old 01 Mar 2012, 20:06
Terminal-Access Terminal-Access is offline
 
Join Date: Sep 2006
Real name: Lee Wickham
nhawk awesome work on the fix, and i like to confirm that its resolved the two issued i had posted

Additionally and i appologise if this has been asked alredy and i have missed it.
is there a way that when the mod is activated we can hide the whole nav button (and/or the Community Menu item) for the application forms, from the users groups that are not permitted to submit applications rather than just hiding the acctual application's

If im not making any sence let me know and ill try and re-word what im after.

and thanx again !!
Reply With Quote
  #298  
Old 01 Mar 2012, 20:20
nhawk nhawk is offline
 
Join Date: Jan 2011
Originally Posted by Terminal-Access View Post
nhawk awesome work on the fix, and i like to confirm that its resolved the two issued i had posted

Additionally and i appologise if this has been asked alredy and i have missed it.
is there a way that when the mod is activated we can hide the whole nav button (and/or the Community Menu item) for the application forms, from the users groups that are not permitted to submit applications rather than just hiding the acctual application's

If im not making any sence let me know and ill try and re-word what im after.

and thanx again !!
The answer could be both yes and no.

The Yes part... If the usergroup is not allowed to submit any applications at all, put them in the banned usergroups in the main settings page. That hides the tab and community menu from them. The perfect example of this is on my site. I have premium mods and there is a bug report form for each of them. Unless you are a premium mod owner, you don't see the tab on my site.

The No part... If the usergroup can submit even one application type there is no way to hide the tab or community menu from them. They need to see it to submit an app.
Reply With Quote
  #299  
Old 01 Mar 2012, 21:33
1320Nation 1320Nation is offline
 
Join Date: Sep 2008
Thumbs up

This is a very good and useful mod. I gave the 5 star and nominated it for Mod Of The Month.

This mod is very easy to install and very easy to setup in every way. Thanks for the hard work and dedication on this!
Reply With Quote
  #300  
Old 02 Mar 2012, 03:58
Terminal-Access Terminal-Access is offline
 
Join Date: Sep 2006
Real name: Lee Wickham
Originally Posted by nhawk View Post
The answer could be both yes and no.

The Yes part... If the usergroup is not allowed to submit any applications at all, put them in the banned usergroups in the main settings page. That hides the tab and community menu from them. The perfect example of this is on my site. I have premium mods and there is a bug report form for each of them. Unless you are a premium mod owner, you don't see the tab on my site.

The No part... If the usergroup can submit even one application type there is no way to hide the tab or community menu from them. They need to see it to submit an app.

Under stood the No part thats really kind of self explanitory, only thing im a little confused on is were your talking about the "Banned Usergroups" in the main settings page.

so im in Application Form Settings
and have added the following groups to
"Usergroup Settings: Enter the usergroup IDs that you do not want to be able to submit new applications."

"1,2,3,4,5,7,8,11,10,12"

Note: some of those usergroup above are customs we have on our forum.

By default None of thease have Permissions to submit or fill in any applications we acctually only have the default one that comes with the mod as were still testing it out.

however when i view my board as an unregisterd user "usergroup 1" or as a registerd user "usergroup 2" i still see the navbar menu item "Application Forms" when i click on it there are no applications.

Update: ok i have noticed that when enabled the community menu works as desribed i.e when usergroups are addedd to the banned usergroups list, those of that usergroup will not be able to see the application, but it appears at least on my forum that the navbar menu item dose seem to want to play ball, the only time i wont display for any usegroup is when the mod is disabled.

Unless there is another section of settings im missing.

Last edited by Terminal-Access; 02 Mar 2012 at 04:33.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 06:52.

Layout Options | Width: Wide Color: