Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Show Link To Thread in WOL (users viewing inline attachments) Details »
Show Link To Thread in WOL (users viewing inline attachments)
Mod Version: 1.2, by MarkFL (Coder) MarkFL is offline
Developer Last Online: Nov 2019 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (3 votes - 5.00 average) Installs: 20
Released: 22 Jul 2015 Last Update: 22 Jul 2015 Downloads: 53
Not Supported Uses Plugins Translations  

If you allow inline attachments on your forum, you may have noticed that users viewing threads with such attachments are reported in "Who's Online" as simply "Viewing Attachment."

This simple add-on will display a link to the thread which contains the attachment:



Update: version 1.1
  • Bug whereby no valid postid could be found is fixed.

Update: version 1.2
  • User action now shows "Viewing Thread" instead of "Viewing Attachment."

To Install:

Download and extract the attached .zip file.

In AdminCP go to Plugins & Products -> Manage Products -> Add/Import Product.

Click on "Choose File" and browse to the product xml file that was packaged in the .zip file.

Click "Import"

There are no settings to configure, once you import it, the add-on is active.

Support for this product can be found here:

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	attachthread.png
Views:	368
Size:	27.1 KB
ID:	152968  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Comments
  #2  
Old 22 Jul 2015, 15:53
Stratis's Avatar
Stratis Stratis is offline
 
Join Date: Jan 2010
Real name: Stratis
Great, installed.
Works fine in vb4.2.0pl4 and its very useful.

Thank you Mark

EDIT:
I get errors, not all time.

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Some times in refresh, i had 10 errors so far.

Last edited by Stratis; 22 Jul 2015 at 17:02.
Reply With Quote
  #3  
Old 22 Jul 2015, 18:40
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Update: version 1.1
  • Bug whereby no valid postid could be found is fixed.

Stratis, please let me know if the update resolves the MySQL error.
Reply With Quote
  #4  
Old 22 Jul 2015, 20:15
Stratis's Avatar
Stratis Stratis is offline
 
Join Date: Jan 2010
Real name: Stratis
Ok, I am testing, but what about thread id, this error came before your update.
SELECT thread.*
FROM thread AS thread
WHERE threadid =;

I don't know if it fixes this to?
Reply With Quote
  #5  
Old 22 Jul 2015, 20:20
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
It should, unless you have posts without threadids.
Reply With Quote
  #6  
Old 22 Jul 2015, 21:23
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Update: version 1.2
  • User action now shows "Viewing Thread" instead of "Viewing Attachment."
Reply With Quote
  #7  
Old 23 Jul 2015, 08:49
Stratis's Avatar
Stratis Stratis is offline
 
Join Date: Jan 2010
Real name: Stratis
First no problem with errors yet after the update to v1.1

Installed to v1.2 I will see what about "Viewing Attachment.", and test it several times.

EDIT: v1.2 tested, all works fine so far.
Thank you for goodies

Last edited by Stratis; 23 Jul 2015 at 10:50.
Reply With Quote
  #8  
Old 23 Jul 2015, 08:57
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by Stratis View Post
First no problem with errors yet after the update to v1.1

Installed to v1.2 I will see what about "Viewing Attachment.", and test it several times.
Thanks for the feedback...it is greatly appreciated.
Reply With Quote
  #9  
Old 12 Sep 2015, 16:29
hazem_aliraqi's Avatar
hazem_aliraqi hazem_aliraqi is offline
 
Join Date: Oct 2010
Real name: Hazim M
excellent its work fine
Reply With Quote
  #10  
Old 12 Nov 2015, 15:57
Stratis's Avatar
Stratis Stratis is offline
 
Join Date: Jan 2010
Real name: Stratis
Mark i have noticed today when i hover the link that some member is "viewing inline image attachment"

its shows code if exists,

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Its not a big deal, but i thought you better know.
Reply With Quote
  #11  
Old 12 Nov 2015, 18:49
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by Stratis View Post
Mark i have noticed today when i hover the link that some member is "viewing inline image attachment"

its shows code if exists,

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Its not a big deal, but i thought you better know.
Can you provide a screenshot?
Reply With Quote
  #12  
Old 16 Nov 2015, 09:22
Stratis's Avatar
Stratis Stratis is offline
 
Join Date: Jan 2010
Real name: Stratis
Image12.jpg

That's what i mean, its not a big deal though
Reply With Quote
  #13  
Old 16 Nov 2015, 15:41
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by Stratis View Post
Attachment 153674

That's what i mean, its not a big deal though
It looks like it is behaving as it should.
Reply With Quote
  #14  
Old 23 Nov 2015, 16:25
Stratis's Avatar
Stratis Stratis is offline
 
Join Date: Jan 2010
Real name: Stratis
Originally Posted by MarkFL View Post
It looks like it is behaving as it should.
I don't think that should be right but its not a big deal.
Reply With Quote
  #15  
Old 23 Nov 2015, 19:57
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by Stratis View Post
I don't think that should be right but its not a big deal.
Without this add-on, that user would simply be shown in WOL as "Viewing Attachment," but instead they are shown as viewing the thread containing the attachment. That's what your screenshot shows and that's what this add-on does. I don't understand what you think should be going on instead.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 10:05.

Layout Options | Width: Wide Color: