Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 26 Apr 2010, 08:42
robdevereux robdevereux is offline
 
Join Date: Apr 2010
variables dont work in 3.8.5

We have been using vbulletin 3.7.2 for some time now on live forums and in order to bring the forums up to the latest software, I have been testing upgrading the forums offline to 3.8.5.

Everything seemed to work fine from the point of view of the templates, style sheets and general appearance but one thing that has become apparent is that where we were using variables in various phrases in the forum e.g. confirmation of registration, emails to acknowledge registration, they now just get displayed only in their variable form e.g. $username or $email and not as the actual substituted data that should appear ie the username for the particular registrant or their email address.

I can't find anywhere where the variables are listed or even where there might be a reference dictionary of what might work in the software. Is anyone aware of code changes that would have stopped these working 3.7.2 to 3.8.5 and does anyone have an idea of how to solve the issue?

Rob
Reply With Quote
  #2  
Old 26 Apr 2010, 14:50
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Usually you can't use variables in PMs or emails unless you used a modification to allow it.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #3  
Old 27 Apr 2010, 09:33
robdevereux robdevereux is offline
 
Join Date: Apr 2010
Originally Posted by Lynne View Post
Usually you can't use variables in PMs or emails unless you used a modification to allow it.
Hi Lynne

Well, upto version 3.7.2 it has worked absolutely fine. We have a live forum running version 3.7.2 and that works absolutely fine with the variables. It is only in upgrading this test system that the variables suddenly don't work and the information from the updated phrases suggested that it was changed in 3.8.1 but no suggestion as to what to change or how.

Rob

--------------- Added 27 Apr 2010 at 10:25 ---------------

Originally Posted by Lynne View Post
Usually you can't use variables in PMs or emails unless you used a modification to allow it.
Also, can you explain the modification process a little more. i am fairly new to vbulletin and there have been a series of people adapting the forums over the years, some of whom are no longer with the company, so tracing their changes isn't so simple.

Last edited by robdevereux; 27 Apr 2010 at 10:25. Reason: Auto-Merged DoublePost
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 13:21.

Layout Options | Width: Wide Color: