Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 28 Nov 2013, 15:07
thunderclap82 thunderclap82 is offline
 
Join Date: Dec 2008
Manually Update CKEditor?

I've dealt with a bug in vBulletin for almost two years, one other have experienced and one that is extremely annoying. The bug has been in the vB tracker for that entire time, has been voted on, yet vB has done nothing to fix it. They haven't even assigned it to anyone.

The bug seems to be CKEditor itself and affects webkit browsers such as Chrome and Safari. Basically, if you type something into the editor, then switch to bold, italics, etc. and then use backspace, the cursor jumps back a word or two before deleting text. I've talked to vB support about this and all they say is that they'll get to it if they feel it necessary, though after two years I'm guessing it won't be resolved.

So several questions: has anyone else experienced this and fixed it? If so, how? Is there anyway to manually update CKEditor manually without breaking vB? (I asked this of vB support and they said no as the CKEditor code used in vB is customized and just updating the editor will break vB.) I'm hoping some crafty programmer has found a way to do this.

I appreciate any insight someone might have in helping resolve this issue.
Reply With Quote
  #2  
Old 28 Nov 2013, 15:38
tbworld tbworld is offline
 
Join Date: Oct 2008
Just to confirm. When adding bold, italic, underline tags you immediately press back-arrow (as backspace would delete the words since the area is highlighted). It then traverses left till it finds a ']' bracket and then jumps to the right most bracket '[' on the second back-arrow. It only does this in 'edit' mode. On my system Firefox v25 did the same thing. Note: you do not actually see the brackets since it is in editor mode, but pretend they are there per this example.

Can you confirm this is what you are seeing?

Last edited by tbworld; 28 Nov 2013 at 15:43.
Reply With Quote
  #3  
Old 28 Nov 2013, 16:36
thunderclap82 thunderclap82 is offline
 
Join Date: Dec 2008
Originally Posted by tbworld View Post
Just to confirm. When adding bold, italic, underline tags you immediately press back-arrow (as backspace would delete the words since the area is highlighted). It then traverses left till it finds a ']' bracket and then jumps to the right most bracket '[' on the second back-arrow. It only does this in 'edit' mode. On my system Firefox v25 did the same thing. Note: you do not actually see the brackets since it is in editor mode, but pretend they are there per this example.

Can you confirm this is what you are seeing?
Not quite. I'm not talking the back arrow but backspace. Say you're typing in bold, italic or underline and make a mistake and need to delete it, the cursor jumps back. I'm linking to a video capture to highlight what I'm talking about.

Also, I'm running the latest version of vBulletin. I've also tried disabling all my plug-ins and using the default vBulletin style. Neither of these things resolve the problem. vB support seems to think it's a CKEditor bug.

Bug Example on YouTube
Reply With Quote
  #4  
Old 28 Nov 2013, 18:02
tbworld tbworld is offline
 
Join Date: Oct 2008
Thank you for the video, I see what you are saying and I will at least take a further look at it tonight to see what it is doing.
Reply With Quote
  #5  
Old 30 Nov 2013, 17:02
thunderclap82 thunderclap82 is offline
 
Join Date: Dec 2008
Any luck?
Reply With Quote
  #6  
Old 30 Nov 2013, 17:45
tbworld tbworld is offline
 
Join Date: Oct 2008
Originally Posted by thunderclap82 View Post
Any luck?
I will take a look at this, but have not had the time as of yet. A few other requests I have to get done before this one. I will get back to you.
Reply With Quote
  #7  
Old 30 Nov 2013, 20:00
thunderclap82 thunderclap82 is offline
 
Join Date: Dec 2008
Originally Posted by tbworld View Post
I will take a look at this, but have not had the time as of yet. A few other requests I have to get done before this one. I will get back to you.
Sounds good. I just wanted to make sure you hadn't forgotten to to respond letting me know you hadn't had any luck. No pressure, and I appreciate the help.
Reply With Quote
  #8  
Old 30 Nov 2013, 21:01
tbworld tbworld is offline
 
Join Date: Oct 2008
I try to take on jobs that help the most people on the site here. The real question here is weather the code has to be altered in the CKEditor or just the vbulletin plugin code. If it is just the vbulletin plugin code, I can probably come up with a patch. I am not sure I would have the time to sift through the CKEditor code. My first check will be at the CKEditor site to review their bug reports.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 14:23.

Layout Options | Width: Wide Color: