Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Goldbrick Audio/Video Media System Details »
Goldbrick Audio/Video Media System
Mod Version: 1.5, by nix (Member) nix is offline
Developer Last Online: Nov 2010 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.7.0 Beta 2 Rating: (46 votes - 4.59 average) Installs: 546
Released: 18 Dec 2007 Last Update: 08 Jan 2009 Downloads: 8168
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Is in Beta Stage  

Goldbrick Media system for vBulletin 3.7

Thanks to all who nominated or voted this for MOTM.

Some of you might be looking for Anymedia. Well this has replaced it. It's a total rewrite from the ground up. A huge thanks goes to Sir Adrian for creating the framework. He can't cook soup but he sure can code.

Why the name goldbrck?

From Wikipedia:
Goldbricking, in today's terms, generally refers to staff who use their work internet access for personal reasons while maintaining the appearance of working.
From Urban Dictionary:
Goldbricking: To loaf or goof around on the job. Supposedly an old union term describing laborers (or more specifically, bricklayers) who were going so slow, it was as if each brick were made of solid gold. One can alse be referred to as a "goldbricker".

Dude, I spent all day at work goldbricking - surfing the web, making long distance phone calls - basically just picking my ass.
Goldbrick uses the following third party Products:

What's new in Goldbrick?
  • Complete code overhaul.
  • Plays most media types.
  • Forum admins can add their own video sites
  • Updated Highslide.js
  • Attachment Images work with Goldbrick
  • Don't need to use BBCODE
  • Auto Phrases URL's
  • Media Options per post
  • Much more on the way!

Goldbrick's Requirements:
  • Vbulletin :P
  • PHP 5



Planned Features:

- Youtube like interface
- Video Comments
- Media Tags
- Media Searching

Install Instructions:
  1. Upload file contents in the upload folder.
  2. Import the Product.xml

Goldbrick Version 1.5:
- Fixed Vbadvanced integration
- Fixed extensions permissions checking
- Added pickup of old [media] tags
- More code changes for later features


Goldbrick Version 1.4:
- Fixed Apple trailers
- Added Added Viemo videos
- More code changes for later features


Goldbrick Version 1.3:
- Fixed Images
- Fixed MP3's
- Fixed Myspace, now supports myspacetv.com
- Added Increase or decrease video size for the classic player (testebr gets the credit for this one)
- Added Added ESPN videos
- Added Veoh video site.


Goldbrick Version 1.2:
- Added Videos for Profiles for vbulletin 3.7
- Added Classic Skin
- Added Vblog Support
- Added Vbadvanced Support
- Fixed Attachments
- Rewrote some of the code



Supported Video Sites: 19 so far. Looking in goldbrick/sites folder for a full list. Users can create their own. I'll post a HOW-TO with the details.



Please report any issues or suggestions.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	Picture 1.png
Views:	5561
Size:	18.2 KB
ID:	73342   Click image for larger version

Name:	Picture 2.png
Views:	6396
Size:	96.7 KB
ID:	73343   Click image for larger version

Name:	Picture 3.png
Views:	6063
Size:	33.7 KB
ID:	73344   Click image for larger version

Name:	Picture 7.png
Views:	6642
Size:	35.4 KB
ID:	73345  

Click image for larger version

Name:	Picture 8.png
Views:	4198
Size:	20.5 KB
ID:	73346  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #976  
Old 04 Aug 2008, 20:38
EvilJohn's Avatar
EvilJohn EvilJohn is offline
 
Join Date: Apr 2006
Real name: John
I get the same thing, Other than that works great. Thanks

When I tried to add a video link from youtube to my profile, I ge the error message below

Your submission could not be processed because a security token was missing.

If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.

Is there any fix for this?
thanks for your help
__________________
Give me a server target rich.
Gaming site.
Reply With Quote
  #977  
Old 04 Aug 2008, 23:44
nix's Avatar
nix nix is offline
 
Join Date: Mar 2005
Originally Posted by alexsinev View Post
It doesn't work for me on 3.7.0. PHP 5.2.2. It seems as if it's absent at all. Doesn't play attachments or links to mediafiles. Everything is turned on. All permissions are Ok. I try to play .mov or .qt or .pdf -- nothing, only download. Tried IE7 and Firefox 3.
You have to add the attachments in vbulletins attachment manager.

Originally Posted by osariase View Post
When I tried to add a video link from youtube to my profile, I ge the error message below

Your submission could not be processed because a security token was missing.

If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.


Is there any fix for this?
thanks for your help
It's been fixed in a version a couple of pages back.
Reply With Quote
  #978  
Old 05 Aug 2008, 00:01
EvilJohn's Avatar
EvilJohn EvilJohn is offline
 
Join Date: Apr 2006
Real name: John
Originally Posted by nix View Post
You have to add the attachments in vbulletins attachment manager.


It's been fixed in a version a couple of pages back.
I just installed your 1.5 version. What do I need to do to fix the error?

Your submission could not be processed because a security token was missing.

If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.

Custom style with vb3.7.2
__________________
Give me a server target rich.
Gaming site.
Reply With Quote
  #979  
Old 05 Aug 2008, 05:16
alexsinev alexsinev is offline
 
Join Date: Jun 2007
Originally Posted by nix View Post
You have to add the attachments in vbulletins attachment manager.

It's been fixed in a version a couple of pages back.
Everything is added in attachment manager. I've updated to 1.91. Nothing changed. It's not working at all, as if it's absent. What's the matter?
__________________
ARTinvestment.RU
Reply With Quote
  #980  
Old 05 Aug 2008, 20:07
nix's Avatar
nix nix is offline
 
Join Date: Mar 2005
Originally Posted by EvilJohn View Post
I just installed your 1.5 version. What do I need to do to fix the error?

Your submission could not be processed because a security token was missing.

If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.

Custom style with vb3.7.2
Version 1.9 has been posted a couple of pages back. I hope to make it an official release sometime this month.
Originally Posted by alexsinev View Post
Everything is added in attachment manager. I've updated to 1.91. Nothing changed. It's not working at all, as if it's absent. What's the matter?
Are you using the attachments in the file system and not the database?
Reply With Quote
  #981  
Old 05 Aug 2008, 20:54
sweeps78 sweeps78 is offline
 
Join Date: Sep 2006
I'm having a bit of trouble with some videos that one of my users are trying to embed:

http://forums.trossenrobotics.com/showthread.php?t=1981

The page also gives me a message asking me to install some missing plugins. The problem is, is that when I click on the button, the plugin can't be found...

The file type is .mpg. I've tried to view these videos in both Firefox 3.0 and IE ver 7, and neither will allow me to view them

I haven't looked through the 66 pages here, hehe, so if this was already mentioned and is in the works of getting fixed with the latest release, my pre-apologies.
Reply With Quote
  #982  
Old 05 Aug 2008, 22:27
TheInsaneManiac TheInsaneManiac is offline
 
Join Date: Feb 2008
When uninstalling I get:
syntax error, unexpected T_OBJECT_OPERATOR admincp/plugin.php(1512) : eval()'d code on line 1

It looks like it uninstalled, but I am not 100% and don't want any problems in the future.
Reply With Quote
  #983  
Old 05 Aug 2008, 23:13
EvilJohn's Avatar
EvilJohn EvilJohn is offline
 
Join Date: Apr 2006
Real name: John
LOL you have to work to find the latest version. Thank you NIX!

http://www.vbulletin.org/forum/showp...&postcount=882
__________________
Give me a server target rich.
Gaming site.
Reply With Quote
  #984  
Old 06 Aug 2008, 05:53
alexsinev alexsinev is offline
 
Join Date: Jun 2007
I coped with the problem, it works and was working, but there are some nuances.

Originally Posted by nix View Post
Are you using the attachments in the file system and not the database?
Yes I am. This was not the thing.

First, I turned on the option 'Use Goldbrick Media system when uploading an attachment'. After that the mod recognized my .mov file when I attached it, but refused to play it. It said that the QuickTime plugin was not installed though it was.

Second, I tried to make a hyperlink to a copy of the same .mov file placed to my server. The mod didn't recognized the link. When I manually added [media][/media] around the link, the mod recognized it and started to play.

Anyway, thanks for your help, nix! (though the mod doesn't play my .mov attachment, so I've removed the attachment)

And one more thing. The window cuts the QT player's control bar a little. I tried to increase the window size, but this was helpless, it doesn't have an influence on it at all. You can look at it here:

http://forum.artinvestment.ru/showthread.php?t=3265

(the forum is in Russian, sorry)
__________________
ARTinvestment.RU

Last edited by alexsinev; 06 Aug 2008 at 06:06.
Reply With Quote
  #985  
Old 06 Aug 2008, 14:48
Aidden Aidden is offline
 
Join Date: Dec 2004
Has anyone been able to successfully add a flickr video page yet?

Apparently my mind is not capable of making it work.


sample: http://www.flickr.com/photos/theorem/2736241144/
Reply With Quote
  #986  
Old 06 Aug 2008, 14:55
Zilvia's Avatar
Zilvia Zilvia is offline
 
Join Date: Apr 2002
Originally Posted by nix View Post
If you know how to edit plugins, change the newpost_proceses execute order to 4.
Can you elaborate on this? I have the newpost_process.php file up but dont see what to change. Although Im likely looking in the wrong place.

I have vbSEO and am rewriting, and so I get blank pages after I activate the plugin.
Reply With Quote
  #987  
Old 06 Aug 2008, 14:56
PAKIDIL PAKIDIL is offline
 
Join Date: Jan 2007
hello do we also has to set the bbcode becoz youtube movie is not running when i put the link for example http://www.youtube.com/watch?v=_kumHgPO4qc
this its become like this [ media]http://www.youtube.com/watch?v=_kumHgPO4qc [ /media]

and it doesnt run only picture comes with the youtube original movie title
waiting for reply

thanks
Reply With Quote
  #988  
Old 06 Aug 2008, 20:26
aggiefan aggiefan is offline
 
Join Date: Apr 2005
just another question (and its the only thing keeping me from using the new version) is i hate the defacto image for the highslide video. is there any way (hopefully with the caching stuff) that you could put a graphic there of the video instead of the one graphic? its the only reason im still using the old view is it has that pre-render screenshot of the video.

and i know a few sites do it right (youtube seems to be the only one so far... atleast that we use) but it needs to work with all of them.
__________________
Owner of http://www.aggiefans.com
Our Custom Hacks:
Reputation Report
vBContest (college pickem script)

Last edited by aggiefan; 07 Aug 2008 at 20:35.
Reply With Quote
  #989  
Old 07 Aug 2008, 15:58
cosy cosy is offline
 
Join Date: Jul 2007
Originally Posted by nix View Post
It's been fixed in a version a couple of pages back.
link plz
Reply With Quote
  #990  
Old 08 Aug 2008, 21:14
sweeps78 sweeps78 is offline
 
Join Date: Sep 2006
anyone?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 12:19.

Layout Options | Width: Wide Color: