Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
[AJAX] Tabbed Forum Home Details »
[AJAX] Tabbed Forum Home
Mod Version: 1.5.0, by bobster65 (Member) bobster65 is offline
Developer Last Online: Nov 2013 I like it Show Printable Version Email this Page

vB Version: 3.8.x Rating: (75 votes - 4.92 average) Installs: 592
Released: 10 Apr 2008 Last Update: 03 Sep 2008 Downloads: 9228
Not Supported Template Edits Code Changes Additional Files Translations  

Tabbed Forum Home version 1.01

[AJAX] Tabbed Forum Home version 1.5.0 (BETA)

NOTE: Works with both 3.7x and 3.6x

Description: This MOD is for creating a "Tabbed" Forum Home Page to have Categories displayed within Tab containers (similar to what the new Profile System looks like on vb3.7). Please do not confuse this with the Tab Menu System here at vbulletin.org. They are totally different systems. These Tabs actually switch the content without leaving the main forums page.

I wrote the initial Non AJAX version based on reading many requests from members asking about how namepros created their custom tabbed forum home page. The first implementation I did was a request by bbwforums.net (which you can visit to see a working example). I have shared this version with many members already and decided to release it since it seems to be something that a lot of members are interested in.

UPDATE: I have released a BETA [AJAX] version for those that what something a little more robust and easier to install/configure. This Beta version will never go into production tho as version 2.0 will utilize the YUI AJAX Tabview Toolset. It IS stable tho and is currently running on a few live sites.

NOTE: Keep in mind, I wrote this with the assumption that you are fairly well versed and comfortable with editing files/templates and following the flow of things. If there is something you don't understand, PLEASE let me know so that I can help you understand it. This IS NOT a product that a novice can just plug and play and it takes a little bit of time to setup, but its well worth it in the end (if you want a custom unique look to your forum home page)... the next version (Don't ask when, cause its just on the drawing board) will be a product with ACP controls for easy setup

The attached Zip File(s) contain the Files and Instructions necessary to install each version.

DEMO: www.bbwforums.net or www.namepros.com
[Moderator Edit: The first URL has been un-linked as there has been reported malware on that domain. The mod author may edit this notice once the situation has been cleaned.]

Screen Shots: None, visit one or both of the above links as seeing them in action is better than some static image(s)..

Bobster

Change Log

version 1.01 -
tabcontent.js ver 2.2 to support remote links
updated install instructions (both in txt and rtf format)

version 1.5.0 -
BETA [AJAX] version

July 8, 2008 - Added xml file for WOL
Sep 2, 2008 - Updated xml file for WOL

Download Now

Only licensed members can download files, Click Here for more information.

Supporters / CoAuthors

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #631  
Old 03 Aug 2008, 19:41
Bustah Bustah is offline
 
Join Date: Jul 2008
Thats exactly what I want to do.

I want to display "The Vault"'s subforums underneath a tab. Its not working.

Its blank when you click the tab, no forums show up.
Reply With Quote
  #632  
Old 04 Aug 2008, 07:28
bobster65's Avatar
bobster65 bobster65 is offline
 
Join Date: Mar 2006
Real name: Bob
Originally Posted by Bustah View Post
Thats exactly what I want to do.

I want to display "The Vault"'s subforums underneath a tab. Its not working.

Its blank when you click the tab, no forums show up.
PM me and I'll take a look when I can ..
__________________
Please Do Not PM me for vBulletin assistance... I am currently only doing customization & addon's for Xenforo.
Reply With Quote
  #633  
Old 05 Aug 2008, 02:06
bitbender's Avatar
bitbender bitbender is offline
 
Join Date: Jan 2002
Real name: Philip
yea, I am seeing the same here For instance;

Basic Help Collection(BHC) - Top level category
----> Linux Basics - sub forum
----> Windows Basics - subforum

They show fine in the tab for BHC.

I have the code for all my other categories working great, but when I tried to do these two subs to bring them forward in the tab bar, I get blanki

It's the same code block from the prev tab in my forumhome, all I changed was the forumid and var name doubles for the collapse, and the $forumbits variable name increment-I followed your instructions on naming convention.

I'm pretty sure it's correct.. I have beeen sitting here comparing the two code blocks over and over, trying to see where I coded incorrectly - No joy..

So any help will be appreciated.
__________________

www.bitbenderforums.com Vb 4.1.3
www.jamgoodbluegrass.com vb 4.1.10
Reply With Quote
  #634  
Old 06 Aug 2008, 11:41
oz_girl's Avatar
oz_girl oz_girl is offline
 
Join Date: Mar 2008
I would really love this on my forums but its a little out of my knowledge range, can i ask someone to do this for me please?
Reply With Quote
  #635  
Old 06 Aug 2008, 23:11
iBaker's Avatar
iBaker iBaker is offline
 
Join Date: Nov 2006
Bobster
Mate, this is simply brilliant

I am using 3.7.2 and vBadvanced with many different categories and this has made it easy for users to just use the category or categories that they want to view whilst keeping the overall look, feel and structure of my site - thank YOU!

Can I just make one small suggestion for the next update - it would finish it off if when a user was using the advance search that the forum search list only displayed the forums that are within that category or that the other categories are condensed to line items and only the category that the user is in has the forums in an expanded view - just a suggestion.
__________________
Regards Ian (Xenforo: Recreational Flying. vBulletin: Aviation Enthusiasts)
NOTE: Previously whatever I posted on forums was copied by a competing site. So I post this in the hope that it does help others but on the condition that anything that I post is not allowed to be used by Glenn Inwood of Cowra NSW Australia or anyone associated with him.
Reply With Quote
  #636  
Old 07 Aug 2008, 02:44
TheInsaneManiac TheInsaneManiac is offline
 
Join Date: Feb 2008
I have a small issue. I unactivated a forum to hide it from the main forums. The only problem is when I go view that forum in a tab, it shows I can access it, but all the forums say they have never been posted in. If I click one of the forums I can clearly see that they have indeed been posted in.
Reply With Quote
  #637  
Old 07 Aug 2008, 03:16
iBaker's Avatar
iBaker iBaker is offline
 
Join Date: Nov 2006
Oops, I spoke to soon

It seems the mod is not allowing my forums to shrink in width depending on what screen resolution the user has i.e. if a user has 1024x768 then the forums go off the right edge causing the horizontal slider appearing for the user to be able to see the right side of the page.

The line that is causing it is:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

-- EDIT --
Spoke to soon again
I am using the Cyb - Sub-Forum Manager mod and I didn't realise that my sub forums were being pushed across the page causing a blow out in the overall width of my site - made the amendments as per http://www.vbulletin.org/forum/showp...&postcount=566 and all is working great - thanks!
__________________
Regards Ian (Xenforo: Recreational Flying. vBulletin: Aviation Enthusiasts)
NOTE: Previously whatever I posted on forums was copied by a competing site. So I post this in the hope that it does help others but on the condition that anything that I post is not allowed to be used by Glenn Inwood of Cowra NSW Australia or anyone associated with him.

Last edited by iBaker; 07 Aug 2008 at 04:41.
Reply With Quote
  #638  
Old 07 Aug 2008, 07:00
Ziki's Avatar
Ziki Ziki is offline
 
Join Date: Nov 2005
Here are a few suggestions: In the templates remove the trailing slash before clientscript/tabs
also this should be removed in the javascript file as the image is not displaying.Also remove
<br style="clear: left" /> from the template because it sepparates the forum and the tabs (whitespace) in IE7.
__________________
My free mods~click here
Reply With Quote
  #639  
Old 07 Aug 2008, 12:06
TheInsaneManiac TheInsaneManiac is offline
 
Join Date: Feb 2008
Originally Posted by Ziki View Post
Here are a few suggestions: In the templates remove the trailing slash before clientscript/tabs
also this should be removed in the javascript file as the image is not displaying.Also remove
<br style="clear: left" /> from the template because it sepparates the forum and the tabs (whitespace) in IE7.
Yea, but if you remove that it would work in IE, but not firefox, so put a conditional statement for it.
Reply With Quote
  #640  
Old 07 Aug 2008, 18:16
Deepdog009's Avatar
Deepdog009 Deepdog009 is offline
 
Join Date: Dec 2004
Arrow ???

Originally Posted by Ziki View Post
Here are a few suggestions: In the templates remove the trailing slash before clientscript/tabs
also this should be removed in the javascript file as the image is not displaying.Also remove
<br style="clear: left" /> from the template because it sepparates the forum and the tabs (whitespace) in IE7.
Originally Posted by TheInsaneManiac View Post
Yea, but if you remove that it would work in IE, but not firefox, so put a conditional statement for it.
*************************************************
Ziki,,,
Good looking out...

TheInsaneManiac,,,
Great feedback...

*************************************************

bobster65,,,

Keep the ball rolling...>>><<<
__________________
Long vacation folks, back 2 dabble and doodle... *** Enjoy the Forums
Reply With Quote
  #641  
Old 09 Aug 2008, 02:12
King Kovifor's Avatar
King Kovifor King Kovifor is offline
 
Join Date: Nov 2004
Real name: Jeremy
Originally Posted by Ziki View Post
Here are a few suggestions: In the templates remove the trailing slash before clientscript/tabs
also this should be removed in the javascript file as the image is not displaying.Also remove
<br style="clear: left" /> from the template because it sepparates the forum and the tabs (whitespace) in IE7.
This will be fixed in 2.0
__________________
Former vBulletin.org Staff Member

Do not request support through any other means except the forums.

Useful Post With Links on Learning How To Develop vBulletin Plugins

Latest Modification: Stop Forum Spam Integration
Reply With Quote
  #642  
Old 09 Aug 2008, 07:45
Salar Salar is offline
 
Join Date: Jun 2005
very useful mod, but i can't add it to my froum no luck!! hope you make it easier on ver 2.0
Reply With Quote
  #643  
Old 10 Aug 2008, 13:51
Scamorz Scamorz is offline
 
Join Date: Oct 2006
Hi bob, i would to know if the script automatically switch a style when i click on the tab...
How i can do that?

Thanks
Reply With Quote
  #644  
Old 10 Aug 2008, 14:28
bobster65's Avatar
bobster65 bobster65 is offline
 
Join Date: Mar 2006
Real name: Bob
Originally Posted by Scamorz View Post
Hi bob, i would to know if the script automatically switch a style when i click on the tab...
How i can do that?

Thanks
what exactly do you mean? Can you give us a more detailed explanation of what you want?
__________________
Please Do Not PM me for vBulletin assistance... I am currently only doing customization & addon's for Xenforo.
Reply With Quote
  #645  
Old 10 Aug 2008, 22:05
Scamorz Scamorz is offline
 
Join Date: Oct 2006
Ok, sorry for my english

I have 2 tabs; when i click on the second tab i would want change automatically the style with another one. Is it impossible?

I suppose tab's link must have a redirect to a specified style id (&styleid=xx)...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:19.

Layout Options | Width: Wide Color: