Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 03 May 2019, 09:50
BlackxRam BlackxRam is offline
 
Join Date: Aug 2003
VB4 Post Editor, is there an update or mod?

Is there an update to the VB4 wysiwyg editor or possibly a mod that gives it better functionality?
Reply With Quote
  #2  
Old 03 May 2019, 13:25
In Omnibus's Avatar
In Omnibus In Omnibus is offline
 
Join Date: Apr 2010
Real name: Kris
There are no updates of any kind for vB4. Development on it stopped quite some time ago.

The CKEditor is open source but vBulletin always uses a customization of it so you can't simply replace the existing one with the newest version. It would require substantial coding.
Reply With Quote
  #3  
Old 14 May 2019, 20:45
Meister2017 Meister2017 is offline
 
Join Date: Sep 2017
There is a manual in German for an update to 3.6.6.2. If necessary, use Google Translate.

Beim CkEditor gab es viele und auch einige Wichtige Updates:
https://svn.ckeditor.com/CKEditor/trunk/CHANGES.html

vBulletin 4.2.5 hat standardmäßig CkEditor 3.2

Diese Änderungen wurden getestet mit:
PHP 7.2.4 u. 7.2.3
PHP 7.0.22
Unter PHP 7.1 müsste es also auch funktionieren.

CkEditor 3.6.6.2 runterladen: https://download.cksource.com/CKEdit...or_3.6.6.2.zip

Alles außer:
_samples
_source
adapters
CHANGES.html
ckeditor.asp
ckeditor.pack
ckeditor_basic_source.js
ckeditor_php4.php
config.js
content.css
ISTALL.html
LICENSE.html

kopieren nach clientscript/ckeditor/
Hinweis: Im Ordner Plugins würde es sich empfehlen auch nur die zu kopieren, welche in vB schon vorhanden sind.


Nicht notwendig:
https://davidwalsh.name/prevent-xss-ckeditor einbauen wer mag:
Den Code in clientscript/ckeditor/ckeditorChange.js packen (Datei neu erstellen)

in /clientscript/ckeditor/ckeditor_php5.php

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

und drunter hinzufügen:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

und in /vb/ckeditor.php
in der Funktion getJsIncludes() auch wieder die ckeditorChange.js hinzufügen.



Wieder notwendig:

clientscript/ckeditor/ckeditor.js
suche:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


ersetzte mit:




in clientscript/ckeditor/ckeditor_php5.php

alle
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

durch
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

ersetzten.
Bsp.1:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

durch

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Bsp.2:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

durch

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.




Wer Probleme mit UTF-8 hat kann noch benötigen:

includes/functions.php in Z. 7093 einfügen:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


und vor Zeile 7319

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

hinzufügen

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #4  
Old 14 May 2019, 21:10
final kaoss final kaoss is offline
 
Join Date: Apr 2006
Did you write that yourself or is there a source article that you can attribute that to?
Reply With Quote
  #5  
Old 14 May 2019, 22:06
scottkoz20 scottkoz20 is offline
 
Join Date: Jan 2016
Real name: Scott
looks like there is something here - https://forum.vbdev.de/showthread.ph...or-3-2-3-6-6-2 (in german - translated to English)

however, something I will call out immediately is the following

vBulletin 4.2.5 defaults to CkEditor 3.2

These changes have been tested with:
PHP 7.2.4 u. 7.2.3
PHP 7.0.22
It should work under PHP 7.1.


I'm running php 5.6.40 on my vB4.2.5 site. Not sure how many vB4 sites are using php7.1+ at this point.
Reply With Quote
  #6  
Old 14 May 2019, 22:29
Meister2017 Meister2017 is offline
 
Join Date: Sep 2017
These changes are from "kleinerzwerg" and also work under php 5.6. I recommend to use at least php 7.0 because the board runs a lot faster.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 19:56.

Layout Options | Width: Wide Color: