Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Lightweight Style for Small Screen Devices (cell phone, iphone, mobile, android) Details »
Lightweight Style for Small Screen Devices (cell phone, iphone, mobile, android)
Mod Version: 1.0.3, by dartho (Coder/Designer) dartho is offline
Developer Last Online: Aug 2020 I like it Show Printable Version Email this Page

vB Version: 4.1.8 Rating: (98 votes - 4.82 average) Installs: 895
Released: 25 Aug 2010 Last Update: 16 Dec 2011 Downloads: 6248
Not Supported Re-usable Code  

A lightweight *forum only style aimed at small screen devices such as Windows Smartphones, Nokias and even iPhones. It has VERY low bandwidth requirements - 15 times less on my site - 20K as opposed to 300K for forumhome.

*forum only - I have done a very small amount of rough work on CMS templates, a simple single column CMS *could* be created to work with this style without too much effort. However I am not sure if you can have a different CMS layout dependent on which style you are using?

This is an update to the mobile style I have previously released.

The changes are predominantly aesthetic to take advantage of larger screens.

It is also much easier to change colour schemes by editing the commented CSS file.


Demo: http://vbdev.org/forum.php?styleid=7

This is a a lightweight style and as such has much reduced functionality/information over the default vBulletin style.

Install instructions:
  • Firstly, if upgrading, I recommend installing this as a new style rather than overwriting your previous install. This way you get to test it first without trashing your existing style.
  • BACKUP YOUR EXISTING lightweight.css.php FILE IF YOU HAVE CSS CUSTOMISATIONS
  • Download ZIP file
  • Unzip to a local/temp directory
  • Edit lightweight.css.php file to customise colours if required
  • Upload contents of the upload directory in the zip file folder to your forum root.
  • Install style XML via Style Manager in your ADMINCP
  • **Install and configure "LightWeight Style Options"
  • See post 2 for a FAQ
  • Click "Mark as Installed"
  • Test it out
  • Leave a rating
  • Leave feedback
  • Enjoy checking your site from your mobile phone without the need to pinch/zoom/wait etc...
Version Control:
1.0.0 - 25 AUG 2010 - Initial Release on vBulletin.org
1.0.1 - 26 AUG 2010 - Fixed "Mark All Forums Read" link in Search results. Released Lightweight Style Options to customise this
1.0.2 - 21 MAR 2011 - Updated to 4.1.2, removed short tags from CSS, fixed some issues discovered since last release, added some stuff.
1.0.3 - 16 DEC 2011 - Updated to 1.0.3, tried to fix all known issues. Nothing new. If you have updated your site as bugs have been found, probably no need to upgrade. But if you're upgrading your site from to 4.1.9, might be worthwhile.
1.0.3a - 16 DEC 2011 - remove test ad hook code accidently left in postbit_legacy template
Branding Free:
The style is free to use. However I ask that you keep links in the footer. If you want to remove them - send me a donation of an amount you can afford, or that you think is fair/reasonable, it's up to you how much.

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Screenshots

Click image for larger version

Name:	lightweight-screenshot.png
Views:	41573
Size:	30.6 KB
ID:	121268  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases Mobile Phone / iPhone / PDA Detection and Style Assignment dartho vBulletin 3.8 Add-ons 147 23 Jun 2020 14:30
Forum Display Enhancements Mobile Phone / iPhone / PDA Detection and Style Assignment dartho vBulletin 3.7 Add-ons 407 19 Mar 2015 15:53
Mobile, Cell, Phone, PDA, iPhone Style dartho vBulletin 3.7 Styles 795 16 Aug 2012 14:39
Mobile/Cell Phone Style dartho vBulletin 3.6 Styles 313 21 Aug 2011 23:04

  #241  
Old 09 Jan 2011, 12:19
BadgerDog BadgerDog is offline
 
Join Date: Oct 2006
Real name: Doug
When I installed this, I didn't realize (my bad) that it would also embed my advert code from each forum, generated from this mod:

Add Ads to each forum.

The graphic ads appear at the top of the forums, slowing down Dartho's excellent skin style.

Since the ad mod uses HTML, I think the fix for me is simple ...

Can you provide me with the IF statement in vBulletin jargon that I can put in front of my HTML code for the forum ads so it DOES NOT execute if the style equals the value of my mobile skin?

In other words ..

===================
If style not equal to "x" then skip to end and do not execute adsense code display ...

adsense code

end
=============

Thanks ...

Regards,
Doug

ps: Has anyone who uses it, been able to solve the conflict with this mod that I mentioned in a previous pic?

Separate Sticky and Normal Threads by pdtan
Reply With Quote
  #242  
Old 09 Jan 2011, 21:54
DaffyDuck DaffyDuck is offline
 
Join Date: Jul 2006
Originally Posted by dartho View Post
works fine under 4.1pl2. Sounds like you either haven't uploaded the CSS.PHP file to your forum root, or perhaps your server doesn;t support php short tags, in which case you should download the alternative CSS.PHP file available in the first post (or first reply to this thread as the case may be)
I did upload the file, but you are probably correct with the short tags reference -- it sees the css file, but doesn't seem to react to all of it. Let me try that -- thanks for your quick response.

EDIT: Thanks, that did it!
Reply With Quote
  #243  
Old 10 Jan 2011, 05:18
wh1t3dr3am wh1t3dr3am is offline
 
Join Date: Oct 2010
How to change style from mobile to default style ?Any advice ?
Reply With Quote
  #244  
Old 10 Jan 2011, 12:44
dartho dartho is offline
 
Join Date: Sep 2005
Originally Posted by wh1t3dr3am View Post
How to change style from mobile to default style ?Any advice ?
as per install instructions:

**Install and configure "LightWeight Style Options"
@BadgerDog - I will get back to you soon
Reply With Quote
  #245  
Old 15 Jan 2011, 16:19
Mark Hewitt Mark Hewitt is offline
 
Join Date: Nov 2001
Sorry if this is an obvious question but I've installed it and it overwrites my default style! I've had to revert to a backup copy of the database to get rid of it! What have I done wrong?
Reply With Quote
  #246  
Old 15 Jan 2011, 16:45
Mark Hewitt Mark Hewitt is offline
 
Join Date: Nov 2001
PS I have installed Lightweight sytle options - I think! But then it still only gives me the mobile style I cannot get back to the default style - more database restores and lost posts Nightmare.
Reply With Quote
  #247  
Old 16 Jan 2011, 00:07
dartho dartho is offline
 
Join Date: Sep 2005
sounds like you merged it into your default style - this now has happened to about 3 people that I know of and I can see no reason why. Perhaps it's a bug in vBulletin? Do you have debug mode enabled?

Make sure you add it as a child style. Someone else said they created a new style with no parent, and then merged this one into that.

You don;t need to do DB restores to fix either, in teh vBulletin download package there is a tools.php file - upload it to admincp, open in browser and rebuild master style. That will fix. In the mean time I'll report as a bug ...
Reply With Quote
  #248  
Old 16 Jan 2011, 00:13
BadgerDog BadgerDog is offline
 
Join Date: Oct 2006
Real name: Doug
Originally Posted by dartho View Post
@BadgerDog - I will get back to you soon
Roger that ...

Regards,
Doug
Reply With Quote
  #249  
Old 16 Jan 2011, 00:18
fly fly is offline
 
Join Date: Oct 2003
Originally Posted by dartho View Post
sounds like you merged it into your default style - this now has happened to about 3 people that I know of and I can see no reason why. Perhaps it's a bug in vBulletin? Do you have debug mode enabled?

Make sure you add it as a child style. Someone else said they created a new style with no parent, and then merged this one into that.

You don;t need to do DB restores to fix either, in teh vBulletin download package there is a tools.php file - upload it to admincp, open in browser and rebuild master style. That will fix. In the mean time I'll report as a bug ...
I've done it before, and it wasn't a bug. ID10T error
Reply With Quote
  #250  
Old 16 Jan 2011, 11:44
Mark Hewitt Mark Hewitt is offline
 
Join Date: Nov 2001
Tried it again but adding it as a child style, same result it seems to overwrite *all* my styles, if I do index.php?styleid=XX all I ever get is the mobile style!

Here's what I'm doing - vbulletin 4.1.1

Download / Upload Styles
Import Style XML File:
Import the XML from your server: mobile.xml (renamed by me)
Merge into style: (Create new style)
Ignore style version: Yes
Title for uploaded style: Mobile
Parent Style: Default Style
Display Order: 10
Allow user selection: Yes

It then goes through the upload process, which appears to be sucessful, but then I just get the mobile style and nothing else!
Reply With Quote
  #251  
Old 16 Jan 2011, 14:15
dartho dartho is offline
 
Join Date: Sep 2005
give it a go with no parent (which would make teh Master style the parent which is the default style unmodified)
Reply With Quote
  #252  
Old 17 Jan 2011, 08:15
Mark Hewitt Mark Hewitt is offline
 
Join Date: Nov 2001
Originally Posted by dartho View Post
give it a go with no parent (which would make teh Master style the parent which is the default style unmodified)
I've got it working now. The only difference to the above was that I uploaded the style from my PC rather then specifying a file on the server. Shouldn't make any difference but it seemed to do so in this case!
Reply With Quote
  #253  
Old 17 Jan 2011, 10:29
dartho dartho is offline
 
Join Date: Sep 2005
Good to hear it's now going as it should ...
Reply With Quote
  #254  
Old 17 Jan 2011, 13:08
dartho dartho is offline
 
Join Date: Sep 2005
@BadgerDog -

First - if you have the Lightweight STyule Options add-on installed, try adding this:
$vbulletin->options['dt_separate_sticky_normal_active']=0;
$vbulletin->options['dt_separate_sticky_normal_remove']=0;

to the code to disable add-ons section.

If that doesn't work, try editing the Separate Sticky and Normal Threads plugin for for seperate sticky/normal threads and wrap it in

if (STYLEID!=n){

existing pluginin code

}

where n is the lightweight style ID

As for teh Ads stuff, try deleting teh entire contents of the forumhome_ads_code template in the lightweight style
Reply With Quote
  #255  
Old 17 Jan 2011, 13:25
dartho dartho is offline
 
Join Date: Sep 2005
Originally Posted by Mark Hewitt View Post
I've got it working now. The only difference to the above was that I uploaded the style from my PC rather then specifying a file on the server. Shouldn't make any difference but it seemed to do so in this case!
Mark - I don't think it's you. Same just happened on my test site Uploading from PC = fine. Installing from file on server = messed_up

using tools.php didn;t help either!!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 21:41.

Layout Options | Width: Wide Color: